# Problem beim Update 5.1.6 -&gt; 5.2.1

**URL:** https://forum.shopware.com/t/problem-beim-update-5-1-6-gt-5-2-1/38117
**Category:** Installation/Einstieg
**Created:** [11. Juli 2016 um 15:11 UTC](https://forum.shopware.com/t/problem-beim-update-5-1-6-gt-5-2-1/38117 "2016-07-11T15:11:49Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![emario](https://avatars.discourse-cdn.com/v4/letter/e/46a35a/32.png) [@emario](https://forum.shopware.com/u/emario)
#### Post date: [11. Juli 2016 um 15:11 UTC](https://forum.shopware.com/t/problem-beim-update-5-1-6-gt-5-2-1/38117/1 "2016-07-11T15:11:49Z")

</div>

Beim Update von der Version 5.1.6 auf 5.2.1 tritt beim Datenbank-Update (Datenbank Migration) der folgende Fehler auf:

```
Warning: Uncaught exception 'ErrorException' with message 'require(/var/www/vhosts/WEBSITE.de/construction/vendor/composer/../ircmaxell/password-compat/lib/password.php): failed to open stream: No such file or directory' in /var/www/vhosts/WEBSITE.de/construction/vendor/composer/autoload_real.php:66 Stack trace: #0 /var/www/vhosts/WEBSITE.de/construction/vendor/composer/autoload_real.php(66): Slim\Slim::handleErrors(2, 'require(/var/ww...', '/var/www/vhosts...', 66, Array) #1 /var/www/vhosts/WEBSITE.de/construction/vendor/composer/autoload_real.php(66): composerRequireShopware() #2 /var/www/vhosts/WEBSITE.de/construction/vendor/composer/autoload_real.php(56): composerRequireShopware('e40631d46120a9c...', '/var/www/vhosts...') #3 /var/www/vhosts/WEBSITE.de/construction/vendor/autoload.php(7): ComposerAutoloaderInitShopware::getLoader() #4 /var/www/vhosts/WEBSITE.de/construction/autoload.php(31): require('/var/www/vhosts...') #5 /var/www/vhosts/WEBSITE.de/construction/recovery/update/src/DependencyInjection/Container.ph in /var/www/vhosts/WEBSITE.de/construction/vendor/composer/autoload_real.php on line 66

Fatal error: composerRequireShopware(): Failed opening required '/var/www/vhosts/WEBSITE.de/construction/vendor/composer/../ircmaxell/password-compat/lib/password.php' (include_path='.:/opt/plesk/php/5.6/share/pear') in/var/www/vhosts/WEBSITE.de/construction/vendor/composer/autoload_real.php on line 66

```

Hat vielleicht noch&nbsp;jemand das Problem gehabt (und es bereits gelöst)?

Viele Grüße

Emario

---

<div class="post-metadata">

### Author: ![ndzoesch](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/ndzoesch/32/20970_2.png) [@ndzoesch](https://forum.shopware.com/u/ndzoesch)
#### Post date: [12. Juli 2016 um 06:18 UTC](https://forum.shopware.com/t/problem-beim-update-5-1-6-gt-5-2-1/38117/2 "2016-07-12T06:18:48Z")

</div>

Hallo&nbsp;Emario,

das sieht ganz so aus, als fehle eine Datei in deiner vendor folder oder aber die composer.json ist nicht aktuell.

Wie bist Du bei dem Update vorgegangen? Hast Du es über das Backend angestoßen oder die Dateien per FTP hochgeladen?

Gruß, Niklas

---

<div class="post-metadata">

### Author: ![emario](https://avatars.discourse-cdn.com/v4/letter/e/46a35a/32.png) [@emario](https://forum.shopware.com/u/emario)
#### Post date: [12. Juli 2016 um 07:11 UTC](https://forum.shopware.com/t/problem-beim-update-5-1-6-gt-5-2-1/38117/3 "2016-07-12T07:11:11Z")

</div>

Hallo Niklas,  
das Update ging über das Backend. Bis zur Datenbank Migration läuft alles wie gewohnt aber dann kommt es zur Fehlermeldung.

Es sieht so aus, als ob der komplette&nbsp; **ircmaxell&nbsp;** Folder&nbsp;bereits gelöscht wurde.

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/0/07e9c5995cf090f00315bb360379e39a5df383ba.jpeg)

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/c/cabea6cd53b289cc7d1bfbab325570dcadce6e7c.jpeg) ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/8/8cf14e78bf7526c69f933daf8cc09b1dcbf205d5.jpeg)

Vielen Dank&nbsp;für die Hilfe!

Viele Grüße

Emario

---

<div class="post-metadata">

### Author: ![emario](https://avatars.discourse-cdn.com/v4/letter/e/46a35a/32.png) [@emario](https://forum.shopware.com/u/emario)
#### Post date: [16. Juli 2016 um 13:02 UTC](https://forum.shopware.com/t/problem-beim-update-5-1-6-gt-5-2-1/38117/4 "2016-07-16T13:02:45Z")

</div>

In der Zwischenzeit habe ich den&nbsp; **ircmaxell&nbsp;** Folder aus dem Backup hineinkopiert. Zunächst sah es so aus, als ob dies die Lösung ist. Datenbank Migration wurde erfolgreich durchgeführt&nbsp;aber die&nbsp;nächsten Fehler traten schon beim Aufräumen auf.

Nun bleibe ich Dank des Backups bei&nbsp;SW&nbsp;5.1.6.
