# Plugin Frontend Widget Cache-Problem 500er nach Reload

**URL:** <https://forum.shopware.com/t/plugin-frontend-widget-cache-problem-500er-nach-reload/69200>\
**Category:** Plugins\
**Created:** [26. August 2020 um 21:51 UTC](https://forum.shopware.com/t/plugin-frontend-widget-cache-problem-500er-nach-reload/69200 "2020-08-26T21:51:39Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![MichaelRusch](https://avatars.discourse-cdn.com/v4/letter/m/c0e974/32.png) [@MichaelRusch](https://forum.shopware.com/u/MichaelRusch)\
**Post date:** [26. August 2020 um 21:51 UTC](https://forum.shopware.com/t/plugin-frontend-widget-cache-problem-500er-nach-reload/69200/1 "2020-08-26T21:51:39Z")

</div>

Moin,

ich schreibe gerade ein Plugin mit einem Frontend Widget. Das Widget ist über einen {action}-Block in der frontend/index/index.tpl eingebunden.

Wenn ich nun die Startseite zum ersten mal nach der installation (Cache neu aufgebaut) aufrufe ist alles korrekt. Sobald ich die Seite dann aber mit F5 neu lade bekomme ich einen einen 500er Fehler. Die Seite läd nur den Header, Menü und dann läuft der Ajax-Loader.

Ich habe das Widget in dem HTTP-Cache unter die „Nicht gecachte Controller“ eingetragen. Das hat aber keinerlei Auswirkung.

Hat jemand eine Idee?

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [27. August 2020 um 06:02 UTC](https://forum.shopware.com/t/plugin-frontend-widget-cache-problem-500er-nach-reload/69200/2 "2020-08-27T06:02:32Z")

</div>

Und was macht man bei einem 500er Fehler? Man schaut in die Logs!

- Fehlermeldungen in Shopware debuggen und untersuchen  
[https://docs.shopware.com/de/shopware-5-de/tutorials-und-faq/fehlermeldungen-in-shopware-debuggen](https://docs.shopware.com/de/shopware-5-de/tutorials-und-faq/fehlermeldungen-in-shopware-debuggen)

- Fehlermeldungen in error\_log auf Server untersuchen (mögliche PHP-Fehler)  
Bitte nicht mit Shopware Log verwechseln. Liegt meist außerhalb vom httpdocs-Order der Domain - ggf. beim Hoster anfragen.

&nbsp;

---

<div class="post-metadata">

**Author:** ![MichaelRusch](https://avatars.discourse-cdn.com/v4/letter/m/c0e974/32.png) [@MichaelRusch](https://forum.shopware.com/u/MichaelRusch)\
**Post date:** [29. August 2020 um 07:37 UTC](https://forum.shopware.com/t/plugin-frontend-widget-cache-problem-500er-nach-reload/69200/3 "2020-08-29T07:37:17Z")

</div>

Hi. Danke für den Hinweis. Hatte die Logs falsch konfiguriert auf dem Server.

Apache meldet jetzt:  
PHP Fatal error:&nbsp; Uncaught SmartyException: Unable to load template snippet ‘widgets/error/generic\_error.tpl’ in /www/…/engine/Library/Smarty/sysplugins/smarty\_internal\_templatebase.php:127

Shopware meldet:  
core.CRITICAL: Unable to load template snippet ‘widgets/mycontroller/index.tpl’

Hab das nach Doku gemacht. Das Template widgets/mycontroller/index.tpl ist vorhanden. Schreibweise kontrolliert.

Ich komm nicht drauf…
