# Plugin Aktualisieren: unknown error within zip archive

**URL:** <https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346>\
**Category:** Shopware 3.5\
**Tags:** other\
**Created:** [25. März 2013 um 15:33 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346 "2013-03-25T15:33:22Z")\
**Posts on this page:** 17\
**Page:** 1

<div class="post-metadata">

**Author:** ![tbcs](https://avatars.discourse-cdn.com/v4/letter/t/34f0e0/32.png) [@tbcs](https://forum.shopware.com/u/tbcs)\
**Post date:** [25. März 2013 um 15:33 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/1 "2013-03-25T15:33:22Z")

</div>

Moin, ich habe bereits im Forum gesucht aber keine konkrete Hilfe gefunden die auf mein Problem passt. Wenn ich PayPal aktualisieren will bekomme ich diese Meldung: unknown error within zip archive Ich kann das Plugin nicht manuell herunterladen da es in Shopware intrigiert ist. Die Ordner /engine/Shopware/Plugins & Unterordner hab ich auf 777 stehen. Laut [All-Inkl.com](http://All-Inkl.com) ist das entpacken von Zip möglich. Was mache ich falsch? hab ich irgendwelche rechte übersehen? Grüße Danny

---

<div class="post-metadata">

**Author:** ![tbcs](https://avatars.discourse-cdn.com/v4/letter/t/34f0e0/32.png) [@tbcs](https://forum.shopware.com/u/tbcs)\
**Post date:** [2. April 2013 um 12:18 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/2 "2013-04-02T12:18:16Z")

</div>

Falls jemand das selbe Problem hat, hier die Lösung: Mein Hoster hat in die .htaccess folgende Zeile eingebaut: `AddHandler php5-cgi .php`

---

<div class="post-metadata">

**Author:** ![bossashop](https://avatars.discourse-cdn.com/v4/letter/b/45deac/32.png) [@bossashop](https://forum.shopware.com/u/bossashop)\
**Post date:** [20. April 2013 um 16:17 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/3 "2013-04-20T16:17:30Z")

</div>

Das gleiche Problem habe ich auch. Allerdings lassen sich andere PlugIns problemlos aktualisieren, nur das Paypal nicht (2.1.1 auf 2.1.4). Mit dem Hinzufügen des Codes in die htaccess lässt sich die Frontseite nicht mehr aufrufen und im Backend dreht sich das Rad ewig. Das scheint von Hoster zu Hoster unterschiedlich zu sein (mein Hoster ist Hosteurope). Aber daran kann es ja auch nicht liegen, da andere PlugIns aktualisierbar sind!? Hat jemand evtl. noch eine andere Lösung für dieses Problem parat?

---

<div class="post-metadata">

**Author:** ![paralyse](https://avatars.discourse-cdn.com/v4/letter/p/dbc845/32.png) [@paralyse](https://forum.shopware.com/u/paralyse)\
**Post date:** [21. April 2013 um 04:08 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/4 "2013-04-21T04:08:17Z")

</div>

Moin, ich schließe mich der Fragestellung einfach mal an. Es oedet mich ziemlich an, jedes Mal den richtigen Pfad fuer Plugins zu erraten und es manuell zu entpacken. Und selbstverstaendlich auch jedes Mal die Konfigation neu vornehmen zu muessen, vor allem bei Paypal. Beim letzten Mal hat’s mir ja gleich den ganzen Ordner geloescht. Wenn da ein Telefonat mit dem Provider reicht, dann wuerde ich das gern tun, aber ohne ihm sagen zu koennen, worum es geht … koennte schwierig sein. 🙂 Herzliche Grueße, paralyse.

---

<div class="post-metadata">

**Author:** ![bossashop](https://avatars.discourse-cdn.com/v4/letter/b/45deac/32.png) [@bossashop](https://forum.shopware.com/u/bossashop)\
**Post date:** [13. Mai 2013 um 21:55 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/5 "2013-05-13T21:55:09Z")

</div>

Nun gibt es wieder ein Update für das Paypal Plugin und es lässt sich nicht installieren, ich habe mittlerweile Shopware 4.0.7 laufen und immer noch Paypal 2.1.1 (neu ist 2.1.4). Es erscheint immer wieder der gleiche Fehler „unknown error within zip archive“. Wie lässt sich das manuell installieren bzw. wo liegt hier das Problem? Die erwähnte Änderung in der htaccess bringt bei mir nichts bzw. bringt Fehler, es funktioniert dann gar nichts mehr.

---

<div class="post-metadata">

**Author:** ![bossashop](https://avatars.discourse-cdn.com/v4/letter/b/45deac/32.png) [@bossashop](https://forum.shopware.com/u/bossashop)\
**Post date:** [13. Mai 2013 um 22:24 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/6 "2013-05-13T22:24:32Z")

</div>

Das Plugin lässt sich meines Wissens ja auch nirgendwo herunterladen und manuell installieren. Habe schon alles abgesucht, oder habe ich etwas übersehen? Wenn ich es neu installieren will über das Backend aus dem Store erscheint die Meldung “Sie haben das Plugin bereits gekauft”. Oder einfach aus dem Ordner per FTP löschen? Andere Plugins lassen sich übrigens problemlos aktualisieren ohne Fehlermeldung.

---

<div class="post-metadata">

**Author:** ![bossashop](https://avatars.discourse-cdn.com/v4/letter/b/45deac/32.png) [@bossashop](https://forum.shopware.com/u/bossashop)\
**Post date:** [14. Mai 2013 um 14:39 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/7 "2013-05-14T14:39:36Z")

</div>

Hallo Dennis, vielen Dank dafür, dann weiß ich in Zukunft, welchen Weg ich nehmen kann, falls eine derartige Fehlermeldung erneut auftaucht. Sobald die htaccess abgeschaltet ist, werde ich berichten, ob es daran lag! Danke nochmals und viele Grüße Gabriel

---

<div class="post-metadata">

**Author:** ![bossashop](https://avatars.discourse-cdn.com/v4/letter/b/45deac/32.png) [@bossashop](https://forum.shopware.com/u/bossashop)\
**Post date:** [24. Mai 2013 um 00:24 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/8 "2013-05-24T00:24:52Z")

</div>

A propos Shopware Account: Ich kann mich mit meinen Zugangsdaten nicht mehr in den Shopware Account einloggen, um dort meine Lizenzen, Downloads o.ä. einzusehen etc.!? Das hat bisher immer funktioniert. Selbst wenn ich ein neues Passwort anfordern will, erhalte ich die Fehlermeldung, dass die Shopware ID nicht existiert. Daran wurde jedoch nichts geändert. Ich hoffe und gehe stark davon aus, dass mein Account nicht gelöscht wurde? Danke und viele Grüße

---

<div class="post-metadata">

**Author:** ![bossashop](https://avatars.discourse-cdn.com/v4/letter/b/45deac/32.png) [@bossashop](https://forum.shopware.com/u/bossashop)\
**Post date:** [24. Mai 2013 um 09:20 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/9 "2013-05-24T09:20:55Z")

</div>

Hat sich erledigt! Heute funktioniert der Login mit der Shopware ID wieder, das war wohl eine temporäre Störung oder Wartungsarbeiten auf Serverseite bei Shopware - war ja auch schon etwas später in der Nacht. By the way…die Uhrzeit hier im Forum bei den Posts ist um 1h verschoben, d.h. die Beiträge zeigen das Erstellungsdatum um 1 Stunde früher an als die tatsächliche Uhrzeit.

---

<div class="post-metadata">

**Author:** ![cati-collektion](https://avatars.discourse-cdn.com/v4/letter/c/ecd19e/32.png) [@cati-collektion](https://forum.shopware.com/u/cati-collektion)\
**Post date:** [31. Mai 2013 um 11:52 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/10 "2013-05-31T11:52:38Z")

</div>

Hallo, habe das gleiche Problem aber bei mir lässt es sich nicht einfach mit dem Download beheben. Ich hatte das gleich auch bei Billsafe hier hat es mit dem Download geholfen. Aber PayPal weigert sich. Wir nutzen PayPal 2.1.1 und wollen auf 2.1.4 updaten. Die Shopware Version ist 4.0.8. Gibt es noch einen Trick ohne PayPal zu deinstallieren und alles neu zu machen?

---

<div class="post-metadata">

**Author:** ![mfpro](https://avatars.discourse-cdn.com/v4/letter/m/eb9ed0/32.png) [@mfpro](https://forum.shopware.com/u/mfpro)\
**Post date:** [22. Juni 2013 um 12:32 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/11 "2013-06-22T12:32:40Z")

</div>

Wenn bspw. “HeidelAction” zur Aktualisierung aussteht, gibt’s den besagten Zip-Error ebenfalls. Auf der Maschine ist natürlich Zip und Unzip vorhanden. Was hierbei hilft, ist schlichtweg dem Ordner /plugins/Default/Backend/HeidelActions schreibrechte zu geben… Order die keine Schreibrechte haben, können nicht sonderlich gut beschrieben werden. In diesem Fall ging es um eine automatisierte GitHub-Shopware-Installation, die eigentlich die direkt passenden Schreibrechte von Shopware mitbringt - so am Rande erwähnt. Und immer dran denken: 777 ist böse. 😉

---

<div class="post-metadata">

**Author:** ![cagr](https://avatars.discourse-cdn.com/v4/letter/c/6de8d8/32.png) [@cagr](https://forum.shopware.com/u/cagr)\
**Post date:** [7. Juli 2013 um 20:20 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/12 "2013-07-07T20:20:21Z")

</div>

Nachdem bei mir derselbe Fehler aufgetreten ist (Shopware Version 4.0.8, PayPal Version 2.1.1) wollte ich das Update auch manuell installieren: Dazu habe ich es unter Plugin Manager --\> Meine Einkäufe/Lizenzen heruntergeladen (Meldung „Plugin wurde erfolgreich heruntergeladen“), aber dennoch erscheint unter „Alle Erweiterungen“ bei PayPal Payment neben dem Bleistift- und Deinstallieren-Symbol kein weiteres Zeichen. Woran könnte das liegen?

---

<div class="post-metadata">

**Author:** ![bossashop](https://avatars.discourse-cdn.com/v4/letter/b/45deac/32.png) [@bossashop](https://forum.shopware.com/u/bossashop)\
**Post date:** [19. Juli 2013 um 14:20 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/13 "2013-07-19T14:20:58Z")

</div>

Neuerdings kann ich Plugin-Aktualisierungen im Plugin Manager weder über „Updates“ noch über „Meine Einkäufe / Lizenzen“ aktivieren bzw. laden. Ich erhalte z.B. im Falle des Paypal Plugins (momentan ist die 2.1.6 als Update verfügbar) folgende Fehlermeldung: 1. „Access forbidden“ (im Menü Updates) 2. „Beim download des Plugins ist ein Fehler aufgetreten: Given file is no zip archive Bitte prüfen Sie zuerst Ihre Dateirechte auf den Ordnern /files/downloads und engine/Shopware/Plugins/Community“ (im Menü Meine Einkäufe / Lizenzen) Ich hatte letztlich das Rechtekonzept aller Dateien auf den Webserver-Benutzer umgestellt, sodass dieser einwandfreie Schreib- und Leserechte haben müsste (und somit auch Scripte etc.). Aber selbst wenn ich die oben genannten Verzeichnisse testhalber auf 777 stelle, erhalte ich trotzdem die besagten Fehlermeldungen. Shopware 4.0.8 Welche Erklärung könnte es dafür geben?

---

<div class="post-metadata">

**Author:** ![beauty](https://avatars.discourse-cdn.com/v4/letter/b/5f8ce5/32.png) [@beauty](https://forum.shopware.com/u/beauty)\
**Post date:** [22. Juli 2013 um 08:32 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/14 "2013-07-22T08:32:32Z")

</div>

[quote=„cagr“]Nachdem bei mir derselbe Fehler aufgetreten ist (Shopware Version 4.0.8, PayPal Version 2.1.1) wollte ich das Update auch manuell installieren: Dazu habe ich es unter Plugin Manager --\> Meine Einkäufe/Lizenzen heruntergeladen (Meldung „Plugin wurde erfolgreich heruntergeladen“), aber dennoch erscheint unter „Alle Erweiterungen“ bei PayPal Payment neben dem Bleistift- und Deinstallieren-Symbol kein weiteres Zeichen. Woran könnte das liegen?[/quote] so sieht es auch bei mir aus. Hat jemand eine weitere Lösung parat?

---

<div class="post-metadata">

**Author:** ![Daniel.B](https://avatars.discourse-cdn.com/v4/letter/d/e99b99/32.png) [@Daniel.B](https://forum.shopware.com/u/Daniel.B)\
**Post date:** [23. Juli 2013 um 19:06 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/15 "2013-07-23T19:06:25Z")

</div>

Leider habe ich den Fehler „unknown error within zip archive“ auch. Der von Dennis beschriebene Weg, funktioniert mit dem aktualisiert Pfeil zwar für andere Plug-Ins aber leider nicht für PayPal. Auch ein manuelles aktualisieren ist nicht möglich da in der Download -/ Lizenzübersicht das PayPal Plugin nur bis nur SW 4.1.0 | Plain möglich ist. Aktuell ist aber 4.1.6 Der shop ist erstmal im Wartungsmodus bis das Proble behoben ist

---

<div class="post-metadata">

**Author:** ![Daniel.B](https://avatars.discourse-cdn.com/v4/letter/d/e99b99/32.png) [@Daniel.B](https://forum.shopware.com/u/Daniel.B)\
**Post date:** [23. Juli 2013 um 21:20 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/16 "2013-07-23T21:20:33Z")

</div>

Habe es gelöst.Ein Update auf 4.10 brachte die Lösung in Verbindung mit dem von Dennis beschriebene Weg erscheint jetzt auch der aktualisieren Pfeil für PayPal

---

<div class="post-metadata">

**Author:** ![backtraum1](https://avatars.discourse-cdn.com/v4/letter/b/a9a28c/32.png) [@backtraum1](https://forum.shopware.com/u/backtraum1)\
**Post date:** [24. Oktober 2013 um 09:51 UTC](https://forum.shopware.com/t/plugin-aktualisieren-unknown-error-within-zip-archive/12346/17 "2013-10-24T09:51:31Z")

</div>

Bei mir hat das mit dem Download über “Meine Einkäufe” nicht funktioniert, gab eine Fehlermeldung bezüglich Rechte. Ich hab dann über die Website hier in meinem Konto die aktuelle Version für mein Shopware (4.0.5) als .zip runtergeladen und in den Ordner files/downloads geschoben. Dann hab ich nochmal über “Meine Einkäufe” den download probiert und er sagte mir es ging dann. Danach war auch der blaue Kreis bei der Plugin Übersicht sichtbar und das Update war möglich. Konnte so bei Paypal von 2.1.5 auf 2.1.6. kommen.
