# PHP7 HTTPS Error 500

**URL:** <https://forum.shopware.com/t/php7-https-error-500/47034>\
**Category:** Allgemein\
**Created:** [20. Juli 2017 um 17:40 UTC](https://forum.shopware.com/t/php7-https-error-500/47034 "2017-07-20T17:40:37Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![livaro2014](https://avatars.discourse-cdn.com/v4/letter/l/439d5e/32.png) [@livaro2014](https://forum.shopware.com/u/livaro2014)\
**Post date:** [20. Juli 2017 um 17:40 UTC](https://forum.shopware.com/t/php7-https-error-500/47034/1 "2017-07-20T17:40:37Z")

</div>

Hallo,

funktioniert Shopware 5 nicht mit PHP7?

Seit der Umstellung bekomme ich einen Error 500.

Erst wenn ich wieder auf 5.6 umstelle geht alles wieder.

Vielen Dank

---

<div class="post-metadata">

**Author:** ![kulli](https://avatars.discourse-cdn.com/v4/letter/k/a3d4f5/32.png) [@kulli](https://forum.shopware.com/u/kulli)\
**Post date:** [20. Juli 2017 um 18:13 UTC](https://forum.shopware.com/t/php7-https-error-500/47034/2 "2017-07-20T18:13:54Z")

</div>

Selbstverständlich funktioniert Shopware mit php 7.

Wahrscheinlich liegt es an den Einstellungen auf dem Server. Vergleiche doch mal die Einstellungen von der 5.6 mit Deiner PHP 7 Konfiguration,

Auch mal hier im Forum suchen oder mal den Hosting-Anbieter kontaktieren bezüglich der Einstellungen.

Und die Error-Logs anschauen (Server und Shopware).

Und: [http://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen\_detail\_1880.html](http://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen_detail_1880.html)

&nbsp;

&nbsp;

&nbsp;

&nbsp;

---

<div class="post-metadata">

**Author:** ![brettvormkopp](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/brettvormkopp/32/7788_2.png) [@brettvormkopp](https://forum.shopware.com/u/brettvormkopp)\
**Post date:** [20. Juli 2017 um 18:52 UTC](https://forum.shopware.com/t/php7-https-error-500/47034/3 "2017-07-20T18:52:13Z")

</div>

Geht sogar mit php7.1, jedoch ist beim umstellen darauf zu achten, dass auch die IONCube version korrekt ist falls du z.B. verschlüsselte Plugins oder den Lizenzmanager installiert hast.

---

<div class="post-metadata">

**Author:** ![livaro2014](https://avatars.discourse-cdn.com/v4/letter/l/439d5e/32.png) [@livaro2014](https://forum.shopware.com/u/livaro2014)\
**Post date:** [20. Juli 2017 um 19:00 UTC](https://forum.shopware.com/t/php7-https-error-500/47034/4 "2017-07-20T19:00:22Z")

</div>

Ich bin bei all-inkl, habe den Support mal angeschrieben, schauen was die sagen.

---

<div class="post-metadata">

**Author:** ![livaro2014](https://avatars.discourse-cdn.com/v4/letter/l/439d5e/32.png) [@livaro2014](https://forum.shopware.com/u/livaro2014)\
**Post date:** [20. Juli 2017 um 19:29 UTC](https://forum.shopware.com/t/php7-https-error-500/47034/5 "2017-07-20T19:29:31Z")

</div>

Also der Support meinte shopware arbeitet aktuell noch nicht mit php7 zusammen. Stimmt doch gar nicht oder?

---

<div class="post-metadata">

**Author:** ![sonic](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sonic/32/25728_2.png) [@sonic](https://forum.shopware.com/u/sonic)\
**Post date:** [20. Juli 2017 um 19:34 UTC](https://forum.shopware.com/t/php7-https-error-500/47034/6 "2017-07-20T19:34:01Z")

</div>

Absoluter Blödsinn. SW5 läuft bestens schon seit es PHP 7 gibt bei All-Inkl. Diesbezüglich gibt es auch genügend Beiträge hier.  
Ohne Deine Config zu kennen, gehe ich mal davon aus, dass PHP bisher in der Default-Einstellung “apache\_mod” lief, und nun entweder via KAS oder htaccess auf PHP 7 umgestellt wurde, was so nur mit&nbsp;FastCGI geht. apache\_mod und FastCGI laufen aber als unterschiedliche User.  
Wenn also von apache\_mod auf FastCGI umgestellt wurde, müssen auch via KAS=\>FTP für alle Verzeichnisse und Dateien der Besitzer umgestellt werden, da SW sonst schlicht nicht in Cache, Web, Media etc. Verzeichnisse schreiben kann.

Bin ich von All-Inkl gar nicht gewohnt, dass so ein Unsinn verkündet wird.  
Da meine Shops schon immer unter FastCGI laufen, kann ich per KAS/htaccess munter die PHP-Versionen wechseln, ohne das etwas passiert.

Edit: Und wie brettvormkopp schrieb, kann Ioncube bei Verwendung von verschlüssleten Plugins zum Problem werden. Da müsste man dann vorher in der Doku von SW gucken, was man vorbereitend machen muss.

---

<div class="post-metadata">

**Author:** ![livaro2014](https://avatars.discourse-cdn.com/v4/letter/l/439d5e/32.png) [@livaro2014](https://forum.shopware.com/u/livaro2014)\
**Post date:** [20. Juli 2017 um 20:31 UTC](https://forum.shopware.com/t/php7-https-error-500/47034/7 "2017-07-20T20:31:01Z")

</div>

Hier die nächste Antwort von All-inkl.

Unseren Informationen bzw. Erfahrungen nach arbeitet Shopware aktuell noch nicht mit PHP 7 zusammen. Wenn Sie alle notwendigen Einstellungen vorgenommen haben, liegt es an Shopware selbst. Sie können sich auch gern an Shopware wenden bzw. probieren, ob die CGI-Variante zu 7.0 und 7.1. für Sie arbeitet.

&nbsp;

Welche PHP Version nutzt ihr?&nbsp;

Welchen Hoster könnt ihr empfehlen?

---

<div class="post-metadata">

**Author:** ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)\
**Post date:** [20. Juli 2017 um 20:46 UTC](https://forum.shopware.com/t/php7-https-error-500/47034/8 "2017-07-20T20:46:03Z")

</div>

> [@brettvormkopp schrieb:](https://forum.shopware.com/profile/6611/brettvormkopp "brettvormkopp")
> 
> Geht sogar mit php7.1, jedoch ist beim umstellen darauf zu achten, dass auch die IONCube version korrekt ist falls du z.B. verschlüsselte Plugins oder den Lizenzmanager installiert hast.

Welchen Ioncube Loader benutzt du denn für php 7.1?&nbsp;

---

<div class="post-metadata">

**Author:** ![brettvormkopp](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/brettvormkopp/32/7788_2.png) [@brettvormkopp](https://forum.shopware.com/u/brettvormkopp)\
**Post date:** [20. Juli 2017 um 21:09 UTC](https://forum.shopware.com/t/php7-https-error-500/47034/9 "2017-07-20T21:09:29Z")

</div>

> Welchen Ioncube Loader benutzt du denn für php 7.1?&nbsp;

Gar keinen IONCube. Verschlüsselte Plugins haben Hausverbot und werden ggf. unverschlüsselt vom Hersteller freundlich angefordert.

---

<div class="post-metadata">

**Author:** ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)\
**Post date:** [20. Juli 2017 um 21:13 UTC](https://forum.shopware.com/t/php7-https-error-500/47034/10 "2017-07-20T21:13:50Z")

</div>

Ah, okay, dann ist alles klar, danke!&nbsp; ![Wearing-Sunglasses](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/301eaa4db0af1251d93dae7904e5b71a4b15e729.png "Wearing-Sunglasses")

---

<div class="post-metadata">

**Author:** ![erhan27tr](https://avatars.discourse-cdn.com/v4/letter/e/f1d935/32.png) [@erhan27tr](https://forum.shopware.com/u/erhan27tr)\
**Post date:** [20. Juli 2017 um 23:23 UTC](https://forum.shopware.com/t/php7-https-error-500/47034/11 "2017-07-20T23:23:39Z")

</div>

Hast du dein PHP Zugriffrechte geprüft?

---

<div class="post-metadata">

**Author:** ![sonic](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sonic/32/25728_2.png) [@sonic](https://forum.shopware.com/u/sonic)\
**Post date:** [21. Juli 2017 um 06:25 UTC](https://forum.shopware.com/t/php7-https-error-500/47034/12 "2017-07-21T06:25:54Z")

</div>

Meine Meinung zum Problem:  
Wenn Du Dein Problem mit PHP7 bei All-Inkl. nicht selber gelöst bekommst - da sind nämlich keine - solltest Du Deinen Shop von jemanden mit Fachwissen aufsetzen und warten lassen. Es gibt genügend User im Forum, bei denen der Shop bei All-Inkl. ohne Probleme unter PHP 7 läuft. Es müssen halt nur die Besitzer- und Zugriffsrechte zur Umgebung passen (und ggf. der Verschlüsselungstrojaner IonCube geändert und die Plugins neu installiert werden) - und dafür benötigt man keinen All-Inkl.-Support.
