# Obskure Fehler nach 6.4.18.0 Neuinstallation

**URL:** <https://forum.shopware.com/t/obskure-fehler-nach-6-4-18-0-neuinstallation/97749>\
**Category:** Allgemein\
**Created:** [25. Dezember 2022 um 15:41 UTC](https://forum.shopware.com/t/obskure-fehler-nach-6-4-18-0-neuinstallation/97749 "2022-12-25T15:41:12Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![EricARM](https://avatars.discourse-cdn.com/v4/letter/e/8e7dd6/32.png) [@EricARM](https://forum.shopware.com/u/EricARM)\
**Post date:** [25. Dezember 2022 um 15:41 UTC](https://forum.shopware.com/t/obskure-fehler-nach-6-4-18-0-neuinstallation/97749/1 "2022-12-25T15:41:12Z")

</div>

Hallo!

Nach neuer Installation von SW 6.4.18.0 auf einem neuen Server treten an verschiedenen Stellen Fehler auf die vermutlich alle die selbe Ursache haben.

Z.B. beim Versuch der Shopware Store zu aktivieren:

 ![image](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/9/3/93becaf4ab507f54d70d7c937a2a142377ff2211.jpeg)

Beim Versuch den Migrations-Assistenten über den Ersteinrichtungs-Assistenten zu installieren:

```auto
Internal Server Error
Store signature validation failed. Error: Error during private key read:
error:1E08010C:DECODER routines::unsupported
error:0480006C:PEM routines::no start line
error:1E08010C:DECODER routines::unsupported
error:0480006C:PEM routines::no start line
error:1E08010C:DECODER routines::unsupported
error:0480006C:PEM routines::no start line
error:1E08010C:DECODER routines::unsupported
error:0480006C:PEM routines::no start line
error:0480006C:PEM routines::no start line
error:03000098:digital envelope routines::invalid digest

```

Ereignis Log zu diesen Fehlern

```auto
AxiosError: Request failed with status code 500

{
  "component": "Unknown component",
  "stack": "Unknown stack",
  "url": "https://lavinerie.de/admin#/sw/extension/my-extensions/account"
}

```

Hat vielleicht jemand eine Idee`?

Vielen Dank und schöne Feiertage!

Eric

---

<div class="post-metadata">

**Author:** ![EricARM](https://avatars.discourse-cdn.com/v4/letter/e/8e7dd6/32.png) [@EricARM](https://forum.shopware.com/u/EricARM)\
**Post date:** [25. Dezember 2022 um 17:12 UTC](https://forum.shopware.com/t/obskure-fehler-nach-6-4-18-0-neuinstallation/97749/2 "2022-12-25T17:12:53Z")

</div>

Hat sich schon erledigt 🙂

Ursache war wohl, dass RHEL9 basierte Betriebssysteme von default SHA-1 zu SHA-256 umgestellt wurden.

Stellt sich mir nun die Frage: nutzt denn niemand sowas? AlmaLinux9, etc?

---

<div class="post-metadata">

**Author:** ![dsc](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/dsc/32/19386_2.png) [@dsc](https://forum.shopware.com/u/dsc)\
**Post date:** [4. Januar 2023 um 10:06 UTC](https://forum.shopware.com/t/obskure-fehler-nach-6-4-18-0-neuinstallation/97749/3 "2023-01-04T10:06:35Z")

</div>

Vielleicht sei noch der Workaround für alle die erwähnt die, wie ich, hier landen und das Problem haben.  
Bei mir macht es sich beim Einrichtungsassistenten bei der Paypal Konfiguration bemerkbar.

OS: Rocky 9  
Shopware: 6.4.17.2

Workaround:

```auto
[root@shopware6-01 ~]# update-crypto-policies --set legacy

```

Danach funktioniert SHA-1 wieder, bis Shopware ein entsprechendes Update bereitstellt und man wieder folgendes machen kann:

```auto
[root@shopware6-01 ~]# update-crypto-policies --set default

```

Viel Erfolg!

---

<div class="post-metadata">

**Author:** ![lenniep](https://avatars.discourse-cdn.com/v4/letter/l/3ec8ea/32.png) [@lenniep](https://forum.shopware.com/u/lenniep)\
**Post date:** [3. Mai 2023 um 16:50 UTC](https://forum.shopware.com/t/obskure-fehler-nach-6-4-18-0-neuinstallation/97749/4 "2023-05-03T16:50:53Z")

</div>

Vielen Dank, das hat mir sehr geholfen =)
