# Neuer Artikel (und ein paar alte) Artikel führen auf Artikelseite zu 500er Seite

**URL:** <https://forum.shopware.com/t/neuer-artikel-und-ein-paar-alte-artikel-fuhren-auf-artikelseite-zu-500er-seite/71681>\
**Category:** Allgemein\
**Created:** [21. Dezember 2020 um 07:17 UTC](https://forum.shopware.com/t/neuer-artikel-und-ein-paar-alte-artikel-fuhren-auf-artikelseite-zu-500er-seite/71681 "2020-12-21T07:17:42Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![cnc4me](https://avatars.discourse-cdn.com/v4/letter/c/edb3f5/32.png) [@cnc4me](https://forum.shopware.com/u/cnc4me)\
**Post date:** [21. Dezember 2020 um 07:17 UTC](https://forum.shopware.com/t/neuer-artikel-und-ein-paar-alte-artikel-fuhren-auf-artikelseite-zu-500er-seite/71681/1 "2020-12-21T07:17:42Z")

</div>

Hallo zusammen,

ich habe gestern folgendes entdeckt:

- einige Artikelseiten sind nicht erreichbar (für mich sieht es noch fast zufällig aus - es sind alle Kategorien und (Nicht)-Variant-Artikel betroffen

- wenn ich einen neuen Artikel anlege (keine Varianten) und nur einen Titel, einen Preis und eine Kategorie eingebe, gibt diese Artikelseite ebenfalls eine 500 aus

- wenn ich eine betroffene Artikelseite aufrufe, ist der Server-Core zu 99 % ausgelastet und es gibt diesen Log-Eintrag: [Sun Dec 20 22:22:26.845916 2020] [fcgid:warn] [pid 5850:tid 140229121890048] (104)Connection reset by peer: [client 93.189.174.241:48360] mod\_fcgid: error reading data from FastCGI server [Sun Dec 20 22:22:26.845988 2020] [core:error] [pid 5850:tid 140229121890048] [client 93.189.174.241:48360] End of script output before headers: shopware.php

Ich verwende Shopware 5.6.9 (also alles Updates installiert).

Ich bin an dieser Stelle völlig ratlos, wenn sogar ein neuer, fast leerer Artikel nicht funktioniert. Hat jemand eine Idee, was ich noch ausprobieren könnte? Kann ich euch noch weitere, hilfreiche Informationen zusammensuchen?

Vielen Dank im Voraus für eure Hilfe!

Viele Grüße,

Tobias

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [21. Dezember 2020 um 10:58 UTC](https://forum.shopware.com/t/neuer-artikel-und-ein-paar-alte-artikel-fuhren-auf-artikelseite-zu-500er-seite/71681/2 "2020-12-21T10:58:28Z")

</div>

Hallo Tobias,

du kannst am besten einmal das erweiterte Errordebugging in der config.php aktivieren:&nbsp;[Shopware 5 - Tutorials & FAQs - Fehlermeldungen in Shopware debuggen](https://docs.shopware.com/de/shopware-5-de/tutorials-und-faq/fehlermeldungen-in-shopware-debuggen#erweitertes-error-debugging)

---

<div class="post-metadata">

**Author:** ![cnc4me](https://avatars.discourse-cdn.com/v4/letter/c/edb3f5/32.png) [@cnc4me](https://forum.shopware.com/u/cnc4me)\
**Post date:** [21. Dezember 2020 um 12:00 UTC](https://forum.shopware.com/t/neuer-artikel-und-ein-paar-alte-artikel-fuhren-auf-artikelseite-zu-500er-seite/71681/3 "2020-12-21T12:00:58Z")

</div>

Hallo Moritz,

vielen Dank für deine schnelle Reaktion. Ich habe in der config.php „`'showException' => true,`“ gesetzt.

Der Fehler im Browser bleibt unverändert. Unter /var/log gibt es kein neue Logdatei und auch unter „Einstellungen/Logfile“ wird kein neuer Log angelegt.

Viele Grüße, Tobias

---

<div class="post-metadata">

**Author:** ![cnc4me](https://avatars.discourse-cdn.com/v4/letter/c/edb3f5/32.png) [@cnc4me](https://forum.shopware.com/u/cnc4me)\
**Post date:** [22. Dezember 2020 um 16:41 UTC](https://forum.shopware.com/t/neuer-artikel-und-ein-paar-alte-artikel-fuhren-auf-artikelseite-zu-500er-seite/71681/4 "2020-12-22T16:41:06Z")

</div>

Ich habe noch eine Sache ausprobiert - ich habe das Template auf „Responsive“ zurückgestellt - das Resultat ist jedoch das gleiche. Kann jemand mit dem Log-Eintrag etwas anfangen?

Vielen Dank für eure Hilfe!

---

<div class="post-metadata">

**Author:** ![cnc4me](https://avatars.discourse-cdn.com/v4/letter/c/edb3f5/32.png) [@cnc4me](https://forum.shopware.com/u/cnc4me)\
**Post date:** [29. Dezember 2020 um 10:32 UTC](https://forum.shopware.com/t/neuer-artikel-und-ein-paar-alte-artikel-fuhren-auf-artikelseite-zu-500er-seite/71681/5 "2020-12-29T10:32:03Z")

</div>

Ich habe nun endlich die Ursache gefunden:

Es waren alle Artikel betroffen, die einen " Artikel bei Bestand \<= 0 nicht bestellbar " deaktiviert und keine Maximalabnahme definiert war. Dann hatte das Select-Feld für die Artikelanzahl 5000 Einträge - dann ist in der engine/Shopware/Components/Template/HtmlMinCompressor.php die Zeile " return preg\_replace(’#(?ix)(?\>[^\S  
\> ]\s\*|\s{2,})(?=(?:(?:[^ \> ?\>textarea|pre|script)\b|\z))#’, ’ ', $content);" explodiert. Wenn ich diese Zeile auskommentiert hatte, wurde die Artikelseite zwar geladen, aber der Browser abgestürzt, sobald ich eine Anzahl auswählen wollte.

Ich habe nun alle Artikel-Anzahl-Felder durch ein \<input type=„number“ … ersetzt.\>

Für mich sieht das so aus, als ob das ein Shopware-Bug wäre, oder?

Wo kann ich diesen Fehler reporten? Vielen Dank!

---

<div class="post-metadata">

**Author:** ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)\
**Post date:** [29. Dezember 2020 um 11:54 UTC](https://forum.shopware.com/t/neuer-artikel-und-ein-paar-alte-artikel-fuhren-auf-artikelseite-zu-500er-seite/71681/6 "2020-12-29T11:54:33Z")

</div>

[https://issues.shopware.com](https://issues.shopware.com)
