# Neue Version Migrationsassistent

**URL:** <https://forum.shopware.com/t/neue-version-migrationsassistent/60606>\
**Category:** Installation / Einstieg\
**Created:** [23. Juli 2019 um 10:53 UTC](https://forum.shopware.com/t/neue-version-migrationsassistent/60606 "2019-07-23T10:53:17Z")\
**Posts on this page:** 11\
**Page:** 1

<div class="post-metadata">

**Author:** ![Urs\_Landis](https://avatars.discourse-cdn.com/v4/letter/u/3be4f8/32.png) [@Urs\_Landis](https://forum.shopware.com/u/Urs_Landis)\
**Post date:** [23. Juli 2019 um 10:53 UTC](https://forum.shopware.com/t/neue-version-migrationsassistent/60606/1 "2019-07-23T10:53:17Z")

</div>

Ich habe gerade die neue Version des Migrationsassistenten PlugIns installiert. Nun ist meine Konfiguration weg. In der Datenbank noch vorhanden im BE aber weg.

Ist das so gewollt?

Grüsse

&nbsp;

---

<div class="post-metadata">

**Author:** ![Urs\_Landis](https://avatars.discourse-cdn.com/v4/letter/u/3be4f8/32.png) [@Urs\_Landis](https://forum.shopware.com/u/Urs_Landis)\
**Post date:** [23. Juli 2019 um 10:58 UTC](https://forum.shopware.com/t/neue-version-migrationsassistent/60606/2 "2019-07-23T10:58:54Z")

</div>

und eine neue Verbindung kann ich auch nicht anlegen, da kommt:

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/b/bfcc37c5d4e338e5cce68963be84369d76365053.png)

---

<div class="post-metadata">

**Author:** ![Urs\_Landis](https://avatars.discourse-cdn.com/v4/letter/u/3be4f8/32.png) [@Urs\_Landis](https://forum.shopware.com/u/Urs_Landis)\
**Post date:** [23. Juli 2019 um 11:03 UTC](https://forum.shopware.com/t/neue-version-migrationsassistent/60606/3 "2019-07-23T11:03:57Z")

</div>

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/2/220975e97414932b58ddaa5a6e3b3daa251b26fa.png) ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/f/fef4a683afc36e7c5b22ca593419eeaffe8a850e.png)

---

<div class="post-metadata">

**Author:** ![Urs\_Landis](https://avatars.discourse-cdn.com/v4/letter/u/3be4f8/32.png) [@Urs\_Landis](https://forum.shopware.com/u/Urs_Landis)\
**Post date:** [23. Juli 2019 um 11:05 UTC](https://forum.shopware.com/t/neue-version-migrationsassistent/60606/4 "2019-07-23T11:05:40Z")

</div>

1. {errors: [{code: “0”, status: “500”, title: “Internal Server Error”,…}]}
2. errors:&nbsp;[{code: “0”, status: “500”, title: “Internal Server Error”,…}]  
1. 0:&nbsp;{code: “0”, status: “500”, title: “Internal Server Error”,…}
  1. code:&nbsp;“0”
  2. detail:&nbsp;“Argument 9 passed to SwagMigrationAssistant\Migration\Run\RunService::\_\_construct() must implement interface Shopware\Core\Framework\DataAbstractionLayer\EntityRepositoryInterface, instance of Shopware\Core\Framework\DataAbstractionLayer\Indexing\MessageQueue\IndexerMessageSender given, called in /var/www/vhosts/neu.shoppet.ch/httpdocs/xyxyxy/var/cache/prod\_k6911cee2\_p525306e8/ContainerCmx2E7G/getRunServiceService.php on line 32”
  3. status:&nbsp;“500”
  4. title:&nbsp;“Internal Server Error”

---

<div class="post-metadata">

**Author:** ![Krispin](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/krispin/32/12849_2.png) [@Krispin](https://forum.shopware.com/u/Krispin)\
**Post date:** [23. Juli 2019 um 11:16 UTC](https://forum.shopware.com/t/neue-version-migrationsassistent/60606/5 "2019-07-23T11:16:07Z")

</div>

> [@aqula schrieb:](https://forum.shopware.com/profile/13809/aqula "aqula")
> 
> 1. {errors: [{code: „0“, status: „500“, title: „Internal Server Error“,…}]}
> 2. errors:&nbsp;[{code: „0“, status: „500“, title: „Internal Server Error“,…}]
> 3. 0:&nbsp;{code: „0“, status: „500“, title: „Internal Server Error“,…}
> 4. code:&nbsp;„0“
> 5. detail:&nbsp;„Argument 9 passed to SwagMigrationAssistant\Migration\Run\RunService::\_\_construct() must implement interface Shopware\Core\Framework\DataAbstractionLayer\EntityRepositoryInterface, instance of Shopware\Core\Framework\DataAbstractionLayer\Indexing\MessageQueue\IndexerMessageSender given, called in /var/www/vhosts/neu.shoppet.ch/httpdocs/xyxyxy/var/cache/prod\_k6911cee2\_p525306e8/ContainerCmx2E7G/getRunServiceService.php on line 32“
> 6. status:&nbsp;„500“
> 7. title:&nbsp;„Internal Server Error“

Bitte clear nochmal den Cache per Konsole.&nbsp;

---

<div class="post-metadata">

**Author:** ![Urs\_Landis](https://avatars.discourse-cdn.com/v4/letter/u/3be4f8/32.png) [@Urs\_Landis](https://forum.shopware.com/u/Urs_Landis)\
**Post date:** [23. Juli 2019 um 11:17 UTC](https://forum.shopware.com/t/neue-version-migrationsassistent/60606/6 "2019-07-23T11:17:41Z")

</div>

Habe den ganzen cache ordner schon gelöscht…

---

<div class="post-metadata">

**Author:** ![Urs\_Landis](https://avatars.discourse-cdn.com/v4/letter/u/3be4f8/32.png) [@Urs\_Landis](https://forum.shopware.com/u/Urs_Landis)\
**Post date:** [23. Juli 2019 um 11:30 UTC](https://forum.shopware.com/t/neue-version-migrationsassistent/60606/7 "2019-07-23T11:30:08Z")

</div>

Nochmals alles gelöscht, jetzt geht’s wieder!

---

<div class="post-metadata">

**Author:** ![Krispin](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/krispin/32/12849_2.png) [@Krispin](https://forum.shopware.com/u/Krispin)\
**Post date:** [23. Juli 2019 um 11:40 UTC](https://forum.shopware.com/t/neue-version-migrationsassistent/60606/8 "2019-07-23T11:40:21Z")

</div>

> [@aqula schrieb:](https://forum.shopware.com/profile/13809/aqula "aqula")
> 
> Nochmals alles gelöscht, jetzt geht’s wieder!

Okay… Was anderes hätte mich auch gewundert.&nbsp;

---

<div class="post-metadata">

**Author:** ![Urs\_Landis](https://avatars.discourse-cdn.com/v4/letter/u/3be4f8/32.png) [@Urs\_Landis](https://forum.shopware.com/u/Urs_Landis)\
**Post date:** [23. Juli 2019 um 12:01 UTC](https://forum.shopware.com/t/neue-version-migrationsassistent/60606/9 "2019-07-23T12:01:36Z")

</div>

Aber die Performance ist massiv schlechter mit der neuen Version, was vorher einige Sekunden/wenige Minuten gadauert hat läuft jetzt schon über 15 Minuten

---

<div class="post-metadata">

**Author:** ![Krispin](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/krispin/32/12849_2.png) [@Krispin](https://forum.shopware.com/u/Krispin)\
**Post date:** [23. Juli 2019 um 12:06 UTC](https://forum.shopware.com/t/neue-version-migrationsassistent/60606/10 "2019-07-23T12:06:17Z")

</div>

In der neuen Version wurde nur der Abschluss der Migration geändert, daher sollten die anderen Request nicht davon betroffen sein…  
Ist vielleicht ein Request-Fehler in der Chrome-Console?

---

<div class="post-metadata">

**Author:** ![japankoi](https://avatars.discourse-cdn.com/v4/letter/j/35a633/32.png) [@japankoi](https://forum.shopware.com/u/japankoi)\
**Post date:** [27. Oktober 2020 um 15:48 UTC](https://forum.shopware.com/t/neue-version-migrationsassistent/60606/11 "2020-10-27T15:48:19Z")

</div>

Hallo @Krispin‍,

wir haben die Community Edition v6.3.2.1 per Installer auf unserem Webspace installiert und wollten mit dem aktuellen Migrationsassistenten (v2.1.2) von Shopware 5 migrieren.  
Wir erhalten jedoch gleiche Fehlermeldung in unserem Browser und in der Browser-Konsole wenn wir eine Verbindung zum DB-System von Shopware 5 herstellen wollen. Cache leeren mithilfe der Shopware-Backend-Option und auch manuell des Inhaltes von Ordner /var/cache/ hat leider zu keiner Besserung beigetragen.

Fällt dir sonst noch ein, was ich probieren könnte?

Viele Grüße

EDIT: folgende Antwort steht im HTTP-Header auch noch "_An exception occurred in driver: SQLSTATE[HY000] [1203] User o755783 already has more than ‚max\_user\_connections‘ active connections"_  
Ich gehe deswegen von meinem Webspace-Anbieter als Fehlerursache aus.

EDIT 2: Habe gerade Shopware 6 bei einem anderen Anbieter aufgesetzt. Hier funktioniert die Einrichtung des Migrationsassistenten, auch wenn ich jetzt beim nächsten Problem hänge ([https://forum.shopware.com/discussion/65807/migrationsassistent-ueber-api-es-wurden-keine-daten-zum-migrieren-gefunden](https://forum.shopware.com/discussion/65807/migrationsassistent-ueber-api-es-wurden-keine-daten-zum-migrieren-gefunden))

Fazit: Ionos (1&1) scheint definitiv nicht der richtige Anbieter zu sein, um Shopware zu hosten 😃
