# Nach Update: Login von Bestandskunden nicht mehr möglich

**URL:** <https://forum.shopware.com/t/nach-update-login-von-bestandskunden-nicht-mehr-moglich/47075>\
**Category:** Installation/Einstieg\
**Created:** [23. Juli 2017 um 21:58 UTC](https://forum.shopware.com/t/nach-update-login-von-bestandskunden-nicht-mehr-moglich/47075 "2017-07-23T21:58:56Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![mvision](https://avatars.discourse-cdn.com/v4/letter/m/bc8723/32.png) [@mvision](https://forum.shopware.com/u/mvision)\
**Post date:** [23. Juli 2017 um 21:58 UTC](https://forum.shopware.com/t/nach-update-login-von-bestandskunden-nicht-mehr-moglich/47075/1 "2017-07-23T21:58:56Z")

</div>

Hallo,

ich habe folgendes Problem: nach einem Update von 5.1.5 auf 5.2.27 kann ich mich als voriger Bestandskunde nicht mehr einloggen. Es erscheint folgende Fehlermeldung:

```
Diese Seite funktioniert nicht

www.***.de kann diese Anfrage momentan nicht verarbeiten.
HTTP ERROR 500

```

Im Server-Error-Log erhalte ich:

```
[Sun Jul 23 21:35:40 2017] [-:error] [pid 15436] ***PHP Fatal error: Call to a member function getId() on null in***/engine/Shopware/Core/sAdmin.php on line 3296

```

Ich habe es auf zwei verschiedenen Servern ausprobiert - es taucht immer dieser Fehler auf.

Allerdings: nur bei Bestandskunden. Wenn ich mich als Neukunde anmelde, wieder auslogge und erneut einlogge klappt alles wunderbar.

Plugins hatte ich alle schon mal gelöscht, das hat aber auch nichts gebracht.

Wer hat eine Idee was das Problem sein könnte?

Vielen Dank schon mal und liebe Grüße

Miriam

---

<div class="post-metadata">

**Author:** ![JanineOverhausKocan](https://avatars.discourse-cdn.com/v4/letter/j/65b543/32.png) [@JanineOverhausKocan](https://forum.shopware.com/u/JanineOverhausKocan)\
**Post date:** [24. Juli 2017 um 08:48 UTC](https://forum.shopware.com/t/nach-update-login-von-bestandskunden-nicht-mehr-moglich/47075/2 "2017-07-24T08:48:25Z")

</div>

Hallo,

hattest du die Kunden irgendwann einmal aus einem anderen System migriert? Es kommt oft vor, dass hier dann andere Passwort-Encoder genutzt wurden. Um diese weiterhin zu nutzen muss zwingend immer die neueste Version des Migration-Plugins installiert und aktiv sein.

Ansonsten könntest du in den s\_user Tabellen in der Datenbank einmal ein Konto eines Bestandskunden mit einem neuen Kunden vergleichen und so feststellen, was hier unterschiedlich ist, das ist dann die Ursache.

Viele Grüße aus Schöppingen  
Janine

---

<div class="post-metadata">

**Author:** ![mvision](https://avatars.discourse-cdn.com/v4/letter/m/bc8723/32.png) [@mvision](https://forum.shopware.com/u/mvision)\
**Post date:** [24. Juli 2017 um 11:08 UTC](https://forum.shopware.com/t/nach-update-login-von-bestandskunden-nicht-mehr-moglich/47075/3 "2017-07-24T11:08:52Z")

</div>

Hallo Janine,

vielen Dank für den Tipp mit der s\_user Tabelle. Ich hatte mir die zwar schon mal angeschaut, mir war aber nicht sofort was aufgefallen. Da hätte ich mal genauer schauen sollen. Offenbar wurde die Spalte default\_shipping\_address\_id nicht befüllt (NULL) - warum auch immer. Nachdem ich nun die Daten von der default\_billing\_address\_id in die shipping übertragen habe funktioniert alles wie es soll.

Vielen Dank!!

Viele Grüße, Miriam
