# Nach Update kein Zugriff auf Kunden und Bestellungen

**URL:** <https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844>\
**Category:** Installation/Einstieg\
**Created:** [4. Juni 2019 um 09:36 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844 "2019-06-04T09:36:59Z")\
**Posts on this page:** 15\
**Page:** 1

<div class="post-metadata">

**Author:** ![drakon](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/drakon/32/7724_2.png) [@drakon](https://forum.shopware.com/u/drakon)\
**Post date:** [4. Juni 2019 um 09:36 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844/1 "2019-06-04T09:36:59Z")

</div>

Hallo,

nach dem Update auf SW 5.5.8 erhalte ich im BE keinen Zugriff mehr auf Kunden bzw. Bestellungen. Es wird ein 500er Fehler angezeigt wenn man entsprechende Menupunkte oder Links anklickt und das Laderädchen dreht sich unendlich. Alles andere im Frontend und im BE funktioniert fehlerfrei. Ich hab mal eine Fehlermeldung aus dem Server-Log hier rein kopiert:

```
23568 FastCGI sent in stderr: "PHP message: PHP Fatal error: Uncaught PDOException: SQLSTATE[23000]: Integrity constraint violation: 1048 Column 'value' cannot be null in ../engine/Library/Zend/Db/Statement/Pdo.php:219
Stack trace:
#0 ../engine/Library/Zend/Db/Statement/Pdo.php(219): PDOStatement->execute(Array)
#1 ../engine/Library/Zend/Db/Statement.php(297): Zend_Db_Statement_Pdo->_execute(Array)
#2 ../engine/Library/Zend/Db/Adapter/Abstract.php(470): Zend_Db_Statement->execute(Array)
#3 ../engine/Library/Zend/Db/Adapter/Pdo/Abstract.php(232): Zend_Db_Adapter_Abstract->query('INSERT INTO `s_...', Array)
#4 ../engine/Library/Enlight/Components/Db/Adapter/Pdo/Mysql.php(85): Zend_Db_Adapter_Pdo_Abstract->query('INSERT INTO `s_...', Array)
#5 ../engine/Library/Zend/Db/Adapter/Abstract.php(" while reading response header from upstream, client: 2.204.123.9, server: drak.de, request: "GET ../backend/Customer/loadStores?_dc=1559637520194&page=1&start=0&limit=25 HTTP/2.0", upstream: "fastcgi://unix:/var/lib/php5-fpm/web5.sock:", host: "www.example.tld", referrer: "https://www.example.tld/backend/"

```

Wer kennt den Fehler und wichtiger die Lösung oder kann sonst helfen?

&nbsp;

PHP 7.0 / 7.1 / 7.2 ändert nichts / NGINX - Timmehosting  
Die Aktivierung des Sicherheitsmodus im Pluginmanager beseitigt den Fehler ebenfalls nicht - es sollte also nicht an einem der installierten Plugins liegen.

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [4. Juni 2019 um 09:44 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844/2 "2019-06-04T09:44:25Z")

</div>

Ich glaube nicht, dass die Fehlermeldung etwas mit dem Problem zu tun hat.

Schau am besten mal in der Netzwerkübersicht deines Browsers, ob da ein bestimmter Request fehlschlägt (meistens rot dargestellt).

---

<div class="post-metadata">

**Author:** ![drakon](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/drakon/32/7724_2.png) [@drakon](https://forum.shopware.com/u/drakon)\
**Post date:** [4. Juni 2019 um 10:01 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844/3 "2019-06-04T10:01:33Z")

</div>

Hallo,

ok, es wird die folgnde Zeile rot dargestellt:

loadStores?\_dc=1559642291898&orderId=34107&page=1&start=0&limit=25

Request URL: [https://www.example.tld/backend/Order/loadStores?\_dc=1559642291898&orderId=XXXXX&page=1&start=0&limit=25](https://www.example.tld/backend/Order/loadStores?_dc=1559642291898&orderId=XXXXX&page=1&start=0&limit=25)

&nbsp;

Wie bringt mich das jetzt der Ursache näher bzw. was muss ich mir dazu anschauen?

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [4. Juni 2019 um 10:07 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844/4 "2019-06-04T10:07:31Z")

</div>

Da im Netzwerktab muss es auch einen Reiter für „Antwort/Response“ geben. Steht da eine Fehlermeldung drin?  
Alternativ, wenn das einfach leer ist und garnichts drin steht, müsste man mal die Fehlerausgabe aktivieren und dann nochmal schauen:&nbsp;[Shopware 5 - Tutorials & FAQs - Fehlermeldungen in Shopware debuggen](https://docs.shopware.com/de/shopware-5-de/tutorials-und-faq/fehlermeldungen-in-shopware-debuggen#erweitertes-error-debugging)

&nbsp;

&nbsp;

&nbsp;

---

<div class="post-metadata">

**Author:** ![drakon](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/drakon/32/7724_2.png) [@drakon](https://forum.shopware.com/u/drakon)\
**Post date:** [4. Juni 2019 um 10:17 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844/5 "2019-06-04T10:17:03Z")

</div>

Hallo,

mit aktivierter Fehlerausgabe bekomme ich als Response das was ich oben zitiert habe.

---

<div class="post-metadata">

**Author:** ![hth](https://avatars.discourse-cdn.com/v4/letter/h/b77776/32.png) [@hth](https://forum.shopware.com/u/hth)\
**Post date:** [4. Juni 2019 um 10:23 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844/6 "2019-06-04T10:23:11Z")

</div>

Die Seite ist komplett offline?&nbsp; Erst nachdem Du debug aktiviert und Caches geleert hast?

&nbsp;

---

<div class="post-metadata">

**Author:** ![drakon](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/drakon/32/7724_2.png) [@drakon](https://forum.shopware.com/u/drakon)\
**Post date:** [4. Juni 2019 um 10:28 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844/7 "2019-06-04T10:28:44Z")

</div>

> Die Seite ist komplett offline?&nbsp; Erst nachdem Du debug aktiviert und Caches geleert hast?

??? Nix ist offline, wie bereits geschrieben&nbsp;funktioniert alles andere bestens.&nbsp;Frontend und der Rest vom Backend.

---

<div class="post-metadata">

**Author:** ![hth](https://avatars.discourse-cdn.com/v4/letter/h/b77776/32.png) [@hth](https://forum.shopware.com/u/hth)\
**Post date:** [4. Juni 2019 um 10:35 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844/8 "2019-06-04T10:35:16Z")

</div>

Also bei mir sehr wohl: 500er Errror

---

<div class="post-metadata">

**Author:** ![drakon](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/drakon/32/7724_2.png) [@drakon](https://forum.shopware.com/u/drakon)\
**Post date:** [4. Juni 2019 um 10:53 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844/9 "2019-06-04T10:53:22Z")

</div>

Hallo,

mein Fehler, hab beim Einfügen der Fehlerausgabe einen Typo eingebaut.

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [4. Juni 2019 um 10:56 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844/10 "2019-06-04T10:56:20Z")

</div>

Von welcher Version ausgehend hast du denn aktualisiert?  
Die Fehlermeldung selbst bringt uns hier aktuell wenig weiter.

---

<div class="post-metadata">

**Author:** ![drakon](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/drakon/32/7724_2.png) [@drakon](https://forum.shopware.com/u/drakon)\
**Post date:** [4. Juni 2019 um 11:00 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844/11 "2019-06-04T11:00:37Z")

</div>

Hallo Moritz,

auf jeden Fall danke für Deine Hilfe, egal was dabei raus kommt.

Das Update war von der letzten 5.4.er Version (die lief meines Wissens fehlerfrei) auf jetzt SW 5.5.8

&nbsp;

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [4. Juni 2019 um 11:08 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844/12 "2019-06-04T11:08:28Z")

</div>

Magst du mir mal einen Backend-Zugang an [forum@shopware.com](mailto:forum@shopware.com) schicken? Dann schau ich da mal rein.

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [4. Juni 2019 um 12:28 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844/13 "2019-06-04T12:28:53Z")

</div>

Ich habe die Ursache bei @drakon‍ finden können.

In der s\_core\_states gab es verschiedene Bestell- und Zahlungsstatus mit einem Wert „NULL“ im Feld „Name“. Das Feld Name ist allerdings zwingend notwendig für die Ausgabe der Übersetzungen der jeweiligen Statusnamen. Ich habe dies in der Datenbank einmal korrigiert und danach funktionierte auch das Modul direkt wieder.

---

<div class="post-metadata">

**Author:** ![drakon](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/drakon/32/7724_2.png) [@drakon](https://forum.shopware.com/u/drakon)\
**Post date:** [4. Juni 2019 um 12:35 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844/14 "2019-06-04T12:35:21Z")

</div>

Hallo Moritz,

Du bist mein Held des heutigen Tages!

Davon hatte ich schon mal im Forum gelesen, meine ich. Aber nie im Leben wäre ich da von alleine drauf gekommen.

Weiss man, was das verursacht hat, oder ist das einfach ein alter Datenstand (immerhin hat der Shop als SW 4.x angefangen)?

&nbsp;

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [4. Juni 2019 um 13:14 UTC](https://forum.shopware.com/t/nach-update-kein-zugriff-auf-kunden-und-bestellungen/59844/15 "2019-06-04T13:14:57Z")

</div>

Ist natürlich schwer zu sagen, an was das jetzt konkret lag.

Ich glaube 2 davon wurden manuell oder durch ein Plugin erstellt. Es ist auch nicht auszuschließen, dass die Basis in SW4 mal eine andere war.
