# Nach Update 5.12 auf aktuelle version kein Backend +Frontend mehr

**URL:** <https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505>\
**Category:** Installation/Einstieg\
**Created:** [2. Januar 2017 um 08:11 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505 "2017-01-02T08:11:54Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![madunus](https://avatars.discourse-cdn.com/v4/letter/m/ecae2f/32.png) [@madunus](https://forum.shopware.com/u/madunus)\
**Post date:** [2. Januar 2017 um 08:11 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/1 "2017-01-02T08:11:54Z")

</div>

Hallo

Hat jemand eine Ideen warum das Update fehlschlägt und mein Shop nicht mehr erreichbar ist.

&nbsp;

folgende Fehlermeldung habe ich erhalten.

&nbsp;

Auch eine Rücksicherung war nicht erfolgreich.

&nbsp;

ERROR

**Message:**

```
 exception 'RuntimeException' with message 'SplFileInfo::getSize(): stat failed for /var/www/vhosts/hydraulikdichtungsshop-online.de/httpdocs/files/update\_7d08ac622c6d7db60effa7d02470749534e3cc42.zip.part' in /var/www/vhosts/hydraulikdichtungsshop-online.de/httpdocs/engine/Shopware/Plugins/Default/Backend/SwagUpdate/Components/Download.php:212

 Stack trace:

 #0 /var/www/vhosts/hydraulikdichtungsshop-online.de/httpdocs/engine/Shopware/Plugins/Default/Backend/SwagUpdate/Components/Download.php(212): SplFileInfo-\>getSize()

 #1 /var/www/vhosts/hydraulikdichtungsshop-online.de/httpdocs/engine/Shopware/Plugins/Default/Backend/SwagUpdate/Components/Steps/DownloadStep.php(76): ShopwarePlugins\SwagUpdate\Components\Download-\>downloadFile('http://releases...', '/var/www/vhosts...', '33252957', '7d08ac622c6d7db...')

 #2 /var/www/vhosts/hydraulikdichtungsshop-online.de/httpdocs/engine/Shopware/Plugins/Default/Backend/SwagUpdate/Controllers/Backend/SwagUpdate.php(326): ShopwarePlugins\SwagUpdate\Components\Steps\DownloadStep-\>run('0')

 #3 /var/www/vhosts/hydraulikdichtungsshop-online.de/httpdocs/engine/Library/Enlight/Controller/Action.php(158): Shopware\_Controllers\_Backend\_SwagUpdate-\>downloadAction()

 #4 /var/www/vhosts/hydraulikdichtungsshop-online.de/httpdocs/engine/Library/Enlight/Controller/Dispatcher/Default.php(523): Enlight\_Controller\_Action-\>dispatch('downloadAction')

 #5 /var/www/vhosts/hydraulikdichtungsshop-online.de/httpdocs/engine/Library/Enlight/Controller/Front.php(226): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp))

 #6 /var/www/vhosts/hydraulikdichtungsshop-online.de/httpdocs/engine/Shopware/Kernel.php(153): Enlight\_Controller\_Front-\>dispatch()

 #7 /var/www/vhosts/hydraulikdichtungsshop-online.de/httpdocs/vendor/symfony/http-kernel/HttpCache/HttpCache.php(492): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)

 #8 /var/www/vhosts/hydraulikdichtungsshop-online.de/httpdocs/engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)

 #9 /var/www/vhosts/hydraulikdichtungsshop-online.de/httpdocs/vendor/symfony/http-kernel/HttpCache/HttpCache.php(263): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true)

 #10 /var/www/vhosts/hydraulikdichtungsshop-online.de/httpdocs/engine/Shopware/Components/HttpCache/AppCache.php(103): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true)

 #11 /var/www/vhosts/hydraulikdichtungsshop-online.de/httpdocs/shopware.php(101): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request))

 #12 {main}

```

**Time:**

```
 2017-01-01T12:34:30.304434+0100

```

**Channel:**

```
 core

```

**request:**

```
 {

 &nbsp;&nbsp;&nbsp; "uri": "/backend/SwagUpdate/download?\_dc=1483270470277&offset=0",

 &nbsp;&nbsp;&nbsp; "method": "GET",

 &nbsp;&nbsp;&nbsp; "query": {

 &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "\_dc": "1483270470277",

 &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "offset": "0",

 &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "module": "backend",

 &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "controller": "SwagUpdate",

 &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp; "action": "download"

 &nbsp;&nbsp;&nbsp; },

 &nbsp;&nbsp;&nbsp; "post": []

 }

```

**session:**

```
 {

 &nbsp;&nbsp;&nbsp; "userId": "48",

 &nbsp;&nbsp;&nbsp; "roleId": "1"

 }

```

**shop:**

```
 No shop data available
```

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [2. Januar 2017 um 14:31 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/2 "2017-01-02T14:31:55Z")

</div>

Kannst Du mal schauen, ob Du noch genug freien Festplattenplatz hast oder ob sie vollgelaufen ist?

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)

---

<div class="post-metadata">

**Author:** ![madunus](https://avatars.discourse-cdn.com/v4/letter/m/ecae2f/32.png) [@madunus](https://forum.shopware.com/u/madunus)\
**Post date:** [2. Januar 2017 um 16:29 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/3 "2017-01-02T16:29:19Z")

</div>

Nein das ist es nicht, da sind noch 85% Kapazität frei

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [3. Januar 2017 um 11:45 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/4 "2017-01-03T11:45:36Z")

</div>

Ich würde vorschlagen mal das Update per Browser zu machen - also Updatesatz per FTP hochladen. Wie es geht steht auf der Download-Seite von Shopware.

Ansonsten ggf. Hinweise zum jeweiligen Update beachten.

&nbsp;

---

<div class="post-metadata">

**Author:** ![madunus](https://avatars.discourse-cdn.com/v4/letter/m/ecae2f/32.png) [@madunus](https://forum.shopware.com/u/madunus)\
**Post date:** [3. Januar 2017 um 12:16 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/5 "2017-01-03T12:16:19Z")

</div>

Ich denke es hat damit zu tun ?

&nbsp;

 ![https://i.imgur.com/BsSJITU.png](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/44ffe2324caf36b9ad117de8781a5014aa24230f.jpeg)

---

<div class="post-metadata">

**Author:** ![useg](https://avatars.discourse-cdn.com/v4/letter/u/df705f/32.png) [@useg](https://forum.shopware.com/u/useg)\
**Post date:** [3. Januar 2017 um 12:24 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/6 "2017-01-03T12:24:23Z")

</div>

[https://www.google.de/#q=update+shopware+duplicate+entry](https://www.google.de/#q=update+shopware+duplicate+entry)

---

<div class="post-metadata">

**Author:** ![madunus](https://avatars.discourse-cdn.com/v4/letter/m/ecae2f/32.png) [@madunus](https://forum.shopware.com/u/madunus)\
**Post date:** [3. Januar 2017 um 15:10 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/7 "2017-01-03T15:10:04Z")

</div>

So nun habe ich nochmal alles per ftp hochgeladen.

&nbsp;

Weiter wie zu diesem Punkt komme ich aber nicht.

&nbsp;

Error

Please try to fix this error and restart the update.

Response

```
 "ERROR: SQLSTATE[HY000] [2002] php\_network\_getaddresses: getaddrinfo failed: Name or service not known"

```

&nbsp;

&nbsp;

&nbsp;

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [3. Januar 2017 um 16:32 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/8 "2017-01-03T16:32:16Z")

</div>

Wenn Du Zugriff auf die Kommandozeile hast, prüfe mal bitte, ob der Server die Domain/den Hostnamen auflösen kann:

dig [www.deinedomain.de](http://www.deinedomain.de)

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)

---

<div class="post-metadata">

**Author:** ![madunus](https://avatars.discourse-cdn.com/v4/letter/m/ecae2f/32.png) [@madunus](https://forum.shopware.com/u/madunus)\
**Post date:** [4. Januar 2017 um 07:18 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/9 "2017-01-04T07:18:04Z")

</div>

Hallo

&nbsp;

Nun bin ich soweit mein Shopware neu aufzusetzen. Ist vielleicht das beste um einige Fehler auszumerzen

Genügt es die Datenbank auf dem Server zu löschen,. Shopware neu zu installieren und eine gesicherte Datenbank wieder einzuspielen?

Gehen da irgendwelche Einstellungen verloren ?

Ist es besser die Daten auf dem Server zu entpacken oder entpackt per FTP auf den Server zu schieben?

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [4. Januar 2017 um 13:29 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/10 "2017-01-04T13:29:38Z")

</div>

> php\_network\_getaddresses: getaddrinfo failed: Name or service not known

Mit dieser Fehlermeldung ist eine Neuinstallation zeitverschwendung. Diese Meldung muss beim Server erst behoben werden.&nbsp;

---

<div class="post-metadata">

**Author:** ![madunus](https://avatars.discourse-cdn.com/v4/letter/m/ecae2f/32.png) [@madunus](https://forum.shopware.com/u/madunus)\
**Post date:** [4. Januar 2017 um 14:49 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/11 "2017-01-04T14:49:17Z")

</div>

&nbsp;

&nbsp;

Das hat sich schon wieder geändert. (Siehe unten)

Ich möchte aber den Weg der Neuinstallation gehen um andere Fehler die schon länger bestehen und noch vermutlich aus der 4er Version sind auszumerzen)

&nbsp;

&nbsp;\>\>\>\>\>\>Nun bin ich soweit mein Shopware neu aufzusetzen. Ist vielleicht das beste um einige Fehler auszumerzen

Genügt es die Datenbank auf dem Server zu löschen,. Shopware neu zu installieren und eine gesicherte Datenbank wieder einzuspielen?

Gehen da irgendwelche Einstellungen verloren ?

Ist es besser die Daten auf dem Server zu entpacken oder entpackt per FTP auf den Server zu schieben?&nbsp;&nbsp; \<\<\<\<\<\<

&nbsp;

Error

Received the following error message:  
Could not apply migration: SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name ‘default\_shipping\_address\_id’

Please try to fix this error and restart the update.

Response

```
 {"valid":false,"errorMsg":"Could not apply migration: SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name 'default\_shipping\_address\_id'"}
```

---

<div class="post-metadata">

**Author:** ![steinsoftware](https://avatars.discourse-cdn.com/v4/letter/s/b487fb/32.png) [@steinsoftware](https://forum.shopware.com/u/steinsoftware)\
**Post date:** [4. Januar 2017 um 15:44 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/12 "2017-01-04T15:44:45Z")

</div>

Nein, das geht so nicht. Daten von zwei verschiedenen Datenbankstrukturen (vor und nach dem update) problemlos einspielen.Außerdem hat er ja Teile des Updates schon durchgeführt, andere nicht. Auch bei Backup-Einspielungen muss die komplette Datenbank gelöscht werden und DANACH das Backup eingespielt werden. Am besten die Dateien erst auf dem Server entpacken.

Die erste Fehlermeldung deutet darauf hin, dass in der media album Tabelle bereits ein Album mit der id -13 existiert. Diese id -13 wird ab Shopware 5 vom Papierkorb-Album besetzt. Für eigene Alben (oder generell eigene Einträge) sollte man IMMER positive IDs nehmen, damit Core-Änderungen ohne Probleme greifen.

&nbsp;

---

<div class="post-metadata">

**Author:** ![madunus](https://avatars.discourse-cdn.com/v4/letter/m/ecae2f/32.png) [@madunus](https://forum.shopware.com/u/madunus)\
**Post date:** [4. Januar 2017 um 15:51 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/13 "2017-01-04T15:51:15Z")

</div>

Ich nehme natürlich meine vor 2 Wochen gesicherten Daten als alles noch auf der Version 5.12 war und funktionierte. Die Datenbank wo ich schon das Update aufgespielt habe bleibt natürlich aussen vor.

---

<div class="post-metadata">

**Author:** ![steinsoftware](https://avatars.discourse-cdn.com/v4/letter/s/b487fb/32.png) [@steinsoftware](https://forum.shopware.com/u/steinsoftware)\
**Post date:** [4. Januar 2017 um 15:59 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/14 "2017-01-04T15:59:07Z")

</div>

Naja die letzte Fehlermeldung erscheint halt in der Regel dann, wenn man eine Datenbank Updaten möchte die schon (teilweise) Upgedatet ist.

---

<div class="post-metadata">

**Author:** ![madunus](https://avatars.discourse-cdn.com/v4/letter/m/ecae2f/32.png) [@madunus](https://forum.shopware.com/u/madunus)\
**Post date:** [4. Januar 2017 um 16:02 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/15 "2017-01-04T16:02:51Z")

</div>

Das kann ich ausschliessen.

Ich habe von 4… auf 5.12 upgedatet vor ca. 9 Monaten. Danach wurde nichts mehr gemacht

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [4. Januar 2017 um 16:24 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/16 "2017-01-04T16:24:35Z")

</div>

Die Spalte gibt es aber erst ab 5.2 - du hast also definitiv einen mischstand. Gibt hier im Forum auch Threads dazu mit Lösungswegen.

---

<div class="post-metadata">

**Author:** ![madunus](https://avatars.discourse-cdn.com/v4/letter/m/ecae2f/32.png) [@madunus](https://forum.shopware.com/u/madunus)\
**Post date:** [4. Januar 2017 um 18:02 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/17 "2017-01-04T18:02:29Z")

</div>

Ich habe die Treads verfolgt aber keine Lösung gefunden. Definitiv habe ich keine 5.2 er Version draufgehabt.

Da gibt es in den Diskussionen viele die das ähnlich geschildert haben und die gleichen oder ähjnliche r Probleme geschilödert haben.

Die meisten waren sich sicher keine 5.2 er Version draufgehabt zu haben.

&nbsp;

Meine Frage ist ja nur,ob ich wenn ich Shopware neu installiere und die Datenbank von der 5.12er Version einspiele ob das im Normalfall funktioniert.

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [4. Januar 2017 um 19:28 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/18 "2017-01-04T19:28:37Z")

</div>

Nein, weil deine Datenbank ja schon defekt ist und keinen 5.1-Stand mehr hat.  
Bei allen anderen hier im Forum war das Problem, dass die nach einem fehlerhaften Update ein Backup eingespielt haben und dann einen Mischstand der Datenbank hatten. Fixes dazu gibt es hier zahlreiche.

Hier eigentlich ein identisches Thema: [https://forum.shopware.com/discussion/comment/170022/#Comment\_170022](https://forum.shopware.com/discussion/comment/170022/#Comment_170022)

---

<div class="post-metadata">

**Author:** ![madunus](https://avatars.discourse-cdn.com/v4/letter/m/ecae2f/32.png) [@madunus](https://forum.shopware.com/u/madunus)\
**Post date:** [5. Januar 2017 um 10:22 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/19 "2017-01-05T10:22:53Z")

</div>

Komisch ist nur dass ich diese Datei&nbsp; mit PHP My admin nicht finde.

Also dürfte sie auch nicht vorhanden sein.

---

<div class="post-metadata">

**Author:** ![madunus](https://avatars.discourse-cdn.com/v4/letter/m/ecae2f/32.png) [@madunus](https://forum.shopware.com/u/madunus)\
**Post date:** [5. Januar 2017 um 12:40 UTC](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505/20 "2017-01-05T12:40:57Z")

</div>

```
 Das ist nun der aktuelle Stand. Per Kommandozeile wir der Hostnamen aber aufgelöst "ERROR: SQLSTATE[HY000] [2002] php\_network\_getaddresses: getaddrinfo failed: Name or service not known"

```

&nbsp;

&nbsp;

&nbsp;

[Nächste Seite](https://forum.shopware.com/t/nach-update-5-12-auf-aktuelle-version-kein-backend-frontend-mehr/42505.md?page=2)
