# Nach erstellung neuer Artikel Fehlermeldung:

**URL:** <https://forum.shopware.com/t/nach-erstellung-neuer-artikel-fehlermeldung/31685>\
**Category:** Shopware 3.5\
**Tags:** general\
**Created:** [26. Oktober 2015 um 21:01 UTC](https://forum.shopware.com/t/nach-erstellung-neuer-artikel-fehlermeldung/31685 "2015-10-26T21:01:29Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![DLZE24](https://avatars.discourse-cdn.com/v4/letter/d/f05b48/32.png) [@DLZE24](https://forum.shopware.com/u/DLZE24)\
**Post date:** [26. Oktober 2015 um 21:01 UTC](https://forum.shopware.com/t/nach-erstellung-neuer-artikel-fehlermeldung/31685/1 "2015-10-26T21:01:29Z")

</div>

Hallo, unsere Kunden wollen zum Anmelden und bekommen dies zu sehen: Fatal error: Class ‘sOrder’ not found in /var/www/clients/client1/web2/web/engine/Shopware/Proxies/sOrderProxy.php on line 2 Fatal error: Undefined class constant ‘PRIMARY\_TYPE\_NUM’ in /var/www/clients/client1/web2/web/engine/Enlight/Vendor/Zend/library/Zend/Session/SaveHandler/DbTable.php on line 522 Was kann das sein?

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [26. Oktober 2015 um 21:07 UTC](https://forum.shopware.com/t/nach-erstellung-neuer-artikel-fehlermeldung/31685/2 "2015-10-26T21:07:06Z")

</div>

Hallo, geht das sicher um Shopware 4? Das sieht irgendwie nach Anpassung der Core Klassen aus. Evtl. über die Datenbank in der s\_core\_factory, wie das bei Shopware 2 und 3 möglich war. Ist das jetzt ganz neu aufgetreten oder wurde irgendwas gemacht? Das steht ja, dass die Core Klasse sOrder fehlt. Hast du den ganzen Cache einmal manuell gelöscht, so dass die Proxies neu aufgebaut werden können? Sebastian PS: evtl. ist was am Server geändert worden? PHP Version nicht mehr passend

---

<div class="post-metadata">

**Author:** ![DLZE24](https://avatars.discourse-cdn.com/v4/letter/d/f05b48/32.png) [@DLZE24](https://forum.shopware.com/u/DLZE24)\
**Post date:** [26. Oktober 2015 um 21:10 UTC](https://forum.shopware.com/t/nach-erstellung-neuer-artikel-fehlermeldung/31685/3 "2015-10-26T21:10:45Z")

</div>

Ist Shopware 3.5.6. Cache ist komplett geleert. Habe nur neue Artikel erstellt.

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [26. Oktober 2015 um 21:13 UTC](https://forum.shopware.com/t/nach-erstellung-neuer-artikel-fehlermeldung/31685/4 "2015-10-26T21:13:23Z")

</div>

Hi, dann verschiebe ich den Post. Mit Cache meine ich auch die Proxies. Siehst du ja in der URL. Den Inhalt des Proxies Ordners löschen. Den baut Shopware auch dynamisch auf. Durch einen Artikel kann da so eigentlich gar nicht passieren. Evtl. ist der Cache dadurch aktualisiert worden und dann erst aufgefallen. Ursache muss da was anderes sein Nachtrag: mögliche Ursache In der Vergangenheit könnte das auch Plugins verursachen. Mit dem Abend Framework könnte es auch bei bestimmten PHP Versionen Probleme geben. Zusätzlich wird die Datei und Zeile genannt. Da reinsehen sollte ebenfalls helfen. Sebastian

---

<div class="post-metadata">

**Author:** ![DLZE24](https://avatars.discourse-cdn.com/v4/letter/d/f05b48/32.png) [@DLZE24](https://forum.shopware.com/u/DLZE24)\
**Post date:** [26. Oktober 2015 um 21:39 UTC](https://forum.shopware.com/t/nach-erstellung-neuer-artikel-fehlermeldung/31685/5 "2015-10-26T21:39:23Z")

</div>

Ok, da der leerung des Proxies Ordner geht es wieder. Vielen Dank!
