# Migrationsfehler - Entity: order\_custom\_field

**URL:** https://forum.shopware.com/t/migrationsfehler-entity-order-custom-field/98121
**Category:** Installation / Einstieg
**Created:** [21. Januar 2023 um 11:23 UTC](https://forum.shopware.com/t/migrationsfehler-entity-order-custom-field/98121 "2023-01-21T11:23:35Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Mercator](https://avatars.discourse-cdn.com/v4/letter/m/e95f7d/32.png) [@Mercator](https://forum.shopware.com/u/Mercator)
#### Post date: [21. Januar 2023 um 11:23 UTC](https://forum.shopware.com/t/migrationsfehler-entity-order-custom-field/98121/1 "2023-01-21T11:23:35Z")

</div>

Hallo zusammen

Ich beisse mir an folgendem Migrationsfehler gerade etwas die Zähne aus.

```auto
[error] SWAG_MIGRATION_RUN_EXCEPTION
An exception occurred
Entity: order_custom_field, sourceId: 4ff01d7663c149129a59ca106fd7ec65
An exception occurred while executing 'INSERT INTO `custom_field` (`id`, `set_id`, `name`, `type`, `config`, `created_at`) VALUES ('~Z-MKRP','.efWA$h','migration_SW5nachSW6_order_attribute6','text','{\"componentName\":\"sw-field\",\"label\":{\"de-DE\":\"attribute6\"},\"helpText\":{\"de-DE\":null},\"placeholder\":{\"de-DE\":null},\"type\":\"text\",\"customFieldType\":\"text\"}','2023-01-20 13:57:34.033');':SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'migration_SW5nachSW6_order_attribute6' for key 'uniq.custom_field.name'

```

Ich habe so überhaupt keine Anhaltspunkte in welcher Tabelle/Feld genau der Fehler sein soll. Hat mir da jemand einen Tipp?

Besten Dank im Voraus  
LG

---

<div class="post-metadata">

### Author: ![Max\_Shop](https://avatars.discourse-cdn.com/v4/letter/m/58f4c7/32.png) [@Max\_Shop](https://forum.shopware.com/u/Max_Shop)
#### Post date: [21. Januar 2023 um 17:47 UTC](https://forum.shopware.com/t/migrationsfehler-entity-order-custom-field/98121/2 "2023-01-21T17:47:15Z")

</div>

Die Migration versucht in die Tabelle custom\_field den Wert migration\_SW5nachSW6\_order\_attribute6 einzutragen, der dort schon drin steht.

Wieso das passiert kann ich dir leider nicht sagen. Vermutlich darf es ein attribute6 nicht mehrmals geben (ist geraten).

---

<div class="post-metadata">

### Author: ![grelf111](https://avatars.discourse-cdn.com/v4/letter/g/91b2a8/32.png) [@grelf111](https://forum.shopware.com/u/grelf111)
#### Post date: [23. Januar 2023 um 10:08 UTC](https://forum.shopware.com/t/migrationsfehler-entity-order-custom-field/98121/3 "2023-01-23T10:08:07Z")

</div>

> [@Mercator](#):
>
> `1062 Duplicate entry for key 'uniq.custom_field.name'`

Die Migration versucht aus den Custom Fields einen eindeutigen Namen (uniq) zu machen.  
In den Custom Fields von deiner SW5 Installation ist das nicht eindeutig und fällt auf die Nase.  
Also in der entsprechenden Attribute Tabelle (Orders?) suchen und anpassen.

---

<div class="post-metadata">

### Author: ![Mercator](https://avatars.discourse-cdn.com/v4/letter/m/e95f7d/32.png) [@Mercator](https://forum.shopware.com/u/Mercator)
#### Post date: [25. Januar 2023 um 13:55 UTC](https://forum.shopware.com/t/migrationsfehler-entity-order-custom-field/98121/4 "2023-01-25T13:55:21Z")

</div>

@grelf111 @Max_Shop Herzlichen Dank Euch beiden. Ich weiss jetzt das beim Import von XtCommerce nach Shopware 5 offenbar der MwSt Satz nicht übernommen wird. Weshalb ist mir ein Rätsel. Ich habe schon alles mögliche Überprüft:

- Mwst. bei den Versandkosten eingetragen und Länder (Schweiz, Liechtenstein) freigeschaltet
- MwSt. bei den Zahlungsarten kontrolliert und Länder (Schweiz, Liechtenstein) freigeschaltet  
Grundeinstellungen:
- Steuersätze erfasst → Steuerregel für alle Länder alle Regionen
- Länderzonen Schweiz & Liechtenstein (ich versende nur dort hin) eingerichtet

Doch egal was ich versuche, in den Bestell-Details bleibt der MwSt. Satz stehts 0%

 ![Bestellungs-Details](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/5/e/5e4617d87e4ba96887bc33b99691cd0fc3d263d9.png)

Auffällig ist auch, dass bei der Migration alle Bestellungen mit „Deutschland“ anstatt Schweiz deklariert sind. Wie mir eine Suche hier im Forum zeigte, scheint dies jedoch ein Bug zu sein und kann nur über folgenden SQL Befehl geändert werden.

```auto
UPDATE s_user_addresses SET country_id='26' WHERE country_id='2'

```

Ob dies der Grund für den verweigerten Steuersatz-Import ist, weiss ich allerdings nicht. Vielleicht habt ihr ja noch eine Idee wie ich diesen doch noch rein bekomme?

LG
