Migration von xtc3.04 auf Shopware 4.1-> Kategorienzuordnung

Bei Nutzung des Migrations-Plugins werden die Artikel inkl. der Varianten und Bilder gut migriert. Allerdings ist die Zuordnung der Artikel zu Kategorien fehlerhaft. Ich versuche das eigenwillige Fehlerbild zu beschreiben: Artikel A sei im alten Shop in Kategorie X. Im neuen Shop ist Artikel A dann im Backend der Kategorie X, Y und Z zugewiesen. Im Frontend wird Artikel A aber auch noch bei Kategorie W angezeigt (ja, der Artikel wird in einer Kategorie angezeigt, die ihm in der Artikelbeschreibung im Backend gar nicht zugewiesen ist). Ich habe keine Idee, wie ich dem Problem auf die Schliche kommen könnte. Ich hab auch bei Artikeln testweise im Backend alle Kategorien entfernt, neu zu gewiesen - doch die falsche Zuordnung im Frontend bleibt. Wenn ich nach dem Artikel im Frontend suche, kommt als Ergebnis ein Artikel in einer Kategorie, die ihm nicht zugewiesen wurde. Es gibt auch kein erkennbares System. Manche Artikel tauchen in 23 Kategorien auf, manche nur in 4. Einige wenige sind sogar korrekt. Hat irgendjemand einen Tipp? Danke im Voraus!

Hi, hab gerade das gleiche Problem nur mit einem Oxid Shop zu Shopware Hast du da schon ne lösung erhalten? Grüße

ich hatte ein ähnliches Problem und konnte dies dann lösen (post73986.html#p73986) ich habe über Cache/Performance Modul den Kategoriebaum neu erstellen lassen und schon funktionierte alles … Vielleicht ist das ja bei euch auch die Lösung … einfach mal versuchen :slight_smile:

jup habs auch schon rausgefunden! trotzdem danke Grüße Phil