# Migation von 5.4 nach 6 übernimmt kaum Daten

**URL:** <https://forum.shopware.com/t/migation-von-5-4-nach-6-uebernimmt-kaum-daten/102498>\
**Category:** Shopware 6 (German)\
**Created:** [13. Januar 2024 um 13:42 UTC](https://forum.shopware.com/t/migation-von-5-4-nach-6-uebernimmt-kaum-daten/102498 "2024-01-13T13:42:15Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![cachito](https://avatars.discourse-cdn.com/v4/letter/c/ce7236/32.png) [@cachito](https://forum.shopware.com/u/cachito)\
**Post date:** [13. Januar 2024 um 13:42 UTC](https://forum.shopware.com/t/migation-von-5-4-nach-6-uebernimmt-kaum-daten/102498/1 "2024-01-13T13:42:15Z")

</div>

Hallo zusammen,

ich versuche für unseren Shop gerade die Migration von 5.4 nach 6 durchzuführen. Dies funktioniert allerdings eher bescheiden. Bestellungen und Kunden werden fast komplett übernommen, aber bei den Produkten sind es von knapp 2900 nur etwas weniger als 200.

Leider tu ich mir sehr schwer aus den Logfiles schlau zu werden. Ich hab auch schon einmal versucht mir die swag\_migration\_\*-Tabellen anzuschauen, kann dort aber das eigentlcihe Problem, warum ein Produkt nicht übernommen wird auch nicht herauslesen.

Wie geht ihr denn vor bei der Fehlersuche?

Beispiele von Fehlermeldungen:  
[error] SWAG\_MIGRATION\_RUN\_EXCEPTION  
An exception occurred  
Entity: product, sourceId: 018ce4c2cfa372079c76d1444f623a6e  
An exception occurred while executing a query: SQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fails (`w9m9js46_atlas`.`product`, CONSTRAINT `fk.product.parent_id` FOREIGN KEY (`parent_id`, `parent_version_id`) REFERENCES `product` (`id`, `version_id`) ON DELETE CASCADE ON UPDATE CASCADE)

[error] SWAG\_MIGRATION\_RUN\_EXCEPTION  
An exception occurred  
Entity: product\_option\_relation, sourceId: 018ce4c6d0fb7049a907214f1e0e6e57  
There are 5 error(s) while writing data.1. [/0/taxId] Dieser Wert sollte nicht leer sein.1. [/0/price] Dieser Wert sollte nicht leer sein.1. [/0/productNumber] Dieser Wert sollte nicht leer sein.1. [/0/stock] Dieser Wert sollte nicht leer sein.1. [/0/translations/2fbb5fe2e29a4d70aa5854ce7ce3e20b/name] Dieser Wert sollte nicht leer sein.

[error] SWAG\_MIGRATION\_RUN\_EXCEPTION  
An exception occurred  
Entity: product\_option\_relation, sourceId: 018ce4c6d0fb7049a907214f1f0df703  
There are 5 error(s) while writing data.1. [/0/taxId] Dieser Wert sollte nicht leer sein.1. [/0/price] Dieser Wert sollte nicht leer sein.1. [/0/productNumber] Dieser Wert sollte nicht leer sein.1. [/0/stock] Dieser Wert sollte nicht leer sein.1. [/0/translations/2fbb5fe2e29a4d70aa5854ce7ce3e20b/name] Dieser Wert sollte nicht leer sein.

[error] SWAG\_MIGRATION\_\_WRITE\_EXCEPTION\_OCCURRED  
A write exception has occurred  
{  
„entity“: „product\_option\_relation“,  
„dataId“: „018ce4c6d0fb7049a907214f1f5c4265“,  
„error“: {  
„code“: „c1051bb4-d103-4f74-8988-acbcafc7fdc3“,  
„status“: „400“,  
„detail“: „Dieser Wert sollte nicht leer sein.“,  
„template“: „This value should not be blank.“,  
„meta“: {  
„parameters“: {  
„{{ value }}“: „null“  
}  
},  
„source“: {  
„pointer“: „/0/translations/2fbb5fe2e29a4d70aa5854ce7ce3e20b/name“  
}  
}  
}

Vielen Dank  
Gerhard

---

<div class="post-metadata">

**Author:** ![acr\_kno](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/acr_kno/32/8564_2.png) [@acr\_kno](https://forum.shopware.com/u/acr_kno)\
**Post date:** [17. April 2024 um 13:49 UTC](https://forum.shopware.com/t/migation-von-5-4-nach-6-uebernimmt-kaum-daten/102498/2 "2024-04-17T13:49:20Z")

</div>

> [@cachito](#):
>
> ing a query: SQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fails (`w9m9js46_atlas`.`product`, CONSTRAINT `fk.product.parent_id` FOREIGN KEY (`parent_id`, `parent_version_id`) REFERENCES `product` (`id`, `version_id`) ON DELETE CASCADE ON UPDATE CAS

Hallo Gerhard,

hast du das mittlerweile lösen können? Ich steh vor dem gleichen Problem 😪 über 54.000 dieser „foreign key constraint fails“ Fehler.

Wo anders habe ich gelesen dass es helfen soll wenn man die Fremdschlüsselprüfung in der Datenbank deaktiviert. Hat bei mir nur nichts gebracht 😑

---

<div class="post-metadata">

**Author:** ![acr\_kno](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/acr_kno/32/8564_2.png) [@acr\_kno](https://forum.shopware.com/u/acr_kno)\
**Post date:** [17. April 2024 um 13:50 UTC](https://forum.shopware.com/t/migation-von-5-4-nach-6-uebernimmt-kaum-daten/102498/3 "2024-04-17T13:50:54Z")

</div>

Vielleicht kann uns @Mercator hier weiterhelfen? 🙏🏻

---

<div class="post-metadata">

**Author:** ![area-net-gmbh](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/area-net-gmbh/32/21995_2.png) [@area-net-gmbh](https://forum.shopware.com/u/area-net-gmbh)\
**Post date:** [17. April 2024 um 14:12 UTC](https://forum.shopware.com/t/migation-von-5-4-nach-6-uebernimmt-kaum-daten/102498/4 "2024-04-17T14:12:47Z")

</div>

Da müsste man sich von einem Fehler mal über das Mapping zum Ursprungsprodukt in SW5 durchforsten und das genau prüfen. Irgendwo fehlen dort Daten und/oder Verknüpfungen. Vermutlich liegt es gar nicht am Produkt selber, sondern an einem fehlenden, verknüpften Datensatz. Zum Beispiel Steuersatz oder Shop/Verkaufskanal.

---

<div class="post-metadata">

**Author:** ![cachito](https://avatars.discourse-cdn.com/v4/letter/c/ce7236/32.png) [@cachito](https://forum.shopware.com/u/cachito)\
**Post date:** [22. April 2024 um 16:10 UTC](https://forum.shopware.com/t/migation-von-5-4-nach-6-uebernimmt-kaum-daten/102498/5 "2024-04-22T16:10:54Z")

</div>

Nein, ich habe bisher leider keine Lösung, bin aber für jeden Tipp dankbar.

Eines habe ich herausgefunden: bei Mediendateien, die in der DB stehen aber im Filesystem nicht vorhanden sind wird die Übernahme auch abgebrochen.

---

<div class="post-metadata">

**Author:** ![DCS](https://avatars.discourse-cdn.com/v4/letter/d/85f322/32.png) [@DCS](https://forum.shopware.com/u/DCS)\
**Post date:** [23. April 2024 um 06:38 UTC](https://forum.shopware.com/t/migation-von-5-4-nach-6-uebernimmt-kaum-daten/102498/6 "2024-04-23T06:38:18Z")

</div>

Eventuell eine nicht kompatible Datenbankversion? Gleiches Problem hatten wir auch.  
Nicht jede MYSQL und Maria DB Version ist mit jeder SW6 Version kompatibel. Nachdem  
wir damals die Datenbank gewechselt haben, wurden die Daten vollständig übernommen.  
Vorher waren wir auch fast am verzweifeln, weil die Migration immer entweder abgebrochen  
wurde oder durchlief und dann viele Daten gefehlt haben.

---

<div class="post-metadata">

**Author:** ![cachito](https://avatars.discourse-cdn.com/v4/letter/c/ce7236/32.png) [@cachito](https://forum.shopware.com/u/cachito)\
**Post date:** [23. April 2024 um 16:07 UTC](https://forum.shopware.com/t/migation-von-5-4-nach-6-uebernimmt-kaum-daten/102498/7 "2024-04-23T16:07:57Z")

</div>

Ich habe hier mySQL 5.7 für den 5er Shop und 8.0 für den 6er Shop. Welche hattet/habt ihr denn im Einsatz?

---

<div class="post-metadata">

**Author:** ![DCS](https://avatars.discourse-cdn.com/v4/letter/d/85f322/32.png) [@DCS](https://forum.shopware.com/u/DCS)\
**Post date:** [24. April 2024 um 06:32 UTC](https://forum.shopware.com/t/migation-von-5-4-nach-6-uebernimmt-kaum-daten/102498/8 "2024-04-24T06:32:01Z")

</div>

Leider gibt es bei Shopware 6 keine „pauschale“ Kompatibilität von MySQL 8.0.  
Die Kompatibilität ist abhängig von der Shopware 6 Version.

Welche Datenbankversion zu den jeweiligen SW6 Versionen passt, findest Du unter

> **[Shopware 6 - Erste Schritte - Systemvoraussetzungen](https://docs.shopware.com/de/shopware-6-de/erste-schritte/systemvoraussetzungen)**
>
> Hier listen wir Dir auf welche Voraussetzungen Dein System erfüllen muss, um Shopware 6 betreiben zu können und was wir darüber hinaus als Empfehlungen aussprechen um den Betrieb zu optimieren.

in den Systemvoraussetzungen (rechts die Version auswählen). Hier ist dann jeweils  
aufgeführt, welche Datenbankversionen kompatibel sind und bei welchen es Probleme  
gibt.

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [24. April 2024 um 07:26 UTC](https://forum.shopware.com/t/migation-von-5-4-nach-6-uebernimmt-kaum-daten/102498/9 "2024-04-24T07:26:38Z")

</div>

> [@cachito](#):
>
> Leider tu ich mir sehr schwer aus den Logfiles schlau zu werden.

Das Problem werden wohl (leider) viele haben. Die Fehlermeldungen sind leider nicht immer eindeutig. Nach mittlerweile mehreren Migartionen kann ich sagen, dass es mehrere Faktoren sein können, warum eine Migration nicht geht. Angefangen von fehlerhaften Verknüpfungen bis hin zu inkorrekten Daten im Quellsystem.

> [@cachito](#):
>
> [/0/price] Dieser Wert sollte nicht leer sein.

Bei einer Migration hatte ich solche Fehler auch, zu hundertfach. Optisch sah es im SW5 Shop, also im Qullsystem, ganz normal aus. Preis etc. stand alles drin. Tagelang nach der Ursache gesucht, warum die Produkte nicht übernommen werden. Dann nur mal aus Spaß, das Produkt im SW5 System auf speichern geklick und eine neue Migration durchgeführt. Plötzlich wurde das Produkt übernommen.

Diesen Fall hatte ich hier erwähnt:  
=\> [Migration Error product\_option\_relation](https://forum.shopware.com/t/migration-error-product-option-relation/102674)

> [@cachito](#):
>
> Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fails

Solche Meldungen passieren oft, wenn Verknüpfungen fehlen. Über die sourceId muss man das in Detektivarbeit analysieren.

Ein Problem mit der DB halte ich hier aber ausgeschlossen. Erst recht wenn Hinweise auf sourceId kommen. Das deutet immer darauf hin, dass zwar der Datensatz aus dem SW5 übernommen wurde, im Mapping vom SW6 gespeichert wurde, aber dann nicht mehr schreiben konnte, wiel die Daten unsauber sind. Das muss nicht zwangsläufig an der DB Version liegen.

---

<div class="post-metadata">

**Author:** ![cachito](https://avatars.discourse-cdn.com/v4/letter/c/ce7236/32.png) [@cachito](https://forum.shopware.com/u/cachito)\
**Post date:** [8. Mai 2024 um 10:10 UTC](https://forum.shopware.com/t/migation-von-5-4-nach-6-uebernimmt-kaum-daten/102498/10 "2024-05-08T10:10:00Z")

</div>

Einen Fehler in der alten DB habe ich jetzt gefunden, und er betrifft immer Variantenartikel.

[error] SWAG\_MIGRATION\_RUN\_EXCEPTION  
An exception occurred  
Entity: product, sourceId: xxxx  
Parent entity for „product: yyyy.z“ child not found.

in der SW5-DB steht in der articeles\_details-Tabelle bei der Hauptvariante als kind „2“, bei einer Untervariante „1“. Es muss aber genau umgekehrt sein. Nach der Änderung werden die Artikel bei mir übernommen.
