# Medienupload funktioniert nicht mehr

**URL:** <https://forum.shopware.com/t/medienupload-funktioniert-nicht-mehr/26370>\
**Category:** Shopware 3.5\
**Tags:** administration\
**Created:** [20. April 2015 um 17:30 UTC](https://forum.shopware.com/t/medienupload-funktioniert-nicht-mehr/26370 "2015-04-20T17:30:42Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![mariabau](https://avatars.discourse-cdn.com/v4/letter/m/7feea3/32.png) [@mariabau](https://forum.shopware.com/u/mariabau)\
**Post date:** [20. April 2015 um 17:30 UTC](https://forum.shopware.com/t/medienupload-funktioniert-nicht-mehr/26370/1 "2015-04-20T17:30:42Z")

</div>

Hallo liebe Gemeinde! Vielleicht weiß jemand von euch, wieso der Medienupload bei uns nicht mehr läuft. Bei hinzufügen von Bildern bleibt der „Ladebalken“ auf 0 und die Browserconsole wirft folgende Fehlermeldung aus: ` ... jQuery(document).ready(function ($) { var cok = document.cookie.match(/session- **Fatal error** : Call to a member function getId() on a non-object in **/var/www/clients/client1/web2/web/shopware/cache/templates/backend\_de\_DE\_5b909/62/c3/5a/62c35ab15b87a189f13b013bb50d4a1e7715cd0b.snippet.index.tpl.php** on line **1903** 503 Service Unavailable ... Header: Request URL:http://xxxxxx/backend/mediaManager/upload?albumID=1 Request Method:POST Status Code:503 Service Unavailable ----- Failed to load resource: the server responded with a status of 503 (Service Unavailable)Ext.define.uploadFile @ base?file=bootstrap&loggedIn=1429521282:2525 ` - Cache wurde gelöscht - Die Festplatte ist nicht voll - Es wurde kein Update durchgeführt Shopware 4.3.2 läuft auf nginx Irgendwer eine Idee? Liebe Grüße,

---

<div class="post-metadata">

**Author:** ![mariabau](https://avatars.discourse-cdn.com/v4/letter/m/7feea3/32.png) [@mariabau](https://forum.shopware.com/u/mariabau)\
**Post date:** [22. April 2015 um 21:02 UTC](https://forum.shopware.com/t/medienupload-funktioniert-nicht-mehr/26370/2 "2015-04-22T21:02:15Z")

</div>

Hallo! Ich habe noch immer keine Lösung gefunden. ☹ In der Logdatei steht folgendes: ` 2015/04/20 09:41:31 [error] 7362#0: \*172156 FastCGI sent in stderr: "PHP message: PHP Warning: File upload error - unable to create a temporary file in Unknown on line 0 PHP message: PHP Fatal error: Call to a member function getId() on a non-object in /var/www/clients/client1/web2/web/shopware/cache/templates/backend\_de\_DE\_5b909/62/c3/5a/62c35ab15b87a189f13b013bb50d4a1e7715cd0b.snippet.index.tpl.php on line 1924" while reading response header from upstream, client: 222.77.7.77, server: meinshop.de, request: "POST /backend/mediaManager/upload HTTP/1.1", upstream: "fastcgi://unix:/var/lib/php5-fpm/web2.sock:", host: "meinshop.de", referrer: "http://meinshop.de" ` Weiss wer WO die Datei temporär gespeichert wird? Vll. fehlen da Schreibrechte? Kann ich mir aber nicht vorstellen da nichts geändert wurde.

---

<div class="post-metadata">

**Author:** ![mariabau](https://avatars.discourse-cdn.com/v4/letter/m/7feea3/32.png) [@mariabau](https://forum.shopware.com/u/mariabau)\
**Post date:** [24. April 2015 um 09:30 UTC](https://forum.shopware.com/t/medienupload-funktioniert-nicht-mehr/26370/3 "2015-04-24T09:30:02Z")

</div>

Keiner eine Idee?

---

<div class="post-metadata">

**Author:** ![zapperlot](https://avatars.discourse-cdn.com/v4/letter/z/b2d939/32.png) [@zapperlot](https://forum.shopware.com/u/zapperlot)\
**Post date:** [13. Mai 2016 um 10:46 UTC](https://forum.shopware.com/t/medienupload-funktioniert-nicht-mehr/26370/4 "2016-05-13T10:46:02Z")

</div>

Ich hatte zwischenzeitlich Bildimporte über die Konsole gemacht … Das fürhrt dazu, dass der Verzeichnisdschungel unter images dann teilweise dem Benutzer gehört, der ihn ausgeführt hat. Wenn der Medienupload dann versucht darunter weitere Verzeichnisse anzulegen schlägt das fehl …

Bei mir half chown -R www-data:www-data media/images&nbsp;

Schön wäre es, wenn das das Konsolen-Skript selbst tun würde… (soweit es das darf - oder meckern)
