# Mailverschlüsselung und/oder Digitale Signatur per S/MIME und/oder OpenPGP

**URL:** <https://forum.shopware.com/t/mailverschlusselung-und-oder-digitale-signatur-per-s-mime-und-oder-openpgp/56030>\
**Category:** Allgemein\
**Created:** [27. Oktober 2018 um 08:45 UTC](https://forum.shopware.com/t/mailverschlusselung-und-oder-digitale-signatur-per-s-mime-und-oder-openpgp/56030 "2018-10-27T08:45:13Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Urbansoftware](https://avatars.discourse-cdn.com/v4/letter/u/90db22/32.png) [@Urbansoftware](https://forum.shopware.com/u/Urbansoftware)\
**Post date:** [27. Oktober 2018 um 08:45 UTC](https://forum.shopware.com/t/mailverschlusselung-und-oder-digitale-signatur-per-s-mime-und-oder-openpgp/56030/1 "2018-10-27T08:45:13Z")

</div>

Nachdem das Durchsuchen des Forums und der Plugins zu keinem Ergebnis führte, habe ich mir gedach, dass es Zeit ist dies einmal in die Runde zu schreiben.

Hat sich mit dem&nbsp;Thema Verschlüsselung/Digitale Signatur von Mails schon einmal jemand beschäftigt? Hiermit meine ich NICHT die SSL-Anbindung zum E-Mail-Provider sondern das Signieren bzw. Verschlüsseln von Mails wie es in&nbsp;RFC 1847 / RFC 2633 / RFC 2440 festgehalten ist. Ich schreibe hier immer bewusst von Verschlüsselung/Signierung, da es sich hierbei um zwei&nbsp;unterschiedliche Dinge handelt, die einzeln oder zusammen eingesetzt werden können.

Und falls sich wirklich noch niemand damit auseinandergesetzt hat, haltet ihr dies als Plugin für eine sinnvolle Idee?

Der PHPMailer ja ist in der Lage mit Zertifikaten umzugehen und auch die entsprechenden Verschlüsselungen/Signierungen vorzunehmen.

Viele Grüße,  
Franz Urban  
&nbsp;

---

<div class="post-metadata">

**Author:** ![Kai23](https://avatars.discourse-cdn.com/v4/letter/k/c89c15/32.png) [@Kai23](https://forum.shopware.com/u/Kai23)\
**Post date:** [9. Juli 2020 um 21:07 UTC](https://forum.shopware.com/t/mailverschlusselung-und-oder-digitale-signatur-per-s-mime-und-oder-openpgp/56030/2 "2020-07-09T21:07:09Z")

</div>

Hallo Franz,&nbsp;

wie ging es&nbsp;weiter?  
Hast du die Idee verworfen? Wenn ja warum?

---

<div class="post-metadata">

**Author:** ![Kai23](https://avatars.discourse-cdn.com/v4/letter/k/c89c15/32.png) [@Kai23](https://forum.shopware.com/u/Kai23)\
**Post date:** [29. September 2020 um 23:21 UTC](https://forum.shopware.com/t/mailverschlusselung-und-oder-digitale-signatur-per-s-mime-und-oder-openpgp/56030/3 "2020-09-29T23:21:13Z")

</div>

Ich habe es jetzt mit&nbsp;[https://signing-milter.org](https://signing-milter.org) gemacht.  
Als Mailer ist in Shopware smtp&nbsp;127.0.0.1 port 25 eingestellt.  
MTA ist postifx, der zieht die Shop Mails durch den&nbsp;signing-milter und übergibt die signierte Mail&nbsp;mit SASL also SMTP User und Passwort&nbsp;an den MX Server.&nbsp;

Wäre schon nice wenn das Shopware direkt in PHP machen würde. Und DKIM.
