# Kunde anlegen nutzt falsche Datenbank connection

**URL:** <https://forum.shopware.com/t/kunde-anlegen-nutzt-falsche-datenbank-connection/88489>\
**Category:** Shopware 6 (German)\
**Tags:** installation--gettin, administration\
**Created:** [21. Juni 2021 um 12:55 UTC](https://forum.shopware.com/t/kunde-anlegen-nutzt-falsche-datenbank-connection/88489 "2021-06-21T12:55:59Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![joshkreud](https://avatars.discourse-cdn.com/v4/letter/j/898d66/32.png) [@joshkreud](https://forum.shopware.com/u/joshkreud)\
**Post date:** [21. Juni 2021 um 12:55 UTC](https://forum.shopware.com/t/kunde-anlegen-nutzt-falsche-datenbank-connection/88489/1 "2021-06-21T12:55:59Z")

</div>

Hallo,

Ich versuche gerade in meiner Shopware Testinstanz (6.4.1.1) einen neuen Kunden anzulegen.  
Dabei bekomme ich allerdings immer einen Datenbankfehler:

```auto
# An exception occurred while executing 'INSERT INTO `customer_address` (`id`, `customer_id`, `country_id`, `salutation_id`, `first_name`, `last_name`, `zipcode`, `city`, `street`, `created_at`) VALUES ('\\�ό_@N[��|E{�','+ݟ*�BA��#-��','(8W��A�����-��','Jal�\\HNN�:�\Z�.','wef','wef','wef','wef','wef','2021-06-21 12:50:25.307');':

SQLSTATE[HY000]: General error: 1449 The user specified as a definer ('swapp'@'localhost') does not exist

```

Das macht ergibt auch Sinn, da der user „swapp“ garnicht mehr existiert.  
Laut .env heißt der User jetzt „shopware“ und alle anderen Datenbank Aktionen laufen auch.

Ich habe schon manuell ./var/cache/\* geleert, und folgende commands ausgeführt:

```auto
bin/console cache:clear
bin/console system:install
bin/console dal:refresh:index
composer update

```

Kann sich hier jemand zusammenreimen, warum das Kunden erstellen nicht die Datenbank Connection aus der .env nutzt?

Die Installation ist von einem anderen Server kopiert worden, da der Migrationsassistent nicht so wollte.  
Im Zuge dessen wurde auch der Datenbank Nutzer geändert.

Hier auch noch mal die .env:

```auto
$cat .env | grep DATABASE

DATABASE_URL=mysql://shopware:superdupersecretpassword@localhost:3306/shopware

```

---

<div class="post-metadata">

**Author:** ![dominikmank](https://avatars.discourse-cdn.com/v4/letter/d/c77e96/32.png) [@dominikmank](https://forum.shopware.com/u/dominikmank)\
**Post date:** [21. Juni 2021 um 15:17 UTC](https://forum.shopware.com/t/kunde-anlegen-nutzt-falsche-datenbank-connection/88489/2 "2021-06-21T15:17:20Z")

</div>

Hast du einen Datenbank Dump einer anderen Instanz (mit dem alten Benutzer) genommen? Das sollte ein Fehler sein, der durch Trigger ausgelöst wird. Über den Dump werden Trigger mit exportiert, die auch noch auf den alten Benutzer zeigen. Das besagt die Fehlermeldung. Für customer\_address gibt es 2 Trigger die benutzt werden, wo du die definer löschen müsstest. (geht über eine datenbank oberfläche deiner wahl)  
müssten customer\_address\_vat\_id\_insert und customer\_address\_vat\_id\_update sein wenn mich nicht alles täuscht.

---

<div class="post-metadata">

**Author:** ![joshkreud](https://avatars.discourse-cdn.com/v4/letter/j/898d66/32.png) [@joshkreud](https://forum.shopware.com/u/joshkreud)\
**Post date:** [22. Juni 2021 um 05:16 UTC](https://forum.shopware.com/t/kunde-anlegen-nutzt-falsche-datenbank-connection/88489/3 "2021-06-22T05:16:42Z")

</div>

Hey Dominik,

Danke für die Hilfe, das war tatsächlich das Problem.
