# Interpretation einer Fehlermeldung nach Update auf SW 5.6

**URL:** <https://forum.shopware.com/t/interpretation-einer-fehlermeldung-nach-update-auf-sw-5-6/61086>\
**Category:** Allgemein\
**Created:** [14. August 2019 um 16:58 UTC](https://forum.shopware.com/t/interpretation-einer-fehlermeldung-nach-update-auf-sw-5-6/61086 "2019-08-14T16:58:39Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![videho](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/videho/32/13888_2.png) [@videho](https://forum.shopware.com/u/videho)\
**Post date:** [14. August 2019 um 16:58 UTC](https://forum.shopware.com/t/interpretation-einer-fehlermeldung-nach-update-auf-sw-5-6/61086/1 "2019-08-14T16:58:39Z")

</div>

Hallo!

Habe unseren Shop von 5.5.10 auf 5.6 aktualisiert. Voraussetzungen waren alle im grünen Bereich. Jetzt kommt eine Fehlermeldung, wenn ich den Pluginmanager öffnen möchte.

Könnte jemand so nett sein und mir bei der Interpretation helfen? Sieht so aus das eine Plugins probleme machen. Vor dem Update stand nur, dass einige Plugins nach dem Shopware Update ein Plugin-Update zur Verfügung stehen würde.

Freue mich über einen Tipp 🙂

\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_

Error

Uncaught ArgumentCountError: Too few arguments to function Shopware\_Components\_Translation::\_\_construct(), 0 passed in /www/htdocs/w0132fdb/quovadisverlag.net/custom/plugins/NetiFoundation/Service/PluginManager/MailTemplates.php on line 51 and exactly 2 expected in /www/htdocs/w0132fdb/quovadisverlag.net/engine/Shopware/Components/Translation.php:50 Stack trace: #0 /www/htdocs/w0132fdb/quovadisverlag.net/custom/plugins/NetiFoundation/Service/PluginManager/MailTemplates.php(51): Shopware\_Components\_Translation-\>\_\_construct() #1 /www/htdocs/w0132fdb/quovadisverlag.net/var/cache/production\_201908091314/proxies/ShopwareProductionfed94bfd9f656ca3b6e396da1f7c829cef3d04eeProjectContainer.php(7734): NetiFoundation\Service\PluginManager\MailTemplates-\>\_\_construct(Object(Shopware\Components\Model\ModelManager), Object(NetiFoundation\Service\Logging\FileLoggingService)) #2 /www/htdocs/w0132fdb/quovadisverlag.net/vendor/symfony/dependency-injection/Container.php(306): ShopwareProductionfed94bfd9f656ca3b6e396da1f7c829cef3

File:/ www/ htdocs/ w0132fdb/ [quovadisverlag.net/](http://quovadisverlag.net/) engine/ Shopware/ Components/ Translation.php

&nbsp;

---

<div class="post-metadata">

**Author:** ![ffneurope](https://avatars.discourse-cdn.com/v4/letter/f/8c91f0/32.png) [@ffneurope](https://forum.shopware.com/u/ffneurope)\
**Post date:** [14. August 2019 um 17:38 UTC](https://forum.shopware.com/t/interpretation-einer-fehlermeldung-nach-update-auf-sw-5-6/61086/2 "2019-08-14T17:38:08Z")

</div>

Selbes Problem bei uns. Ausserdem funktioniert bei Shopware das Feedback-Menu nicht. Kommt die Fehlermeldung " **[issues.shopware.com](http://issues.shopware.com)** &nbsp;refused to connect."  
Evtl. ist dieses ganze Shopware&nbsp;nur Schall und Rauch, ohne Human Support&nbsp; ![Thumb-down](https://forum.shopware.com/plugins/CKEditor/plugins/smiley/images/thumb-down.png "Thumb-down")

---

<div class="post-metadata">

**Author:** ![EikeBrandtWarneke](https://avatars.discourse-cdn.com/v4/letter/e/cdc98d/32.png) [@EikeBrandtWarneke](https://forum.shopware.com/u/EikeBrandtWarneke)\
**Post date:** [14. August 2019 um 17:38 UTC](https://forum.shopware.com/t/interpretation-einer-fehlermeldung-nach-update-auf-sw-5-6/61086/3 "2019-08-14T17:38:56Z")

</div>

Hast du das&nbsp;NetiFoundation Plugin auf Version 4.0?

Viele Grüße  
[https://www.digitvision.de](https://www.digitvision.de)

---

<div class="post-metadata">

**Author:** ![Strombose](https://avatars.discourse-cdn.com/v4/letter/s/4da419/32.png) [@Strombose](https://forum.shopware.com/u/Strombose)\
**Post date:** [14. August 2019 um 17:39 UTC](https://forum.shopware.com/t/interpretation-einer-fehlermeldung-nach-update-auf-sw-5-6/61086/4 "2019-08-14T17:39:58Z")

</div>

Ich habe das selbe Problem.&nbsp;Würde mich auch um Hilfe freuen.

Was ich festegstellt habe bei meinem Server ist die MySQL-Version leider nur 5.5.5. Vorausetzung sind aber 5.7.0. Kann es daran liegen?

Shopware hatte keine Fehlermeldung/Hinweis vor dem Update ausgegeben.

&nbsp;

---

<div class="post-metadata">

**Author:** ![Strombose](https://avatars.discourse-cdn.com/v4/letter/s/4da419/32.png) [@Strombose](https://forum.shopware.com/u/Strombose)\
**Post date:** [14. August 2019 um 17:54 UTC](https://forum.shopware.com/t/interpretation-einer-fehlermeldung-nach-update-auf-sw-5-6/61086/5 "2019-08-14T17:54:52Z")

</div>

> [@EikeWarneke schrieb:](https://forum.shopware.com/profile/11752/EikeWarneke "EikeWarneke")
> 
> Hast du das&nbsp;NetiFoundation Plugin auf Version 4.0?
> 
> Viele Grüße

Perfekt, danke für den Hinweis.&nbsp;Das NetiFoundation Plugin hat den Plugin-Manager abgeschossen.

Zur Lösung.

Das Plugin in der Datenbank unter s\_core\_plugins deaktivieren, indem man den Wert „active“ von 1 auf 0 setzt.

Dann habe ich zusätzlich nochmal den Cache gelöscht. Keine Ahnung ob das notwenig war oder nicht.

Jedenfalls startet der Plugin-Manager wieder und man kann updaten…

&nbsp;

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [14. August 2019 um 18:23 UTC](https://forum.shopware.com/t/interpretation-einer-fehlermeldung-nach-update-auf-sw-5-6/61086/6 "2019-08-14T18:23:53Z")

</div>

> [@Strombose schrieb:](https://forum.shopware.com/profile/32360/Strombose "Strombose")
> 
> Was ich festegstellt habe bei meinem Server ist die MySQL-Version leider nur 5.5.5. Vorausetzung sind aber 5.7.0. Kann es daran liegen?

&nbsp;Wahrscheinlich hast du MariaDB, wenn die Version nicht passt, meckert das Update. Die Systeminformation zeigt das manchmal falsch an, weil MariaDB dann 5.5 als MySQL Version zurück gibt. Was genau du hast, kannst du in&nbsp;Phpmyadmin&nbsp;sehen.

---

<div class="post-metadata">

**Author:** ![videho](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/videho/32/13888_2.png) [@videho](https://forum.shopware.com/u/videho)\
**Post date:** [15. August 2019 um 12:03 UTC](https://forum.shopware.com/t/interpretation-einer-fehlermeldung-nach-update-auf-sw-5-6/61086/7 "2019-08-15T12:03:00Z")

</div>

> [@Strombose schrieb:](https://forum.shopware.com/profile/32360/Strombose "Strombose")
> 
> > [@EikeWarneke schrieb:](https://forum.shopware.com/profile/11752/EikeWarneke "EikeWarneke")
> > 
> > Hast du das&nbsp;NetiFoundation Plugin auf Version 4.0?
> > 
> > Viele Grüße
> 
> Perfekt, danke für den Hinweis.&nbsp;Das NetiFoundation Plugin hat den Plugin-Manager abgeschossen.
> 
> Zur Lösung.
> 
> Das Plugin in der Datenbank unter s\_core\_plugins deaktivieren, indem man den Wert „active“ von 1 auf 0 setzt.
> 
> Dann habe ich zusätzlich nochmal den Cache gelöscht. Keine Ahnung ob das notwenig war oder nicht.
> 
> Jedenfalls startet der Plugin-Manager wieder und man kann updaten…
> 
> &nbsp;

Vielen Dank! Das hat geholfen. Aber das NetiFoundations Plugin hat es scheinbar „in sich“. Jetzt erscheint bei mir bei jeder Plugin-Manager Aktion:

\_\_\_\_\_\_\_\_\_\_\_\_\_

Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. Plugin by name „KplngiBodyColor“ not found. in custom/plugins/NetiFoundation/Service/PluginManager/Base.php on line 112 Stack trace: #0 custom/plugins/NetiFoundation/Subscriber/PluginManager.php(102): NetiFoundation\Service\PluginManager\Base-\>getPluginByName(‚KplngiBodyColor‘) #1 engine/Library/Enlight/Event/Handler/Default.php(87): NetiFoundation\Subscriber\PluginManager-\>getFormAction(Object(Enlight\_Hook\_HookArgs)) #2 engine/Library/Enlight/Event/EventManager.php(214): Enlight\_Event\_Handler\_Default-\>execute(Object(Enlight\_Hook\_HookArgs)) #3 engine/Library/Enlight/Hook/HookExecutionContext.php(98): Enlight\_Event\_EventManager-\>notify(‚Shopware\_Contro…‘, Object(Enlight\_Hook\_HookArgs)) #4 engine/Library/Enlight/Hook/HookManager.php(180): Enlight\_Hook\_HookExecutionContext-\>execute() #5 var/cache/production\_201908091314/proxies/ShopwareControllersBackendConfigProxy.php(90): Enlight\_Hook\_HookManager-\>executeHooks(Object(Shopware\_Proxies\_ShopwareControllersBackendConfigProxy), ‚getFormAction‘, Array) #6 engine/Library/Enlight/Controller/Action.php(192): Shopware\_Proxies\_ShopwareControllersBackendConfigProxy-\>getFormAction() #7 engine/Library/Enlight/Controller/Dispatcher/Default.php(478): Enlight\_Controller\_Action-\>dispatch(‚getFormAction‘) #8 engine/Library/Enlight/Controller/Front.php(228): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #9 engine/Shopware/Kernel.php(184): Enlight\_Controller\_Front-\>dispatch() #10 vendor/symfony/http-kernel/HttpCache/SubRequestHandler.php(102): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #11 vendor/symfony/http-kernel/HttpCache/HttpCache.php(448): Symfony\Component\HttpKernel\HttpCache\SubRequestHandler::handle(Object(Shopware\Kernel), Object(Symfony\Component\HttpFoundation\Request), 1, true) #12 engine/Shopware/Components/HttpCache/AppCache.php(256): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #13 vendor/symfony/http-kernel/HttpCache/HttpCache.php(238): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true) #14 engine/Shopware/Components/HttpCache/AppCache.php(99): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true) #15 shopware.php(122): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request)) #16 {main} &nbsp;

_OK_

_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\_\__

&nbsp;

---

<div class="post-metadata">

**Author:** ![Beck33](https://avatars.discourse-cdn.com/v4/letter/b/6a8cbe/32.png) [@Beck33](https://forum.shopware.com/u/Beck33)\
**Post date:** [27. August 2019 um 10:59 UTC](https://forum.shopware.com/t/interpretation-einer-fehlermeldung-nach-update-auf-sw-5-6/61086/8 "2019-08-27T10:59:03Z")

</div>

Hi, ich hatte das gleiche Problem.

Ich habe die Plugins auch über die&nbsp;&nbsp;s\_core\_plugins deaktiviert, den Cache gelöscht und einzeln aktualisiert. Danach hatte ich keine Probleme mehr und beide Plugins laufen mit der 5.6

---

<div class="post-metadata">

**Author:** ![Net\_Inventors\_GmbH](https://avatars.discourse-cdn.com/v4/letter/n/b38774/32.png) [@Net\_Inventors\_GmbH](https://forum.shopware.com/u/Net_Inventors_GmbH)\
**Post date:** [17. September 2019 um 07:47 UTC](https://forum.shopware.com/t/interpretation-einer-fehlermeldung-nach-update-auf-sw-5-6/61086/9 "2019-09-17T07:47:51Z")

</div>

Ahoi zusammen,

als Plugin-Hersteller möchten wir uns auch mal zu Wort melden 🙂

Das beschriebene Problem liegt daran, dass Foundation 3.x unter Shopware 5.6.x eingesetzt wird, wofür es nicht kompatibel ist.  
Beim Shop-Update von 5.5 auf 5.6 wird explizit darauf hingewiesen, welche Plugins nicht mit der neuen Shop-Version kompatibel sind.  
Diese Plugins sollten also zwingend vor dem Update deaktiviert werden.

Wir haben dazu einen Eintrag in unserem Support-Portal verfasst:  
[https://support.netinventors.de/hc/de/articles/360009247679–Update-von-Version-3-x-auf-Version-4-x-f%C3%BCr-Shopware-ab-5-6-0](https://support.netinventors.de/hc/de/articles/360009247679--Update-von-Version-3-x-auf-Version-4-x-f%C3%BCr-Shopware-ab-5-6-0)

@videho‍  
Dein Problem haben wir in der Foundation-Version 4.0.1 behoben.  
Hier gab es einen kleinen Fehler, den wir unmittelbar korrigiert haben.  
Für die zwischenzeitlichen Unannehmlichkeiten entschuldigen wir uns natürlich.

Beste Grüße aus Hamburg  
Sascha
