# Internal Server Error 500 nach Update auf php 8 (8.0.17)

**URL:** <https://forum.shopware.com/t/internal-server-error-500-nach-update-auf-php-8-8-0-17/98790>\
**Category:** Administration\
**Created:** [4. März 2023 um 12:41 UTC](https://forum.shopware.com/t/internal-server-error-500-nach-update-auf-php-8-8-0-17/98790 "2023-03-04T12:41:41Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![pfannen-joschi](https://avatars.discourse-cdn.com/v4/letter/p/c6cbf5/32.png) [@pfannen-joschi](https://forum.shopware.com/u/pfannen-joschi)\
**Post date:** [4. März 2023 um 12:41 UTC](https://forum.shopware.com/t/internal-server-error-500-nach-update-auf-php-8-8-0-17/98790/1 "2023-03-04T12:41:41Z")

</div>

Hallo,  
ich nutze Shopware 5.7.16 und wollte nun einmal auf PHP 8 umsteigen.

Leider erhalte ich dann einen Internal Server Error 500 nachdem ich das (in Plesk) umstelle.

Sollte Shopware mittlerweile für PHP 8 nicht langsam gerüstet sein?

Freue mich auf eine kurze Einschätzung von den Profis hier.

Danke euch im Voraus.

---

<div class="post-metadata">

**Author:** ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)\
**Post date:** [4. März 2023 um 12:54 UTC](https://forum.shopware.com/t/internal-server-error-500-nach-update-auf-php-8-8-0-17/98790/2 "2023-03-04T12:54:29Z")

</div>

Hallo,

die Ursache für den Fehler 500 solltest Du unter „Protokolle“ in Plesk finden können.  
Ursache ist vermutlich ein Dritt-Anbieter-Plugin.

Viele Grüße

---

<div class="post-metadata">

**Author:** ![pfannen-joschi](https://avatars.discourse-cdn.com/v4/letter/p/c6cbf5/32.png) [@pfannen-joschi](https://forum.shopware.com/u/pfannen-joschi)\
**Post date:** [4. März 2023 um 14:03 UTC](https://forum.shopware.com/t/internal-server-error-500-nach-update-auf-php-8-8-0-17/98790/3 "2023-03-04T14:03:18Z")

</div>

Danke Dir.

Damit habe ich schon einmal das Belboon Conversion Tracking als Fehlerquelle identifiziert. Das Frontend funktioniert schonmal.

Allerdings funktioniert nun das Backend (z. B. die Grundeinstellungen) nicht mehr.

Im Log stehen folgende Apache Fehler:

```auto
2023-03-04 14:54:26	Error	84.167.136.238 AH01071: Got error 'PHP message: PHP Fatal error: Declaration of Shopware_Plugins_Backend_MdvOrderConfirmationMail_Bootstrap::update() must be compatible with Shopware_Components_Plugin_Bootstrap::update($version) in /var/www/vhosts/pfannen-joschi.de/httpdocs/engine/Shopware/Plugins/Community/Backend/MdvOrderConfirmationMail/Bootstrap.php on line 50', referer: https://www.pfannen-joschi.de/backend/ Apache-Fehler
2023-03-04 14:54:26	Error	84.167.136.238 AH01071: Got error 'PHP message: PHP Fatal error: Declaration of Shopware_Plugins_Backend_MdvOrderConfirmationMail_Bootstrap::update() must be compatible with Shopware_Components_Plugin_Bootstrap::update($version) in /var/www/vhosts/pfannen-joschi.de/httpdocs/engine/Shopware/Plugins/Community/Backend/MdvOrderConfirmationMail/Bootstrap.php on line 50', referer: https://www.pfannen-joschi.de/backend/ Apache-Fehler

2023-03-04 14:54:32	Error	84.167.136.238 AH01071: Got error 'PHP message: PHP Fatal error: Declaration of Shopware_Plugins_Backend_MdvOrderConfirmationMail_Bootstrap::update() must be compatible with Shopware_Components_Plugin_Bootstrap::update($version) in /var/www/vhosts/pfannen-joschi.de/httpdocs/engine/Shopware/Plugins/Community/Backend/MdvOrderConfirmationMail/Bootstrap.php on line 50', referer: https://www.pfannen-joschi.de/backend/	

2023-03-04 14:54:55	Error	84.167.136.238 AH01071: Got error 'PHP message: PHP Fatal error: Uncaught Error: Call to undefined function Shopware\\Components\\opcache_get_status() in /var/www/vhosts/pfannen-joschi.de/httpdocs/engine/Shopware/Components/CacheManager.php:418\nStack trace:\n#0 /var/www/vhosts/pfannen-joschi.de/httpdocs/engine/Shopware/Controllers/Backend/Cache.php(83): Shopware\\Components\\CacheManager->getOpCacheCacheInfo()\n#1 /var/www/vhosts/pfannen-joschi.de/httpdocs/engine/Library/Enlight/Controller/Action.php(187): Shopware_Controllers_Backend_Cache->getInfoAction()\n#2 /var/www/vhosts/pfannen-joschi.de/httpdocs/engine/Library/Enlight/Controller/Dispatcher/Default.php(467): Enlight_Controller_Action->dispatch('getInfoAction')\n#3 /var/www/vhosts/pfannen-joschi.de/httpdocs/engine/Library/Enlight/Controller/Front.php(225): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_RequestHttp), Object(Enlight_Controller_Response_ResponseHttp))\n#4 /var/www/vhosts/pfannen-joschi.de/httpdocs/engine/Shopware/Kernel.php(197): Enlight_Contr...', referer: https://www.pfannen-joschi.de/backend/

```

Im Backend erscheint nun

 ![image](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/7/c/7cd807c47431e20962c823ab6d43dd5cecf9268d.png)

Das hilft mir jetzt leider nicht weiter.

Sicher, dass Shopware bereits php 8 kompatibel ist?

Danke für Deine Einschätzung.

---

<div class="post-metadata">

**Author:** ![SmartStylez](https://avatars.discourse-cdn.com/v4/letter/s/a88e4f/32.png) [@SmartStylez](https://forum.shopware.com/u/SmartStylez)\
**Post date:** [4. März 2023 um 14:21 UTC](https://forum.shopware.com/t/internal-server-error-500-nach-update-auf-php-8-8-0-17/98790/4 "2023-03-04T14:21:14Z")

</div>

Hast du solch ein Plugin, welches aktiv ist?

„MdvOrderConfirmationMail“

---

<div class="post-metadata">

**Author:** ![SCOOPEX](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/scoopex/32/18328_2.png) [@SCOOPEX](https://forum.shopware.com/u/SCOOPEX)\
**Post date:** [4. März 2023 um 14:30 UTC](https://forum.shopware.com/t/internal-server-error-500-nach-update-auf-php-8-8-0-17/98790/5 "2023-03-04T14:30:53Z")

</div>

Deaktiviere mal, wie @SmartStylez erwähnt hat, das Plugin „MdvOrderConfirmationMail“ - falls das Backend nicht sauber funktioniert, evtl. zunächst zurück auf PHP 7.4 stellen, Plugin deaktivieren und dann wieder zurück auf PHP8 stellen oder direkt in der Datenbank in der Tabelle s\_core\_plugins bei diesem Plugin in der Spalte „Active“ statt 1 eine 0 eintragen.

---

<div class="post-metadata">

**Author:** ![pfannen-joschi](https://avatars.discourse-cdn.com/v4/letter/p/c6cbf5/32.png) [@pfannen-joschi](https://forum.shopware.com/u/pfannen-joschi)\
**Post date:** [13. Dezember 2023 um 11:31 UTC](https://forum.shopware.com/t/internal-server-error-500-nach-update-auf-php-8-8-0-17/98790/6 "2023-12-13T11:31:08Z")

</div>

Erst einmal sorry für die späte Rückmeldung.

Ich hatte zwischenzeitlich auf 8.0.18 upgedatet. Das oben genannte Plugin MdvOrderConfirmationMail (Bestellbestätigung nochmal senden) habe ich rausgeschmissen 😉

Und siehe da: Es hat funktioniert. Ich hoffe da folgen jetzt nicht noch Probleme.

Danke für die Hilfe!

Gruß  
Gernot

> **[Pfannen Joschi Würzburg](https://www.pfannen-joschi.de)**
>
> Pfannen Joschi Onlineshop für Pfannen, Töpfe und Küchenhelfer. ➤ Versand ab 25 Euro kostenlos ➤ Zahlungsarten: PayPal, Rechnung, Vorkasse ➤ Beratung …
