# Installation -  Routing-Einstellungen Deines Webservers ?

**URL:** https://forum.shopware.com/t/installation-routing-einstellungen-deines-webservers/61218
**Category:** Installation / Einstieg
**Created:** [21. August 2019 um 07:15 UTC](https://forum.shopware.com/t/installation-routing-einstellungen-deines-webservers/61218 "2019-08-21T07:15:12Z")
**Posts on this page:** 13
**Page:** 1

<div class="post-metadata">

### Author: ![FloC3](https://avatars.discourse-cdn.com/v4/letter/f/838e76/32.png) [@FloC3](https://forum.shopware.com/u/FloC3)
#### Post date: [21. August 2019 um 07:15 UTC](https://forum.shopware.com/t/installation-routing-einstellungen-deines-webservers/61218/1 "2019-08-21T07:15:12Z")

</div>

Hallo,

in der [Installationsanleitung](https://docs.shopware.com/de/shopware-6-de/erste-schritte/shopware-6-installieren?category=shopware-6-de/erste-schritte&_ga=2.100427230.136045306.1566368649-1448006319.1562854152&_gac=1.226691695.1564050077.CjwKCAjwpuXpBRAAEiwAyRRPgU4uVFdSVly5bT3Fc46F241rt_JMhDjwX9hhPewZB4UwJU_Xa9U5vRoC1MIQAvD_BwE)&nbsp;ist die Rede von dem hier:

_Bevor Du aber nun mit der Installation beginnst, solltest Du dich vergewissern, dass Dein System die&nbsp;[Systemvoraussetzungen](https://docs.shopware.com/de/shopware-6-de/erste-schritte/systemvoraussetzungen)&nbsp;für Shopware 6 erfüllt.  
Darüber hinaus empfiehlt es sich die Routing-Einstellungen Deines Webservers ggf. anzupassen.&nbsp;  
Ein entsprechendes Beispiel anhand von Apache haben wir Dir hier unten aufgeführt.&nbsp;_

```
 ServerName "_HOST_NAME_" 
 DocumentRoot _SHOPWARE_DIR_/public 

  
  Options Indexes FollowSymLinks MultiViews 
  AllowOverride All 
  Order allow,deny 
  allow from all 
  

 ErrorLog ${APACHE_LOG_DIR}/shopware-platform.error.log 
 CustomLog ${APACHE_LOG_DIR}/shopware-platform.access.log combined 
 LogLevel debug 

```

doch was genau soll das sein? Wo muss ich das einstellen? In eine htaccess kann ich es ja nicht packen, da die selbst im /public liegt …

&nbsp;

ich hab es ohne versucht, doch bekomme den Fehler

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/25b287888d50eb5d7d6f31dc362c4ad5a61d06a5.png)

habe versucht die Domain direkt auf /public zu rooten, dann werde ich beim Aufruf meiner Domain zumindest weitergeleitet auf&nbsp;/recovery/install/ … dann bekomme ich aber folgenden Fehler

```
Fatal error: Uncaught Symfony\Component\Dotenv\Exception\PathException: Unable to read the "/meinhosting/shop/shopware6/test/public/../.env" environment file. in /meinhosting/shop/shopware6/test/vendor/symfony/dotenv/Dotenv.php:484 Stack trace: #0 /meinhosting/shop/shopware6/test/vendor/symfony/dotenv/Dotenv.php(65): Symfony\Component\Dotenv\Dotenv->doLoad(false, Array) #1 /meinhosting/shop/shopware6/test/public/index.php(41): Symfony\Component\Dotenv\Dotenv->load('/meinhosting/shop/...') #2 {main} thrown in /meinhosting/shop/shopware6/test/vendor/symfony/dotenv/Dotenv.php on line 484

```

Berechtitungen habe ich via CHMOD auf 777 gesetzt (rekursiv natürlich)

---

<div class="post-metadata">

### Author: ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)
#### Post date: [21. August 2019 um 07:38 UTC](https://forum.shopware.com/t/installation-routing-einstellungen-deines-webservers/61218/2 "2019-08-21T07:38:45Z")

</div>

Beim Routing muss der VHost nur auf /public zeigen. Mehr muss man da nicht machen. Dein Fehler hat eher nichts mit dem routing zu tun. Ansonsten muss man die URL halt immer mit /public aufrufen wenn man das nicht hat.

Der Fehler klingt eher so, als ob Dateien fehlen. Alles direkt auf dem Server entpackt?

---

<div class="post-metadata">

### Author: ![FloC3](https://avatars.discourse-cdn.com/v4/letter/f/838e76/32.png) [@FloC3](https://forum.shopware.com/u/FloC3)
#### Post date: [21. August 2019 um 07:42 UTC](https://forum.shopware.com/t/installation-routing-einstellungen-deines-webservers/61218/3 "2019-08-21T07:42:13Z")

</div>

direkt auf Server entpackt via Console ja. gerade runtergeladen von hier&nbsp;[https://www.shopware.com/de/download/](https://www.shopware.com/de/download/)

was ist denn dieses&nbsp;/shopware6/test/public/…/.env environment file und wo sollte es liegen? Muss ich das selbst anlegen?

es wird ja offenbar versucht das File in&nbsp;/vendor/symfony/dotenv/Dotenv.php:484 zu laden…&nbsp;

auffällig ist am Pfad ja der doppelte Punkt&nbsp;/public/ **…/**.env … die Datei hab ich überhaupt nicht, die sollte ja dann wohl außerhalb von /public liegen oder?

---

<div class="post-metadata">

### Author: ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)
#### Post date: [21. August 2019 um 07:58 UTC](https://forum.shopware.com/t/installation-routing-einstellungen-deines-webservers/61218/4 "2019-08-21T07:58:54Z")

</div>

Dann schau doch erstmal ob das .env File denn da überhaupt ist. Lau Fehlermeldung wird es ja ein Verzeichnis über public gesucht.

---

<div class="post-metadata">

### Author: ![FloC3](https://avatars.discourse-cdn.com/v4/letter/f/838e76/32.png) [@FloC3](https://forum.shopware.com/u/FloC3)
#### Post date: [21. August 2019 um 08:03 UTC](https://forum.shopware.com/t/installation-routing-einstellungen-deines-webservers/61218/5 "2019-08-21T08:03:21Z")

</div>

hab die Datei .env mit der Hand leer angelegt, dann komm ich zwar einen Schritt weiter aber zum nächsten Fehler

```
Warning: require(/meinhosting/shop/shopware6/test/vendor/composer/../symfony/polyfill-ctype/bootstrap.php): failed to open stream: No such file or directory in /meinhosting/shop/shopware6/test/vendor/composer/autoload_real.php on line 66

Fatal error: require(): Failed opening required '/meinhosting/shop/shopware6/test/vendor/composer/../symfony/polyfill-ctype/bootstrap.php' (include_path='.:/usr/local/lib/php') in /meinhosting/shop/shopware6/test/vendor/composer/autoload_real.php on line 66

```

irgendwie ist das unbefriedigend…&nbsp; kann die Installation nicht einfach&nbsp;funktioniern ohne Probleme, so wie es bei SW5 der Fall war?

Warum muss ich überhaupt eine Datei mit der Hand anlegen?

---

<div class="post-metadata">

### Author: ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)
#### Post date: [21. August 2019 um 08:31 UTC](https://forum.shopware.com/t/installation-routing-einstellungen-deines-webservers/61218/6 "2019-08-21T08:31:30Z")

</div>

Muss man ja garnicht, funktioniert bei anderen ja auch so&nbsp; ![Wink](https://forum.shopware.com/plugins/CKEditor/plugins/smiley/images/wink.png "Wink")

Schmeiß die Installation mal weg und beginne von vorne. Kenne dein System jetzt nicht, aber bei unseren zertifizierten Hostern läuft das out of the Box. Lokal mit Standard Lamp unter Ubuntu auch. Php7.2 auch aktiv?

---

<div class="post-metadata">

### Author: ![FloC3](https://avatars.discourse-cdn.com/v4/letter/f/838e76/32.png) [@FloC3](https://forum.shopware.com/u/FloC3)
#### Post date: [21. August 2019 um 08:38 UTC](https://forum.shopware.com/t/installation-routing-einstellungen-deines-webservers/61218/7 "2019-08-21T08:38:52Z")

</div>

1. Verezeichnis im Hosting (Domainfactory via jWeiland)&nbsp;gelöscht

2. Verzeichnis neu angelegt, ZIP neu heruntergeladen, auf Server geladen und entpackt

3. PHP 7.2.11 aktiv

4. chmod -R 777

5. selber Fehler wieder mit den&nbsp;.env File --\> .env File manuell erstellt

&nbsp;

erhalte jetzt diesen Fehler

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/0/038b65be1ea01e1c7e55c51357a6b48f53a6563a.png)

---

<div class="post-metadata">

### Author: ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)
#### Post date: [21. August 2019 um 08:45 UTC](https://forum.shopware.com/t/installation-routing-einstellungen-deines-webservers/61218/8 "2019-08-21T08:45:24Z")

</div>

Verzeichnisrechte pauschal auf 0777 setzen ist auch ein eigenartiger Schritt. Stelle mal sicher, dass der Prozess der den Webserver betreibt auch Besitzer der Dateien ist. Dann braucht man auch kein 0777.&nbsp;Wenn das nötige ist, liegt ja generell was im Argen auf dem Server. Wie gesagt, dass env File musst du nicht erstellen, war eben nur ein Test.&nbsp;

1. entpacken auf dem Server

2. Verzeichnisrechte anpassen, wie es der Server benötigt &nbsp;(nicht 0777, ist im Web immer eine schlechte Idee)

3. Domain/recovery/install/index.php aufrufen&nbsp;

&nbsp;

Wenn das nicht klappt, musst du mal debuggen woran es liegt, sind ja nur php Dateien. Generell hat es hier&nbsp;ja bei Profihost, All-Inkl., Timme, lokal usw. schon hundertfach funktioniert. Der Installer basiert auf dem SW5 installer, da hat sich nicht groß etwas verändert.

&nbsp;

&nbsp;

---

<div class="post-metadata">

### Author: ![FloC3](https://avatars.discourse-cdn.com/v4/letter/f/838e76/32.png) [@FloC3](https://forum.shopware.com/u/FloC3)
#### Post date: [21. August 2019 um 08:49 UTC](https://forum.shopware.com/t/installation-routing-einstellungen-deines-webservers/61218/9 "2019-08-21T08:49:45Z")

</div>

tut mir leid, aber ich debugge doch nicht einen Installer von dem ich erwarte, dass er auf jedem Hosting einwandfrei funktioniert.

das ist dann wohl das Todesurteil für uns in Sachen Shopware 6, für sowas hat niemand Zeit. Ein neuer Shop muss in 5min installiert sein… ging ja bei SW5 auch einwandfrei.

ob das setzen von 777 gut oder schlecht ist, ist ja erstmal egal. Ich wollte halt auf Nummer sicher gehen um das Problem so evtl. zu beseitigen.

“Prozess der den Webserver betreibt auch Besitzer der Dateien ist” --\> wie stellst du dir das vor, wie ich das machen soll?

&nbsp;

EDIT:

wenn ich direkt&nbsp;/recovery/install/index.php aufrufe, komme ich zu einem Installer. Mal sehen ob das durch geht… wieso leitet mich die BaseURL dann nicht auf&nbsp;/recovery/install/index.php weiter sondern auf&nbsp;/recovery/install ?

---

<div class="post-metadata">

### Author: ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)
#### Post date: [21. August 2019 um 08:57 UTC](https://forum.shopware.com/t/installation-routing-einstellungen-deines-webservers/61218/10 "2019-08-21T08:57:16Z")

</div>

Wenn du einen Webserver betreibst solltest du dich auch mit Linux auseinander setzen, ansonsten den Hoster fragen. Besitz- und Zugriffsrechte sind sehr komplex und müssen auf den Betrieb der Seite abgestimmt werden. Alles für alle freigeben (0777) öffnet nur Haus und Hof für mögliche Angriffe durch dritte. Das hat auch nichts mit Shopware zu tun. Das ist für jede Art von Webserver immer eine schlechte Idee.

Und der Installer leitet korrekt weiter. Wahrscheinlich ignoriert dein Webserver hier die Konfiguration, dass die index.php angesprochen werden soll, wenn keine Datei übermittelt wird. Aber auch das ist Konfigurationssache auf dem Server.

Der Installer wird nicht überall funktionieren. Das gibt es schlichtweg nicht. Dafür gibt es Hoster die sich mit den Betrieb von Webservern auseinander setzen und die korrekt konfigurieren. Wobei das nun wirklich noch eine Kleinigkeit ist.

&nbsp;

---

<div class="post-metadata">

### Author: ![drakon](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/drakon/32/7724_2.png) [@drakon](https://forum.shopware.com/u/drakon)
#### Post date: [21. August 2019 um 10:15 UTC](https://forum.shopware.com/t/installation-routing-einstellungen-deines-webservers/61218/11 "2019-08-21T10:15:04Z")

</div>

Domainfactory und Shopware war und ist immer ein Gefrickel. (liegt an dem speziellen Setup, den dF abweichend zu anderen Hostern hat).&nbsp;Wenn es dann funktioniert, ist es im Vergleich zu Angeboten von Hostern, die spezielle Shopware-Angebote in der selben Preisklasse&nbsp;haben, recht langsam. Das war einer,&nbsp;aber nicht der einzige Grund, warum ich vor ein paar Jahren von dF weg bin.

---

<div class="post-metadata">

### Author: ![FloC3](https://avatars.discourse-cdn.com/v4/letter/f/838e76/32.png) [@FloC3](https://forum.shopware.com/u/FloC3)
#### Post date: [21. August 2019 um 10:42 UTC](https://forum.shopware.com/t/installation-routing-einstellungen-deines-webservers/61218/12 "2019-08-21T10:42:39Z")

</div>

@drakon‍ ja das mit der Performance unter DF hab ich auch schon feststellen müssen… lässt sich leider nicht ändern.

was aber noch viel gravierender ist, was ich gerade festgestellt habe:

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/8/8b3ade2c3d401c502e8b48b239a9fa14fa99b727.png)

höher als 5.6.19 komme ich bei DF aber nicht. Shopware 6 und DomainFactory sind also nicht kompatibel… Mist

---

<div class="post-metadata">

### Author: ![drakon](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/drakon/32/7724_2.png) [@drakon](https://forum.shopware.com/u/drakon)
#### Post date: [21. August 2019 um 10:50 UTC](https://forum.shopware.com/t/installation-routing-einstellungen-deines-webservers/61218/13 "2019-08-21T10:50:25Z")

</div>

Und da dF zumindest in der Vergangenheit sehr „konservativ“ beim Umsetzen von Technologie(Updates|Neuheiten|Sprüngen) war, ist davon auszugehen, dass auch die MySQL&nbsp;5.7. eher erst in Monaten oder Jahren eingeführt wird.

Das soll kein Bashing sein, muss man aber als (pot.) Kunde wissen.
