# Installation klapp nicht

**URL:** https://forum.shopware.com/t/installation-klapp-nicht/17705
**Category:** Shopware 3.5
**Tags:** installation--gettin
**Created:** [10. Januar 2014 um 13:21 UTC](https://forum.shopware.com/t/installation-klapp-nicht/17705 "2014-01-10T13:21:24Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![zanu](https://avatars.discourse-cdn.com/v4/letter/z/e68b1a/32.png) [@zanu](https://forum.shopware.com/u/zanu)
#### Post date: [10. Januar 2014 um 13:21 UTC](https://forum.shopware.com/t/installation-klapp-nicht/17705/1 "2014-01-10T13:21:24Z")

</div>

Hallo Forengemeinde, ich laufe schon im Kreis, kann aber den Fehler nicht bestimmen! Auch die Lösungen hier im Forum, meinem Problem ähnlich haben nicht geholfen. Shopware Version 4.1.4 - installiert in Unterordner /shopware. mode\_rewrite steht auf aktiv, 2 Tests zeigen unabhängig aktiv an! Der Software-Check zeigt alle Punkte OK! Um Shopware zu installieren musst ich die .htacces deaktivieren, dann lief das Script anstandslos, Ändereungen in der .htacces haben nichts gebracht. Immer Fehler 500-Internal Server Error. Nach Installation Test mit .htaccess, Fehler 500-Internal Server Error im Backend und im Frontend! Deaktivierte .htaccess bringt Fehler 403-You don’t have permission to access /shopware/ on this server. Änderungen in der .htaccess bringen nichts, zumindest die Änderungen die ich mache! Wer kennt das Problem? Danke für Hilfe im Voraus, Gruss zanu

---

<div class="post-metadata">

### Author: ![Martin\_Weinmayr](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/martin_weinmayr/32/13016_2.png) [@Martin\_Weinmayr](https://forum.shopware.com/u/Martin_Weinmayr)
#### Post date: [10. Januar 2014 um 18:54 UTC](https://forum.shopware.com/t/installation-klapp-nicht/17705/2 "2014-01-10T18:54:38Z")

</div>

Servus, Ein paar Fragen. Was steht bei dir in der htacces rewritebase? Welcher hoster? Was passiert wenn du [deinshop.de/shopware/shopware.php](http://deinshop.de/shopware/shopware.php) Aufrufst? Vg

---

<div class="post-metadata">

### Author: ![brandings4you](https://avatars.discourse-cdn.com/v4/letter/b/b4bc9f/32.png) [@brandings4you](https://forum.shopware.com/u/brandings4you)
#### Post date: [10. Januar 2014 um 20:43 UTC](https://forum.shopware.com/t/installation-klapp-nicht/17705/3 "2014-01-10T20:43:30Z")

</div>

Hm, spielt nicht auch ioncube eine Rolle bei der Installation? Bei mir zeigte der Systemcheck einige Fehler, dabei war alles wie es sein muss; so hatte ich angeblich ein mode\_rewrite obwohl das Ding “on” war. Noch einige Dinge die als Fehler angezeigt wurden, aber die Installation lief durch und alles funktioniert. Lediglich die Systeminfo zeigt mir noch an das irgeneine “grid” und eine “template” Datei nicht vorhanden sind…Shop läuft trotzdem. Bin ja selbst Neuling und hab keine Ahnung von nichts, aber trotzdem habe ich es schon bis hierher geschafft: [brandings4you.de](http://brandings4you.de) Ich versuche gerade das Template abzuändern, Farben zu tauschen, aber da klappt seit 2 Tagen gar nichts… Also wenn Ioncube nicht installiert ist denke ich, wird Shopware auch nicht laufen… Gruß, Wolfram

---

<div class="post-metadata">

### Author: ![zanu](https://avatars.discourse-cdn.com/v4/letter/z/e68b1a/32.png) [@zanu](https://forum.shopware.com/u/zanu)
#### Post date: [10. Januar 2014 um 21:48 UTC](https://forum.shopware.com/t/installation-klapp-nicht/17705/4 "2014-01-10T21:48:09Z")

</div>

Hallo Martin, danke erstmal für deine rasche Antwort! Wenn ich [meinshop.net/shopware/shopware.php](http://meinshop.net/shopware/shopware.php) aufrufe erhalte ich den Fehler:\> Fehler 404 — The requested URL /shopware.php was not found on this server. Rufe ich das Backend auf, kommt folgender Fehler: Fehler 500 — Internal Server Error gehostet bei — [webhoster.de](http://webhoster.de) — In meiner .htaccess steht:  
RewriteEngine on  
RewriteBase/ [color=red]— hier auch ohne Slash das selbe Ergebnis! —[/color]  
RewriteRule shopware.dll shopware.php  
RewriteRule files/documents/.\* engine [NC,L]  
RewriteRule backend/media/(.\*) media/1 [NC,L] RewriteCond %{REQUEST\_URI} !(\/(engine|files|templates)\/) RewriteCond %{REQUEST\_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/) RewriteCond %{REQUEST\_FILENAME} !-f RewriteCond %{REQUEST\_FILENAME} !-d RewriteRule ^(.\*) shopware.php [PT,L,QSA]  
# Staging-Rules start #SetEnvIf Host „staging.test.shopware.in“ ENV=staging DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php # Disables download of configuration  
Deny from all  
# Enable gzip compression  
AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/json  
  
  
ExpiresActive on  
ExpiresDefault „access plus 1 month“  
FileETag None  
  
Header append Cache-Control „public“  
Header unset ETag  
  
  
# Disables auto directory index  
Options -Indexes  
  
Options -MultiViews

# php\_value memory\_limit 128M

# php\_value max\_execution\_time 120

# php\_value upload\_max\_filesize 20M

php\_flag phar.readonly off  
php\_flag magic\_quotes\_gpc off  
php\_flag session.auto\_start off  
php\_flag suhosin.session.cryptua off  
php\_flag zend.ze1\_compatibility\_mode off  
# AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php Hallo Wolfram, Ioncube ist installiert! Gruss an euch beide, zanu

---

<div class="post-metadata">

### Author: ![brandings4you](https://avatars.discourse-cdn.com/v4/letter/b/b4bc9f/32.png) [@brandings4you](https://forum.shopware.com/u/brandings4you)
#### Post date: [10. Januar 2014 um 23:23 UTC](https://forum.shopware.com/t/installation-klapp-nicht/17705/5 "2014-01-10T23:23:01Z")

</div>

Hey Zanu, versuch bitte mal folgendes:  
RewriteEngine on

RewriteBase /[color=blue]shopware/[/color]

RewriteRule shopware.dll shopware.php  
RewriteRule files/documents/.\* engine [NC,L]  
RewriteRule backend/media/(.\*) media/$1 [NC,L]

RewriteCond %{REQUEST\_URI} !(/(engine|files|templates)/)  
RewriteCond %{REQUEST\_URI} !(/media/(archive|banner|image|music|pdf|unknown|video)/)  
RewriteCond %{REQUEST\_FILENAME} !-f  
RewriteCond %{REQUEST\_FILENAME} !-d  
RewriteRule ^(.\*)$ shopware.php [PT,L,QSA]  
# Staging-Rules start #SetEnvIf Host “staging.test.shopware.in” ENV=staging DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php füge das blaue an entsprechender Stelle in die ht.access ein und ruf nochmal den Shop auf wie Du es vorher gemacht hast. Da Du ja in einem Unterordner installiert hast, musst Du ihn vielleicht auch wie hier oben beschrieben ansprechen… glaube ich; ist nur ne Idee, wie gesagt hab ich keinen Plan vom Ganzen. Gruß, Wolfram

---

<div class="post-metadata">

### Author: ![zanu](https://avatars.discourse-cdn.com/v4/letter/z/e68b1a/32.png) [@zanu](https://forum.shopware.com/u/zanu)
#### Post date: [11. Januar 2014 um 08:56 UTC](https://forum.shopware.com/t/installation-klapp-nicht/17705/6 "2014-01-11T08:56:54Z")

</div>

Hallo Wolfram, habe ich schon versucht, Frontend und Backend mit domain/shopware domain/shopware/shopware.php domain/backend Ergebnis: Fehler 500 Internal Server Error leider, trotzdem danke für deine Antwort, Gruss zanu

---

<div class="post-metadata">

### Author: ![brandings4you](https://avatars.discourse-cdn.com/v4/letter/b/b4bc9f/32.png) [@brandings4you](https://forum.shopware.com/u/brandings4you)
#### Post date: [11. Januar 2014 um 09:23 UTC](https://forum.shopware.com/t/installation-klapp-nicht/17705/7 "2014-01-11T09:23:01Z")

</div>

Moinsen Zanu, was passiert wenn Du domain/shopware/index.php eintippst? Sind ja nur Überlegungen, aber vielleicht liegt irgend etwas nicht da wo es eigentlich hingehört…oder es ist wieder ein einzelner Punkt in der ht. die Du speziell wegen Deinem Hoster auskommentieren musst. Hast Du bei Webhoster in den FAQ mal gestöbert? Ansonsten bin ich persönlich auch ratlos, sorry. Wenn die Punkte auch schon ergebnislos abgearbeitet sind bleibt nur die Frage beim professionellen Support denke ich. Viel Erfolg wünsche ich Dir bei der Bastelei; ich mach mich auch wieder ans Werk… Gruß, Wolfram

---

<div class="post-metadata">

### Author: ![Martin\_Weinmayr](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/martin_weinmayr/32/13016_2.png) [@Martin\_Weinmayr](https://forum.shopware.com/u/Martin_Weinmayr)
#### Post date: [11. Januar 2014 um 09:49 UTC](https://forum.shopware.com/t/installation-klapp-nicht/17705/8 "2014-01-11T09:49:25Z")

</div>

Kannst du mal folgendes testen bitte. Htaccess RewriteBase /shopware/ RewriteBase / #RewriteBase /shopware/ (Jeweils natürlich nur mit einem versuchen) Und dass bitte wahlweise so aufrufen [Domain.de/shopware/](http://Domain.de/shopware/) [Domain.de/shopware/shopware.php](http://Domain.de/shopware/shopware.php) Vor allem die letzte Domain mit der auskommentierten rewritebase muss eigentlich laut Logik klappen… Vg

---

<div class="post-metadata">

### Author: ![zanu](https://avatars.discourse-cdn.com/v4/letter/z/e68b1a/32.png) [@zanu](https://forum.shopware.com/u/zanu)
#### Post date: [11. Januar 2014 um 11:24 UTC](https://forum.shopware.com/t/installation-klapp-nicht/17705/9 "2014-01-11T11:24:53Z")

</div>

Hallo Martin, mit: RewriteBase /shopware/ — und domain/shopware — fehler 500 domain/shopware/shopware.php — fehler 500 mit: RewriteBase / — und Aufruf wie oben —Fehler 500 mit #RewriteBase /shopware/ — -"- — Fehler 500 also mit keiner Einstellung und keinem Aufruf ein pos. Ergebnis. Immer Internal Server Error Gruss zanu

---

<div class="post-metadata">

### Author: ![zanu](https://avatars.discourse-cdn.com/v4/letter/z/e68b1a/32.png) [@zanu](https://forum.shopware.com/u/zanu)
#### Post date: [11. Januar 2014 um 15:29 UTC](https://forum.shopware.com/t/installation-klapp-nicht/17705/10 "2014-01-11T15:29:35Z")

</div>

Hallo Martin, Problem gelöst (mit Vorbehalt) hier meine .htaccess  
RewriteEngine on

RewriteBase /shopware/

RewriteRule shopware.dll shopware.php  
RewriteRule files/documents/.\* engine [NC,L]  
RewriteRule backend/media/(.\*) media/$1 [NC,L]

RewriteCond %{REQUEST\_URI} !(/(engine|files|templates)/)  
RewriteCond %{REQUEST\_URI} !(/media/(archive|banner|image|music|pdf|unknown|video)/)  
RewriteCond %{REQUEST\_FILENAME} !-f  
RewriteCond %{REQUEST\_FILENAME} !-d  
RewriteRule ^(.\*)$ shopware.php [PT,L,QSA]  
# Staging-Rules start #SetEnvIf Host „staging.test.shopware.in“ ENV=staging DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php # Disables download of configuration #

# Deny from all

## Enable gzip compression #

# AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/json

##  
#

# ExpiresActive on

# ExpiresDefault „access plus 1 month“

# FileETag None

# 

# Header append Cache-Control „public“

# Header unset ETag

# 

#  
## # Disables auto directory index #

# Options -Indexes

##

# Options -MultiViews

## #

# php\_value memory\_limit 128M

# php\_value max\_execution\_time 120

# php\_value upload\_max\_filesize 20M

# php\_flag phar.readonly off

# php\_flag magic\_quotes\_gpc off

# php\_flag session.auto\_start off

# php\_flag suhosin.session.cryptua off

# php\_flag zend.ze1\_compatibility\_mode off

## # AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php # mein Sohn (Programmierer) ist zu Besuch und hat den Shop in 2 Minuten zum laufen gebracht. Er hat das naheliegende gemacht und alles nicht notwendige auskommentiert. Shop ist nun mit aktiver .htaccess neu installiert. Frontend und Backend problemlos zu erreichen. Das Backend habe ich nur angetestet und aus Zeitmangel (WE und Familie) abgebrochen. Sollte ein Forenmitglied das selbe Problem haben, bitte die .htaccess mit Vorsicht anwenden. Falls im Backend nicht alle Funktionen aktiv sind müsste man Schritt für Schritt die .htaccess weiter aufarbeiten. Schönes Wochenende und Gruss, zanu
