# Installation auf Profihost beginnt mit Fehler

**URL:** https://forum.shopware.com/t/installation-auf-profihost-beginnt-mit-fehler/22456
**Category:** Shopware 3.5
**Tags:** installation--gettin
**Created:** [16. September 2014 um 14:34 UTC](https://forum.shopware.com/t/installation-auf-profihost-beginnt-mit-fehler/22456 "2014-09-16T14:34:55Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![markmobile](https://avatars.discourse-cdn.com/v4/letter/m/ee59a6/32.png) [@markmobile](https://forum.shopware.com/u/markmobile)
#### Post date: [16. September 2014 um 14:34 UTC](https://forum.shopware.com/t/installation-auf-profihost-beginnt-mit-fehler/22456/1 "2014-09-16T14:34:55Z")

</div>

Hallo, will einen Testshop von Shopware installieren. Den Shop habe ich in ein Unterverzeichniss kopiert. Und rufe die Installation üder das Verzeichnis \Recovery\install\index.php auf. Dabei erhalte ich folgende Fehlermeldung: [quote]Warning: require\_once(\_\_DIR\_\_/…/common/autoload.php) [function.require-once]: failed to open stream: No such file or directory in /schjhrmr/www.schulranzen-geiger.de/shopware/recovery/install/index.php on line 25 Fatal error: require\_once() [function.require]: Failed opening required ‚\_\_DIR\_\_/…/common/autoload.php‘ (include\_path=’.:/usr/local/php5.2/lib/php’) in /schjhrmr/www.schulranzen-geiger.de/shopware/recovery/install/index.php on line 25[/quote] Zur Zeit nutzen wir einen Oxid Shop Version 4.4

---

<div class="post-metadata">

### Author: ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)
#### Post date: [16. September 2014 um 14:38 UTC](https://forum.shopware.com/t/installation-auf-profihost-beginnt-mit-fehler/22456/2 "2014-09-16T14:38:26Z")

</div>

Hi, ich vermute da passt was mit den Systemvoraussetungen nicht. Da ist eine Meldung bzgl. PHP 5.2 Shopware benötigt mindestens 5.3 Das sollte zuerst geprüft werden. Im weiteren Schritt bitte mal nachsehen, ob die angezeigte Datei auch wirklich vorhanden ist Sebastian

---

<div class="post-metadata">

### Author: ![Shopwareianer](https://avatars.discourse-cdn.com/v4/letter/s/b4bc9f/32.png) [@Shopwareianer](https://forum.shopware.com/u/Shopwareianer)
#### Post date: [16. September 2014 um 14:39 UTC](https://forum.shopware.com/t/installation-auf-profihost-beginnt-mit-fehler/22456/3 "2014-09-16T14:39:18Z")

</div>

Unter dem Verzeichnis wird nichts gefunden -\> [http://schulranzen-geiger.de/shopware/](http://schulranzen-geiger.de/shopware/) Evtl. verbietet die .htaccess Unterverzeichnisse bzw. versucht der Oxid Shop ja hier die URL aufzurufen. Da du hier das ebend auch mit [http://schulranzen-geiger.de/shopware/](http://schulranzen-geiger.de/shopware/) aufrufst, besser wäre hier wohl eine Subdomain. [shopware.schulranzen-geiger.de](http://shopware.schulranzen-geiger.de) Damit wird es vermutlich gehen. Ansonsten wende dich doch einmal an den Profihost Support, dafür zahlst du doch ?

---

<div class="post-metadata">

### Author: ![markmobile](https://avatars.discourse-cdn.com/v4/letter/m/ee59a6/32.png) [@markmobile](https://forum.shopware.com/u/markmobile)
#### Post date: [16. September 2014 um 14:56 UTC](https://forum.shopware.com/t/installation-auf-profihost-beginnt-mit-fehler/22456/4 "2014-09-16T14:56:14Z")

</div>

Hallo Sebastian, das ging aber schnell DANKE Ja das stimmt auf dem Server läuft die PHP Version 5.2.17. Dann ist das wohl der Fehler. Zur Zeit nutzen wir einen Oxid Shop Version 4.4 die Frage ist wie wirkt sich ein Update auf PHP 5.3 aus. Der Shop ist ja Produktiv. Edit @Kayyy Deine Antwort habe ich übersehen. Das Verzeichniss habe ich nach dem Test umbenannt. Das mit der Subdomain hatte ich auch schon getestet gleicher Fehler.

---

<div class="post-metadata">

### Author: ![profihost1](https://avatars.discourse-cdn.com/v4/letter/p/ecccb3/32.png) [@profihost1](https://forum.shopware.com/u/profihost1)
#### Post date: [17. September 2014 um 09:55 UTC](https://forum.shopware.com/t/installation-auf-profihost-beginnt-mit-fehler/22456/5 "2014-09-17T09:55:44Z")

</div>

Hallo, Sie können die PHP Version innerhalb eines Verzeichnisses umstellen. Dies betrifft dann das aktuelle Verzeichnis inklusive Unterordner. Die Umstellung betrifft aber keine übergeordneten Verzeichnisse. Somit haben Sie in dem Shopware Verzeichnis die Version 5.4 laufen und Ihr anderes Shopsystem läuft weiterhin auf PHP 5.2 Gehen Sie in das Verzeichnis, in welchem Sie Shopware installieren wollen. Laden Sie dort die Shopware Installationsdateien hoch und fügen Sie folgende Informationen der Datei “.htaccess” hinzuzu: `# Liste der Dateiendungen die als PHP5.4 verarbeitet werden sollen AddHandler php-fastcgi5.4 .php .phtml` Den entsprechenden FAQ Artikel finden Sie hier: [https://www.profihost.com/forum/skripts … erl-python](https://www.profihost.com/forum/skriptsprachen-(php-perl-python))/php-5-4-aktivieren/ Außerdem empfehle ich folgende PHP Einstellungen für Shopware. [https://www.profihost.com/forum/shopwar … -shopware/](https://www.profihost.com/forum/shopware-shopsystem/empfohlene-ini-datei-fur-shopware/)

---

<div class="post-metadata">

### Author: ![markmobile](https://avatars.discourse-cdn.com/v4/letter/m/ee59a6/32.png) [@markmobile](https://forum.shopware.com/u/markmobile)
#### Post date: [17. September 2014 um 10:53 UTC](https://forum.shopware.com/t/installation-auf-profihost-beginnt-mit-fehler/22456/6 "2014-09-17T10:53:10Z")

</div>

Hallo, und danke für den Tipp. Habe das Gestern an meinen Webadmin weiter gegeben und der hat das so gemacht. Leider kam immer noch ein Fehler bei mod\_Rewrite obwohl eingeschaltet. Den kann man laut Profihost überspringen. Der Shop läuft nun!! Danke für die Unterstützung!

---

<div class="post-metadata">

### Author: ![markmobile](https://avatars.discourse-cdn.com/v4/letter/m/ee59a6/32.png) [@markmobile](https://forum.shopware.com/u/markmobile)
#### Post date: [17. September 2014 um 13:25 UTC](https://forum.shopware.com/t/installation-auf-profihost-beginnt-mit-fehler/22456/7 "2014-09-17T13:25:01Z")

</div>

Wollte das Plugin für den Datenimport von Oxid laden. Leider klappt die Verifizierung der Domain nicht obwohl die HTML Datei erreichbar ist. [schulranzen-geiger.de/shopware/1f0826e16a7b2b04b2220c4aaa27833c.html](http://schulranzen-geiger.de/shopware/1f0826e16a7b2b04b2220c4aaa27833c.html) Habe es schon mehrfach getestet… Dadurch kann ich im Shop nicht einkaufen auch nicht kostenlose Plugins.

---

<div class="post-metadata">

### Author: ![markmobile](https://avatars.discourse-cdn.com/v4/letter/m/ee59a6/32.png) [@markmobile](https://forum.shopware.com/u/markmobile)
#### Post date: [17. September 2014 um 16:18 UTC](https://forum.shopware.com/t/installation-auf-profihost-beginnt-mit-fehler/22456/8 "2014-09-17T16:18:33Z")

</div>

GELÖST mit Hilfe der WIKI [http://wiki.shopware.de/Shopware-Account-Shopware-ID\_detail\_89.html](http://wiki.shopware.de/Shopware-Account-Shopware-ID%5C_detail%5C_89.html)
