# Import - es werden immer nur max 50 Artikel / Elemente importiert

**URL:** <https://forum.shopware.com/t/import-es-werden-immer-nur-max-50-artikel-elemente-importiert/69091>\
**Category:** Administration\
**Created:** [21. August 2020 um 10:46 UTC](https://forum.shopware.com/t/import-es-werden-immer-nur-max-50-artikel-elemente-importiert/69091 "2020-08-21T10:46:33Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![der\_eder](https://avatars.discourse-cdn.com/v4/letter/d/65b543/32.png) [@der\_eder](https://forum.shopware.com/u/der_eder)\
**Post date:** [21. August 2020 um 10:46 UTC](https://forum.shopware.com/t/import-es-werden-immer-nur-max-50-artikel-elemente-importiert/69091/1 "2020-08-21T10:46:33Z")

</div>

Hallo zusammen,

ich habe eine Frage zum Importer. Egal was ich importiere (Artikel, Varianten, usw), es werden immer nur 50 Elemente importiert.  
An was könnte dies liegen? Nach ca. 30 Sek. erscheint immer eine Meldung „Request failed with status code 500“.

Danke für jeden Hinweis.

Viele Grüße  
Michael

---

<div class="post-metadata">

**Author:** ![AndreHerking](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/andreherking/32/7839_2.png) [@AndreHerking](https://forum.shopware.com/u/AndreHerking)\
**Post date:** [21. August 2020 um 11:07 UTC](https://forum.shopware.com/t/import-es-werden-immer-nur-max-50-artikel-elemente-importiert/69091/2 "2020-08-21T11:07:22Z")

</div>

Klingt wie ein Timeout - was ist bei dir max\_execution\_time auf dem Server? Setzt die ggf. mal hoch und schaue dann.

---

<div class="post-metadata">

**Author:** ![der\_eder](https://avatars.discourse-cdn.com/v4/letter/d/65b543/32.png) [@der\_eder](https://forum.shopware.com/u/der_eder)\
**Post date:** [21. August 2020 um 15:51 UTC](https://forum.shopware.com/t/import-es-werden-immer-nur-max-50-artikel-elemente-importiert/69091/3 "2020-08-21T15:51:30Z")

</div>

War auch mein ursprünglicher Verdacht. Aber die ist seit jeher auf&nbsp;300 eingestellt.&nbsp;

Komisch ist, dass es immer nur 50 Elemente sind die importiert werden.

---

<div class="post-metadata">

**Author:** ![Schwob2](https://avatars.discourse-cdn.com/v4/letter/s/47e85d/32.png) [@Schwob2](https://forum.shopware.com/u/Schwob2)\
**Post date:** [19. März 2021 um 16:29 UTC](https://forum.shopware.com/t/import-es-werden-immer-nur-max-50-artikel-elemente-importiert/69091/4 "2021-03-19T16:29:13Z")

</div>

Ich kann ohne Probleme bis zu 1100 Produkte importieren. HAbe aber mit mehr Probleme. Eine Datei mit 6.000 Artikel wird nicht importiert. Nach ein paar Sekunden kommt der grüne Haken und dann folgender Logeintrag:

Filename - 180320\_Loadscsv.csv  
Type - Import  
Successfully imported records - 0  
File size - 0.00B  
User - admin  
Date / Time - 19/03/21, 17:21  
Status - Succeeded

Datei hat 7MB. Gibt es harte Beschränkungen bei der Import Funktion bezüglich Dateigröße oder Anzahl Records? Oder muss ich eher bei mir nach dem Problem suchen? Danke

---

<div class="post-metadata">

**Author:** ![DavidH](https://avatars.discourse-cdn.com/v4/letter/d/a4c791/32.png) [@DavidH](https://forum.shopware.com/u/DavidH)\
**Post date:** [23. Juli 2021 um 12:43 UTC](https://forum.shopware.com/t/import-es-werden-immer-nur-max-50-artikel-elemente-importiert/69091/5 "2021-07-23T12:43:17Z")

</div>

Hallo,

habe leider das gleiche Problem wie @der_eder … max\_execution\_time ist auf 500 gesetzt und versuche den Namen und das Coverbild von Varianten zu ändern. Importiert werden taxId, translations.DEFAULT.name, stock, productNumber, id und cover.mediaId. Die Datei hat ~1200 Artikel, habe Sie aber Testweise auf 4 Dateien mit je ~300 Artikeln und einer Dateigröße von ~30 kb heruntergebrochen. Trotzdem kommt immer wieder die Fehlermeldung: „Request failed with status code 500“

Weiß zufällig jemand woran das liegt oder was man da machen kann? @AndreHerking eventuell?  
Wäre über jede Hilfe Dankbar.

LG  
David

---

<div class="post-metadata">

**Author:** ![AndreHerking](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/andreherking/32/7839_2.png) [@AndreHerking](https://forum.shopware.com/u/AndreHerking)\
**Post date:** [27. Juli 2021 um 13:02 UTC](https://forum.shopware.com/t/import-es-werden-immer-nur-max-50-artikel-elemente-importiert/69091/6 "2021-07-27T13:02:41Z")

</div>

Die Meldung reicht leider nicht, wir benötigen den Fehler hinter den Code 500 - schau am Besten mal ins PHP Error Log, oder aber in der Google Dev Console im Netzwerk Tab.

---

<div class="post-metadata">

**Author:** ![DavidH](https://avatars.discourse-cdn.com/v4/letter/d/a4c791/32.png) [@DavidH](https://forum.shopware.com/u/DavidH)\
**Post date:** [28. Juli 2021 um 07:44 UTC](https://forum.shopware.com/t/import-es-werden-immer-nur-max-50-artikel-elemente-importiert/69091/7 "2021-07-28T07:44:04Z")

</div>

Hallo Andre, Danke für deine Hilfe! Hier die entsprechenden Fehlermeldungen:

Fehlermeldung aus dem Log:  
2021-07-28 09:36:30.157908 [INFO] [3772957] [87.139.63.6:64929:HTTP2-155#APVH\_evacomfort.de:443] Connection idle time: 121 while in state: 7 stream flag: 1253633,close!  
2021-07-28 09:36:30.157998 [NOTICE] [3772957] [87.139.63.6:64929:HTTP2-155#APVH\_evacomfort.de:443] Content len: 55, Request line: ‚POST /api/\_action/import-export/process HTTP/1.1‘  
2021-07-28 09:36:30.158004 [INFO] [3772957] [87.139.63.6:64929:HTTP2-155#APVH\_evacomfort.de:443] Cookie len: 339, timezone=Europe/Berlin; cookie-preference=1; \_\_tawkuuid=e::evacomfort.de::WIp3l/UqEcjjWLkiTOQG8K/umgctJpvl4w4y3lh0/gwowvI/ziRJhEF4zVX+HdBC::2; session-=5jqpsb96jiouc8h4eeo1rkgq5v; csrf[frontend.checkout.switch-language]=GZBI4Zi623qmMn6I9rFnfVBzQGXn5d9dcwoKNYO\_Rnc; csrf[frontend.store-api.proxy]=uQDTv5mhJsKu8zXqcjTV0mXh3zBbRU–B5dFC0MzHrk  
2021-07-28 09:36:30.158009 [NOTICE] [3772957] [87.139.63.6:64929:HTTP2-155#APVH\_evacomfort.de:443] Redirect: #1, URL: /index.php  
2021-07-28 09:36:30.158017 [INFO] [3772957] [87.139.63.6:64929:HTTP2-155#APVH\_evacomfort.de:443] HttpExtConnector state: 8, request body sent: 55, response body size: -2, response body sent:0, left in buffer: 0, attempts: 0.  
2021-07-28 09:36:30.158026 [INFO] [3772957] [87.139.63.6:64929:HTTP2-155#APVH\_evacomfort.de:443] Lsapi connection state: 3, watching event: 25, respState: 1, m\_iTotalPending:0, m\_iPacketLeft:0, m\_iCurRespHeader:12, req sent for 121 seconds,Total processing time: 121.

Fehlermeldung aus der Dev Konsole:  
process:1 Failed to load resource: the server responded with a status of 500 ()  
[Violation] ‚setTimeout‘ handler took 50ms

---

<div class="post-metadata">

**Author:** ![AndreHerking](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/andreherking/32/7839_2.png) [@AndreHerking](https://forum.shopware.com/u/AndreHerking)\
**Post date:** [28. Juli 2021 um 08:00 UTC](https://forum.shopware.com/t/import-es-werden-immer-nur-max-50-artikel-elemente-importiert/69091/8 "2021-07-28T08:00:03Z")

</div>

Die Meldungen enthalten keine Exceptions oder Stack-Traces, entsprechend kommen wir damit nicht weiter. Das Logging von PHP muss soweit angepasst werden, dass die Fehler detailiert geloggt werden. Die Meldungen hier scheinen eher aus einer Art Access Log zu stammen.

---

<div class="post-metadata">

**Author:** ![DavidH](https://avatars.discourse-cdn.com/v4/letter/d/a4c791/32.png) [@DavidH](https://forum.shopware.com/u/DavidH)\
**Post date:** [28. Juli 2021 um 10:33 UTC](https://forum.shopware.com/t/import-es-werden-immer-nur-max-50-artikel-elemente-importiert/69091/9 "2021-07-28T10:33:23Z")

</div>

Okay, leider kenne ich mich hiermit nicht so gut aus. Das waren alle Log Einträge welche ich dazu finden konnte. Ich wende mich wohl erstmal an unseren Hoster und versuche da schlauer zu werden.  
Danke

---

<div class="post-metadata">

**Author:** ![oajan](https://avatars.discourse-cdn.com/v4/letter/o/4491bb/32.png) [@oajan](https://forum.shopware.com/u/oajan)\
**Post date:** [22. August 2021 um 11:40 UTC](https://forum.shopware.com/t/import-es-werden-immer-nur-max-50-artikel-elemente-importiert/69091/10 "2021-08-22T11:40:14Z")

</div>

wir hatten so ein Problem auch. Wenn du client\_max\_body\_size anpasst dann dürfte das gehen. Die Datei ist schlicht für den Prozess wohl zu groß?

Wir haben die Parameter wie Time Out etc. massiv erhöht… dann ging’s 🙂
