# Immer wiederkehrende Fehlermeldung nach Leerung des Caches

**URL:** <https://forum.shopware.com/t/immer-wiederkehrende-fehlermeldung-nach-leerung-des-caches/19323>\
**Category:** Shopware 3.5\
**Tags:** general\
**Created:** [25. März 2014 um 12:08 UTC](https://forum.shopware.com/t/immer-wiederkehrende-fehlermeldung-nach-leerung-des-caches/19323 "2014-03-25T12:08:44Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![PPE\_Andreas](https://avatars.discourse-cdn.com/v4/letter/p/f1d935/32.png) [@PPE\_Andreas](https://forum.shopware.com/u/PPE_Andreas)\
**Post date:** [25. März 2014 um 12:08 UTC](https://forum.shopware.com/t/immer-wiederkehrende-fehlermeldung-nach-leerung-des-caches/19323/1 "2014-03-25T12:08:44Z")

</div>

Hallo Shopware-Community, seit wir mit Shopware arbeiten tritt folgende Fehlermeldung immer wieder auf: Fatal error: Uncaught exception ‘InvalidArgumentException’ with message ‘The directory “/var/www/virtual/shop…at/htdocs/cache/doctrine/proxies/201402131706” is not writable.’ in /var/www/virtual/shop…at/htdocs/engine/Shopware/Components/Model/Configuration.php:288 Stack trace: #0 /var/www/virtual/shop…at/htdocs/engine/Shopware/Components/Model/Configuration.php(71): Shopware\Components\Model\Configuration-\>setProxyDir(’/var/www/virtua…’) #1 /var/www/virtual/shop…at/htdocs/cache/proxies/Shopware201402131706ProductionProjectContainer.php(220): Shopware\Components\Model\Configuration-\>\_\_construct(Array, Object(Zend\_Cache\_Core), Object(Enlight\_Hook\_HookManager)) #2 /var/www/virtual/shop…at/htdocs/vendor/symfony/dependency-injection/Symfony/Component/DependencyInjection/Container.php(312): Shopware201402131706ProductionProjectContainer-\>getModelconfigService() #3 /var/www/virtual/shop…at/htdocs/engine/Shopware/Components/DependencyInjection/Container.php(253): Symfo in /var/www/virtual/shop…at/htdocs/engine/Shopware/Components/Model/Configuration.php on line 288 503 Service Unavailable Mittlerweile haben wir 3 Shopware-Shops auf 2 Servern laufen. Wir können uns die genaue Ursache für diesen Fehler einfach nicht erklären. Wie kann man dieses Problem langfristig lösen? Vielen Dank Andreas

---

<div class="post-metadata">

**Author:** ![Dennis\_Wahl](https://avatars.discourse-cdn.com/v4/letter/d/838e76/32.png) [@Dennis\_Wahl](https://forum.shopware.com/u/Dennis_Wahl)\
**Post date:** [25. März 2014 um 12:13 UTC](https://forum.shopware.com/t/immer-wiederkehrende-fehlermeldung-nach-leerung-des-caches/19323/2 "2014-03-25T12:13:48Z")

</div>

Hi Andreas, überprüfe mal deine Cache Ordner sieht aus als wenn hier die Rechte nicht korrekt gesetzt sind. Ebenso überprüfe einmal den Besitzer der Ordner / Dateien. Gruß Dennis

---

<div class="post-metadata">

**Author:** ![ppe-stores](https://avatars.discourse-cdn.com/v4/letter/p/49beb7/32.png) [@ppe-stores](https://forum.shopware.com/u/ppe-stores)\
**Post date:** [25. März 2014 um 14:53 UTC](https://forum.shopware.com/t/immer-wiederkehrende-fehlermeldung-nach-leerung-des-caches/19323/3 "2014-03-25T14:53:55Z")

</div>

Hi Dennis, die Rechte vom Ordner cache und deren Unterordner, welche bei der Installation dabei waren, haben die Rechte 777 und den Besitzer der hochgeladenen FTP-Benutzers. Hier gibt es auch nur einen. Was mir aber aufgefallen ist, ist das die von Shopware erstellten Ordner die Rechte 771 haben. Wenn ich das Cache Plugin im Backend aufrufe, erhalte ich folgende Fehlermeldung: Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. RecursiveDirectoryIterator::\_\_construct(/var/www/virtual/…/htdocs/cache/general/shopware–Zend): failed to open dir: Permission denied in Shopware/Components/CacheManager.php on line 345 Stack trace: #0 [internal function]: RecursiveDirectoryIterator-\>\_\_construct(’/var/www/virtua…’, 4096) #1 Shopware/Components/CacheManager.php(345): RecursiveDirectoryIterator-\>getChildren() #2 Shopware/Components/CacheManager.php(239): Shopware\Components\CacheManager-\>getDirectoryInfo(’/var/www/virtua…’) #3 Shopware/Controllers/Backend/Cache.php(63): Shopware\Components\CacheManager-\>getConfigCacheInfo() #4 Enlight/Controller/Action.php(159): Shopware\_Controllers\_Backend\_Cache-\>getInfoAction() #5 Enlight/Controller/Dispatcher/Default.php(528): Enlight\_Controller\_Action-\>dispatch(‘getInfoAction’) #6 Enlight/Controller/Front.php(228): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #7 Shopware/Kernel.php(141): Enlight\_Controller\_Front-\>dispatch() #8 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(473): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #9 Shopware/Components/HttpCache/AppCache.php(256): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #10 vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(244): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true) #11 Shopware/Components/HttpCache/AppCache.php(102): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true) #12 shopware.php(91): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request)) #13 {main} Das komische ist, dass dieses Verhalten bei allen 3 Shopinstallationen auftritt, auch auf andere Server verteilt. Um das Problem weiter oben zu beheben, wird über SSH mit chmod 777 -R cache ausgeführt. Dann funktioniert es wieder, bis dann ein Cronjob über das Conjob Plugin ausgeführt ist. Dann kommt die Fehlermeldung wieder. Gruß Flo

---

<div class="post-metadata">

**Author:** ![ppe-stores](https://avatars.discourse-cdn.com/v4/letter/p/49beb7/32.png) [@ppe-stores](https://forum.shopware.com/u/ppe-stores)\
**Post date:** [27. März 2014 um 10:29 UTC](https://forum.shopware.com/t/immer-wiederkehrende-fehlermeldung-nach-leerung-des-caches/19323/4 "2014-03-27T10:29:02Z")

</div>

Gibt es hierzu schon was neues? Gruß Flo

---

<div class="post-metadata">

**Author:** ![FlorianB](https://avatars.discourse-cdn.com/v4/letter/f/e95f7d/32.png) [@FlorianB](https://forum.shopware.com/u/FlorianB)\
**Post date:** [9. Mai 2014 um 10:02 UTC](https://forum.shopware.com/t/immer-wiederkehrende-fehlermeldung-nach-leerung-des-caches/19323/5 "2014-05-09T10:02:44Z")

</div>

Hey, ich habe auch seit einiger Zeit dieselben Probleme! Hat da jmd. ne gute Lösung für?? Gruß, Florian

---

<div class="post-metadata">

**Author:** ![mikesch](https://avatars.discourse-cdn.com/v4/letter/m/fbc32d/32.png) [@mikesch](https://forum.shopware.com/u/mikesch)\
**Post date:** [12. Mai 2014 um 17:42 UTC](https://forum.shopware.com/t/immer-wiederkehrende-fehlermeldung-nach-leerung-des-caches/19323/6 "2014-05-12T17:42:02Z")

</div>

Ich schließe mich hier an. Das selbe Problem besteht bei mir auch 🙂

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [12. Mai 2014 um 17:53 UTC](https://forum.shopware.com/t/immer-wiederkehrende-fehlermeldung-nach-leerung-des-caches/19323/7 "2014-05-12T17:53:43Z")

</div>

Hallo, so reproduzieren können wir das auf keinen Umgebungen. Könnt ihr mal den /cache-Ordner bei euch umbenennen und die Ordner /cache inkl. Unteroprdner aus dem Installationspaket neu auf den Server kopieren? Also so ist dann wirklich sichergestellt, dass dort keine anderen Dateien/Verzeichnise mehr mit ggf. anderen Rechten vorliegen Sebastian PS: wenn das nur nach Ausführung des Cronjobs auftritt, so wird dieser vom falscher User ausgeführt und daher gibt es dann Probleme. Der korrekte User muss ggf. bei der Ausführung mitgegeben werden Schaut mal hier [post89903.html#p89903](http://forum.shopware.de/post89903.html#p89903)
