# httpCache / Widget Problem

**URL:** <https://forum.shopware.com/t/httpcache-widget-problem/26411>\
**Category:** Shopware 3.5\
**Tags:** programming\
**Created:** [22. April 2015 um 10:20 UTC](https://forum.shopware.com/t/httpcache-widget-problem/26411 "2015-04-22T10:20:29Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![ottscho](https://avatars.discourse-cdn.com/v4/letter/o/7ba0ec/32.png) [@ottscho](https://forum.shopware.com/u/ottscho)\
**Post date:** [22. April 2015 um 10:20 UTC](https://forum.shopware.com/t/httpcache-widget-problem/26411/1 "2015-04-22T10:20:29Z")

</div>

Guten Morgen, ich kämpfe mit einem Problem, welches nur mit aktivem httpCache auftritt. Shopware 4.3.2 Mit aktivem httpCache erscheint beim Aufruf des Widgets (eigenes Plugin) im Template folgende Meldung: Fatal error: Uncaught exception ‚SmartyException‘ with message 'Unable to load template snippet ‚widgets/test/index.tpl‘ etc… Der Pfad / Datei ist aber vorhanden. Ist der httpCache deaktiviert, so erscheint diese Fehlermeldung nicht und alles funktioniert korrekt. Hat jemand eine Idee woran dies liegen kann? Danke

---

<div class="post-metadata">

**Author:** ![DanielNogel](https://avatars.discourse-cdn.com/v4/letter/d/96bed5/32.png) [@DanielNogel](https://forum.shopware.com/u/DanielNogel)\
**Post date:** [22. April 2015 um 12:47 UTC](https://forum.shopware.com/t/httpcache-widget-problem/26411/2 "2015-04-22T12:47:51Z")

</div>

Hi, vermutlich fügst du das Template Verzeichnis nur im PostDispatch\_Frontend hinzu. Solange der http Cache deaktiviert ist, kann auch der Subrequest da drauf zugreifen, wenn du den HTTP Cache aber aktivierst, musst du das Template Verzeichnis aber auch im Widgetrequest hinzufügen. Vielleicht liegt es daran? Daniel

---

<div class="post-metadata">

**Author:** ![ottscho](https://avatars.discourse-cdn.com/v4/letter/o/7ba0ec/32.png) [@ottscho](https://forum.shopware.com/u/ottscho)\
**Post date:** [22. April 2015 um 14:13 UTC](https://forum.shopware.com/t/httpcache-widget-problem/26411/3 "2015-04-22T14:13:55Z")

</div>

[quote=“Daniel Nögel”]Hi, vermutlich fügst du das Template Verzeichnis nur im PostDispatch\_Frontend hinzu. Solange der http Cache deaktiviert ist, kann auch der Subrequest da drauf zugreifen, wenn du den HTTP Cache aber aktivierst, musst du das Template Verzeichnis aber auch im Widgetrequest hinzufügen. Vielleicht liegt es daran? Daniel[/quote] danke, ich werde es testen.

---

<div class="post-metadata">

**Author:** ![ottscho](https://avatars.discourse-cdn.com/v4/letter/o/7ba0ec/32.png) [@ottscho](https://forum.shopware.com/u/ottscho)\
**Post date:** [23. April 2015 um 11:29 UTC](https://forum.shopware.com/t/httpcache-widget-problem/26411/4 "2015-04-23T11:29:00Z")

</div>

ich bekomme es nicht hin, oder mache irgendwo noch einen Fehler. Im Event: Enlight\_Controller\_Action\_PostDispatch Wird das Template gesetzt: $view-\>addTemplateDir(dirname(\_\_FILE\_\_).’/Views/’); $view-\>extendsTemplate(‚frontend/plugins/ott\_test/index.tpl‘); Dazu gibt es noch einen Widget Controller: Enlight\_Controller\_Dispatcher\_ControllerPath\_Widgets\_Test Dieser hat nun ebenfalls in der indexAction(): $this-\>View()-\>addTemplateDir(dirname(\_\_FILE\_\_).’/Views/’); Der Fehler mit httpCache bleibt aber erhalten. Hast du es so gemeint?

---

<div class="post-metadata">

**Author:** ![ottscho](https://avatars.discourse-cdn.com/v4/letter/o/7ba0ec/32.png) [@ottscho](https://forum.shopware.com/u/ottscho)\
**Post date:** [23. April 2015 um 11:36 UTC](https://forum.shopware.com/t/httpcache-widget-problem/26411/5 "2015-04-23T11:36:06Z")

</div>

ahh mist, jetzt fällt es mir auch. der Pfad ist ja im Controller anders. f\*\*k Soltle jetzt gelöst sein. Danke
