# HTTP Error 500 im Frontend für Artikel, die über die REST-API angelegt werden (nur mit PHP 7.2)?

**URL:** https://forum.shopware.com/t/http-error-500-im-frontend-fur-artikel-die-uber-die-rest-api-angelegt-werden-nur-mit-php-7-2/57320
**Category:** Programmierung
**Created:** [7. Januar 2019 um 15:35 UTC](https://forum.shopware.com/t/http-error-500-im-frontend-fur-artikel-die-uber-die-rest-api-angelegt-werden-nur-mit-php-7-2/57320 "2019-01-07T15:35:31Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![ffetech](https://avatars.discourse-cdn.com/v4/letter/f/c77e96/32.png) [@ffetech](https://forum.shopware.com/u/ffetech)
#### Post date: [7. Januar 2019 um 15:35 UTC](https://forum.shopware.com/t/http-error-500-im-frontend-fur-artikel-die-uber-die-rest-api-angelegt-werden-nur-mit-php-7-2/57320/1 "2019-01-07T15:35:31Z")

</div>

Hallo Zusammen,

mit Shopware 5.5.4 und PHP 7.2 (es handelt sich um eine Neuinstallation)&nbsp;haben wir&nbsp;das Problem, dass Artikel die über die REST-API angelegt werden, nicht im Frontend angezeigt werden - bzw. es kommt ein HTTP Error 500. Geholfen hat ein Downgrade auf PHP 7.1 und wenn man dann den Artikel neu überträgt.

Bereits mit PHP 7.2 übertragene Artikel funktionieren weiterhin nicht - erst bei Neu-Synchronisierung unter PHP 7.1 ist das Problem beseitigt.&nbsp;Auffällig war auch, dass die URL der betroffenen Artikel teilweise nicht optimal für SEO optimiert ist - “sArticle” & “sCategory” in der URL??

Habt Ihr eine Idee, was wir noch falsch machen? Vielleicht fehlerhafte SEO-Router-Einstellungen o. ä.?&nbsp;Oder sollte ich das Thema als Issue melden?

Ich würde mich sehr über Euere Unterstützung freuen :)&nbsp;und wünsche allen noch ein glückliches und erfolgreiches Jahr 2019!

&nbsp;

&nbsp;

---

<div class="post-metadata">

### Author: ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)
#### Post date: [7. Januar 2019 um 15:59 UTC](https://forum.shopware.com/t/http-error-500-im-frontend-fur-artikel-die-uber-die-rest-api-angelegt-werden-nur-mit-php-7-2/57320/2 "2019-01-07T15:59:49Z")

</div>

Ein generelles Problem mit 7.2 konnte ich in einem Test nicht erkennen.

Interessant wäre ja, was der 500er genau aussagt. Dazu kannst du dir den Fehler mal ausgeben lassen:&nbsp;[Shopware 5 - Tutorials & FAQs - Fehlermeldungen in Shopware debuggen](https://docs.shopware.com/de/shopware-5-de/tutorials-und-faq/fehlermeldungen-in-shopware-debuggen#erweitertes-error-debugging)

---

<div class="post-metadata">

### Author: ![ffetech](https://avatars.discourse-cdn.com/v4/letter/f/c77e96/32.png) [@ffetech](https://forum.shopware.com/u/ffetech)
#### Post date: [19. Januar 2019 um 15:56 UTC](https://forum.shopware.com/t/http-error-500-im-frontend-fur-artikel-die-uber-die-rest-api-angelegt-werden-nur-mit-php-7-2/57320/3 "2019-01-19T15:56:05Z")

</div>

Hallo,

Wir haben mittlerweile rausgefunden, was das&nbsp;Problem war - es hatte doch nichts mit der PHP Version zu tun (das hatten wir falsch wahrgenommen).&nbsp;Die eigentliche Ursache war, dass bei dem Artikel kein Hersteller eingetragen war. Ich hätte gedacht,&nbsp;dass dies früher mal zu einer API-Fehlermeldung führte? „Missing SupplierId“ oder so ähnlich.

Der Fehlerstack bei Artikeln ohne Hersteller ist&nbsp;Folgender:

**Fatal error** : Uncaught Error: Call to a member function getName() on null in /is/htdocs/wp1117995\_FB60ZFNDW4/www/shop/engine/Shopware/Components/Compatibility/LegacyStructConverter.php:526 Stack trace: #0 /is/htdocs/wp1117995\_FB60ZFNDW4/www/shop/engine/Shopware/Core/sArticles.php(2371): Shopware\Components\Compatibility\LegacyStructConverter-\>convertProductStruct(Object(Shopware\Bundle\StoreFrontBundle\Struct\Product)) #1 /is/htdocs/wp1117995\_FB60ZFNDW4/www/shop/engine/Shopware/Core/sArticles.php(1084): sArticles-\>getLegacyProduct(Object(Shopware\Bundle\StoreFrontBundle\Struct\Product), 107, Array) #2 /is/htdocs/wp1117995\_FB60ZFNDW4/www/shop/engine/Shopware/Controllers/Frontend/Detail.php(106): sArticles-\>sGetArticleById(9, NULL, ‚001001‘, Array) #3 /is/htdocs/wp1117995\_FB60ZFNDW4/www/shop/engine/Library/Enlight/Controller/Action.php(193): Shopware\_Controllers\_Frontend\_Detail-\>indexAction() #4 /is/htdocs/wp1117995\_FB60ZFNDW4/www/shop/engine/Library/Enlight/Controller/Dispatcher/Default.php(549): Enlight\_Controller\_Action-\> in&nbsp; **/is/htdocs/wp1117995\_FB60ZFNDW4/www/shop/engine/Shopware/Components/Compatibility/LegacyStructConverter.php** &nbsp;on line&nbsp; **526**
