# Http-Cache ConflictingHeadersException

**URL:** https://forum.shopware.com/t/http-cache-conflictingheadersexception/47517
**Category:** International (English Only)
**Tags:** programming
**Created:** [11. August 2017 um 16:40 UTC](https://forum.shopware.com/t/http-cache-conflictingheadersexception/47517 "2017-08-11T16:40:10Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![odessite](https://avatars.discourse-cdn.com/v4/letter/o/f05b48/32.png) [@odessite](https://forum.shopware.com/u/odessite)
#### Post date: [11. August 2017 um 16:40 UTC](https://forum.shopware.com/t/http-cache-conflictingheadersexception/47517/1 "2017-08-11T16:40:10Z")

</div>

```
 Hello guys, We have some strange errors and can't figure out what is problem, maybe someone had such exception and can describe what can be reason of such thing: 'The request has both a trusted Forwarded header and a trusted Client IP header, conflicting with each other with regards to the originating IP addresses of the request. This is the result of a misconfiguration. You should either configure your proxy only to send one of these headers, or configure Symfony to distrust one of them.

```

Sometimes we have this error several times a day, sometimes within a week we do not have such errors.

I’m not sure, but maybe it’s related our server configuration - we use nGinx for static resources and Apache for php. So nGinx in our case like proxy before Apache, should we set IP of our server like [trusted proxy](https://developers.shopware.com/developers-guide/http-cache/?_ga=2.71762067.1020536282.1502115404-546230334.1501223516#trusted-proxies) or it isn’t related to our issues?

Also some time we got such problem:

```
 Error when rendering "https://XXXX/?action=shopMenu&controller=index&module=widgets" (Status code is 503).

```

I could not trace in which case this problem appears, the problem is solved by itself after a while. Either after clearing the cache.

I will be grateful for any help or reflection on the possible reasons for this behavior.

---

<div class="post-metadata">

### Author: ![NextMike](https://avatars.discourse-cdn.com/v4/letter/n/838e76/32.png) [@NextMike](https://forum.shopware.com/u/NextMike)
#### Post date: [12. August 2017 um 11:41 UTC](https://forum.shopware.com/t/http-cache-conflictingheadersexception/47517/2 "2017-08-12T11:41:47Z")

</div>

Look here if you find any hints:&nbsp;[Shopware 5 performance guide for system administrators](https://developers.shopware.com/sysadmins-guide/shopware-5-performance-for-sysadmins/#nginx)

&nbsp;

---

<div class="post-metadata">

### Author: ![odessite](https://avatars.discourse-cdn.com/v4/letter/o/f05b48/32.png) [@odessite](https://forum.shopware.com/u/odessite)
#### Post date: [14. August 2017 um 06:42 UTC](https://forum.shopware.com/t/http-cache-conflictingheadersexception/47517/3 "2017-08-14T06:42:14Z")

</div>

Thank you for suggestion, but this isn’t really our case.

Shopware handled by Apache server, only static sources goes through nGinx.
