# .htaccess im Unterordner wird ignoriert

**URL:** <https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402>\
**Category:** Shopware 3.5\
**Tags:** general\
**Created:** [6. November 2014 um 08:38 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402 "2014-11-06T08:38:58Z")\
**Posts on this page:** 17\
**Page:** 1

<div class="post-metadata">

**Author:** ![Sebo](https://avatars.discourse-cdn.com/v4/letter/s/e9bcb4/32.png) [@Sebo](https://forum.shopware.com/u/Sebo)\
**Post date:** [6. November 2014 um 08:38 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/1 "2014-11-06T08:38:58Z")

</div>

Hallo Community, vorab das System: Shopware 4.3 Debian/Apache2/Mysql Konfiguration über ISPConfig. Problem: Der Shop ist im Root / installiert. Dort befindet sich die .htaccess für Shopware. [code]  
RewriteEngine on

RewriteBase /

RewriteRule shopware.dll shopware.php  
RewriteRule files/documents/.\* engine [NC,L]  
RewriteRule backend/media/(.\*) media/$1 [NC,L]

RewriteCond %{REQUEST\_URI} !(/(engine|files|templates)/)  
RewriteCond %{REQUEST\_URI} !(/media/(archive|banner|image|music|pdf|unknown|video)/)  
RewriteCond %{REQUEST\_FILENAME} !-f  
RewriteCond %{REQUEST\_FILENAME} !-d  
RewriteRule ^(.\*) shopware.php [PT,L,QSA] \</ifmodule\># Staging-Rules start #SetEnvIf Host "staging.test.shopware.in" ENV=staging DirectoryIndex index.html DirectoryIndex index.php DirectoryIndex shopware.php DirectoryIndex .htaccess # Disables download of configuration\<files\> Deny from all \</files\># Enable gzip compression\<ifmodule mod\_deflate.c\> # disable compression on iconset due to loading problems in google chrome on windows SetEnvIfNoCase Request\_URI icon-set.css no-gzip dont-vary

```
AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/json

```

ExpiresActive on  
ExpiresDefault „access plus 1 month“  
FileETag None  
  
Header append Cache-Control „public“  
Header unset ETag  
  
  
# Disables auto directory index  
Options -Indexes  
  
Options -MultiViews

# php\_value memory\_limit 128M

# php\_value max\_execution\_time 120

# php\_value upload\_max\_filesize 20M

php\_flag phar.readonly off  
php\_flag magic\_quotes\_gpc off  
php\_flag session.auto\_start off  
php\_flag suhosin.session.cryptua off  
php\_flag zend.ze1\_compatibility\_mode off  
# AddType x-mapp-php5 .php # AddHandler x-mapp-php5 .php [/code] Nun möchte ich in dem Unterordner /TestScript eine .htaccess mit Passwortschutz für diesen Ordner einrichten. Leider wird diese ignoriert. Wenn ich die URL [http://www.shopdomain.de/TestScript](http://www.shopdomain.de/TestScript) anspreche, passiert nichts. Die URL bleibt zwar in der Adressleiste aber es wird keine Aktion durchgeführt. Eine zum Test erstellte index.html wird auch ignoriert. Leider wurde ich bei Google nicht fündig. Hat jemand Erfahrung damit? Vielen Dank im Voraus. sebo

---

<div class="post-metadata">

**Author:** ![Shopwareianer](https://avatars.discourse-cdn.com/v4/letter/s/b4bc9f/32.png) [@Shopwareianer](https://forum.shopware.com/u/Shopwareianer)\
**Post date:** [6. November 2014 um 08:50 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/2 "2014-11-06T08:50:16Z")

</div>

Die .htaccess und .htpasswd zum Passwort Schutz liegt auch im Ordner /TestScript ? Mit welchem genauen Inhalt ?

---

<div class="post-metadata">

**Author:** ![t2oh4e](https://avatars.discourse-cdn.com/v4/letter/t/a5b964/32.png) [@t2oh4e](https://forum.shopware.com/u/t2oh4e)\
**Post date:** [6. November 2014 um 09:29 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/3 "2014-11-06T09:29:01Z")

</div>

Der Unterordner wird gar nicht erst aufgerufen. Die Shopware .htaccess leitet die Anfrage direkt an die shopware.php weiter und versucht einen Controller mit dem Namen TestScript zu finden. Den gibt’S aber nicht, darum leitet Shopware auf die Startseite weiter. ` RewriteCond %{REQUEST\_URI} !(\/(engine|files|templates)\/) RewriteCond %{REQUEST\_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/) RewriteCond %{REQUEST\_FILENAME} !-f RewriteCond %{REQUEST\_FILENAME} !-d RewriteRule ^(.\*)$ shopware.php [PT,L,QSA] ` Der Teil dürfte dafür verantwortlich sein. Mit Weiterleitungen bin ich nicht ganz so firm. Vermutlich reicht es in der ersten Zeile die ich gepostet habe den ordner TestScript hinzuzufügen, also so: `RewriteCond %{REQUEST\_URI} !(\/(engine|files|templates|TestScript)\/)`

---

<div class="post-metadata">

**Author:** ![Sebo](https://avatars.discourse-cdn.com/v4/letter/s/e9bcb4/32.png) [@Sebo](https://forum.shopware.com/u/Sebo)\
**Post date:** [6. November 2014 um 09:51 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/4 "2014-11-06T09:51:38Z")

</div>

Leider hat die Erweiterung mit TestScript nicht funktioniert. Shopcache geleerte und Apache neugestartet. `RewriteCond %{REQUEST\_URI} !(\/(engine|files|templates|TestScript)\/)` Der Inhalt der .htaccess im Unterordner wäre: `AuthType Basic AuthName "Please enter your ID and password" AuthUserFile /var/www/clients/client4/web12/web/TestScript/.htpasswd require valid-user`

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [6. November 2014 um 10:06 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/5 "2014-11-06T10:06:51Z")

</div>

Ist in der Apache-Konfiguration AllowOverride All oder zumindest AllowOverride AuthConfig gesetzt?

---

<div class="post-metadata">

**Author:** ![Sebo](https://avatars.discourse-cdn.com/v4/letter/s/e9bcb4/32.png) [@Sebo](https://forum.shopware.com/u/Sebo)\
**Post date:** [6. November 2014 um 10:18 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/6 "2014-11-06T10:18:12Z")

</div>

Die Config vom Vhost der Domain [code]  
AllowOverride None  
Order Deny,Allow  
Deny from all  
  
DocumentRoot /var/www/Shopdomain.de/web

```
	ServerName Shopdomain.de
	ServerAlias www.Shopdomain.de
ServerAlias www.Shopdomain.de Shopdomain.de
	ServerAdmin webmaster@Shopdomain.de

	ErrorLog /var/log/ispconfig/httpd/Shopdomain.de/error.log

	Alias /error/ "/var/www/Shopdomain.de/web/error/"
	ErrorDocument 400 /error/400.html
	ErrorDocument 401 /error/401.html
	ErrorDocument 403 /error/403.html
	ErrorDocument 404 /error/404.html
	ErrorDocument 405 /error/405.html
	ErrorDocument 500 /error/500.html
	ErrorDocument 502 /error/502.html
	ErrorDocument 503 /error/503.html

	<ifmodule mod_ssl.c>
	</ifmodule>

	<directory>
			# Clear PHP settings of this website
			<filesmatch>
					SetHandler None
			</filesmatch>
			Options +FollowSymLinks
			AllowOverride All
							Order allow,deny
			Allow from all
					</directory>
	<directory>
			# Clear PHP settings of this website
			<filesmatch>
					SetHandler None
			</filesmatch>
			Options +FollowSymLinks
			AllowOverride All
							Order allow,deny
			Allow from all
					</directory>

	# cgi enabled
<directory>
					Order allow,deny
		Allow from all
				</directory>
	ScriptAlias /cgi-bin/ /var/www/clients/client4/web12/cgi-bin/
	<filesmatch>
		SetHandler cgi-script
	</filesmatch>
	# suexec enabled
	<ifmodule mod_suexec.c>
		SuexecUserGroup web12 client4
	</ifmodule>
	# php as fast-cgi enabled
# For config options see: http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html
	<ifmodule mod_fcgid.c>
			IdleTimeout 300
			ProcessLifeTime 3600
			# MaxProcessCount 1000
			DefaultMinClassProcessCount 0
			DefaultMaxClassProcessCount 100
			IPCConnectTimeout 3
			IPCCommTimeout 600
			BusyTimeout 3600
	</ifmodule>
	<directory>
			<filesmatch>
				SetHandler fcgid-script
			</filesmatch>
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php3
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php4
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php5
			Options +ExecCGI
			AllowOverride All
							Order allow,deny
			Allow from all
					</directory>
	<directory>
			<filesmatch>
				SetHandler fcgid-script
			</filesmatch>
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php3
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php4
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php5
			Options +ExecCGI
			AllowOverride All
							Order allow,deny
			Allow from all
					</directory>

	# add support for apache mpm_itk
	<ifmodule mpm_itk_module>
		AssignUserId web12 client4
	</ifmodule>

	<ifmodule mod_dav_fs.c>
	# Do not execute PHP files in webdav directory
		<directory>
			<ifmodule mod_security2.c>
				SecRuleRemoveById 960015
				SecRuleRemoveById 960032
			</ifmodule>
			<filesmatch>
				SetHandler None
			</filesmatch>
		</directory>
		DavLockDB /var/www/clients/client4/web12/tmp/DavLock
		# DO NOT REMOVE THE COMMENTS!
		# IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
  # WEBDAV BEGIN
		# WEBDAV END
	</ifmodule>

```

[/code] Und die apache2.conf [code]# # Based upon the NCSA server configuration files originally by Rob McCool. # # This is the main Apache server configuration file. It contains the # configuration directives that give the server its instructions. # See [Apache HTTP Server Version 2.2 Documentation - Apache HTTP Server Version 2.2](http://httpd.apache.org/docs/2.2/) for detailed information about # the directives. # # Do NOT simply read the instructions in here without understanding # what they do. They’re here only as hints or reminders. If you are unsure # consult the online docs. You have been warned. # # The configuration directives are grouped into three basic sections: # 1. Directives that control the operation of the Apache server process as a # whole (the ‘global environment’). # 2. Directives that define the parameters of the ‘main’ or ‘default’ server, # which responds to requests that aren’t handled by a virtual host. # These directives also provide default values for the settings # of all virtual hosts. # 3. Settings for virtual hosts, which allow Web requests to be sent to # different IP addresses or hostnames and have them handled by the # same Apache server process. # # Configuration and logfile names: If the filenames you specify for many # of the server’s control files begin with “/” (or “drive:/” for Win32), the # server will use that explicit path. If the filenames do \*not\* begin # with “/”, the value of ServerRoot is prepended – so “foo.log” # with ServerRoot set to “/etc/apache2” will be interpreted by the # server as “/etc/apache2/foo.log”. # ### Section 1: Global Environment # # The directives in this section affect the overall operation of Apache, # such as the number of concurrent requests it can handle or where it # can find its configuration files. # # # ServerRoot: The top of the directory tree under which the server’s # configuration, error, and log files are kept. # # NOTE! If you intend to place this on an NFS (or otherwise network) # mounted filesystem then please read the LockFile documentation (available # at http:);

# you will save yourself a lot of trouble.

# 

# Do NOT add a slash at the end of the directory path.

# 

#ServerRoot “/etc/apache2”

# 

# The accept serialization lock file MUST BE STORED ON A LOCAL DISK.

# 

LockFile ${APACHE\_LOCK\_DIR}/accept.lock

# 

# PidFile: The file in which the server should record its process

# identification number when it starts.

# This needs to be set in /etc/apache2/envvars

# 

PidFile ${APACHE\_PID\_FILE}

# 

# Timeout: The number of seconds before receives and sends time out.

# 

Timeout 300

# 

# KeepAlive: Whether or not to allow persistent connections (more than

# one request per connection). Set to “Off” to deactivate.

# 

KeepAlive On

# 

# MaxKeepAliveRequests: The maximum number of requests to allow

# during a persistent connection. Set to 0 to allow an unlimited amount.

# We recommend you leave this number high, for maximum performance.

# 

MaxKeepAliveRequests 100

# 

# KeepAliveTimeout: Number of seconds to wait for the next request from the

# same client on the same connection.

# 

KeepAliveTimeout 15

## 

## Server-Pool Size Regulation (MPM specific)

## 

# prefork MPM

# StartServers: number of server processes to start

# MinSpareServers: minimum number of server processes which are kept spare

# MaxSpareServers: maximum number of server processes which are kept spare

# MaxClients: maximum number of server processes allowed to start

# MaxRequestsPerChild: maximum number of requests a server process serves
 StartServers 5 MinSpareServers 5 MaxSpareServers 10 MaxClients 150 MaxRequestsPerChild 0
# worker MPM

# StartServers: initial number of server processes to start

# MaxClients: maximum number of simultaneous client connections

# MinSpareThreads: minimum number of worker threads which are kept spare

# MaxSpareThreads: maximum number of worker threads which are kept spare

# ThreadLimit: ThreadsPerChild can be changed to this maximum value during a

# graceful restart. ThreadLimit can only be changed by stopping

# and starting Apache.

# ThreadsPerChild: constant number of worker threads in each server process

# MaxRequestsPerChild: maximum number of requests a server process serves
 StartServers 2 MinSpareThreads 25 MaxSpareThreads 75 ThreadLimit 64 ThreadsPerChild 25 MaxClients 150 MaxRequestsPerChild 0
# event MPM

# StartServers: initial number of server processes to start

# MaxClients: maximum number of simultaneous client connections

# MinSpareThreads: minimum number of worker threads which are kept spare

# MaxSpareThreads: maximum number of worker threads which are kept spare

# ThreadsPerChild: constant number of worker threads in each server process

# MaxRequestsPerChild: maximum number of requests a server process serves
 StartServers 2 MaxClients 150 MinSpareThreads 25 MaxSpareThreads 75 ThreadLimit 64 ThreadsPerChild 25 MaxRequestsPerChild 0
# These need to be set in /etc/apache2/envvars

User {APACHE\_RUN\_USER} Group {APACHE\_RUN\_GROUP}

# 

# AccessFileName: The name of the file to look for in each directory

# for additional configuration directives. See also the AllowOverride

# directive.

# 

AccessFileName .htaccess

# 

# The following lines prevent .htaccess and .htpasswd files from being

# viewed by Web clients.

# 
 Order allow,deny Deny from all Satisfy all
# 

# DefaultType is the default MIME type the server will use for a document

# if it cannot otherwise determine one, such as from filename extensions.

# If your server contains mostly text or HTML documents, “text/plain” is

# a good value. If most of your content is binary, such as applications

# or images, you may want to use “application/octet-stream” instead to

# keep browsers from trying to display binary files as though they are

# text.

# 

DefaultType text/plain

# 

# HostnameLookups: Log the names of clients or just their IP addresses

# e.g., [www.apache.org](http://www.apache.org) (on) or 204.62.129.132 (off).

# The default is off because it’d be overall better for the net if people

# had to knowingly turn this feature on, since enabling it means that

# each client request will result in AT LEAST one lookup request to the

# nameserver.

# 

HostnameLookups Off

# ErrorLog: The location of the error log file.

# If you do not specify an ErrorLog directive within a

# container, error messages relating to that virtual host will be

# logged here. If you _do_ define an error logfile for a

# container, that host’s errors will be logged there and not here.

# 

ErrorLog ${APACHE\_LOG\_DIR}/error.log

# 

# LogLevel: Control the number of messages logged to the error\_log.

# Possible values include: debug, info, notice, warn, error, crit,

# alert, emerg.

# 

LogLevel warn

# Include module configuration:

Include mods-enabled/_.load  
Include mods-enabled/_.conf

# Include all the user configurations:

Include httpd.conf

# Include ports listing

Include ports.conf

# 

# The following directives define some format nicknames for use with

# a CustomLog directive (see below).

# If you are behind a reverse proxy, you might want to change %h into %{X-Forwarded-For}i

# 

LogFormat “%v:%p %h %l %u %t “%r” %\>s %O “%{Referer}i” “%{User-Agent}i”” vhost\_combined  
LogFormat “%h %l %u %t “%r” %\>s %O “%{Referer}i” “%{User-Agent}i”” combined  
LogFormat “%h %l %u %t “%r” %\>s %O” common  
LogFormat “%{Referer}i -\> %U” referer  
LogFormat “%{User-agent}i” agent

# Include of directories ignores editors’ and dpkg’s backup files,

# see README.Debian for details.

# Include generic snippets of statements

Include conf.d/

# Include the virtual host configurations:

Include sites-enabled/  
[/code]\</http:\>

---

<div class="post-metadata">

**Author:** ![hth](https://avatars.discourse-cdn.com/v4/letter/h/b77776/32.png) [@hth](https://forum.shopware.com/u/hth)\
**Post date:** [6. November 2014 um 10:25 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/7 "2014-11-06T10:25:13Z")

</div>

Hallo, funktioniert eigentlich Shopware und zeigt die Bilder im Frontend an? Hier liegt wahrscheinlich das Problem: `<directory>
      AllowOverride None
            Order Deny,Allow
      Deny from all
      </directory>` In der htaccess von Shopware muss man keine Änderugen vornehmen, um einen LInk (Aufruf im Browser) auf ein existierendes Unterverzeichnis zu erlauben. Diese beiden Bedingungen ermöglichen dies: `RewriteCond %{REQUEST\_FILENAME} !-f RewriteCond %{REQUEST\_FILENAME} !-d` Erste prüft, ob der Link auf eine existierende Datei passt, die zweite Bedingung, ob ein Directory existiert. Wenn eines von beiden wahr ist und nicht in einem der Standard-Directories von Shopware liegt (die Bedingungen davor), wird nicht auf shopware.php umgeleitet. Ist das eigentlich ein managed Server? Hier Referenz für Apache 2.2, falls es 2.4 ist, besser dort nachsehen und dann sollte man auch die Shopware htaccess noch anpassen. [http://httpd.apache.org/docs/2.2/mod/mod\_rewrite.html](http://httpd.apache.org/docs/2.2/mod/mod%5C_rewrite.html)

---

<div class="post-metadata">

**Author:** ![Sebo](https://avatars.discourse-cdn.com/v4/letter/s/e9bcb4/32.png) [@Sebo](https://forum.shopware.com/u/Sebo)\
**Post date:** [6. November 2014 um 10:51 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/8 "2014-11-06T10:51:41Z")

</div>

Der Server wurde selbst eingerichtet mit ISPConfig. Es handelt sich um Apache 2.2. Die Config wurde nun geändert, ohne Erfolg. `<directory>
		AllowOverride All
				Order Deny,Allow
		Allow from all
		</directory>`

---

<div class="post-metadata">

**Author:** ![Shopwareianer](https://avatars.discourse-cdn.com/v4/letter/s/b4bc9f/32.png) [@Shopwareianer](https://forum.shopware.com/u/Shopwareianer)\
**Post date:** [6. November 2014 um 10:54 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/9 "2014-11-06T10:54:21Z")

</div>

[quote=“Sebo”]Leider hat die Erweiterung mit TestScript nicht funktioniert. Shopcache geleerte und Apache neugestartet. `RewriteCond %{REQUEST\_URI} !(\/(engine|files|templates|TestScript)\/)` Der Inhalt der .htaccess im Unterordner wäre: `AuthType Basic AuthName "Please enter your ID and password" AuthUserFile /var/www/clients/client4/web12/web/TestScript/.htpasswd require valid-user`[/quote] Du kannst doch in ISPConfig direkt einen geschützten Ordner anlegen. Klappt es darüber ? Unter Webseiten -\> Web Zugriff -\> Geschützter Ordner / Benuzter

---

<div class="post-metadata">

**Author:** ![Sebo](https://avatars.discourse-cdn.com/v4/letter/s/e9bcb4/32.png) [@Sebo](https://forum.shopware.com/u/Sebo)\
**Post date:** [6. November 2014 um 11:10 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/10 "2014-11-06T11:10:24Z")

</div>

Über ISPConfig geht es leider auch nicht. Wenn die .htaccess im /TestScript Ordner raus ist, kann man ganz normal auf die “Test index.html” zugreifen. Er akzeptiert einfach keine weitere .htaccess… Kann man die Shopware .htaccess erweitern mit der .htpasswd?

---

<div class="post-metadata">

**Author:** ![hth](https://avatars.discourse-cdn.com/v4/letter/h/b77776/32.png) [@hth](https://forum.shopware.com/u/hth)\
**Post date:** [6. November 2014 um 11:23 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/11 "2014-11-06T11:23:54Z")

</div>

Hallo, die Möglichkeit Zugriffsrechte per htaccess zu ändern wird in den -Abschnitten erzeugt. Da sind offensichtlich mehrere im Spiel. Die müsste man jetzt durchgehen und sehen, wie diese in Kombination wirken. Evtl. setzt ipconfig diese bereits, da solltet ihr aufpassen, keine Fehler oder Inkompatibilitäten mit ipconfig einzubauen.

Für das Verzeichnis testordner scheint es kein Allowoverride all zu geben. Setzt das doch einfach mal zu Testzwecken manuell.  
[http://httpd.apache.org/docs/2.2/de/mod … irtualhost](http://httpd.apache.org/docs/2.2/de/mod/core.html#virtualhost)

Habt ihr nach den Änderungen apache neu gestartet?

---

<div class="post-metadata">

**Author:** ![Sebo](https://avatars.discourse-cdn.com/v4/letter/s/e9bcb4/32.png) [@Sebo](https://forum.shopware.com/u/Sebo)\
**Post date:** [6. November 2014 um 11:41 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/12 "2014-11-06T11:41:03Z")

</div>

Apache wurde nach jeder Änderung neugestartet. Habe jetzt das Verzeichnis in die vhost.conf eingetragen. Ohne Erfolg. Sobald die .htaccess aus dem TestScript Ordner raus ist, kann ich auf die Dateien wie die index.html zugreifen. Er ignoriert die .htaccess im Unterordner und kann nicht mehr auf die index.html oder test.txt zugreifen. Es steht dann nur die URL [Shopdomain.de/TestScript/index.html](http://Shopdomain.de/TestScript/index.html) da aber er zeigt die Startseite des Shops. [code]  
AllowOverride All  
Order Deny,Allow  
Allow from all  
  
DocumentRoot /var/www/Shopdomain.de/web

```
	ServerName Shopdomain.de
	ServerAlias www.Shopdomain.de
ServerAlias www.Shopdomain.de Shopdomain.de
	ServerAdmin webmaster@Shopdomain.de

	ErrorLog /var/log/ispconfig/httpd/Shopdomain.de/error.log

	Alias /error/ "/var/www/Shopdomain.de/web/error/"
	ErrorDocument 400 /error/400.html
	ErrorDocument 401 /error/401.html
	ErrorDocument 403 /error/403.html
	ErrorDocument 404 /error/404.html
	ErrorDocument 405 /error/405.html
	ErrorDocument 500 /error/500.html
	ErrorDocument 502 /error/502.html
	ErrorDocument 503 /error/503.html

	<ifmodule mod_ssl.c>
	</ifmodule>

	<directory>
			# Clear PHP settings of this website
			<filesmatch>
					SetHandler None
			</filesmatch>
			Options +FollowSymLinks
			AllowOverride All
							Order allow,deny
			Allow from all
					</directory>
	<directory>
			# Clear PHP settings of this website
			<filesmatch>
					SetHandler None
			</filesmatch>
			Options +FollowSymLinks
			AllowOverride All
							Order allow,deny
			Allow from all
					</directory>

	# cgi enabled
<directory>
					Order allow,deny
		Allow from all
				</directory>
	ScriptAlias /cgi-bin/ /var/www/clients/client4/web12/cgi-bin/
	<filesmatch>
		SetHandler cgi-script
	</filesmatch>
	# suexec enabled
	<ifmodule mod_suexec.c>
		SuexecUserGroup web12 client4
	</ifmodule>
	# php as fast-cgi enabled
# For config options see: http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html
	<ifmodule mod_fcgid.c>
			IdleTimeout 300
			ProcessLifeTime 3600
			# MaxProcessCount 1000
			DefaultMinClassProcessCount 0
			DefaultMaxClassProcessCount 100
			IPCConnectTimeout 3
			IPCCommTimeout 600
			BusyTimeout 3600
	</ifmodule>
	<directory>
			<filesmatch>
				SetHandler fcgid-script
			</filesmatch>
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php3
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php4
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php5
			Options +ExecCGI
			AllowOverride All
							Order allow,deny
			Allow from all
					</directory>
	<directory>
			<filesmatch>
				SetHandler fcgid-script
			</filesmatch>
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php3
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php4
			FCGIWrapper /var/www/php-fcgi-scripts/web12/.php-fcgi-starter .php5
			Options +ExecCGI
			AllowOverride All
							Order allow,deny
			Allow from all
					</directory>

	# add support for apache mpm_itk
	<ifmodule mpm_itk_module>
		AssignUserId web12 client4
	</ifmodule>

	<ifmodule mod_dav_fs.c>
	# Do not execute PHP files in webdav directory
		<directory>
			<ifmodule mod_security2.c>
				SecRuleRemoveById 960015
				SecRuleRemoveById 960032
			</ifmodule>
			<filesmatch>
				SetHandler None
			</filesmatch>
		</directory>
		DavLockDB /var/www/clients/client4/web12/tmp/DavLock
		# DO NOT REMOVE THE COMMENTS!
		# IF YOU REMOVE THEM, WEBDAV WILL NOT WORK ANYMORE!
  # WEBDAV BEGIN
		# WEBDAV END
	</ifmodule>

```

AllowOverride All Order Deny,Allow Allow from all

[/code]

---

<div class="post-metadata">

**Author:** ![hth](https://avatars.discourse-cdn.com/v4/letter/h/b77776/32.png) [@hth](https://forum.shopware.com/u/hth)\
**Post date:** [6. November 2014 um 11:59 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/13 "2014-11-06T11:59:25Z")

</div>

[quote=“Sebo”] Sobald die .htaccess aus dem TestScript Ordner raus ist, kann ich auf die Dateien wie die index.html zugreifen. Er ignoriert die .htaccess im Unterordner und kann nicht mehr auf die index.html oder test.txt zugreifen. Es steht dann nur die URL [Shopdomain.de/TestScript/index.html](http://Shopdomain.de/TestScript/index.html) da aber er zeigt die Startseite des Shops.[/quote] Letzteres ist das Shopware-Verhalten, wenn weder ein Directory noch eine Datei mit dem Namen des Links exitiert und es kein Shopware-Link ist (Artikel oder so). Das heißt doch, dass deine htaccess-Datei im Testskript-Ordner bewirkt, dass nicht auf die Datei zugegriffen werden kann. Der Server ignoriert die htaccess-Datei aber nicht. Was passiert denn, wenn man eine simple deny all htaccess in das Testverzeichnis packt. Kommt dann ein 401 Error im Browser an? Sind die Pfade in der htaccess eigentlich korrekt gesetzt?

---

<div class="post-metadata">

**Author:** ![Sebo](https://avatars.discourse-cdn.com/v4/letter/s/e9bcb4/32.png) [@Sebo](https://forum.shopware.com/u/Sebo)\
**Post date:** [6. November 2014 um 12:24 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/14 "2014-11-06T12:24:20Z")

</div>

Die Pfade sollten alle richtig sein. Habe jetzt `order deny,allow deny from all` in die .htaccess des TestScript Ordners rein. Zeigt aber wieder nur die Startseite und die getippte URL. Keine 401.

---

<div class="post-metadata">

**Author:** ![hth](https://avatars.discourse-cdn.com/v4/letter/h/b77776/32.png) [@hth](https://forum.shopware.com/u/hth)\
**Post date:** [6. November 2014 um 13:27 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/15 "2014-11-06T13:27:26Z")

</div>

[quote=„Sebo“]Die Pfade sollten alle richtig sein. Habe jetzt `order deny,allow deny from all` in die .htaccess des TestScript Ordners rein. Zeigt aber wieder nur die Startseite und die getippte URL. Keine 401.[/quote] Schau nach, was in den Error-Logs steht.

---

<div class="post-metadata">

**Author:** ![Sebo](https://avatars.discourse-cdn.com/v4/letter/s/e9bcb4/32.png) [@Sebo](https://forum.shopware.com/u/Sebo)\
**Post date:** [6. November 2014 um 14:08 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/16 "2014-11-06T14:08:05Z")

</div>

.htaccess ist im Unterordner /TestScript drin. Die Error.log gibt nichts aus. Aber die other\_vhost\_access.log ` tail -f other\_vhosts\_access.log | grep xx.xx.xx.xx Shopdomain.de:80 xx.xx.xx.xx - - [06/Nov/2014:14:03:38 +0100] "GET /TestScript/index.html HTTP/1.1" 404 8259 "-" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.111 Safari/537.36" Shopdomain.de:80 xx.xx.xx.xx - - [06/Nov/2014:14:03:40 +0100] "GET /widgets/index/refreshStatistic?requestPage=/TestScript/index.html&requestController=index&session-1=e7f70698fa2ea12cf093d46d52fd8484b0d88476&callback=jQuery17209250959842465818\_1415279013840&\_=1415279013936 HTTP/1.1" 200 448 "http://www.Shopdomain.de/TestScript/index.html" "Mozilla/5.0 (Windows NT 6.3; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/38.0.2125.111 Safari/537.36" `

---

<div class="post-metadata">

**Author:** ![Sebo](https://avatars.discourse-cdn.com/v4/letter/s/e9bcb4/32.png) [@Sebo](https://forum.shopware.com/u/Sebo)\
**Post date:** [19. Februar 2015 um 09:45 UTC](https://forum.shopware.com/t/htaccess-im-unterordner-wird-ignoriert/23402/17 "2015-02-19T09:45:24Z")

</div>

Hallo Community, leider konnte ich bis heute das Problem nicht lösen. Es besteht aber noch immer. Es haben sich nun einige Dinge geändert. Vielleicht könnte mir jemand von Shopware erklären warum das so ist. Ich habe jetzt einen neuen Server. Alles frisch und konfiguriert. Ich habe nun einen Test gemacht. Habe auf dem gleichen Server einen neuen Shop angelegt, neue ShopwareID und siehe da, ES GEHT! 🙂 Leider funktioniert das nicht mit der Domain, bei der es gehen soll. Konfiguration ist 1:1 identisch. Gleicher Server, gleiche Settings. Zum Test habe ich mal den Pfad in der betreffenden Domain auf /shop geändert. Die Dateien aber nicht in den Order /shop kopiert. Geht trotzdem, in der Adresszeile steht [domain.de/shop](http://domain.de/shop). Kopiere ich die Daten in den /shop Ordner bekomme ich nur eine weiße Seite ohne Inhalt. Jetzt ist meine Frage, kann es sein dass bei Shopware im Account etwas falsches drin steht? Die Domain scheint richtig eingetragen zu sein. P.S. Ich habe zum Test mal den Shop komplett gelöscht, neue Datenbank angelegt und den Demoshop installiert…1x im Hauptverzeichnis, 1x /shop Verzeichnis. Geht auch nicht. Also kann es nicht an der Konfiguration von Shop liegen.
