# HILFE! Internal Server Error 500 -  Nach Update backend bestellungen, netfoundations,

**URL:** https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457
**Category:** Programmierung
**Created:** [17. November 2016 um 18:10 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457 "2016-11-17T18:10:08Z")
**Posts on this page:** 16
**Page:** 1

<div class="post-metadata">

### Author: ![holzhofbayern](https://avatars.discourse-cdn.com/v4/letter/h/73ab20/32.png) [@holzhofbayern](https://forum.shopware.com/u/holzhofbayern)
#### Post date: [17. November 2016 um 18:10 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/1 "2016-11-17T18:10:08Z")

</div>

Servus

nach Update auf&nbsp;5.2.10 und Update Backend Bestellungen ist der Zugriff auf die Homepage und das Backend eingeschränkt

&nbsp;

Fehlermeldung 500 Internal Server Error

Klick auf Bestellungen -\> Internal Server error 500

klick auf Artikel Übersicht -\>&nbsp;Internal Server error 500

&nbsp;

Ganz unten in der Logfile ist der Fehler beschrieben,

Nach Update auf 5.2.10 lief der Shop problemlos, nach update des Plugins Backend Bestellungen kamen die ersten Probleme

Deaktivieren hat leider nicht s gebracht&nbsp;

&nbsp;

&nbsp;

&nbsp;

```
[2016-11-17 18:51:00] core.ERROR: Unable to Connect to ssl://holzhof-bayern.de:443. Error #0: {"exception":"[object] (Zend_Http_Client_Adapter_Exception(code: 0): Unable to Connect to ssl://holzhof-bayern.de:443. Error #0: at /www/htdocs/xxxxx/XXXXXXXX/shop/engine/Library/Zend/Http/Client/Adapter/Socket.php:235)"} {"uid":"4aa2124"}
[2016-11-17 18:51:00] core.ERROR: Unable to Connect to ssl://holzhof-bayern.de:443. Error #0: {"exception":"[object] (Zend_Http_Client_Adapter_Exception(code: 0): Unable to Connect to ssl://holzhof-bayern.de:443. Error #0: at /www/htdocs/xxxxx/XXXXXXXX/shop/engine/Library/Zend/Http/Client/Adapter/Socket.php:235)"} {"uid":"4aa2124"}
[2016-11-17 18:51:13] core.ERROR: Unable to Connect to ssl://holzhof-bayern.de:443. Error #0: {"exception":"[object] (Zend_Http_Client_Adapter_Exception(code: 0): Unable to Connect to ssl://holzhof-bayern.de:443. Error #0: at /www/htdocs/xxxxx/XXXXXXXX/shop/engine/Library/Zend/Http/Client/Adapter/Socket.php:235)"} {"uid":"1c42e71"}

```

&nbsp;

Danke schonmal 🙂

&nbsp;

Grüße

---

<div class="post-metadata">

### Author: ![kulli](https://avatars.discourse-cdn.com/v4/letter/k/a3d4f5/32.png) [@kulli](https://forum.shopware.com/u/kulli)
#### Post date: [17. November 2016 um 19:17 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/2 "2016-11-17T19:17:41Z")

</div>

cache komplett geleert, template kompiliert ?

und erstmal die anderen inkompatiblen plugins deinstallieren : (stcomm side widget, tawk to )

ist den das Plugin backend bestellungen schon kompatibel ?

&nbsp;

---

<div class="post-metadata">

### Author: ![holzhofbayern](https://avatars.discourse-cdn.com/v4/letter/h/73ab20/32.png) [@holzhofbayern](https://forum.shopware.com/u/holzhofbayern)
#### Post date: [17. November 2016 um 20:15 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/3 "2016-11-17T20:15:11Z")

</div>

> [@kulli schrieb:](https://forum.shopware.com/profile/14033/kulli "kulli")
> 
> cache komplett geleert, template kompiliert ?
> 
> und erstmal die anderen inkompatiblen plugins deinstallieren : (stcomm side widget, tawk to )
> 
> ist den das Plugin backend bestellungen schon kompatibel ?
> 
> &nbsp;

Danke für deine schnelle Antwort.

Ja habe bereits Plugins deaktiviert und gelöscht anschließend kompiliert.

Plugins sind alle kompatibel.

&nbsp;

---

<div class="post-metadata">

### Author: ![holzhofbayern](https://avatars.discourse-cdn.com/v4/letter/h/73ab20/32.png) [@holzhofbayern](https://forum.shopware.com/u/holzhofbayern)
#### Post date: [17. November 2016 um 20:22 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/4 "2016-11-17T20:22:05Z")

</div>

Wenn ich die Fehlermeldungen im Frontend per config.php sichtbar mache bekomme ich folgende Fehlermeldung

```
Fatal error: Cannot redeclare Shopware\Models\Attribute\Article::getNetiIgnoreSc() in /www/htdocs/xxxxx/xxxxx/shop/var/cache/production_201611151410/doctrine/attributes/Article.php on line 563

```

&nbsp;

---

<div class="post-metadata">

### Author: ![kulli](https://avatars.discourse-cdn.com/v4/letter/k/a3d4f5/32.png) [@kulli](https://forum.shopware.com/u/kulli)
#### Post date: [18. November 2016 um 05:22 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/5 "2016-11-18T05:22:50Z")

</div>

Und was sagen die error-logs des servers ?

schon mit backup vor dem Crash versucht ?

Ist der Shop recht neu ? Dan tippe ich auch auf einen falsch konfigurierten Server - da funktioniert auch “erstmal” meistens die installation und nach kurzer Zeit fängt das Chaos an.

Lösche mal manuell per ftp den cache in web/cache

und benenne den production-cache in var/cache um

danach nochmal alle Einstellungen des Servers (vor allem ob das SSL richtig eingebunden ist) und die des Shops (alle cache einstellungen und Grundeinstellungen diesbezüglich) prüfen.

danach nochmal kompilieren

&nbsp;

Andere Maßnahmen fallen mir jetzt nicht ein&nbsp;

&nbsp;

---

<div class="post-metadata">

### Author: ![malzfons](https://avatars.discourse-cdn.com/v4/letter/m/58956e/32.png) [@malzfons](https://forum.shopware.com/u/malzfons)
#### Post date: [18. November 2016 um 05:45 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/6 "2016-11-18T05:45:34Z")

</div>

Ich hänge mich hier mal dran da ich ähnliche Probleme mit meinem missglückten Update von 5.1.5 auf 5.2.10 hatte.

Frage 1:

Hast du auch von der 5.1 auf 5.2 upgedatet oder war es bereits 5.2?

Frage 2:

Wenn man von 5.1 auf 5.2 updatet, sind ja auch die Freitextfeld Optionen neu. Wenn ich nun Plugins im Einsatz habe, die Freitextfelder z.B. bei Anlegen von Kategorien nutzen, sollte man diese dann vor dem Update deaktivieren oder deinstallieren? Reicht ein Deaktivieren des Plugins vor dem Update generell aus?

&nbsp;

Bei mir kam nämlich auch ein Fehler 500 aber ohne Fehlermeldung. Aber erst nachdem ich die Plugins upgedatet habe. Danach ging nix mehr…

Evtl. wäre es besser, vor dem Update von 5.1 auf 5.2 alle Plugins zu deaktivieren und dann nach dem Update auf 5.2 im Shopware Account die Version dementsprechend einstellen. Denn dann werden ja erst die benötigten Plugin Updates im Plugin Manager für 5.2 Kompatibilität freigeschaltet bzw. angezeigt.

Dann jedes Plugin updaten und einzeln der Reihe nach aktivieren. Vielleicht nach jedem aktivierten Plugin Cache komplett löschen und Theme kompilieren.

&nbsp;

Wenn ich ein Plugin deinstalliere, kann es ja auch sein, dass diverse Einstellungen ja verloren gehen. Daher sollte ein normales deaktivieren doch ausreichen oder?

&nbsp;

Viele Grüße

Matthias

&nbsp;

---

<div class="post-metadata">

### Author: ![kulli](https://avatars.discourse-cdn.com/v4/letter/k/a3d4f5/32.png) [@kulli](https://forum.shopware.com/u/kulli)
#### Post date: [18. November 2016 um 05:54 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/7 "2016-11-18T05:54:30Z")

</div>

bezüglich Fehlermeldungen hilft sicher auch das:

> **[Shopware Dokumentation](https://docs.shopware.com/de)**

> **[Shopware Dokumentation](https://docs.shopware.com/de)**

---

<div class="post-metadata">

### Author: ![malzfons](https://avatars.discourse-cdn.com/v4/letter/m/58956e/32.png) [@malzfons](https://forum.shopware.com/u/malzfons)
#### Post date: [18. November 2016 um 06:07 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/8 "2016-11-18T06:07:02Z")

</div>

Danke. Habe mir den Webug grade installiert. Wenn aber im Backend gar nichts mehr ginge, kann man aber z.B. den Debugger ja gar nicht installieren im Plugin Manager. 🙂

Viele Grüße

Matthias

&nbsp;

&nbsp;

---

<div class="post-metadata">

### Author: ![kulli](https://avatars.discourse-cdn.com/v4/letter/k/a3d4f5/32.png) [@kulli](https://forum.shopware.com/u/kulli)
#### Post date: [18. November 2016 um 06:35 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/9 "2016-11-18T06:35:07Z")

</div>

Dann sollte man eine Datensicherung haben von de rZeit als es noch “lief”

Wenn man die auch nicht hat ist man selber Schuld ![Smile](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/bac5f5766b6a20565a8fb995345b4e41d24daac0.png "Smile")

Dann könnte noch eine recovery/install oder recovery/update helfen:

> **[Shopware Dokumentation](https://docs.shopware.com/de?_ga=1.162941567.2104024513.1478876662)**

&nbsp;

&nbsp;

---

<div class="post-metadata">

### Author: ![malzfons](https://avatars.discourse-cdn.com/v4/letter/m/58956e/32.png) [@malzfons](https://forum.shopware.com/u/malzfons)
#### Post date: [18. November 2016 um 06:39 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/10 "2016-11-18T06:39:48Z")

</div>

Gut ich habe ja das Backup nach dem fehlgeschlagenem Update drübergespielt. Der Shop läuft ja wieder auf 5.1.5

Wegen dem Debugger:

Kann man den bereits installieren, unmittelbar bevor man sich auf das Update wagt?

Oder nimmt das bezüglich dem Update zu viel Performance weg?

&nbsp;

Viele Grüße

Matthias

&nbsp;

---

<div class="post-metadata">

### Author: ![kulli](https://avatars.discourse-cdn.com/v4/letter/k/a3d4f5/32.png) [@kulli](https://forum.shopware.com/u/kulli)
#### Post date: [18. November 2016 um 06:44 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/11 "2016-11-18T06:44:41Z")

</div>

Da verstehe ich die Frage nicht: Wenn man ein Update vorhat oder Fehler sucht sollte man sich wegen der Performance keine gedanken machen müssen, denn das sollte man beides sowieso nicht am Live-System durchführen sondern erstmal an einem gleichgeschaltetem Testsystem.

Das ist aber alles schon ausführlichst im Forum beschrieben und wir sollten nicht hier dem holzhofbayern seinem Thread missbrauchen.

---

<div class="post-metadata">

### Author: ![malzfons](https://avatars.discourse-cdn.com/v4/letter/m/58956e/32.png) [@malzfons](https://forum.shopware.com/u/malzfons)
#### Post date: [18. November 2016 um 06:50 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/12 "2016-11-18T06:50:25Z")

</div>

jop stimmt 🙂

&nbsp;

---

<div class="post-metadata">

### Author: ![holzhofbayern](https://avatars.discourse-cdn.com/v4/letter/h/73ab20/32.png) [@holzhofbayern](https://forum.shopware.com/u/holzhofbayern)
#### Post date: [18. November 2016 um 08:09 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/13 "2016-11-18T08:09:25Z")

</div>

> [@malzfons schrieb:](https://forum.shopware.com/profile/22034/malzfons "malzfons")
> 
> Ich hänge mich hier mal dran da ich ähnliche Probleme mit meinem missglückten Update von 5.1.5 auf 5.2.10 hatte.
> 
> Frage 1:
> 
> Hast du auch von der 5.1 auf 5.2 upgedatet oder war es bereits 5.2?
> 
> Frage 2:
> 
> Wenn man von 5.1 auf 5.2 updatet, sind ja auch die Freitextfeld Optionen neu. Wenn ich nun Plugins im Einsatz habe, die Freitextfelder z.B. bei Anlegen von Kategorien nutzen, sollte man diese dann vor dem Update deaktivieren oder deinstallieren? Reicht ein Deaktivieren des Plugins vor dem Update generell aus?
> 
> &nbsp;
> 
> Bei mir kam nämlich auch ein Fehler 500 aber ohne Fehlermeldung. Aber erst nachdem ich die Plugins upgedatet habe. Danach ging nix mehr…
> 
> Evtl. wäre es besser, vor dem Update von 5.1 auf 5.2 alle Plugins zu deaktivieren und dann nach dem Update auf 5.2 im Shopware Account die Version dementsprechend einstellen. Denn dann werden ja erst die benötigten Plugin Updates im Plugin Manager für 5.2 Kompatibilität freigeschaltet bzw. angezeigt.
> 
> Dann jedes Plugin updaten und einzeln der Reihe nach aktivieren. Vielleicht nach jedem aktivierten Plugin Cache komplett löschen und Theme kompilieren.
> 
> &nbsp;
> 
> Wenn ich ein Plugin deinstalliere, kann es ja auch sein, dass diverse Einstellungen ja verloren gehen. Daher sollte ein normales deaktivieren doch ausreichen oder?
> 
> &nbsp;
> 
> Viele Grüße
> 
> Matthias
> 
> &nbsp;

Ja war auch von 5.1 auf 5.2

Wie spiele ich sauber ein Backup ein?&nbsp;

---

<div class="post-metadata">

### Author: ![malzfons](https://avatars.discourse-cdn.com/v4/letter/m/58956e/32.png) [@malzfons](https://forum.shopware.com/u/malzfons)
#### Post date: [18. November 2016 um 15:54 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/14 "2016-11-18T15:54:59Z")

</div>

Du müsstest ein Backup für die Datenbank und eins für den files Ordner haben.

hast du cpanel?

da geht das über den sicherungsassistenten.

notfalls Provider anrufen.

oftmals kann dein Provider auch das Backup vom Vortag zurücksetzen

viele grüsse

matthias

&nbsp;

---

<div class="post-metadata">

### Author: ![holzhofbayern](https://avatars.discourse-cdn.com/v4/letter/h/73ab20/32.png) [@holzhofbayern](https://forum.shopware.com/u/holzhofbayern)
#### Post date: [22. November 2016 um 15:05 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/15 "2016-11-22T15:05:53Z")

</div>

Habe die alte&nbsp;Version 5.1.6 wiederhergestellt.

Alles funktioniert&nbsp;soweit&nbsp;außer das Logo in der PDF Belegerstellung wird nicht angezeigt.

Auf der Rechnung wird&nbsp;nur das Symbol mit dem roten Kreuz angezeigt.

&nbsp;

Cache gelöscht, Logo neu eingefügt&nbsp;

&nbsp;

Habt ihr&nbsp;noch&nbsp;eine Idee?

---

<div class="post-metadata">

### Author: ![malzfons](https://avatars.discourse-cdn.com/v4/letter/m/58956e/32.png) [@malzfons](https://forum.shopware.com/u/malzfons)
#### Post date: [23. November 2016 um 03:32 UTC](https://forum.shopware.com/t/hilfe-internal-server-error-500-nach-update-backend-bestellungen-netfoundations/41457/16 "2016-11-23T03:32:21Z")

</div>

da auch ich bei einem meiner Projekte noch von&nbsp;5.1.5 auf 5.2.10 updaten muss und das Update letzte Woche bei mir ebenfalls in die Hose ging, habe ich mir folgendes Überlegt:

Zuerst alle Plugins deaktivieren bzw. je nach Plugin (wenn z.B. viele Freitextfelder benötigt werden) ganz du deinstallieren. Die inkompatiblen Plugins welche nicht weiterentwickelt werden ganz löschen.

Dann das Update durchführen.

Dann im Shopware Account die Version von 5.1.5 auf 5.2.10 aktualisieren. Dann sollten auch alle nötigen Updates für die deaktivierten und deinstallierten Plugins zur Verfügung stehen. Dann Schritt für Schritt immer ein Plugin updaten und installieren. Alles durchsehen ob alles passt usw. und dann zum nächsten Plugin.

Zwischen den Plugins immer Cache komplett leeren und Theme neu kompilieren.

So sollte es eigentlich klappen. Wenn nicht, wird das problematisch.

Das Backend Bestellungen Plugin auf jeden Fall vor dem Update komplett deinstallieren und im deinstallierten Zustand updaten. Und auch als allerletztes Plugin dann installieren.

Kann aber noch bis Dez. dauern bis ich das so mache, da ich grade mit meinem anderen Projekt zu tun habe 🙂

&nbsp;

Viele Grüße

Matthias

&nbsp;
