# Hilfe: Fehlermeldungen im Backend!

**URL:** https://forum.shopware.com/t/hilfe-fehlermeldungen-im-backend/27819
**Category:** Allgemein
**Tags:** resolved-topics
**Created:** [1. Juni 2015 um 16:07 UTC](https://forum.shopware.com/t/hilfe-fehlermeldungen-im-backend/27819 "2015-06-01T16:07:12Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![janico](https://avatars.discourse-cdn.com/v4/letter/j/e95f7d/32.png) [@janico](https://forum.shopware.com/u/janico)
#### Post date: [1. Juni 2015 um 16:07 UTC](https://forum.shopware.com/t/hilfe-fehlermeldungen-im-backend/27819/1 "2015-06-01T16:07:12Z")

</div>

Hallo zusammen Habe auf einmal im Chrome (Chrome 43.0.2357.81) seit heute Nachmittag folgende Fehlermeldungen nach dem Einloggen ins Backend (FireFox funktioniert alles): Hier die Fehlermeldungen (Screenshot): [http://imgur.com/a/3HwgI](http://imgur.com/a/3HwgI) Pfad der Anforderung: /backend/Article/load/ HTTP-Fehlermeldung: - HTTP-Statuscode: 0 / GET Hier noch die Fehlermeldung, welche ich per Mail zugesandt bekommen habe (weiss aber nicht, ob das einen Zusammenhang hat): `Message: exception 'Enlight\_Controller\_Exception' with message 'Unauthorized' in /home/tradebyt/public\_html/shopware/engine/Shopware/Plugins/Default/Backend/Auth/Bootstrap.php:202 Stack trace: #0 /home/tradebyt/public\_html/shopware/engine/Library/Enlight/Event/Handler/Plugin.php(149): Shopware\_Plugins\_Backend\_Auth\_Bootstrap-\>onPreDispatchBackend(Object(Enlight\_Controller\_ActionEventArgs)) #1 /home/tradebyt/public\_html/shopware/engine/Library/Enlight/Event/EventManager.php(211): Enlight\_Event\_Handler\_Plugin-\>execute(Object(Enlight\_Controller\_ActionEventArgs)) #2 /home/tradebyt/public\_html/shopware/engine/Library/Enlight/Controller/Action.php(138): Enlight\_Event\_EventManager-\>notify('Enlight\_Control...', Object(Enlight\_Controller\_ActionEventArgs)) #3 /home/tradebyt/public\_html/shopware/engine/Library/Enlight/Controller/Dispatcher/Default.php(524): Enlight\_Controller\_Action-\>dispatch('getVisitorsActi...') #4 /home/tradebyt/public\_html/shopware/engine/Library/Enlight/Controller/Front.php(227): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #5 /home/tradebyt/public\_html/shopware/engine/Shopware/Kernel.php(143): Enlight\_Controller\_Front-\>dispatch() #6 /home/tradebyt/public\_html/shopware/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(490): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #7 /home/tradebyt/public\_html/shopware/engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #8 /home/tradebyt/public\_html/shopware/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(261): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true) #9 /home/tradebyt/public\_html/shopware/engine/Shopware/Components/HttpCache/AppCache.php(103): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true) #10 /home/tradebyt/public\_html/shopware/shopware.php(101): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request)) #11 {main} Time: 2015-06-01T15:05:42.236795+0200 Channel: core request: { "uri": "/backend/widgets/getVisitors?\_dc=1433163942104&page=1&start=0&limit=25", "method": "GET", "query": { "\_dc": "1433163942104", "page": "1", "start": "0", "limit": "25", "module": "backend", "controller": "widgets", "action": "getVisitors" }, "post": [] } session: No session data available shop: No shop data available ` Wer kann weiterhelfen? Besten Dank und Gruss Cyril edit: Ich kann auch keine Artikel mehr „neu“ anlegen oder bestehende Artikel bearbeiten… „Anlegen wird geladen…“ und „Shopware.apps.Article wird geladen…“

---

<div class="post-metadata">

### Author: ![Dennis\_Wahl](https://avatars.discourse-cdn.com/v4/letter/d/838e76/32.png) [@Dennis\_Wahl](https://forum.shopware.com/u/Dennis_Wahl)
#### Post date: [1. Juni 2015 um 16:42 UTC](https://forum.shopware.com/t/hilfe-fehlermeldungen-im-backend/27819/2 "2015-06-01T16:42:22Z")

</div>

Hallo tradeby, handelt es sich bei dem Backend Benutzer eventuell um einen Benutzer mit eingeschränkten Rechten? Gruß Dennis

---

<div class="post-metadata">

### Author: ![janico](https://avatars.discourse-cdn.com/v4/letter/j/e95f7d/32.png) [@janico](https://forum.shopware.com/u/janico)
#### Post date: [1. Juni 2015 um 16:45 UTC](https://forum.shopware.com/t/hilfe-fehlermeldungen-im-backend/27819/3 "2015-06-01T16:45:18Z")

</div>

> [@Dennis Wahl](#):
>
> Hallo tradeby, handelt es sich bei dem Backend Benutzer eventuell um einen Benutzer mit eingeschränkten Rechten? Gruß Dennis[/quote] Hallo Dennis Das ist fast korrekt. Dieses Problem tritt auf, auch mit dem „admin“ - Account. Jedoch hat der Benutzer mit „beschränkten“ Rechte eine Hauptkategorie erstellt. Seit diesem Zeitpunkt habe ich Probleme. Den Benutzer mit beschränkten Rechte habe ich vorübergehend deaktiviert. Der Admin hat alle Rechte… Irgendwo muss ja der Haken sein…bekomme jetzt per Mail in kleinen Abständen immer die „gleiche“ Fehlermeldung: Gruss & Dank Cyril [quote]Message: exception ‚Enlight\_Controller\_Exception‘ with message ‚Unauthorized‘ in /home/tradebyt/public\_html/shopware/dev/shopware4/engine/Shopware/Plugins/Default/Backend/Auth/Bootstrap.php:202 Stack trace: #0 /home/tradebyt/public\_html/shopware/dev/shopware4/engine/Library/Enlight/Event/Handler/Plugin.php(149): Shopware\_Plugins\_Backend\_Auth\_Bootstrap-\>onPreDispatchBackend(Object(Enlight\_Controller\_ActionEventArgs)) #1 /home/tradebyt/public\_html/shopware/dev/shopware4/engine/Library/Enlight/Event/EventManager.php(211): Enlight\_Event\_Handler\_Plugin-\>execute(Object(Enlight\_Controller\_ActionEventArgs)) #2 /home/tradebyt/public\_html/shopware/dev/shopware4/engine/Library/Enlight/Controller/Action.php(138): Enlight\_Event\_EventManager-\>notify(‚Enlight\_Control…‘, Object(Enlight\_Controller\_ActionEventArgs)) #3 /home/tradebyt/public\_html/shopware/dev/shopware4/engine/Library/Enlight/Controller/Dispatcher/Default.php(524): Enlight\_Controller\_Action-\>dispatch(‚columnConfigAct…‘) #4 /home/tradebyt/public\_html/shopware/dev/shopware4/engine/Library/Enlight/Controller/Front.php(227): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp)) #5 /home/tradebyt/public\_html/shopware/dev/shopware4/engine/Shopware/Kernel.php(143): Enlight\_Controller\_Front-\>dispatch() #6 /home/tradebyt/public\_html/shopware/dev/shopware4/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(490): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true) #7 /home/tradebyt/public\_html/shopware/dev/shopware4/engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL) #8 /home/tradebyt/public\_html/shopware/dev/shopware4/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(261): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true) #9 /home/tradebyt/public\_html/shopware/dev/shopware4/engine/Shopware/Components/HttpCache/AppCache.php(103): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true) #10 /home/tradebyt/public\_html/shopware/dev/shopware4/shopware.php(101): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request)) #11 {main} Time: 2015-06-01T16:33:02.938526+0200 Channel: core request: { „uri“: „/dev/shopware4/backend/ArticleList/columnConfig?\_dc=1433169178651&resource=product“, „method“: „GET“, „query“: { „\_dc“: „1433169178651“, „resource“: „product“, „module“: „backend“, „controller“: „ArticleList“, „action“: „columnConfig“ }, „post“: } session: No session data available shop: No shop data available

---

<div class="post-metadata">

### Author: ![janico](https://avatars.discourse-cdn.com/v4/letter/j/e95f7d/32.png) [@janico](https://forum.shopware.com/u/janico)
#### Post date: [2. Juni 2015 um 09:30 UTC](https://forum.shopware.com/t/hilfe-fehlermeldungen-im-backend/27819/4 "2015-06-02T09:30:51Z")

</div>

Gelöst! Konnte das Problem lösen. Hattte was mit Verzeichnisschutz zu tun. Und musste darauf achten, dass die URL einmal mit resp. ohne https:// war… Gruss & vielen Dank Cyril

---

<div class="post-metadata">

### Author: ![janico](https://avatars.discourse-cdn.com/v4/letter/j/e95f7d/32.png) [@janico](https://forum.shopware.com/u/janico)
#### Post date: [2. Juni 2015 um 10:27 UTC](https://forum.shopware.com/t/hilfe-fehlermeldungen-im-backend/27819/5 "2015-06-02T10:27:48Z")

</div>

[quote=“tradeby”]Gelöst! Konnte das Problem lösen. Hattte was mit Verzeichnisschutz zu tun. Und musste darauf achten, dass die URL einmal mit resp. ohne https:// war… Gruss & vielen Dank Cyril[/quote] Sorry, Problem taucht wieder auf. Habe Evtl. das Gefühl könnte mit der .htaccess zusammenhängen? Folgende Fehlermeldungen: [quote]exception ‘Exception’ with message ‘Signature is not valid’ in /home/tradebyt/public\_html/shopware/engine/Shopware/Plugins/Default/Backend/SwagUpdate/Components/UpdateCheck.php:94 Stack trace: #0 /home/tradebyt/public\_html/shopware/engine/Shopware/Plugins/Default/Backend/SwagUpdate/Components/UpdateCheck.php(129): ShopwarePlugins\SwagUpdate\Components\UpdateCheck-\>verifyBody(NULL, '\r\n

\<… shopwareplugins\>checkUpdate(‘5.0.1’, Array)  
#2 /home/tradebyt/public\_html/shopware/engine/Shopware/Plugins/Default/Backend/SwagUpdate/Controllers/Backend/SwagUpdate.php(271): Shopware\_Controllers\_Backend\_SwagUpdate-\>fetchUpdateVersion()  
#3 /home/tradebyt/public\_html/shopware/engine/Library/Enlight/Controller/Action.php(159): Shopware\_Controllers\_Backend\_SwagUpdate-\>popupAction()  
#4 /home/tradebyt/public\_html/shopware/engine/Library/Enlight/Controller/Dispatcher/Default.php(524): Enlight\_Controller\_Action-\>dispatch(‘popupAction’)  
#5 /home/tradebyt/public\_html/shopware/engine/Library/Enlight/Controller/Front.php(227): Enlight\_Controller\_Dispatcher\_Default-\>dispatch(Object(Enlight\_Controller\_Request\_RequestHttp), Object(Enlight\_Controller\_Response\_ResponseHttp))  
#6 /home/tradebyt/public\_html/shopware/engine/Shopware/Kernel.php(143): Enlight\_Controller\_Front-\>dispatch()  
#7 /home/tradebyt/public\_html/shopware/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(490): Shopware\Kernel-\>handle(Object(Symfony\Component\HttpFoundation\Request), 1, true)  
#8 /home/tradebyt/public\_html/shopware/engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true, NULL)  
#9 /home/tradebyt/public\_html/shopware/vendor/symfony/http-kernel/Symfony/Component/HttpKernel/HttpCache/HttpCache.php(261): Shopware\Components\HttpCache\AppCache-\>forward(Object(Symfony\Component\HttpFoundation\Request), true)  
#10 /home/tradebyt/public\_html/shopware/engine/Shopware/Components/HttpCache/AppCache.php(103): Symfony\Component\HttpKernel\HttpCache\HttpCache-\>pass(Object(Symfony\Component\HttpFoundation\Request), true)  
#11 /home/tradebyt/public\_html/shopware/shopware.php(101): Shopware\Components\HttpCache\AppCache-\>handle(Object(Symfony\Component\HttpFoundation\Request))  
#12 {main}  
2015-06-02T10:25:02.499539+0200  
core  
{  
“uri”: “/backend/SwagUpdate/popup?\_dc=1433233499521”,  
“method”: “GET”,  
“query”: {  
“\_dc”: “1433233499521”,  
“module”: “backend”,  
“controller”: “SwagUpdate”,  
“action”: “popup”  
},  
“post”:   
}  
{  
“userId”: “50”,  
“roleId”: “1”  
}  
No shop data available  
[/quote]

Die .htaccess-Datei:

[code]  
RewriteEngine on

#RewriteBase /shopware/

# Https config for the backend

RewriteCond %{HTTPS} !=on  
RewriteRule (.\*) https://%{HTTP\_HOST}%{REQUEST\_URI} [L,R=301]

RewriteRule shopware.dll shopware.php  
RewriteRule files/documents/.\* engine [NC,L]  
RewriteRule backend/media/(.\*) media/$1 [NC,L]

RewriteCond %{REQUEST\_URI} !(/(engine|files|templates)/)  
RewriteCond %{REQUEST\_URI} !(/media/(archive|banner|image|music|pdf|unknown|video)/)  
RewriteCond %{REQUEST\_FILENAME} !-f  
RewriteCond %{REQUEST\_FILENAME} !-d  
RewriteRule ^(.\*)$ shopware.php [PT,L,QSA]

# Fix missing authorization-header on fast\_cgi installations

RewriteRule .\* - [E=HTTP\_AUTHORIZATION:%{HTTP:Authorization},L]

 # Block access to VCS directories RedirectMatch 404 /\\.(svn|git|hg|bzr|cvs)(/|$)
# Staging environment

#SetEnvIf Host “staging.test.shopware.in” SHOPWARE\_ENV=staging

# Development environment

#SetEnvIf Host “dev.shopware.in” SHOPWARE\_ENV=dev  
#SetEnv SHOPWARE\_ENV dev

DirectoryIndex index.html  
DirectoryIndex index.php  
DirectoryIndex shopware.php

# Disables download of configuration
 # Deny all requests from Apache 2.4+. Require all denied 

```
# Deny all requests from Apache 2.0-2.2.
<ifmodule>
    Deny from all
</ifmodule>

```

# Enable gzip compression
 AddOutputFilterByType DEFLATE text/html text/xml text/plain text/css text/javascript application/json application/x-font-woff application/font-woff ExpiresActive on ExpiresDefault "access plus 1 month" FileETag None Header append Cache-Control "public" Header unset ETag 
# Disables auto directory index
 Options -Indexes Options -MultiViews # php\_value memory\_limit 256M # php\_value max\_execution\_time 120 # php\_value upload\_max\_filesize 20M php\_flag phar.readonly off php\_flag magic\_quotes\_gpc off php\_flag session.auto\_start off php\_flag suhosin.session.cryptua off php\_flag zend.ze1\_compatibility\_mode off
# AddType x-mapp-php5 .php

# AddHandler x-mapp-php5 .php

# AddHandler application/x-httpd-php56 .php

[/code]

Was mache ich falsch? Wo liegt der Haken?  
Denn im FireFox funktioniert alles.

Besten Dank und Grüsse  
Cyril\</…\>

---

<div class="post-metadata">

### Author: ![janico](https://avatars.discourse-cdn.com/v4/letter/j/e95f7d/32.png) [@janico](https://forum.shopware.com/u/janico)
#### Post date: [2. Juni 2015 um 20:23 UTC](https://forum.shopware.com/t/hilfe-fehlermeldungen-im-backend/27819/6 "2015-06-02T20:23:35Z")

</div>

\*up\*

---

<div class="post-metadata">

### Author: ![janico](https://avatars.discourse-cdn.com/v4/letter/j/e95f7d/32.png) [@janico](https://forum.shopware.com/u/janico)
#### Post date: [4. Juni 2015 um 07:22 UTC](https://forum.shopware.com/t/hilfe-fehlermeldungen-im-backend/27819/7 "2015-06-04T07:22:22Z")

</div>

Hallo zusammen Ich habe ein altes Backup eingespielt (Datenbank)…leider besteht das Problem immer noch. Ich dachte zuerst dass der Fehler durch falsche DB-Einträge verursacht wird. Leider ist dem nicht so. Ich habe auch schon das Update 5.0.1 mehrmals drüber installiert…hat auch nichts gebracht, da ich davon ausgegangen bin, dass irgendwo eine Datei Fehlerhaft sein könnte. Noch jemand einen Tipp?? Besten Dank und Gruss Cyril EDIT: Sobald ich in der .htacces die RewriteCond %{HTTPS} !=on und RewriteRule (.\*) https://%{HTTP\_HOST}%{REQUEST\_URI} [L,R=301] als Kommentar setze mit # und ich das Shopware Backend OHNE https:// aufrufe, dann habe ich keine Fehlermeldungen mehr. Sieht so aus, als würde das SSL Zertifikat, resp. der SSL-Pfad die Fehlermeldungen im Backend aufrufen…

---

<div class="post-metadata">

### Author: ![janico](https://avatars.discourse-cdn.com/v4/letter/j/e95f7d/32.png) [@janico](https://forum.shopware.com/u/janico)
#### Post date: [5. Juni 2015 um 13:25 UTC](https://forum.shopware.com/t/hilfe-fehlermeldungen-im-backend/27819/8 "2015-06-05T13:25:08Z")

</div>

Hallo zusammen habe jetzt eine demo-Installation installiert. Die ist von 0 aufgesetzt worden. tradeby.ch/dev/default Habe Dort im Backend alles auf https:// umgestellt (siehe Screenshot)

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/e47bd0573abef7713e1325ad87d5175fb80661b7.jpeg) Interessant ist, sobald ich dann das Backend via https:// aufrufe, erscheinen folgende Fehlermeldung im Google Chrome 43.0.2357.81 m .htaccess wurde nicht verändert (original) Bin am Verzweifeln, wer kann weiterhelfen? [http://imgur.com/a/MUQuB](http://imgur.com/a/MUQuB) (Screenshots Fehlermeldungen) Weiss jemand um Rat?? Wer kann weiterhelfen? Besten Dank und Grüsse Cyril
