# HELP: Testshop angelegt - bei Aufruf Fehler

**URL:** <https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373>\
**Category:** Allgemein\
**Created:** [1. August 2018 um 11:50 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373 "2018-08-01T11:50:10Z")\
**Posts on this page:** 18\
**Page:** 1

<div class="post-metadata">

**Author:** ![ALA](https://avatars.discourse-cdn.com/v4/letter/a/a8b319/32.png) [@ALA](https://forum.shopware.com/u/ALA)\
**Post date:** [1. August 2018 um 11:50 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/1 "2018-08-01T11:50:10Z")

</div>

Wir betreiben einen Shop ( Vers. 4.2.3 ) [www.ladenbau-gehlert.de](http://www.ladenbau-gehlert.de), welchen wir bei 1und1 gehostet haben. Jetzt habe ich einen Testshop ebenso bei 1und1 auf einen neuen Host angelegt, um verschiedenes vorab zu testen. Also wie beschrieben, den Shop kopiert, die Datenbank angelegt und importiert. In der Datenbank unter &nbsp;s\_core\_shops die Domains geändert und den Pfad, wo der shop liegt. In der config.php den Zugang zur Datenbank angepasst. Beim Aufruf der Domain ebenso bei Aufruf des Backend kommt folgender Fehler:

**Warning** : count(): Parameter must be an array or an object that implements Countable in **/homepages/14/d743866476/htdocs/shop/engine/Library/Enlight/Event/EventManager.php** on line **107**  
**Deprecated** : The each() function is deprecated. This message will be suppressed on further calls in **/homepages/14/d743866476/htdocs/shop/engine/Library/Zend/Cache/Backend.php** on line **66**  
**Warning** : count(): Parameter must be an array or an object that implements Countable in **/homepages/14/d743866476/htdocs/shop/engine/Library/Enlight/Event/EventManager.php** on line **107**  
**Warning** : count(): Parameter must be an array or an object that implements Countable in **/homepages/14/d743866476/htdocs/shop/engine/Library/Enlight/Event/EventManager.php** on line **107**  
**Warning** : count(): Parameter must be an array or an object that implements Countable in **/homepages/14/d743866476/htdocs/shop/engine/Library/Enlight/Event/EventManager.php** on line **107**  
**Warning** : count(): Parameter must be an array or an object that implements Countable in **/homepages/14/d743866476/htdocs/shop/engine/Library/Enlight/Event/EventManager.php** on line **107** …

Was habe ich nicht richtig gemacht ? Wo liegt die Ursache ? Und wie kann ich den Fehler beheben ?

Ich bin noch " blutiger Anfänger " - muss aber den Shop betreuen, da " der Vorgänger " nicht mehr " greifbar ist ".

---

<div class="post-metadata">

**Author:** ![shopyphus](https://avatars.discourse-cdn.com/v4/letter/s/71c47a/32.png) [@shopyphus](https://forum.shopware.com/u/shopyphus)\
**Post date:** [1. August 2018 um 12:11 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/2 "2018-08-01T12:11:45Z")

</div>

Ohne mit der Fehlermeldung direkt etwas anfangen zu können: Wurde der Cache aus der Kopie gelöscht?

Weiß leider nicht, wie das unter Shopware 4 genau geht, aber das lässt sich bestimmt auch herausfinden.

Unter Shopware 5 liegen im Stammverzeichnis unter /var/cache ein oder mehrere Ordner “production\_XXX”. Diese umbenennen, dann sollte automatisch ein neuer erstellt werden.

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [1. August 2018 um 12:14 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/3 "2018-08-01T12:14:10Z")

</div>

Falsche PHP-Version?  
Shopware 4.2 kann maximal php5.6 (glaube vielleicht sogar nur 5.5).

---

<div class="post-metadata">

**Author:** ![ALA](https://avatars.discourse-cdn.com/v4/letter/a/a8b319/32.png) [@ALA](https://forum.shopware.com/u/ALA)\
**Post date:** [1. August 2018 um 12:54 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/4 "2018-08-01T12:54:55Z")

</div>

> [@Moritz Naczenski schrieb:](https://forum.shopware.com/profile/14574/Moritz%20Naczenski "Moritz%20Naczenski")
> 
> Falsche PHP-Version?  
> Shopware 4.2 kann maximal php5.6 (glaube vielleicht sogar nur 5.5).

Vielen Dank für die schnelle Reaktion. Ich war der Meinung, dass wenn ich einen neuen Host beim gleichem Anbieter wie auch der Originalshop läuft, in dem Falle 1und1 anmiete,&nbsp; dass dann die Bedingungen auch gleich sind. Müsste ich mich demnach an den Hoster melden, oder ?

---

<div class="post-metadata">

**Author:** ![ALA](https://avatars.discourse-cdn.com/v4/letter/a/a8b319/32.png) [@ALA](https://forum.shopware.com/u/ALA)\
**Post date:** [1. August 2018 um 12:57 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/5 "2018-08-01T12:57:06Z")

</div>

> [@shopyphus schrieb:](https://forum.shopware.com/profile/28567/shopyphus "shopyphus")
> 
> Ohne mit der Fehlermeldung direkt etwas anfangen zu können: Wurde der Cache aus der Kopie gelöscht?
> 
> Weiß leider nicht, wie das unter Shopware 4 genau geht, aber das lässt sich bestimmt auch herausfinden.
> 
> Unter Shopware 5 liegen im Stammverzeichnis unter /var/cache ein oder mehrere Ordner „production\_XXX“. Diese umbenennen, dann sollte automatisch ein neuer erstellt werden.

Nein - habe nix im Cache gelöscht. Werd mal schauen und ausprobieren. Vielen Dank.

---

<div class="post-metadata">

**Author:** ![ALA](https://avatars.discourse-cdn.com/v4/letter/a/a8b319/32.png) [@ALA](https://forum.shopware.com/u/ALA)\
**Post date:** [1. August 2018 um 13:05 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/6 "2018-08-01T13:05:52Z")

</div>

> [@ALA schrieb:](https://forum.shopware.com/profile/29355/ALA "ALA")
> 
> > [@shopyphus schrieb:](https://forum.shopware.com/profile/28567/shopyphus "shopyphus")
> > 
> > Ohne mit der Fehlermeldung direkt etwas anfangen zu können: Wurde der Cache aus der Kopie gelöscht?
> > 
> > Weiß leider nicht, wie das unter Shopware 4 genau geht, aber das lässt sich bestimmt auch herausfinden.
> > 
> > Unter Shopware 5 liegen im Stammverzeichnis unter /var/cache ein oder mehrere Ordner „production\_XXX“. Diese umbenennen, dann sollte automatisch ein neuer erstellt werden.
> 
> Nein - habe nix im Cache gelöscht. Werd mal schauen und ausprobieren. Vielen Dank.
> 
> Finde leider keinen Ordner "produktion… &nbsp; :-(&nbsp; ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/6/669318661f0e943b97e9535bb09b58dbd633bc35.jpeg)

---

<div class="post-metadata">

**Author:** ![BestShopPossible](https://avatars.discourse-cdn.com/v4/letter/b/6bbea6/32.png) [@BestShopPossible](https://forum.shopware.com/u/BestShopPossible)\
**Post date:** [1. August 2018 um 13:09 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/7 "2018-08-01T13:09:00Z")

</div>

Wie @shopyphus‍ schon schrieb:

> Weiß leider nicht, wie das unter Shopware 4 genau geht, aber das lässt sich bestimmt auch herausfinden.

Google ist dein Freund.&nbsp;

---

<div class="post-metadata">

**Author:** ![shopyphus](https://avatars.discourse-cdn.com/v4/letter/s/71c47a/32.png) [@shopyphus](https://forum.shopware.com/u/shopyphus)\
**Post date:** [1. August 2018 um 13:34 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/8 "2018-08-01T13:34:36Z")

</div>

Das Löschen des Cache scheint unter Shopware 4 etwas heikler zu sein (Ordnerstruktur muss&nbsp;teilweise erhalten bleiben).

Ich würde mich hier orientieren:

[https://forum.shopware.com/discussion/16590/cache-manuell-loeschen](https://forum.shopware.com/discussion/16590/cache-manuell-loeschen)

---

<div class="post-metadata">

**Author:** ![BestShopPossible](https://avatars.discourse-cdn.com/v4/letter/b/6bbea6/32.png) [@BestShopPossible](https://forum.shopware.com/u/BestShopPossible)\
**Post date:** [1. August 2018 um 13:50 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/9 "2018-08-01T13:50:02Z")

</div>

Klingt gut.

---

<div class="post-metadata">

**Author:** ![ALA](https://avatars.discourse-cdn.com/v4/letter/a/a8b319/32.png) [@ALA](https://forum.shopware.com/u/ALA)\
**Post date:** [1. August 2018 um 14:54 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/10 "2018-08-01T14:54:38Z")

</div>

> [@ALA schrieb:](https://forum.shopware.com/profile/29355/ALA "ALA")
> 
> > [@Moritz Naczenski schrieb:](https://forum.shopware.com/profile/14574/Moritz%20Naczenski "Moritz%20Naczenski")
> > 
> > Falsche PHP-Version?  
> > Shopware 4.2 kann maximal php5.6 (glaube vielleicht sogar nur 5.5).
> 
> Vielen Dank für die schnelle Reaktion. Ich war der Meinung, dass wenn ich einen neuen Host beim gleichem Anbieter wie auch der Originalshop läuft, in dem Falle 1und1 anmiete,&nbsp; dass dann die Bedingungen auch gleich sind. Müsste ich mich demnach an den Hoster melden, oder ?
> 
> Hab noch einmal den Original Shop und den Test Shop bei 1und1 nachgeschaut - bei beiden wird die gleiche php Version angezeigt
> 
> ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/0/038b46c4ff296635879bc0d930b68dd9090aae98.jpeg) ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/6/6002ebf4401269412bc5386d4c0eb7f1e83b72f7.jpeg)

---

<div class="post-metadata">

**Author:** ![ALA](https://avatars.discourse-cdn.com/v4/letter/a/a8b319/32.png) [@ALA](https://forum.shopware.com/u/ALA)\
**Post date:** [1. August 2018 um 15:45 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/11 "2018-08-01T15:45:17Z")

</div>

> [@shopyphus schrieb:](https://forum.shopware.com/profile/28567/shopyphus "shopyphus")
> 
> Das Löschen des Cache scheint unter Shopware 4 etwas heikler zu sein (Ordnerstruktur muss&nbsp;teilweise erhalten bleiben).
> 
> Ich würde mich hier orientieren:
> 
> [https://forum.shopware.com/discussion/16590/cache-manuell-loeschen](https://forum.shopware.com/discussion/16590/cache-manuell-loeschen)

Habe allen Inhalt des cache Ordners und deren Unterordner " per Hand " gelöscht. **Leider ohne Erfolg.&nbsp; ![Crying](https://forum.shopware.com/plugins/CKEditor/plugins/smiley/images/crying.png "Crying")**

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [1. August 2018 um 16:45 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/12 "2018-08-01T16:45:47Z")

</div>

Versuch mal rauszubekommen welche PHP-Version läuft, auf den Screenshots steht das nicht.

---

<div class="post-metadata">

**Author:** ![ALA](https://avatars.discourse-cdn.com/v4/letter/a/a8b319/32.png) [@ALA](https://forum.shopware.com/u/ALA)\
**Post date:** [2. August 2018 um 06:55 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/13 "2018-08-02T06:55:22Z")

</div>

> [@Moritz Naczenski schrieb:](https://forum.shopware.com/profile/14574/Moritz%20Naczenski "Moritz%20Naczenski")
> 
> Versuch mal rauszubekommen welche PHP-Version läuft, auf den Screenshots steht das nicht.

Auf dem Originalshop und dem Testshop laufen die gleichen PHP Versionen 5.5.

&nbsp; ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/8/874e4920958a5406eb897b47aef748f8fa22fbc8.jpeg) ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/2X/7/7b578c4d6d31418991d1d23ed7602fd098221772.jpeg)

---

<div class="post-metadata">

**Author:** ![BestShopPossible](https://avatars.discourse-cdn.com/v4/letter/b/6bbea6/32.png) [@BestShopPossible](https://forum.shopware.com/u/BestShopPossible)\
**Post date:** [2. August 2018 um 07:06 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/14 "2018-08-02T07:06:55Z")

</div>

MySQL 5.5 ist die Datenbank (steht da auch einmal oben drüber DATENBANK-DETAILS)

PHP ist nicht MySQL&nbsp;

---

<div class="post-metadata">

**Author:** ![ALA](https://avatars.discourse-cdn.com/v4/letter/a/a8b319/32.png) [@ALA](https://forum.shopware.com/u/ALA)\
**Post date:** [2. August 2018 um 07:21 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/15 "2018-08-02T07:21:00Z")

</div>

> [@BestShopPossible schrieb:](https://forum.shopware.com/profile/27701/BestShopPossible "BestShopPossible")
> 
> MySQL 5.5 ist die Datenbank (steht da auch einmal oben drüber DATENBANK-DETAILS)
> 
> PHP ist nicht MySQL&nbsp;

&nbsp;

Ups - sorry… &nbsp; Im Original System ist PHP Version 5.6.36&nbsp; - sollte im Testsystem wohl genau so sein, denn ich hab ja das Originale ins Testsystem 1 zu 1 übertragen.

 ![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/dc610fd7c9f76c3f48f1f0be21c5b202e02a1528.jpeg)

---

<div class="post-metadata">

**Author:** ![ALA](https://avatars.discourse-cdn.com/v4/letter/a/a8b319/32.png) [@ALA](https://forum.shopware.com/u/ALA)\
**Post date:** [2. August 2018 um 07:26 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/16 "2018-08-02T07:26:50Z")

</div>

> [@ALA schrieb:](https://forum.shopware.com/profile/29355/ALA "ALA")
> 
> > [@BestShopPossible schrieb:](https://forum.shopware.com/profile/27701/BestShopPossible "BestShopPossible")
> > 
> > MySQL 5.5 ist die Datenbank (steht da auch einmal oben drüber DATENBANK-DETAILS)
> > 
> > PHP ist nicht MySQL&nbsp;
> 
> &nbsp;
> 
> Ups - sorry… &nbsp; Im Original System ist PHP Version 5.6.36&nbsp; - sollte im Testsystem wohl genau so sein, denn ich hab ja das Originale ins Testsystem 1 zu 1 übertragen.
> 
> ![image](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/dc610fd7c9f76c3f48f1f0be21c5b202e02a1528.jpeg)
> 
> &nbsp;
> 
> Ich bin wie schon geschrieben, noch blutiger Anfänger, daher mneine Frage noch dazu: wo ist die PHP Skripsprache installiert - im Shopsystem oder auf dem Server ( also Host ) - Meine Frage nur deshalb: ich habe bewust den Testshop auch bei 1und1 angelegt, wie auch das Originalsystem ja läuft und war der Meinung, das die Bedingeungen des Hosts gleich sind.

---

<div class="post-metadata">

**Author:** ![ALA](https://avatars.discourse-cdn.com/v4/letter/a/a8b319/32.png) [@ALA](https://forum.shopware.com/u/ALA)\
**Post date:** [2. August 2018 um 07:37 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/17 "2018-08-02T07:37:19Z")

</div>

> [@ALA schrieb:](https://forum.shopware.com/profile/29355/ALA "ALA")
> 
> > [@ALA schrieb:](https://forum.shopware.com/profile/29355/ALA "ALA")
> > 
> > > [@BestShopPossible schrieb:](https://forum.shopware.com/profile/27701/BestShopPossible "BestShopPossible")
> > > 
> > > MySQL 5.5 ist die Datenbank (steht da auch einmal oben drüber DATENBANK-DETAILS)
> > > 
> > > PHP ist nicht MySQL&nbsp;
> > > 
> > > &nbsp;
> > 
> > &nbsp;
> > 
> > Ups - sorry… &nbsp; Im Original System ist PHP Version 5.6.36&nbsp; - sollte im Testsystem wohl genau so sein, denn ich hab ja das Originale ins Testsystem 1 zu 1 übertragen.
> > 
> > ![image](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/dc610fd7c9f76c3f48f1f0be21c5b202e02a1528.jpeg)
> > 
> > &nbsp;
> > 
> > Ich bin wie schon geschrieben, noch blutiger Anfänger, daher mneine Frage noch dazu: wo ist die PHP Skripsprache installiert - im Shopsystem oder auf dem Server ( also Host ) - Meine Frage nur deshalb: ich habe bewust den Testshop auch bei 1und1 angelegt, wie auch das Originalsystem ja läuft und war der Meinung, das die Bedingeungen des Hosts gleich sind.

Hmm - wer lesen kann ist im Vorteil 🙂 &nbsp; habe auf dem Testhost die PHP Version auf 5.6 umstellen können. - und siehe da - die Website funktioniert :-)&nbsp;

---

<div class="post-metadata">

**Author:** ![ALA](https://avatars.discourse-cdn.com/v4/letter/a/a8b319/32.png) [@ALA](https://forum.shopware.com/u/ALA)\
**Post date:** [1. Oktober 2018 um 08:13 UTC](https://forum.shopware.com/t/help-testshop-angelegt-bei-aufruf-fehler/54373/18 "2018-10-01T08:13:30Z")

</div>

Erledigt - Fehler selbst gefunden
