# \[gelöst\] SW 5.2.9 Cronjob Error

**URL:** <https://forum.shopware.com/t/gelost-sw-5-2-9-cronjob-error/42606>\
**Category:** Administration\
**Created:** [6. Januar 2017 um 14:19 UTC](https://forum.shopware.com/t/gelost-sw-5-2-9-cronjob-error/42606 "2017-01-06T14:19:16Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [6. Januar 2017 um 14:19 UTC](https://forum.shopware.com/t/gelost-sw-5-2-9-cronjob-error/42606/1 "2017-01-06T14:19:16Z")

</div>

Nach einen Update auf 5.2.9 mag der Cronjob nicht mehr ☹

```
[Doctrine\DBAL\DBALException]

An exception occurred while executing 'UPDATE s_crontab SET action = ?, `interval` = ?, data = ?, active = ?, next = ?, start = ?, end = ?, disable_on_error = ? WHERE id = ?' with params ["Shopware_CronJob_ClearHttpCache", 900, "a
  :1:{s:5:\"error\";s:436:\"An exception occurred while executing 'UPDATE s_crontab SET action = ?, `interval` = ?, data = ?, active = ?, next = ?, start = ?, end = ?, disable_on_error = ? WHERE id = ?' with params [\"Shopware_CronJ
  ob_ClearHttpCache\", 900, \"s:19:\\\"Cleared HTTP-Cache\\n\\\";\", \"1\", \"2017-01-05 10:47:56\", \"2017-01-06 15:08:27\", \"2017-05-01 10:45:01\", \"0\", 16]:\n\nSQLSTATE[42S22]: Column not found: 1054 Unknown column 'disable_on
  _error' in 'field list'\";}", "1", "2017-01-06 15:17:56", "2017-01-06 15:08:27", "2017-01-06 15:08:27", "0", 16]:
  

SQLSTATE[42S22]: Column not found: 1054 Unknown column 'disable_on_error' in 'field list'

```

In der Tabelle zum Cronjob gibt es keine Spalte „disable\_on\_error“. Dadurch wird der Cronjob mit Fehler 503 abgebrochen.

**Was kann ich tun?&nbsp;**

---

<div class="post-metadata">

**Author:** ![NextMike](https://avatars.discourse-cdn.com/v4/letter/n/838e76/32.png) [@NextMike](https://forum.shopware.com/u/NextMike)\
**Post date:** [6. Januar 2017 um 14:29 UTC](https://forum.shopware.com/t/gelost-sw-5-2-9-cronjob-error/42606/2 "2017-01-06T14:29:29Z")

</div>

Es sieht so aus, als ob nicht alle Migrationsscripte gelaufen sind. Gab es beim Update irgendwelche Fehler?

---

<div class="post-metadata">

**Author:** ![NextMike](https://avatars.discourse-cdn.com/v4/letter/n/838e76/32.png) [@NextMike](https://forum.shopware.com/u/NextMike)\
**Post date:** [6. Januar 2017 um 14:31 UTC](https://forum.shopware.com/t/gelost-sw-5-2-9-cronjob-error/42606/3 "2017-01-06T14:31:11Z")

</div>

Vielleicht das mal ausführen:&nbsp;[shopware/789-add-crontab-disableonerror.php at 9c393b1218815589b6c05aa41a962fa90b30454a · shopware/shopware · GitHub](https://github.com/shopware/shopware/blob/9c393b1218815589b6c05aa41a962fa90b30454a/_sql/migrations/789-add-crontab-disableonerror.php)

&nbsp;

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [6. Januar 2017 um 14:36 UTC](https://forum.shopware.com/t/gelost-sw-5-2-9-cronjob-error/42606/4 "2017-01-06T14:36:07Z")

</div>

Das wars. Ist wohl beim Update nicht gemacht worden. Danke!
