# \[gelöst\] Shopware5 RC2 - PluginManager communication failure

**URL:** <https://forum.shopware.com/t/gelost-shopware5-rc2-pluginmanager-communication-failure/26172>\
**Category:** Installation/Einstieg\
**Created:** [10. April 2015 um 15:53 UTC](https://forum.shopware.com/t/gelost-shopware5-rc2-pluginmanager-communication-failure/26172 "2015-04-10T15:53:04Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Falko](https://avatars.discourse-cdn.com/v4/letter/f/9de0a6/32.png) [@Falko](https://forum.shopware.com/u/Falko)\
**Post date:** [10. April 2015 um 15:53 UTC](https://forum.shopware.com/t/gelost-shopware5-rc2-pluginmanager-communication-failure/26172/1 "2015-04-10T15:53:04Z")

</div>

Hallo zusammen, sobald ich nach der Shopware 5 RC-Installation das Backend aufrufe und mich einlogge, bekomme ich die folgende Fehlermeldung: ![](https://www.imageupload.co.uk/images/2015/04/10/shopware5rc2%5C_failure.png) Das nginx error.log gibt mir noch folgende Information: [quote]2015/04/10 15:45:49 [error] 12849#0: \*5373 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 192.168.10.140, server: $host, request: “GET /backend/PluginManager?file=app&no-cache=1428672445+1+1 HTTP/1.0”, upstream: “fastcgi://unix:/var/run/php5-fpm.sock:”, host: “[mydomain.com](http://mydomain.com)”, referrer: “[http://mydomain.com/backend/](http://mydomain.com/backend/)”.[/quote] Kann mir hier jemand weiterhelfen? Danke für eure Hilfe.

---

<div class="post-metadata">

**Author:** ![Shopwareianer](https://avatars.discourse-cdn.com/v4/letter/s/b4bc9f/32.png) [@Shopwareianer](https://forum.shopware.com/u/Shopwareianer)\
**Post date:** [10. April 2015 um 15:59 UTC](https://forum.shopware.com/t/gelost-shopware5-rc2-pluginmanager-communication-failure/26172/2 "2015-04-10T15:59:02Z")

</div>

Da gibts es massig Lösungen auf [Google](https://www.google.de/search?q=nginx+upstream+timed+out&oq=nginx+upstream+timed+out&aqs=chrome..69i57j0l5.1036j0j7&sourceid=chrome&es%5C_sm=91&ie=UTF-8) 😉 Kommt der Fehler direkt nach dem einloggen oder direkt beim Aufruf des Plugin Managers ? Oder erst nach einer gewissen Zeit ?

---

<div class="post-metadata">

**Author:** ![Falko](https://avatars.discourse-cdn.com/v4/letter/f/9de0a6/32.png) [@Falko](https://forum.shopware.com/u/Falko)\
**Post date:** [10. April 2015 um 17:04 UTC](https://forum.shopware.com/t/gelost-shopware5-rc2-pluginmanager-communication-failure/26172/3 "2015-04-10T17:04:14Z")

</div>

Danke für deine Antwort. Das Verändern des proxy\_read\_timeout hilft leider nicht. Auch das Hochsetzen der max\_execution\_time im PHP blieb erfolglos. Der Timeout erscheint direkt nach dem Login (die Oberfläche wird daher gar nicht erst geladen) nach ca. 30-60 Sek Ladezeit (schwankend, auch wenn proxy\_read\_timeout, max\_execution\_time, … höher gesetzt wurden). Haben soeben auch einmal einen Apache aufgesetzt, mit diesem haben wir das selbe Verhalten.

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [10. April 2015 um 19:00 UTC](https://forum.shopware.com/t/gelost-shopware5-rc2-pluginmanager-communication-failure/26172/4 "2015-04-10T19:00:13Z")

</div>

Falls Du PHP-FPM einsetzt: gibt es Fehler im FPM-Log?

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [10. April 2015 um 19:02 UTC](https://forum.shopware.com/t/gelost-shopware5-rc2-pluginmanager-communication-failure/26172/5 "2015-04-10T19:02:37Z")

</div>

Was mir noch einfällt: setze fastcgi\_read\_timeout in der nginx-Konfiguration auf einen höheren Wert, z.B. fastcgi\_read\_timeout 1200;

---

<div class="post-metadata">

**Author:** ![Falko](https://avatars.discourse-cdn.com/v4/letter/f/9de0a6/32.png) [@Falko](https://forum.shopware.com/u/Falko)\
**Post date:** [13. April 2015 um 11:00 UTC](https://forum.shopware.com/t/gelost-shopware5-rc2-pluginmanager-communication-failure/26172/6 "2015-04-13T11:00:01Z")

</div>

Danke für eure Unterstützung. Wir haben das Problem mittlerweile lösen können. Es lag an der deaktivierten PHP-Funktion curl\_multi\_exec, die in Shopware 5 durch die guzzlehttp library in /vendor/guzzlehttp/ringphp/src/Client/CurlMultiHandler.php benötigt wird.

---

<div class="post-metadata">

**Author:** ![woodstone](https://avatars.discourse-cdn.com/v4/letter/w/71e660/32.png) [@woodstone](https://forum.shopware.com/u/woodstone)\
**Post date:** [19. Juni 2015 um 18:16 UTC](https://forum.shopware.com/t/gelost-shopware5-rc2-pluginmanager-communication-failure/26172/7 "2015-06-19T18:16:07Z")

</div>

bei mir gibt es den gleichen Fehler, kannst du bitte genauer sagen, was du geändert hast? was meinst du mit “Es lag an der deaktivierten PHP-Funktion curl\_multi\_exec, die in Shopware 5 durch die guzzlehttp library in /vendor/guzzlehttp/ringphp/src/Client/CurlMultiHandler.php benötigt wird”?

---

<div class="post-metadata">

**Author:** ![Falko](https://avatars.discourse-cdn.com/v4/letter/f/9de0a6/32.png) [@Falko](https://forum.shopware.com/u/Falko)\
**Post date:** [22. Juni 2015 um 09:59 UTC](https://forum.shopware.com/t/gelost-shopware5-rc2-pluginmanager-communication-failure/26172/8 "2015-06-22T09:59:27Z")

</div>

In Shopware5 wird die Bibliothek Guzzle verwendet, die in der o.g. genannten PHP-Klasse die PHP-Funktion “curl\_multi\_exec” verwendet (siehe auch hier: [https://github.com/guzzle/RingPHP/blob/ … andler.php](https://github.com/guzzle/RingPHP/blob/master/src/Client/CurlMultiHandler.php)). Diese Funktion war allerdings in unserer php.ini deaktiviert ([http://php.net/manual/de/ini.core.php#i … -functions](http://php.net/manual/de/ini.core.php#ini.disable-functions)) und so kam es wohl zu dem angezeigten Fehler im Shopware-Backend. Durch Anpassen der disable-functions war der Fehler behoben.

---

<div class="post-metadata">

**Author:** ![fogyhouse](https://avatars.discourse-cdn.com/v4/letter/f/848f3c/32.png) [@fogyhouse](https://forum.shopware.com/u/fogyhouse)\
**Post date:** [23. Juni 2015 um 13:08 UTC](https://forum.shopware.com/t/gelost-shopware5-rc2-pluginmanager-communication-failure/26172/9 "2015-06-23T13:08:27Z")

</div>

[quote=“Falko”]Danke für eure Unterstützung. Es lag an der deaktivierten PHP-Funktion curl\_multi\_exec, die in Shopware 5 durch die guzzlehttp library in /vendor/guzzlehttp/ringphp/src/Client/CurlMultiHandler.php benötigt wird.[/quote] Vielen dank für die Lösung. @Shopware: Wir hätten uns viel Zeit gespart, wenn bei der Installation die korrekte Einstellung überprüft worden wäre. Danke fogyhouse imc
