# \[GELÖST\] Seo-Urls für Produktdetailseiten fehlerhaft

**URL:** https://forum.shopware.com/t/gelost-seo-urls-fur-produktdetailseiten-fehlerhaft/8395
**Category:** Shopware 3.5
**Tags:** general
**Created:** [4. September 2012 um 13:36 UTC](https://forum.shopware.com/t/gelost-seo-urls-fur-produktdetailseiten-fehlerhaft/8395 "2012-09-04T13:36:13Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![derKra](https://avatars.discourse-cdn.com/v4/letter/d/8491ac/32.png) [@derKra](https://forum.shopware.com/u/derKra)
#### Post date: [4. September 2012 um 13:36 UTC](https://forum.shopware.com/t/gelost-seo-urls-fur-produktdetailseiten-fehlerhaft/8395/1 "2012-09-04T13:36:13Z")

</div>

Die Einträge in der Datenbank werden Case-Sensitiv angelegt, im Frontend werden die Links in Lowercase angezeigt. Komischerweise funktionieren die Links nur teilweise. Beispiel: my.host/desktop-pc/barebones/media/intel/8646/shuttle-xpc-x50v3-schwarz-39-6cm-15-6-touchscreen?c=720 (SW-Frontendlink, geht nicht, 404) my.host/Desktop-PC/Barebones/Media/Intel/8646/Shuttle-XPC-X50V3-schwarz-39-6cm-15-6-Touchscreen?c=720 (Gegenprobe mit Datenbankeintrag, geht) (Die Tabelle „s\_core\_rewrite\_urls“ ist komplett generiert) Der Ansatz der Url-Generierung ist nicht praktikabel, da hier anscheinend nach Löschen des Caches die Urls pro Frontendrequest nur in 1000er Häpchen generiert werden (php\_ini max\_execution\_time …). Wenn der Shop 10.000 Artikel hat, ist dies ein Problem. Bug? Gruß, Boris

---

<div class="post-metadata">

### Author: ![Heiner\_Lohaus](https://avatars.discourse-cdn.com/v4/letter/h/b5a626/32.png) [@Heiner\_Lohaus](https://forum.shopware.com/u/Heiner_Lohaus)
#### Post date: [5. September 2012 um 11:49 UTC](https://forum.shopware.com/t/gelost-seo-urls-fur-produktdetailseiten-fehlerhaft/8395/2 "2012-09-05T11:49:17Z")

</div>

Hi Boris, um das Problem mit den fehlerhaften SEO-Urls zu lösen, müsstest du einmal in der .htaccess-Datei diese Zeile: RewriteCond %{REQUEST\_URI} !(/(engine|files|templates|media/[a-z]+)/) Durch diese beiden Zeilen ersetzten: RewriteCond %{REQUEST\_URI} !(/(engine|files|templates)/) RewriteCond %{REQUEST\_URI} !(/media/.\*.\w{3}$) Das mit den 1000-Urls pro Request sollte eigentlich doch kein Problem sein, da neue Urls immer sofort erzeugt werden. Den Cache leeren sollte man nur, wenn man z.B. Kategorien umbennent oder verschiebt. Heiner

---

<div class="post-metadata">

### Author: ![derKra](https://avatars.discourse-cdn.com/v4/letter/d/8491ac/32.png) [@derKra](https://forum.shopware.com/u/derKra)
#### Post date: [5. September 2012 um 15:58 UTC](https://forum.shopware.com/t/gelost-seo-urls-fur-produktdetailseiten-fehlerhaft/8395/3 "2012-09-05T15:58:31Z")

</div>

Hallo Heiner, danke für die Antwort. Böse Falle. Ich denke, folgende Änderung wäre noch effektiver: RewriteCond %{REQUEST\_URI} !(/(engine|files|templates|media/[a-z]+)/) ersetzen mit: RewriteCond %{REQUEST\_URI} !(^/(engine|files|templates|media/[a-z]+)/) Damit wirkt sich die Ausnahmeregel nur auf das erste Pfadsegment aus. Der (unwahrscheinliche) Konflikt (mit Kategorie oder CMS-Seite) würde damit nur dort passieren. Grüße, Boris
