# \[GELÖST\] PHP-Fehler nach Löschen der Standard-Kategorien

**URL:** <https://forum.shopware.com/t/gelost-php-fehler-nach-loschen-der-standard-kategorien/8198>\
**Category:** Shopware 3.5\
**Tags:** general\
**Created:** [28. August 2012 um 23:20 UTC](https://forum.shopware.com/t/gelost-php-fehler-nach-loschen-der-standard-kategorien/8198 "2012-08-28T23:20:06Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![mac.u](https://avatars.discourse-cdn.com/v4/letter/m/8e8cbc/32.png) [@mac.u](https://forum.shopware.com/u/mac.u)\
**Post date:** [28. August 2012 um 23:20 UTC](https://forum.shopware.com/t/gelost-php-fehler-nach-loschen-der-standard-kategorien/8198/1 "2012-08-28T23:20:06Z")

</div>

Einen wunderschönen guten Abend. Ich habe heute die neue Version von Shopware installiert und bin soweit auch sehr zufrieden. Nun habe ich jedoch begonnen, erste Artikel anzulegen und die Standard-Kategorien zu löschen und durch neue zu ersetzen. Nach dem Löschen des Caches erhalte ich nun im Frontend nur noch eine Fehlermeldung und weiß leider nicht, wie ich diese beheben soll. [quote]Fatal error: Uncaught exception ‘Doctrine\ORM\EntityNotFoundException’ with message ‘Entity was not found.’ in xxx/engine/Shopware/Proxies/\_\_CG\_\_ShopwareModelsCategoryCategory.php:32 Stack trace: #0 xxx/engine/Shopware/Proxies/\_\_CG\_\_ShopwareModelsCategoryCategory.php(92): Shopware\Proxies\_\_CG\_\_\Shopware\Models\Category\Category-\>\_\_load() #1 xxx/engine/Shopware/Models/Category/Repository.php(297): Shopware\Proxies\_\_CG\_\_\Shopware\Models\Category\Category-\>getLeft() #2 xxx/engine/core/class/sRewriteTable.php(215): Shopware\Models\Category\Repository-\>getActiveChildrenByIdQuery(3) #3 xxx/engine/core/class/sRewriteTable.php(137): sRewriteTable-\>sCreateRewriteTableCategories() #4 xxx/engine/Shopware/Plugins/Default/Frontend/RouterRewrite/Bootstrap.php(177): sRe in xxx/engine/Shopware/Proxies/\_\_CG\_\_ShopwareModelsCategoryCategory.php on line 32[/quote] Eventuell kann mir jemand helfen? Grüße, S.

---

<div class="post-metadata">

**Author:** ![mac.u](https://avatars.discourse-cdn.com/v4/letter/m/8e8cbc/32.png) [@mac.u](https://forum.shopware.com/u/mac.u)\
**Post date:** [28. August 2012 um 23:42 UTC](https://forum.shopware.com/t/gelost-php-fehler-nach-loschen-der-standard-kategorien/8198/2 "2012-08-28T23:42:44Z")

</div>

Habe das Problem selbst gelöst. Lösung ist, dass man in den Grundeinstellungen \> Shopeinstellungen \> Shops bei “Kategorie” einen Eintrag neu festlegen muss. Ist dieser nicht gesetzt, wird dieser Fehler geworfen. Eventuell anzudenken als Fix für eine kommende Version ;). Grüße, S.
