# \[Gelöst\] Nicht existende URL bringt Fehlermeldung statt Weiterleitung

**URL:** https://forum.shopware.com/t/gelost-nicht-existende-url-bringt-fehlermeldung-statt-weiterleitung/56341
**Category:** Allgemein
**Created:** [9. November 2018 um 12:09 UTC](https://forum.shopware.com/t/gelost-nicht-existende-url-bringt-fehlermeldung-statt-weiterleitung/56341 "2018-11-09T12:09:29Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![robjke1](https://avatars.discourse-cdn.com/v4/letter/r/71c47a/32.png) [@robjke1](https://forum.shopware.com/u/robjke1)
#### Post date: [9. November 2018 um 12:09 UTC](https://forum.shopware.com/t/gelost-nicht-existende-url-bringt-fehlermeldung-statt-weiterleitung/56341/1 "2018-11-09T12:09:29Z")

</div>

Moin,

&nbsp;

Wenn ich eine nicht existierende URL aufrufe, z.b. [meinshop.de/gdsaklygnsd](http://meinshop.de/gdsaklygnsd) wird mir ein Fatal Error ausgegeben der mir sagt der Controller existiere nicht, anstatt auf eine 404 oder Startseite weiterzuleiten.

Irgendjemand ne Idee wie das zu fixen ist?

Shopware Version: 5.5.3

---

<div class="post-metadata">

### Author: ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)
#### Post date: [9. November 2018 um 12:41 UTC](https://forum.shopware.com/t/gelost-nicht-existende-url-bringt-fehlermeldung-statt-weiterleitung/56341/2 "2018-11-09T12:41:48Z")

</div>

Ja, du musst die Fehlerausgabe in der config.php wieder deaktivieren, die setzt das Errorhandling außer kraft, was bspw. die 404-Fehler behandelt.

---

<div class="post-metadata">

### Author: ![robjke1](https://avatars.discourse-cdn.com/v4/letter/r/71c47a/32.png) [@robjke1](https://forum.shopware.com/u/robjke1)
#### Post date: [9. November 2018 um 14:26 UTC](https://forum.shopware.com/t/gelost-nicht-existende-url-bringt-fehlermeldung-statt-weiterleitung/56341/3 "2018-11-09T14:26:19Z")

</div>

Ok man sollte nachdem man die debugs aus der config raus hat noch folgendes machen:

- HTTP-Cache neu aufwärmen

- SEO Index neu aufbauen

- nochmal alle Caches löschen

&nbsp;

Dann funtzt es, danke

---

<div class="post-metadata">

### Author: ![sonic](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sonic/32/25728_2.png) [@sonic](https://forum.shopware.com/u/sonic)
#### Post date: [9. November 2018 um 14:31 UTC](https://forum.shopware.com/t/gelost-nicht-existende-url-bringt-fehlermeldung-statt-weiterleitung/56341/4 "2018-11-09T14:31:55Z")

</div>

In der Reihenfolge recht sinnfrei…  
Erst “Cache aufwärmen”, um ihn danach wieder zu löschen?  
Ausserdem sollte man die SEO-Urls VOR dem “Cache aufwärmen” generieren, sonst landen ja erst wieder die alten Urls im Cache… aber der wird ja am Ende wieder gelöscht&nbsp;   
&nbsp;
