# \[GELÖST\] Fehlermeldung in Front- &amp; Backend

**URL:** <https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373>\
**Category:** Shopware 3.5\
**Tags:** administration\
**Created:** [20. September 2011 um 21:51 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373 "2011-09-20T21:51:11Z")\
**Posts on this page:** 18\
**Page:** 1

<div class="post-metadata">

**Author:** ![MINALO](https://avatars.discourse-cdn.com/v4/letter/m/87869e/32.png) [@MINALO](https://forum.shopware.com/u/MINALO)\
**Post date:** [20. September 2011 um 21:51 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/1 "2011-09-20T21:51:11Z")

</div>

Hi habe diese Fehlermeldung plötzlich. Was kann ich darunter verstehen und was muss ich machen? :shock: [quote]Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. SQLSTATE[HY000] [2003] Can’t connect to MySQL server on ‚[minalo.de](http://minalo.de)‘ (13) in Vendor/Zend/library/Zend/Db/Adapter/Pdo/Abstract.php on line 144 Stack trace: #0 Vendor/Zend/library/Zend/Db/Adapter/Pdo/Mysql.php(96): Zend\_Db\_Adapter\_Pdo\_Abstract-\>\_connect() #1 Vendor/Zend/library/Zend/Db/Adapter/Abstract.php(315): Zend\_Db\_Adapter\_Pdo\_Mysql-\>\_connect() #2 Shopware/Bootstrap.php(84): Zend\_Db\_Adapter\_Abstract-\>getConnection() #3 [internal function]: Shopware\_Bootstrap-\>initDb() #4 Enlight/Bootstrap.php(182): call\_user\_func(Array) #5 Shopware/Bootstrap.php(22): Enlight\_Bootstrap-\>loadResource(‚Db‘) #6 Enlight/Application.php(86): Shopware\_Bootstrap-\>run() #7 shopware.php(6): Enlight\_Application-\>run() #8 {main} [/quote] Danke schon voraus… //edit: Ich habe das Thema „Was bedeutet diese fehlermeldung?“ mit diesen Thema zusammengeführt, da die Fehlermeldung 1:1 identisch ist. Viele Grüße, Stephan Pohl :shopware:

---

<div class="post-metadata">

**Author:** ![MINALO](https://avatars.discourse-cdn.com/v4/letter/m/87869e/32.png) [@MINALO](https://forum.shopware.com/u/MINALO)\
**Post date:** [21. September 2011 um 13:41 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/2 "2011-09-21T13:41:15Z")

</div>

hilfffeeee wir sind geblockt der hister sagt das ist ein fehler unser seits ist???

---

<div class="post-metadata">

**Author:** ![MINALO](https://avatars.discourse-cdn.com/v4/letter/m/87869e/32.png) [@MINALO](https://forum.shopware.com/u/MINALO)\
**Post date:** [21. September 2011 um 13:57 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/3 "2011-09-21T13:57:39Z")

</div>

hi was bedeutet diese meldung und was muss ich machen? diese erscheint in front und backend [quote]Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. SQLSTATE[HY000] [2003] Can’t connect to MySQL server on ‚[minalo.de](http://minalo.de)‘ (13) in Vendor/Zend/library/Zend/Db/Adapter/Pdo/Abstract.php on line 144 Stack trace: #0 Vendor/Zend/library/Zend/Db/Adapter/Pdo/Mysql.php(96): Zend\_Db\_Adapter\_Pdo\_Abstract-\>\_connect() #1 Vendor/Zend/library/Zend/Db/Adapter/Abstract.php(315): Zend\_Db\_Adapter\_Pdo\_Mysql-\>\_connect() #2 Shopware/Bootstrap.php(84): Zend\_Db\_Adapter\_Abstract-\>getConnection() #3 [internal function]: Shopware\_Bootstrap-\>initDb() #4 Enlight/Bootstrap.php(182): call\_user\_func(Array) #5 Shopware/Bootstrap.php(22): Enlight\_Bootstrap-\>loadResource(‚Db‘) #6 Enlight/Application.php(86): Shopware\_Bootstrap-\>run() #7 shopware.php(6): Enlight\_Application-\>run() #8 {main} [/quote]

---

<div class="post-metadata">

**Author:** ![Bibeno](https://avatars.discourse-cdn.com/v4/letter/b/13edae/32.png) [@Bibeno](https://forum.shopware.com/u/Bibeno)\
**Post date:** [21. September 2011 um 14:07 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/4 "2011-09-21T14:07:45Z")

</div>

Ist nicht mein Fachgebiet, aber viell. liege ich richtig. Sicher das du bei der Datenbankverbindung [minalo.de](http://minalo.de) angeben musst als server und nicht localhost Sorryy, wenn es falsch ist.

---

<div class="post-metadata">

**Author:** ![MINALO](https://avatars.discourse-cdn.com/v4/letter/m/87869e/32.png) [@MINALO](https://forum.shopware.com/u/MINALO)\
**Post date:** [21. September 2011 um 14:14 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/5 "2011-09-21T14:14:50Z")

</div>

ja nur wo soll ich das eingeben in config.php ist alles richtig drin und hatte ja auch schon mal alles funtuniert und das steht in zeile 144 hoffe das die richtige datei ist: `throw new Zend\_Db\_Adapter\_Exception($e-\>getMessage(), $e-\>getCode(), $e);`

---

<div class="post-metadata">

**Author:** ![Stefan\_Hamann](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@Stefan\_Hamann](https://forum.shopware.com/u/Stefan_Hamann)\
**Post date:** [21. September 2011 um 14:35 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/6 "2011-09-21T14:35:23Z")

</div>

Ja und warum seit ihr geblockt?!

---

<div class="post-metadata">

**Author:** ![MINALO](https://avatars.discourse-cdn.com/v4/letter/m/87869e/32.png) [@MINALO](https://forum.shopware.com/u/MINALO)\
**Post date:** [21. September 2011 um 14:40 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/7 "2011-09-21T14:40:19Z")

</div>

geblockt? wie wo geblockt?

---

<div class="post-metadata">

**Author:** ![Stefan\_Hamann](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@Stefan\_Hamann](https://forum.shopware.com/u/Stefan_Hamann)\
**Post date:** [21. September 2011 um 14:44 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/8 "2011-09-21T14:44:28Z")

</div>

[quote] wir sind geblockt der hister sagt das ist ein fehler unser seits ist??? [/quote] Das hast du doch geschrieben? Der Fehler besagt, dass keine Verbindung zur MySQL-Datenbank hergestellt werden kann. Die Verbindungsdaten stehen in der config.php - da muss also entweder dort ein Tippfehler etc. vorhanden sein, oder falls ihr definitiv nichts verändert habt, ist definitiv der Hoster Schuld (Es sei denn, Ihr habt dort einen Root-Server, wo Ihr euch selbst um die Wartung kümmert!)

---

<div class="post-metadata">

**Author:** ![MINALO](https://avatars.discourse-cdn.com/v4/letter/m/87869e/32.png) [@MINALO](https://forum.shopware.com/u/MINALO)\
**Post date:** [21. September 2011 um 14:48 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/9 "2011-09-21T14:48:09Z")

</div>

achso mit geblockt meinte ich das wir nicht mehr weiter arbeiten können der hoster hat gesagt ich soll bei shopware nachfragen weil sie damit nichts zutun haben in die datenbank komme ich rein und in config.php sind die zugangsdaten richtig wir haben ja nichts geändert nachdem der hoster ein backup eingespielt hat kam diese meldung.

---

<div class="post-metadata">

**Author:** ![Stefan\_Hamann](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@Stefan\_Hamann](https://forum.shopware.com/u/Stefan_Hamann)\
**Post date:** [21. September 2011 um 14:57 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/10 "2011-09-21T14:57:37Z")

</div>

Die Daten in der config.php müssen aber falsch sein - wenn der ein Backup eingespielt hat, ist ja ggf. auch eine ältere Version der config.php mit reingerutscht. Ansonsten führe mal folgendes Test-Script unten in die config.php ein und berichte über das Ergebnis: ` $conn = mysql\_connect($DB\_HOST,$DB\_USER,$DB\_PASSWORD); if (!$conn) echo mysql\_error(); mysql\_select\_db($DB\_DATABASE); echo mysql\_error(); exit; `

---

<div class="post-metadata">

**Author:** ![MINALO](https://avatars.discourse-cdn.com/v4/letter/m/87869e/32.png) [@MINALO](https://forum.shopware.com/u/MINALO)\
**Post date:** [21. September 2011 um 15:13 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/11 "2011-09-21T15:13:36Z")

</div>

da kommt die meldung hier [quote] Can’t connect to MySQL server on ‘[minalo.de](http://minalo.de)’ (13)Access denied for user ‘apache’@‘localhost’ (using password: NO) [/quote]

---

<div class="post-metadata">

**Author:** ![Stefan\_Hamann](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@Stefan\_Hamann](https://forum.shopware.com/u/Stefan_Hamann)\
**Post date:** [21. September 2011 um 15:24 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/12 "2011-09-21T15:24:12Z")

</div>

Bitte schick mir mal den Inhalt deiner config.php per eMail an [forum@shopware.de](mailto:forum@shopware.de) - steht da überhaupt oben was drin in den Variablen? Scheint ja nicht so…

---

<div class="post-metadata">

**Author:** ![MINALO](https://avatars.discourse-cdn.com/v4/letter/m/87869e/32.png) [@MINALO](https://forum.shopware.com/u/MINALO)\
**Post date:** [21. September 2011 um 15:28 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/13 "2011-09-21T15:28:28Z")

</div>

conig.php ist per mail raus…

---

<div class="post-metadata">

**Author:** ![Stefan\_Hamann](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@Stefan\_Hamann](https://forum.shopware.com/u/Stefan_Hamann)\
**Post date:** [21. September 2011 um 15:39 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/14 "2011-09-21T15:39:17Z")

</div>

Trag mal bei DB\_HOST einfach localhost ein, statt [minalo.de](http://minalo.de) - ansonsten muss wirklich der Hoster nochmal gucken - da scheint dann ein generelles Problem mit dem SQL-Server zu bestehen.

---

<div class="post-metadata">

**Author:** ![MINALO](https://avatars.discourse-cdn.com/v4/letter/m/87869e/32.png) [@MINALO](https://forum.shopware.com/u/MINALO)\
**Post date:** [21. September 2011 um 15:41 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/15 "2011-09-21T15:41:54Z")

</div>

ja jetzt geht es hat es jetzt aber nachteile wenn da localhost steht und nicht [minalo.de](http://minalo.de)?

---

<div class="post-metadata">

**Author:** ![tschersich](https://avatars.discourse-cdn.com/v4/letter/t/a9adbd/32.png) [@tschersich](https://forum.shopware.com/u/tschersich)\
**Post date:** [21. September 2011 um 15:58 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/16 "2011-09-21T15:58:20Z")

</div>

Nein, keine. Ganz im Gegenteil. Der User darf MySQL-seitig nur über localhost zugreifen. Das ist gut, denn das lokale PHP greift nur lokal auf MySQL zu und mehr sollte auch nicht gehen.

---

<div class="post-metadata">

**Author:** ![MINALO](https://avatars.discourse-cdn.com/v4/letter/m/87869e/32.png) [@MINALO](https://forum.shopware.com/u/MINALO)\
**Post date:** [21. September 2011 um 16:01 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/17 "2011-09-21T16:01:59Z")

</div>

ok super danke… :shopware: :thumbup:

---

<div class="post-metadata">

**Author:** ![Bibeno](https://avatars.discourse-cdn.com/v4/letter/b/13edae/32.png) [@Bibeno](https://forum.shopware.com/u/Bibeno)\
**Post date:** [21. September 2011 um 16:07 UTC](https://forum.shopware.com/t/gelost-fehlermeldung-in-front-amp-backend/4373/18 "2011-09-21T16:07:49Z")

</div>

[quote=„Stefan Hamann“]Trag mal bei DB\_HOST einfach localhost ein, statt [minalo.de](http://minalo.de) - ansonsten muss wirklich der Hoster nochmal gucken - da scheint dann ein generelles Problem mit dem SQL-Server zu bestehen.[/quote] Ach, hatte ich ja doch mal recht.lach
