# \[GELÖST\] Fehler nach Serverumzug

**URL:** https://forum.shopware.com/t/gelost-fehler-nach-serverumzug/11042
**Category:** Shopware 3.5
**Tags:** installation--gettin
**Created:** [17. Januar 2013 um 21:10 UTC](https://forum.shopware.com/t/gelost-fehler-nach-serverumzug/11042 "2013-01-17T21:10:12Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![sm-team](https://avatars.discourse-cdn.com/v4/letter/s/a9adbd/32.png) [@sm-team](https://forum.shopware.com/u/sm-team)
#### Post date: [17. Januar 2013 um 21:10 UTC](https://forum.shopware.com/t/gelost-fehler-nach-serverumzug/11042/1 "2013-01-17T21:10:12Z")

</div>

Sehr geehrtes Team, nach Serverumzug kommt ein Fehler beim Aufruf unseres Shops. Eigentlich habe ich so ziemlich alle Einstellungen von dem alten Server übernommen. Was mir aufgefallen ist, das er in dem Fehler den alten Server erwähnt. Mit XXXXX habe ich den alten Server markiert und mit YYYYY den neuen. Die Domain wurde jedoch soweit ich es sehe ordnungsgemäß übernommen Laut verschiedenen Foren kann es mit irgendwelche Zugriffsrechten von PHP zu tun. Zugriffsrechte von Ordner des Shops habe ich grob durchgeschaut. BITTE UM HILFE!!! FEHLER: Warning: is\_readable(): open\_basedir restriction in effect. File(/var/www/vhosts/XXXXXXXXXXXXX/httpdocs/testumgebung/engine/Library/Enlight/Controller/Front.php) is not within the allowed path(s): (/var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/:/tmp/) in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php on line 220 Warning: is\_readable(): open\_basedir restriction in effect. File(/var/www/vhosts/XXXXXXXXXXXXX/httpdocs/testumgebung/engine/Shopware/Proxies/EnlightControllerFrontProxy.php) is not within the allowed path(s): (/var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/:/tmp/) in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php on line 220 Warning: is\_readable(): open\_basedir restriction in effect. File(/var/www/vhosts/XXXXXXXXXXXXX/httpdocs/testumgebung/engine/Library/Enlight/Controller/Dispatcher/Default.php) is not within the allowed path(s): (/var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/:/tmp/) in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php on line 220 Warning: is\_readable(): open\_basedir restriction in effect. File(/var/www/vhosts/XXXXXXXXXXXXX/httpdocs/testumgebung/engine/Library/Zend/Db/Table/Abstract.php) is not within the allowed path(s): (/var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/:/tmp/) in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php on line 220 Warning: is\_readable(): open\_basedir restriction in effect. File(/var/www/vhosts/XXXXXXXXXXXXX/httpdocs/testumgebung/engine/Library/Enlight/Components/Db.php) is not within the allowed path(s): (/var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/:/tmp/) in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php on line 220 Warning: is\_readable(): open\_basedir restriction in effect. File(/var/www/vhosts/XXXXXXXXXXXXX/httpdocs/testumgebung/engine/Library/Enlight/Components/Db/Adapter/Pdo/Mysql.php) is not within the allowed path(s): (/var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/:/tmp/) in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php on line 220 Warning: is\_readable(): open\_basedir restriction in effect. File(/var/www/vhosts/XXXXXXXXXXXXX/httpdocs/testumgebung/engine/Library/Zend/Db/Profiler.php) is not within the allowed path(s): (/var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/:/tmp/) in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php on line 220 Warning: is\_readable(): open\_basedir restriction in effect. File(/var/www/vhosts/XXXXXXXXXXXXX/httpdocs/testumgebung/engine/Library/Zend/Cache.php) is not within the allowed path(s): (/var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/:/tmp/) in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php on line 220 Warning: is\_readable(): open\_basedir restriction in effect. File(/var/www/vhosts/XXXXXXXXXXXXX/httpdocs/testumgebung/engine/Library/Zend/Locale/Data.php) is not within the allowed path(s): (/var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/:/tmp/) in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php on line 220 Warning: is\_readable(): open\_basedir restriction in effect. File(/var/www/vhosts/XXXXXXXXXXXXX/httpdocs/testumgebung/engine/Shopware/Components/Plugin/Namespace.php) is not within the allowed path(s): (/var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/:/tmp/) in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php on line 220 Warning: is\_readable(): open\_basedir restriction in effect. File(/var/www/vhosts/XXXXXXXXXXXXX/httpdocs/testumgebung/engine/Library/Enlight/Event/Subscriber/Plugin.php) is not within the allowed path(s): (/var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/:/tmp/) in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php on line 220 Warning: is\_readable(): open\_basedir restriction in effect. File(/var/www/vhosts/XXXXXXXXXXXXX/httpdocs/testumgebung/engine/Library/Enlight/Config.php) is not within the allowed path(s): (/var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/:/tmp/) in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php on line 220 Warning: is\_readable(): open\_basedir restriction in effect. File(/var/www/vhosts/XXXXXXXXXXXXX/httpdocs/testumgebung/engine/Library/Enlight/Event/Handler/Plugin.php) is not within the allowed path(s): (/var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/:/tmp/) in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php on line 220 Warning: is\_readable(): open\_basedir restriction in effect. File(/var/www/vhosts/XXXXXXXXXXXXX/httpdocs/testumgebung/engine/Library/Enlight/Plugin/Namespace/Loader.php) is not within the allowed path(s): (/var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/:/tmp/) in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php on line 220 Warning: is\_readable(): open\_basedir restriction in effect. File(/var/www/vhosts/XXXXXXXXXXXXX/httpdocs/testumgebung/engine/Library/Enlight/Controller/Response/ResponseHttp.php) is not within the allowed path(s): (/var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/:/tmp/) in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php on line 220 Fatal error: Uncaught exception ‘Zend\_Controller\_Response\_Exception’ with message ‘Cannot send headers; headers already sent in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Loader.php, line 220’ in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Zend/Controller/Response/Abstract.php:323 Stack trace: #0 /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Zend/Controller/Response/Abstract.php(115): Zend\_Controller\_Response\_Abstract-\>canSendHeaders(true) #1 /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Shopware/Bootstrap.php(78): Zend\_Controller\_Response\_Abstract-\>setHeader(‘Content-Type’, ‘text/html; char…’) #2 /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Enlight/Application.php(192): Shopware\_Bootstrap-\>run() #3 /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/s in /var/www/vhosts/YYYYYYYYYY/httpdocs/testumgebung/engine/Library/Zend/Controller/Response/Abstract.php on line 323

---

<div class="post-metadata">

### Author: ![datema](https://avatars.discourse-cdn.com/v4/letter/d/4bbf92/32.png) [@datema](https://forum.shopware.com/u/datema)
#### Post date: [17. Januar 2013 um 22:14 UTC](https://forum.shopware.com/t/gelost-fehler-nach-serverumzug/11042/2 "2013-01-17T22:14:20Z")

</div>

vielleicht hilf dir das: [post52104.html#p52104](http://forum.shopware.de/post52104.html#p52104) [quote]Es geht tatsächlich. Ich glaube entscheidend war das Löschen des Caches bzw. dem Inhalt von /engine/Shopware/Models/Attribute/ /engine/Shopware/Proxies[/quote]

---

<div class="post-metadata">

### Author: ![sm-team](https://avatars.discourse-cdn.com/v4/letter/s/a9adbd/32.png) [@sm-team](https://forum.shopware.com/u/sm-team)
#### Post date: [18. Januar 2013 um 10:15 UTC](https://forum.shopware.com/t/gelost-fehler-nach-serverumzug/11042/3 "2013-01-18T10:15:50Z")

</div>

Vielen vielen Dank!!! Eine Server-Umzug-Gebrauchsanweisung an alle die nicht weiterkommen: Also Cache löschen, DB exportieren, Shop-Verzeichnis kopieren, DB importieren, ggf. config.php anpassen und bei Bedarf im Backend (oder in der Datenbank direkt) die neue Shopurl anpassen. Den Inhalt aus folgenden Ordnern löschen: /engine/Shopware/Models/Attribute/ /engine/Shopware/Proxies Gruß
