# \[gelöst\] Fehler mit Elastic Search // im Frontend sind weniger Artikel sichtbar als im Backend fr...

**URL:** <https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047>\
**Category:** Programmierung\
**Created:** [6. April 2017 um 11:15 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047 "2017-04-06T11:15:45Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![SYNERGY\_NETWORKS](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@SYNERGY\_NETWORKS](https://forum.shopware.com/u/SYNERGY_NETWORKS)\
**Post date:** [6. April 2017 um 11:15 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/1 "2017-04-06T11:15:45Z")

</div>

Wir haben das Problem das 48 Artikel im Backend freigegeben wurden für eine Kategorie. Im Frontend kommen aber nur 38 Artikel in der Kategorie an.

Neu indexieren etc. haben wir alles schon probiert. Support von Shopware erhält man leider nur ab aktuellem Enterprise Kundenstatus - hier haben wir vergebens schon nachgefragt.

Das Verhalten viel auch erst auf als neue Artikel angelegt wurden und diese einfach nicht sichtbar waren im Frontend. Auch ältere Artikel sind nicht zu sehen, das konnten wir nun auch schon rausfinden. Warum das allerdings so ist, ist absolut unklar. Da nirgends ein Fehler erscheint.

Hat jemand dies bei sich schon feststellen können und ggf. das Problem lösen können?!

**Im Einsatz ist aktuell:**

- Shopware 5.2.21PE+
- Elastic Search 2.4.4

VG

---

<div class="post-metadata">

**Author:** ![Thomas](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/thomas/32/8167_2.png) [@Thomas](https://forum.shopware.com/u/Thomas)\
**Post date:** [6. April 2017 um 12:18 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/2 "2017-04-06T12:18:18Z")

</div>

> **Im Einsatz ist aktuell:**
> 
> - Shopware 5.2.21PE+
> - Elastic Search 2.4.4

Besteht die Möglichkeit Elastic Search 5.\* auszuprobieren?&nbsp;

---

<div class="post-metadata">

**Author:** ![SYNERGY\_NETWORKS](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@SYNERGY\_NETWORKS](https://forum.shopware.com/u/SYNERGY_NETWORKS)\
**Post date:** [6. April 2017 um 12:24 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/3 "2017-04-06T12:24:37Z")

</div>

Hi Thomas,

schon probiert - das kann aber Shopware akuell noch nicht.

---

<div class="post-metadata">

**Author:** ![SYNERGY\_NETWORKS](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@SYNERGY\_NETWORKS](https://forum.shopware.com/u/SYNERGY_NETWORKS)\
**Post date:** [6. April 2017 um 12:25 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/4 "2017-04-06T12:25:40Z")

</div>

Wenn man in einer lokalen Testumgebung die gleichen Parameter einstellt und ES installiert hat dann funktioniert es.

Sobald aber der ES Server extern liegt gehts nicht mehr. Das habe ich gerade einmal ausprobiert.

---

<div class="post-metadata">

**Author:** ![SYNERGY\_NETWORKS](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@SYNERGY\_NETWORKS](https://forum.shopware.com/u/SYNERGY_NETWORKS)\
**Post date:** [6. April 2017 um 12:27 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/5 "2017-04-06T12:27:00Z")

</div>

Gibts denn bei euch ein Feedback wenn ihr sw:es:backlog:sync ausführt?! Kommt da irgendwas… ? Sowas wie 10 Article aktualisiert o.ä. ?!

---

<div class="post-metadata">

**Author:** ![Thomas](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/thomas/32/8167_2.png) [@Thomas](https://forum.shopware.com/u/Thomas)\
**Post date:** [6. April 2017 um 12:34 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/6 "2017-04-06T12:34:04Z")

</div>

> [@SYNERGY NETWORKS schrieb:](https://forum.shopware.com/profile/7781/SYNERGY%20NETWORKS "SYNERGY%20NETWORKS")
> 
> Gibts denn bei euch ein Feedback wenn ihr sw:es:backlog:sync ausführt?! Kommt da irgendwas… ? Sowas wie 10 Article aktualisiert o.ä. ?!

Das synchronisiert ja nur die Backlog Items nach dem Du einmal ein populate gemacht hast.

Was passiert wenn Du ein&nbsp;

```
 sw:es:index:populate

```

&nbsp;machst?

---

<div class="post-metadata">

**Author:** ![Thomas](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/thomas/32/8167_2.png) [@Thomas](https://forum.shopware.com/u/Thomas)\
**Post date:** [6. April 2017 um 12:37 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/7 "2017-04-06T12:37:18Z")

</div>

> [@SYNERGY NETWORKS schrieb:](https://forum.shopware.com/profile/7781/SYNERGY%20NETWORKS "SYNERGY%20NETWORKS")
> 
> Sobald aber der ES Server extern liegt gehts nicht mehr. Das habe ich gerade einmal ausprobiert.

Völliger quatsch - das funktioniert hier im Cluster Setup &nbsp;einwandfrei mit Elastic Search 5 und Zugriff via remote

```
{
  "name" : "es-1",
  "cluster_name" : "es",
  "cluster_uuid" : "***",
  "version" : {
    "number" : "5.1.2",
    "build_hash" : "***",
    "build_date" : "***",
    "build_snapshot" : false,
    "lucene_version" : "6.3.0"
  },
  "tagline" : "You Know, for Search"
}

```

&nbsp;

---

<div class="post-metadata">

**Author:** ![SYNERGY\_NETWORKS](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@SYNERGY\_NETWORKS](https://forum.shopware.com/u/SYNERGY_NETWORKS)\
**Post date:** [6. April 2017 um 12:41 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/8 "2017-04-06T12:41:04Z")

</div>

> [@Thomas schrieb:](https://forum.shopware.com/profile/16897/Thomas "Thomas")
> 
> > [@SYNERGY NETWORKS schrieb:](https://forum.shopware.com/profile/7781/SYNERGY%20NETWORKS "SYNERGY%20NETWORKS")
> > 
> > Gibts denn bei euch ein Feedback wenn ihr sw:es:backlog:sync ausführt?! Kommt da irgendwas… ? Sowas wie 10 Article aktualisiert o.ä. ?!
> 
> Das synchronisiert ja nur die Backlog Items nach dem Du einmal ein populate gemacht hast.
> 
> Was passiert wenn Du ein&nbsp;
> 
> sw:es:index:populate
> 
> &nbsp;machst?

dann kommt das hier dabei raus:

## Indexing shop .de-DE

Indexing properties  
&nbsp;43/43 [============================] 100% \< 1 sec/\< 1 sec  
Indexing products  
&nbsp;59/59 [============================] 100% \< 1 sec/\< 1 sec

&nbsp;

---

<div class="post-metadata">

**Author:** ![SYNERGY\_NETWORKS](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@SYNERGY\_NETWORKS](https://forum.shopware.com/u/SYNERGY_NETWORKS)\
**Post date:** [6. April 2017 um 12:43 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/9 "2017-04-06T12:43:19Z")

</div>

> [@Thomas schrieb:](https://forum.shopware.com/profile/16897/Thomas "Thomas")
> 
> > [@SYNERGY NETWORKS schrieb:](https://forum.shopware.com/profile/7781/SYNERGY%20NETWORKS "SYNERGY%20NETWORKS")
> > 
> > Sobald aber der ES Server extern liegt gehts nicht mehr. Das habe ich gerade einmal ausprobiert.
> 
> Völliger quatsch - das funktioniert hier im Cluster Setup &nbsp;einwandfrei mit Elastic Search 5 und Zugriff via remote
> 
> {  
> „name“ : „es-1“,  
> „cluster\_name“ : „es“,  
> „cluster\_uuid“ : „_**",  
> „version“ : {  
> „number“ : „5.1.2“,  
> „build\_hash“ : "**_“,  
> „build\_date“ : „\*\*\*“,  
> „build\_snapshot“ : false,  
> „lucene\_version“ : „6.3.0“  
> },  
> „tagline“ : „You Know, for Search“  
> }
> 
> &nbsp;

das haben wir gerade

```
 { "name" : "Ghost Girl", "cluster\_name" : "elasticsearch", "cluster\_uuid" : "\*\*\*", "version" : { "number" : "2.4.4", "build\_hash" : "\*\*\*", "build\_timestamp" : "\*\*\*", "build\_snapshot" : false, "lucene\_version" : "5.5.2" }, "tagline" : "You Know, for Search" }

```

---

<div class="post-metadata">

**Author:** ![Thomas](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/thomas/32/8167_2.png) [@Thomas](https://forum.shopware.com/u/Thomas)\
**Post date:** [6. April 2017 um 12:45 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/10 "2017-04-06T12:45:08Z")

</div>

> [@SYNERGY NETWORKS schrieb:](https://forum.shopware.com/profile/7781/SYNERGY%20NETWORKS "SYNERGY%20NETWORKS")
> 
> dann kommt das hier dabei raus:
> 
> ## Indexing shop .de-DE
> 
> Indexing properties  
> &nbsp;43/43 [============================] 100% \< 1 sec/\< 1 sec  
> Indexing products  
> &nbsp;59/59 [============================] 100% \< 1 sec/\< 1 sec

Sind das denn alle Artikel die Du im Shop hast?

Werden danach alle Artikel angezeigt?&nbsp;

---

<div class="post-metadata">

**Author:** ![SYNERGY\_NETWORKS](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@SYNERGY\_NETWORKS](https://forum.shopware.com/u/SYNERGY_NETWORKS)\
**Post date:** [6. April 2017 um 12:48 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/11 "2017-04-06T12:48:56Z")

</div>

Was habt ihr denn in der elasticsearch.yml eingestellt?

---

<div class="post-metadata">

**Author:** ![SYNERGY\_NETWORKS](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@SYNERGY\_NETWORKS](https://forum.shopware.com/u/SYNERGY_NETWORKS)\
**Post date:** [6. April 2017 um 12:51 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/12 "2017-04-06T12:51:37Z")

</div>

> [@Thomas schrieb:](https://forum.shopware.com/profile/16897/Thomas "Thomas")
> 
> > [@SYNERGY NETWORKS schrieb:](https://forum.shopware.com/profile/7781/SYNERGY%20NETWORKS "SYNERGY%20NETWORKS")
> > 
> > dann kommt das hier dabei raus:
> > 
> > ## Indexing shop .de-DE
> > 
> > Indexing properties  
> > &nbsp;43/43 [============================] 100% \< 1 sec/\< 1 sec  
> > Indexing products  
> > &nbsp;59/59 [============================] 100% \< 1 sec/\< 1 sec
> 
> Sind das denn alle Artikel die Du im Shop hast?
> 
> Werden danach alle Artikel angezeigt?&nbsp;

Die 59 Artikel sind alle Grundartikel im Shopware Backend, davon sind aber nur 48 Artikel aktiv und dürften im Frontend zu sehen sein. 38 Artikel allerdings werden aber nur angezeigt.

---

<div class="post-metadata">

**Author:** ![Thomas](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/thomas/32/8167_2.png) [@Thomas](https://forum.shopware.com/u/Thomas)\
**Post date:** [6. April 2017 um 13:11 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/13 "2017-04-06T13:11:46Z")

</div>

> [@SYNERGY NETWORKS schrieb:](https://forum.shopware.com/profile/7781/SYNERGY%20NETWORKS "SYNERGY%20NETWORKS")
> 
> &nbsp;
> 
> Die 59 Artikel sind alle Grundartikel im Shopware Backend, davon sind aber nur 48 Artikel aktiv und dürften im Frontend zu sehen sein. 38 Artikel allerdings werden aber nur angezeigt.

Dann wirst Du wohl dich durch den Stack hangeln müssen und schauen was der EsRequest an Artikel zurück gibt.

---

<div class="post-metadata">

**Author:** ![SYNERGY\_NETWORKS](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@SYNERGY\_NETWORKS](https://forum.shopware.com/u/SYNERGY_NETWORKS)\
**Post date:** [6. April 2017 um 13:18 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/14 "2017-04-06T13:18:00Z")

</div>

> &nbsp;
> 
> Dann wirst Du wohl dich durch den Stack hangeln müssen und schauen was der EsRequest an Artikel zurück gibt.

&nbsp;und das mache ich wie ?!

---

<div class="post-metadata">

**Author:** ![Thomas](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/thomas/32/8167_2.png) [@Thomas](https://forum.shopware.com/u/Thomas)\
**Post date:** [6. April 2017 um 17:58 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/15 "2017-04-06T17:58:46Z")

</div>

Da wir ja nicht wissen wo der Fehler genau steckt, fangen wir dort an wo das Symptom (zu wenig Artikel werden dargestellt) auftritt.

1. Also im ListingController&nbsp;in der indexAction: [shopware/Listing.php at 5.2 · shopware/shopware · GitHub](https://github.com/shopware/shopware/blob/5.2/engine/Shopware/Controllers/Frontend/Listing.php#L102)
2. Da werden anscheinend&nbsp;die CategoryArticles geholt ([shopware/Listing.php at 5.2 · shopware/shopware · GitHub](https://github.com/shopware/shopware/blob/5.2/engine/Shopware/Controllers/Frontend/Listing.php#L195)).
3. Die Methode&nbsp;sGetArticlesByCategory befindet sich in der sArticles.php ([shopware/sArticles.php at 5.2 · shopware/shopware · GitHub](https://github.com/shopware/shopware/blob/5.2/engine/Shopware/Core/sArticles.php#L421)).
4. Dort wird wiederum die Methode getListing() ([shopware/sArticles.php at 5.2 · shopware/shopware · GitHub](https://github.com/shopware/shopware/blob/5.2/engine/Shopware/Core/sArticles.php#L438)) aufgerufen.
5. Hier wird anscheinen schon eine Suche ausgeführt:&nbsp;[shopware/sArticles.php at 5.2 · shopware/shopware · GitHub](https://github.com/shopware/shopware/blob/5.2/engine/Shopware/Core/sArticles.php#L2354).&nbsp;

Bei den einzelnen Zwischenschritten lässt Du dir die Werte der Variablen ausgeben und überprüfst diese. Wenn Du in den Schritten noch nicht die Ursache gefunden hast machst Du mit dem SearchService genau so weiter.

---

<div class="post-metadata">

**Author:** ![SYNERGY\_NETWORKS](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@SYNERGY\_NETWORKS](https://forum.shopware.com/u/SYNERGY_NETWORKS)\
**Post date:** [8. April 2017 um 18:44 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/16 "2017-04-08T18:44:25Z")

</div>

Hi Thomas und denen die auch mal daran verzweifeln,

wer einmal von SW4 bis hin zur SW 5.2.21 Version updates durchgeführt hat und im Frontend weniger Artikel sieht als eigentlich verfügbar.

**Überprüft eure Artikel!**  
Gibt es Werte die als Beispiel bei einer Variante alle Varianten haben müssten und einer davon besitzt diesen Wert gar nicht - geht es schon nicht und der Artikel wird nicht ausgespielt.

---

<div class="post-metadata">

**Author:** ![SYNERGY\_NETWORKS](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@SYNERGY\_NETWORKS](https://forum.shopware.com/u/SYNERGY_NETWORKS)\
**Post date:** [27. Juli 2017 um 11:03 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/17 "2017-07-27T11:03:18Z")

</div>

Hi Thomas,  
der Fehler hier war wohl einfach der Fehler… das es noch ein **Datumfeld** als Attribute gab und wenn dieses Datum nicht gesetzt wurde, weil man es nicht benötigt dann hat ES nach und nach die Artikel aus dem Listing rausgeschmissen… Wir haben jetzt bei allen ein Datum hinterlegt neu indexiert und siehe da alle artikel sofort im listing wieder vorhanden.

Haben jetzt nur noch mit&nbsp;[calculatedPrices.SB\_1.calculatedReferencePrice] cannot be changed from type [float] to [long]" und Sprachshops ein Problem. Hier stochern wir noch ein wenig im trüben woran das liegen mag.

VG

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [27. Juli 2017 um 11:07 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/18 "2017-07-27T11:07:40Z")

</div>

Bei der ersten indexierung erkennt Elasticsearch automatisch den Feldtyp, bspw. float, long usw.&nbsp;  
Wahrscheinlich hat das Feld manchmal eine ganze Zahl und keinen float (Kommazahl). Müsstest das mal checken. Ob das wirklich der Grund ist, weiß ich nicht, wäre aber denkbar bei der Meldung.

> **[Dynamic mapping | Elasticsearch Reference \[7.11\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/dynamic-mapping.html)**

> **[Numeric field types | Elasticsearch Reference \[7.11\] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/number.html)**

---

<div class="post-metadata">

**Author:** ![SYNERGY\_NETWORKS](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@SYNERGY\_NETWORKS](https://forum.shopware.com/u/SYNERGY_NETWORKS)\
**Post date:** [27. Juli 2017 um 11:26 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/19 "2017-07-27T11:26:35Z")

</div>

Hi Moritz,

die Artikelpreise bei den zwei Artikeln sind alle ohne kommastelle.  
Wie gesagt auffällig ist das dieser Fehler nur in den Sprachshops kommt. bei allen anderen stores gehts ohne probleme.

---

<div class="post-metadata">

**Author:** ![SYNERGY\_NETWORKS](https://avatars.discourse-cdn.com/v4/letter/s/8edcca/32.png) [@SYNERGY\_NETWORKS](https://forum.shopware.com/u/SYNERGY_NETWORKS)\
**Post date:** [27. Juli 2017 um 14:47 UTC](https://forum.shopware.com/t/gelost-fehler-mit-elastic-search-im-frontend-sind-weniger-artikel-sichtbar-als-im-backend-fr/45047/20 "2017-07-27T14:47:59Z")

</div>

Hey Moritz,

&nbsp;

ich habe das dynamic mapping mal ausgeschaltet jedoch brachte das keine lösung der fehler bleibt bestehen mit&nbsp;[calculatedPrices.SB\_1.calculatedReferencePrice] cannot be changed from type [float] to [long]…

VG
