# Gelöst: Error 500 / Fehler Backend nach Installation

**URL:** <https://forum.shopware.com/t/gelost-error-500-fehler-backend-nach-installation/4052>\
**Category:** Shopware 3.5\
**Tags:** installation--gettin\
**Created:** [25. August 2011 um 16:46 UTC](https://forum.shopware.com/t/gelost-error-500-fehler-backend-nach-installation/4052 "2011-08-25T16:46:44Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![aspirahomecouk](https://avatars.discourse-cdn.com/v4/letter/a/5daacb/32.png) [@aspirahomecouk](https://forum.shopware.com/u/aspirahomecouk)\
**Post date:** [25. August 2011 um 16:46 UTC](https://forum.shopware.com/t/gelost-error-500-fehler-backend-nach-installation/4052/1 "2011-08-25T16:46:44Z")

</div>

Hallo Zusammen, ich habe also die Community-Edition für ZendOptimizer und Demoshop per Online Installer installiert und bekam auch die Meldung ‘erfolreich installiert’: [http://aspira-home.co.uk/shopware.php](http://aspira-home.co.uk/shopware.php) Beim Klick auf die Zum-Backend-Taste erschien bei [http://aspira-home.co.uk/shopware.php/backend/auth](http://aspira-home.co.uk/shopware.php/backend/auth) jedoch die Browsermeldung ‘Error 500 (interner Fehler)’. Also hab ich in’s Wiki geschaut und [http://wiki.shopware.de/Installation-Ei … t\_441.html](http://wiki.shopware.de/Installation-Einricht.%5C_cat%5C_441.html) gefunden. Daraufhin habe ich die PHP.INI hinsichtlich dem 1und1-Domainserver angepasst. Danach habe ich einen Cron-Job gestartet mit [http://aspira-home.co.uk/shopware.php?m … oller=cron](http://aspira-home.co.uk/shopware.php?module=backend&controller=cron). Und siehe, jetzt kommt der Login-Dialog und danach ‘so etwas wie ein’ Backend, d.h. es werden Icons und Links sichtbar, jedoch ohne Formatierung über ein Template = alles irgendwie untereinander. (nebenbei: so sieht auch der Demoshop aus, alles untereinander. Ein Test der Templatefähigkeit per z.B. [http://aspira-home.co.uk/?sTpl=dark](http://aspira-home.co.uk/?sTpl=dark) verläuft ebenfalls negativ) Dennoch konnte ich im Backend ‘Shopware-ID registrieren’ ausführen. Ich hab dann also eine leere 31e3d…html angelegt und die Domain registriert. Da ich KEINE Lizenz-Email bekommen habe (warum weiss ich nicht) habe ich die Lizenznummer manuell in die Datenbank eingetragen. Wohin kommt aber der Aktivierungskey ? Nun, weder Backend als auch Shop funktionieren nach wie vor nicht. Die [http://aspira-home.co.uk/check.php](http://aspira-home.co.uk/check.php) zeigt alles OK, bis auf dass die engine/core/class-Dateien fehlen … was wohl mit der Aktivierung zusammenhängt. Ihr seht, ich habe so einige Probleme, könnt ihr mir bitte helfen ? Vielen Dank im Voraus, Uwe

---

<div class="post-metadata">

**Author:** ![tschersich](https://avatars.discourse-cdn.com/v4/letter/t/a9adbd/32.png) [@tschersich](https://forum.shopware.com/u/tschersich)\
**Post date:** [25. August 2011 um 18:00 UTC](https://forum.shopware.com/t/gelost-error-500-fehler-backend-nach-installation/4052/2 "2011-08-25T18:00:01Z")

</div>

[quote=“aspirahomecouk”] Und siehe, jetzt kommt der Login-Dialog und danach ‘so etwas wie ein’ Backend, d.h. es werden Icons und Links sichtbar, jedoch ohne Formatierung über ein Template = alles irgendwie untereinander. (nebenbei: so sieht auch der Demoshop aus, alles untereinander. Ein Test der Templatefähigkeit per z.B. [http://aspira-home.co.uk/?sTpl=dark](http://aspira-home.co.uk/?sTpl=dark) verläuft ebenfalls negativ) Ihr seht, ich habe so einige Probleme, könnt ihr mir bitte helfen ?[/quote] Dir scheinen ein paar Dateien abhanden gekommen zu sein, zumindest fehlt Dir für’s Backend die: [http://aspira-home.co.uk/templates/\_def … /index.css](http://aspira-home.co.uk/templates/%5C_default/backend/%5C_resources/styles/index.css) und für’s Frontend gleich ein halbes Dutzend Dateien (css und js) Vielleicht ist da beim Kopierern etwas schief gelaufen? Sieht man übrigens mit Firebug ganz gut, was da fehlt.

---

<div class="post-metadata">

**Author:** ![aspirahomecouk](https://avatars.discourse-cdn.com/v4/letter/a/5daacb/32.png) [@aspirahomecouk](https://forum.shopware.com/u/aspirahomecouk)\
**Post date:** [26. August 2011 um 07:32 UTC](https://forum.shopware.com/t/gelost-error-500-fehler-backend-nach-installation/4052/3 "2011-08-26T07:32:16Z")

</div>

Tatsächlich, es kommt der Fehler 404 … aber die Datei ist vorhanden = 12.248 bytes, Attribut 644 ! Ich habe eine phpinfo.php daneben abgelegt … und diese kann ich aufrufen ! … was ist denn hier los ?

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [26. August 2011 um 08:25 UTC](https://forum.shopware.com/t/gelost-error-500-fehler-backend-nach-installation/4052/4 "2011-08-26T08:25:46Z")

</div>

Hi, kann das sein, dass die Systemvoraussetzungen bei dir generell noch nicht passen? Sieht z.B. so aus, als könnten die htaccess-Regeln gar nicht korrekt angewendet werden. Leg mal eine check.php (Systemcheck) in einen Untordner und versuche diese dann aufzurufen. Ich vermute, dass die Systemeinstellungen nämlich in den neuen Ordnern nicht mehr greifen. PS: Das aktuelle Tool findest du hier [http://wiki.shopware.de/SystemCheck-Too … l\_135.html](http://wiki.shopware.de/SystemCheck-Tool%5C_detail%5C_135.html) Das prüft auf Basis Shopware 3.5.4

---

<div class="post-metadata">

**Author:** ![aspirahomecouk](https://avatars.discourse-cdn.com/v4/letter/a/5daacb/32.png) [@aspirahomecouk](https://forum.shopware.com/u/aspirahomecouk)\
**Post date:** [26. August 2011 um 16:17 UTC](https://forum.shopware.com/t/gelost-error-500-fehler-backend-nach-installation/4052/5 "2011-08-26T16:17:35Z")

</div>

Hi und danke, die .htaccess zum Anlass nehmend, habe ich lt. [http://wiki.shopware.de/Installation-3. … ainFACTORY](http://wiki.shopware.de/Installation-3.5%5C_detail%5C_518.html#Installation%5C_domainFACTORY) mal folgende Zeile eingefuegt: RewriteBase / … und siehe da, jetzt wird sowohl das Backend als auch der Shop wie erwartet angezeigt ! Die [http://aspira-home.co.uk/check.php](http://aspira-home.co.uk/check.php) zeigt jedoch immernoch fehlende engine/core/class-Dateien ! Im Backend funktioniert auch nicht so viel, d.h. keine Reaktion bei den meisten Menü-Tasten … es kommen unterschiedlich viele Fehlermeldungen in FireBug ! Komisch auch, dass ‘Kein Shopware-Account angelegt’ angezeigt wird. Ich habe doch einen, ansonsten hätte ich doch keine Lizenz, siehe check.php, oder ?

---

<div class="post-metadata">

**Author:** ![SebastianKloepper](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sebastiankloepper/32/21435_2.png) [@SebastianKloepper](https://forum.shopware.com/u/SebastianKloepper)\
**Post date:** [26. August 2011 um 16:26 UTC](https://forum.shopware.com/t/gelost-error-500-fehler-backend-nach-installation/4052/6 "2011-08-26T16:26:46Z")

</div>

Hi, du hast immer noch das alte Systemcheck-Tool im Einsatz! Bitte mal das aktuelle hochladen und es in einem Unterordner ablegen um zu prüfen, ob dort auch alle Voraussetzungen passen. Das Backend sieht zumindest vom Aufruf her (Loginfenster) korrekt aus. Beim Shopware Account muss in den Grundeinstellungen \> System dein Aktivierungsschlüssel hinterlegt werden.

---

<div class="post-metadata">

**Author:** ![aspirahomecouk](https://avatars.discourse-cdn.com/v4/letter/a/5daacb/32.png) [@aspirahomecouk](https://forum.shopware.com/u/aspirahomecouk)\
**Post date:** [26. August 2011 um 17:01 UTC](https://forum.shopware.com/t/gelost-error-500-fehler-backend-nach-installation/4052/7 "2011-08-26T17:01:24Z")

</div>

Oops, sorry … aber jetzt habe ich das neue Tool … und siehe, alles OK bei Aufruf [http://aspira-home.co.uk/check.php](http://aspira-home.co.uk/check.php). Das Problem mit den nicht-reagierenden Menüoptionen im Backend habe ich auch gelöst. Dazu war es notwendig (wohl wegen 1und1) die PHP.INI in alle (!) Verzeichnisse und Unterverzeichnisse die PHP-Dateien beinhalten zu kopieren.
