# \[Gelöst\] Conexco Resp-Template: Fatal Error

**URL:** <https://forum.shopware.com/t/gelost-conexco-resp-template-fatal-error/20767>\
**Category:** Shopware 3.5\
**Tags:** themes--design\
**Created:** [13. Juni 2014 um 10:35 UTC](https://forum.shopware.com/t/gelost-conexco-resp-template-fatal-error/20767 "2014-06-13T10:35:30Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![1imOrt](https://avatars.discourse-cdn.com/v4/letter/1/58956e/32.png) [@1imOrt](https://forum.shopware.com/u/1imOrt)\
**Post date:** [13. Juni 2014 um 10:35 UTC](https://forum.shopware.com/t/gelost-conexco-resp-template-fatal-error/20767/1 "2014-06-13T10:35:30Z")

</div>

Hallo zusammen, wir setzen das Resp-Templte in einem Subshop ein und wenn ich es aktiviere, bleibt die Startseite schon weiß. Wenn ich mir den Quelltext der Startseite dann anschaue, sieht man, wo das Templat abbricht: \<meta name=“application-name” content="\<br /\>  
\<b\>Fatal error\</b\>: Call to a member function config() on a non-object in \<b\>/Shop-Verzeichnis/5727d25302672351710586fe742551a3410b01c3.snippet.index.tpl.php\</b\> on line \<b\>538\</b\>\<br /\>  
503 Service Unavailable

Line 538 in der Php-Datei:  
\<meta name=" application-name\>Bei einem anderen Shop funktioniert das bei uns einwandfrei - beide 4.1.4-Systeme. Hat jemand eine Idee, woran das liegen kann und wie wir das beheben können? Danke und viele Grüße, Alex

---

<div class="post-metadata">

**Author:** ![brettvormkopp](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/brettvormkopp/32/7788_2.png) [@brettvormkopp](https://forum.shopware.com/u/brettvormkopp)\
**Post date:** [13. Juni 2014 um 11:03 UTC](https://forum.shopware.com/t/gelost-conexco-resp-template-fatal-error/20767/2 "2014-06-13T11:03:30Z")

</div>

Hallo, wieso schreibst du dort php rein? entweder smarty oder php. richtig muss es heissen: {config name=shopName}

---

<div class="post-metadata">

**Author:** ![1imOrt](https://avatars.discourse-cdn.com/v4/letter/1/58956e/32.png) [@1imOrt](https://forum.shopware.com/u/1imOrt)\
**Post date:** [13. Juni 2014 um 11:06 UTC](https://forum.shopware.com/t/gelost-conexco-resp-template-fatal-error/20767/3 "2014-06-13T11:06:29Z")

</div>

Ich hab da gar nichts reingeschrieben, sondern nur das Template installiert. Aber das ist ja strange, dass dort so ein Fehler drin ist. Hm, lad ich nochmal ne neue Version aus dem Store und teste das mal…

---

<div class="post-metadata">

**Author:** ![1imOrt](https://avatars.discourse-cdn.com/v4/letter/1/58956e/32.png) [@1imOrt](https://forum.shopware.com/u/1imOrt)\
**Post date:** [13. Juni 2014 um 11:11 UTC](https://forum.shopware.com/t/gelost-conexco-resp-template-fatal-error/20767/4 "2014-06-13T11:11:09Z")

</div>

Gleicher Fehler mit einer frisch aus dem Shop heruntergeladenen Version. Das ist doch ganz strange…

---

<div class="post-metadata">

**Author:** ![brettvormkopp](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/brettvormkopp/32/7788_2.png) [@brettvormkopp](https://forum.shopware.com/u/brettvormkopp)\
**Post date:** [13. Juni 2014 um 11:13 UTC](https://forum.shopware.com/t/gelost-conexco-resp-template-fatal-error/20767/5 "2014-06-13T11:13:07Z")

</div>

Das hat mit dem Template nichts zu tun, so steht das da nicht drin. Da muss jemand per Hand einen anderen Eintrag in den Shopeinstellungen, Textbausteinen oder was auch immer gemacht haben.

---

<div class="post-metadata">

**Author:** ![mac](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/mac/32/7855_2.png) [@mac](https://forum.shopware.com/u/mac)\
**Post date:** [13. Juni 2014 um 11:21 UTC](https://forum.shopware.com/t/gelost-conexco-resp-template-fatal-error/20767/6 "2014-06-13T11:21:52Z")

</div>

Vielleicht liegt es auch an einem anderen Plugin? Einfach mal die zusätzlichen Plugins nach und nach deaktivieren und testen. Gruß Marco

---

<div class="post-metadata">

**Author:** ![1imOrt](https://avatars.discourse-cdn.com/v4/letter/1/58956e/32.png) [@1imOrt](https://forum.shopware.com/u/1imOrt)\
**Post date:** [13. Juni 2014 um 13:08 UTC](https://forum.shopware.com/t/gelost-conexco-resp-template-fatal-error/20767/7 "2014-06-13T13:08:36Z")

</div>

Die Installation ist eh recht sauber, aber bis auf Lizenzmanager und Multishop hatte ich alles rausgenommen =\> auch keine Besserung. Laut Support von Conexco muss das an einer Änderung im \_local-Ordner liegen. Da checken wir jetzt mal…

---

<div class="post-metadata">

**Author:** ![1imOrt](https://avatars.discourse-cdn.com/v4/letter/1/58956e/32.png) [@1imOrt](https://forum.shopware.com/u/1imOrt)\
**Post date:** [14. Juni 2014 um 14:57 UTC](https://forum.shopware.com/t/gelost-conexco-resp-template-fatal-error/20767/8 "2014-06-14T14:57:35Z")

</div>

Zur Info: Der Support von Conexco hat uns sehr schnell geholfen: Das Problem lag darin, dass es noch Altordner aus Shopware 3.x gab (der Shop ist mit 3.5 entstanden und dann auf 4.1 migriert worden), so dass hier Änderungen im templates/\_locale-Ordner vorhanden sind, die nicht erlaubt sind. Wenn man den Ordner bspw. in X\_local umbenennt funktioniert es ohne Probleme (und die Änderungen, die vorher im \_local-Ordner standen, muss man halt in einen anderen Ordner einbauen)
