# \[Gelöst\] Ajax Suche liefert nach Update auf 5.5.3 einen 500 Fehler

**URL:** <https://forum.shopware.com/t/gelost-ajax-suche-liefert-nach-update-auf-5-5-3-einen-500-fehler/56349>\
**Category:** Allgemein\
**Created:** [9. November 2018 um 14:15 UTC](https://forum.shopware.com/t/gelost-ajax-suche-liefert-nach-update-auf-5-5-3-einen-500-fehler/56349 "2018-11-09T14:15:41Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![danielmorfer](https://avatars.discourse-cdn.com/v4/letter/d/4af34b/32.png) [@danielmorfer](https://forum.shopware.com/u/danielmorfer)\
**Post date:** [9. November 2018 um 14:15 UTC](https://forum.shopware.com/t/gelost-ajax-suche-liefert-nach-update-auf-5-5-3-einen-500-fehler/56349/1 "2018-11-09T14:15:41Z")

</div>

Hallo seit dem Update auf die Version 5.5.3 funktioniert die Ajax Suchergebnissliste nicht mehr. Die Konsole liefert beim Tippen einen 500er Fehler.

[https://www.domain.de/ajax\_search?sSearch=tasche](https://www.domain.de/ajax_search?sSearch=tasche) =\> 500er

In den Logs erhalte ich:

```
[Fri Nov 09 10:26:31 2018] [-:error] [pid 20253] [host www.domain.de] PHP Fatal error: Uncaught SmartyException: Unable to load template snippet 'frontend/ajax_search/index.tpl|frontend/plugins/seo/index.tpl' in /is/htdocs/wp12780449_45JNHE9XGK/www/engine/Library/Smarty/sysplugins/smarty_internal_templatebase.php:127\nStack trace:\n#0 /is/htdocs/wp12780449_45JNHE9XGK/www/engine/Library/Enlight/View/Default.php(300): Smarty_Internal_TemplateBase-]fetch()\n#1 /is/htdocs/wp12780449_45JNHE9XGK/www/engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(216): Enlight_View_Default-]render(Object(Enlight_Template_Default))\n#2 /is/htdocs/wp12780449_45JNHE9XGK/www/engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(242): Enlight_Controller_Plugins_ViewRenderer_Bootstrap-]renderTemplate(Object(Enlight_Template_Default))\n#3 /is/htdocs/wp12780449_45JNHE9XGK/www/engine/Library/Enlight/Controller/Plugins/ViewRenderer/Bootstrap.php(136): Enlight_Controller_Plugins_ViewRenderer_Bootstrap-]render()\n#4 /is/htdocs/wp12780449_45JNHE9XGK/www/engine/Library/Enlight/Event/Handler/Default.ph in /is/htdocs/wp12780449_45JNHE9XGK/www/engine/Library/Smarty/sysplugins/smarty_internal_templatebase.php on line 127

```

Das scheint hilfreich zu sein: **Unable to load template snippet 'frontend/ajax\_search/index.tpl|frontend/plugins/seo/index.tpl’**

Bin hier gerade aufgeschmissen, kann das ein Plugin verursachen? Sind ein paar Fremdplugins im Einsatz.

Bin über jede Hilfe dankbar!

---

<div class="post-metadata">

**Author:** ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)\
**Post date:** [10. November 2018 um 01:30 UTC](https://forum.shopware.com/t/gelost-ajax-suche-liefert-nach-update-auf-5-5-3-einen-500-fehler/56349/2 "2018-11-10T01:30:25Z")

</div>

Hast Du den Cache schon geleert?

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)

---

<div class="post-metadata">

**Author:** ![Shopwareianer](https://avatars.discourse-cdn.com/v4/letter/s/b4bc9f/32.png) [@Shopwareianer](https://forum.shopware.com/u/Shopwareianer)\
**Post date:** [10. November 2018 um 06:06 UTC](https://forum.shopware.com/t/gelost-ajax-suche-liefert-nach-update-auf-5-5-3-einen-500-fehler/56349/3 "2018-11-10T06:06:13Z")

</div>

Ja, steht ja da: Das “seo” Plugin. Ist es mit deiner Shopware Version kompatibel?

---

<div class="post-metadata">

**Author:** ![danielmorfer](https://avatars.discourse-cdn.com/v4/letter/d/4af34b/32.png) [@danielmorfer](https://forum.shopware.com/u/danielmorfer)\
**Post date:** [13. November 2018 um 15:34 UTC](https://forum.shopware.com/t/gelost-ajax-suche-liefert-nach-update-auf-5-5-3-einen-500-fehler/56349/4 "2018-11-13T15:34:14Z")

</div>

Hallo, Alle Caches sind natürlich schon geleert worden, sowie Themes neu kompiliert.

Es war nie und es ist kein SEO Plugin in Verwendung. Das wundert mich.

Ich denke mal, damit ist das Standard Plugin „SEO“ gemeint:  
/www/engine/Shopware/Plugins/Default/Frontend/Seo

Was kann man da tun? Fehlen da Dateien?

---

<div class="post-metadata">

**Author:** ![AndreHerking](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/andreherking/32/7839_2.png) [@AndreHerking](https://forum.shopware.com/u/AndreHerking)\
**Post date:** [13. November 2018 um 15:44 UTC](https://forum.shopware.com/t/gelost-ajax-suche-liefert-nach-update-auf-5-5-3-einen-500-fehler/56349/5 "2018-11-13T15:44:36Z")

</div>

Einfach mal den _engine_ Ordner aus dem Installationspaket der jeweiligen Shopware Version in deinen Shop kopieren - wichtig ist, dass du diesen nicht ersetzt sondern die Dateien nach einem Backup überschreibst.

LG Andre

---

<div class="post-metadata">

**Author:** ![danielmorfer](https://avatars.discourse-cdn.com/v4/letter/d/4af34b/32.png) [@danielmorfer](https://forum.shopware.com/u/danielmorfer)\
**Post date:** [13. November 2018 um 16:43 UTC](https://forum.shopware.com/t/gelost-ajax-suche-liefert-nach-update-auf-5-5-3-einen-500-fehler/56349/6 "2018-11-13T16:43:03Z")

</div>

Hallo Andre,

Ich habe den “engine” Ordner mal herunter geladen, dann die aktuelle Shopware Version entpackt und die beiden Ordner via “WinMerge” vergleichen lassen.  
Dabei gab es lediglich unterschiedliche Datei Meldungen im Zusammenhang mit Plugins, welche natürlich nur im Live Shop installiert sind. Das müsste mir ja das hochladen ersparen und würde bedeuten, dass es nicht daran liegt oder?  
&nbsp;

---

<div class="post-metadata">

**Author:** ![danielmorfer](https://avatars.discourse-cdn.com/v4/letter/d/4af34b/32.png) [@danielmorfer](https://forum.shopware.com/u/danielmorfer)\
**Post date:** [19. November 2018 um 15:13 UTC](https://forum.shopware.com/t/gelost-ajax-suche-liefert-nach-update-auf-5-5-3-einen-500-fehler/56349/7 "2018-11-19T15:13:18Z")

</div>

Hat jemand dazu noch einen Tipp? Die besagten .tpl Dateien sind im Bare Template Verzeichnis vorhanden.

---

<div class="post-metadata">

**Author:** ![danielmorfer](https://avatars.discourse-cdn.com/v4/letter/d/4af34b/32.png) [@danielmorfer](https://forum.shopware.com/u/danielmorfer)\
**Post date:** [4. Dezember 2018 um 11:14 UTC](https://forum.shopware.com/t/gelost-ajax-suche-liefert-nach-update-auf-5-5-3-einen-500-fehler/56349/8 "2018-12-04T11:14:36Z")

</div>

Es lag an dem Plugin “Discount Category”: In dem Changelog steht:

25.10.2018

Die Rabattberechnung in der Ajax Suche wurde überarbeitet.

**Wichtig** : Bitte Pluginneuinstallation durchführen, da ansonsten möglicherweise die Ajax-Suche nicht mehr korrekt funktioniert.

&nbsp;

Nach einer Neuinstallierung des Plugins läuft es nun wieder.
