# \[Gelöst\] 503 Service unavailable (nichts dergleichen in der Suche gefunden)

**URL:** https://forum.shopware.com/t/gelost-503-service-unavailable-nichts-dergleichen-in-der-suche-gefunden/38834
**Category:** Administration
**Created:** [5. August 2016 um 18:38 UTC](https://forum.shopware.com/t/gelost-503-service-unavailable-nichts-dergleichen-in-der-suche-gefunden/38834 "2016-08-05T18:38:05Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![Ladenbesitzer](https://avatars.discourse-cdn.com/v4/letter/l/dc4da7/32.png) [@Ladenbesitzer](https://forum.shopware.com/u/Ladenbesitzer)
#### Post date: [5. August 2016 um 18:38 UTC](https://forum.shopware.com/t/gelost-503-service-unavailable-nichts-dergleichen-in-der-suche-gefunden/38834/1 "2016-08-05T18:38:05Z")

</div>

Habe nach einem Update von 5.16 auf 5.23 einen 503 Service unavailable.

Und NEIN, ich habe nichts in der Suche zu genau diesem Problem gefunden falls sich wieder jemand daran stören sollte, das man in einem Forum zu einem Problem eine Frage stellt (eine Person hat sich scheinbar daran gestört gefühlt und gemeldet. Die Moderation fand das Thema wohl auch leidig)

Ich habe kein Payone. Die erste installierte Version war eine 5.x Version. Bis 5.16 funktionierten die Updates, dann gab es mit 5.21 ein grobes Datenbankproblem.

5.22 und 5.23 laufen durch, zeigen im Frontend aber einen 503 Fehler.

Das Backend ist erreichbar, das installierte Paypal und Analytics Plugin lassen sich aber weder deaktivieren noch aktualisieren.

Ich bin sehr dankbar für echte Unterstützung!

---

<div class="post-metadata">

### Author: ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)
#### Post date: [5. August 2016 um 19:01 UTC](https://forum.shopware.com/t/gelost-503-service-unavailable-nichts-dergleichen-in-der-suche-gefunden/38834/2 "2016-08-05T19:01:06Z")

</div>

Hallo,

besorg erstmal die Fehlermeldung:&nbsp;[http://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen\_detail\_1880.html#Frontend\_Error\_Reporter](http://community.shopware.com/Fehlermeldungen-in-Shopware-debuggen_detail_1880.html#Frontend_Error_Reporter)

Ab SW 5.2 wird ohne das immer ein 503 angezeigt bei PHP Errors.

Moritz

---

<div class="post-metadata">

### Author: ![Ladenbesitzer](https://avatars.discourse-cdn.com/v4/letter/l/dc4da7/32.png) [@Ladenbesitzer](https://forum.shopware.com/u/Ladenbesitzer)
#### Post date: [5. August 2016 um 19:20 UTC](https://forum.shopware.com/t/gelost-503-service-unavailable-nichts-dergleichen-in-der-suche-gefunden/38834/3 "2016-08-05T19:20:42Z")

</div>

Hallo Moritz,

ich danke Dir für deine Rückmeldung!

Der ab 5.2 modifizierte Fehlerreport spuckt folgenden Output aus:

**Fatal error** : Uncaught Doctrine\ORM\Mapping\MappingException: No mapping found for field ‘customerGroup’ on class ‘Shopware\Models\Attribute\CustomerGroup’. in /var/www/virtual/vespa/html/vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/MappingException.php:163 Stack trace: #0 /var/www/virtual/vespa/html/vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/ClassMetadataInfo.php(1238): Doctrine\ORM\Mapping\MappingException::mappingNotFound(‘Shopware\Models…’, ‘customerGroup’) #1 /var/www/virtual/vespa/html/engine/Library/Doctrine/ORM/Persisters/Entity/BasicEntityPersister.php(802): Doctrine\ORM\Mapping\ClassMetadataInfo-\>getAssociationMapping(‘customerGroup’) #2 /var/www/virtual/vespa/html/vendor/doctrine/orm/lib/Doctrine/ORM/UnitOfWork.php(2626): Doctrine\ORM\Persisters\Entity\BasicEntityPersister-\>loadOneToOneEntity(Array, Object(Shopware\Models\Customer\Group)) #3 /var/www/virtual/vespa/html/vendor/doctrine/orm/lib/Doctrine/ORM/Internal/Hydration/ObjectHydrator.php(273): Doctrine\ORM\UnitOfWork-\>createEntity(‘Shopware\Models…’ in **/var/www/virtual/vespa/html/vendor/doctrine/orm/lib/Doctrine/ORM/Mapping/MappingException.php** on line **163**  
503 Service Unavailable

---

<div class="post-metadata">

### Author: ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)
#### Post date: [5. August 2016 um 19:36 UTC](https://forum.shopware.com/t/gelost-503-service-unavailable-nichts-dergleichen-in-der-suche-gefunden/38834/4 "2016-08-05T19:36:37Z")

</div>

Könnte ein Problem mit den Foreign Keys sein, hiermit kannst du die reparieren:&nbsp;[http://community.shopware.com/Foreign-Keys-reparieren\_detail\_954.html](http://community.shopware.com/Foreign-Keys-reparieren_detail_954.html)

Sonst könnte es auch ein Plugin sein. Da müsstest du die mal schrittweise deaktivieren. Notfalls über die s\_core\_plugins.

---

<div class="post-metadata">

### Author: ![Ladenbesitzer](https://avatars.discourse-cdn.com/v4/letter/l/dc4da7/32.png) [@Ladenbesitzer](https://forum.shopware.com/u/Ladenbesitzer)
#### Post date: [6. August 2016 um 09:13 UTC](https://forum.shopware.com/t/gelost-503-service-unavailable-nichts-dergleichen-in-der-suche-gefunden/38834/5 "2016-08-06T09:13:28Z")

</div>

Guten Morgen,

die Änderung an den Foreign Keys hat leider nicht geholfen, wobei der cache Ordner nicht gelöscht werden konnte, weil er nicht an der in der Anleitung befindlichen Stelle liegt.

Den Eintrag s\_core\_plugins habe ich gefunden.  
Soll ich dort für “active” int(1) unsigned auf int(0) unsigned ändern?

---

<div class="post-metadata">

### Author: ![Synonymous](https://avatars.discourse-cdn.com/v4/letter/s/57b2e6/32.png) [@Synonymous](https://forum.shopware.com/u/Synonymous)
#### Post date: [6. August 2016 um 10:04 UTC](https://forum.shopware.com/t/gelost-503-service-unavailable-nichts-dergleichen-in-der-suche-gefunden/38834/6 "2016-08-06T10:04:08Z")

</div>

Lösche mal die Inhalte von var/cache bzw. starte das Shell-Script clear-cache.sh in diesem Directory und versuche es dann nochmals.

---

<div class="post-metadata">

### Author: ![Ladenbesitzer](https://avatars.discourse-cdn.com/v4/letter/l/dc4da7/32.png) [@Ladenbesitzer](https://forum.shopware.com/u/Ladenbesitzer)
#### Post date: [6. August 2016 um 13:13 UTC](https://forum.shopware.com/t/gelost-503-service-unavailable-nichts-dergleichen-in-der-suche-gefunden/38834/7 "2016-08-06T13:13:36Z")

</div>

Es funktioniert!

Vielen Dank euch Zwei 🙂

PS: Sollte ich die Modifikaton mit den Foreign Keys drinlassen?

---

<div class="post-metadata">

### Author: ![Synonymous](https://avatars.discourse-cdn.com/v4/letter/s/57b2e6/32.png) [@Synonymous](https://forum.shopware.com/u/Synonymous)
#### Post date: [6. August 2016 um 13:45 UTC](https://forum.shopware.com/t/gelost-503-service-unavailable-nichts-dergleichen-in-der-suche-gefunden/38834/8 "2016-08-06T13:45:12Z")

</div>

Gerne… Frage zu Foreign Keys muss Dir Moritz beantworten.

---

<div class="post-metadata">

### Author: ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)
#### Post date: [6. August 2016 um 14:53 UTC](https://forum.shopware.com/t/gelost-503-service-unavailable-nichts-dergleichen-in-der-suche-gefunden/38834/9 "2016-08-06T14:53:43Z")

</div>

Das ist nur ein SQL Scipt, dass deine Datenbank repariert. Das ist keine Modifikation, daher kannst du auch nichts zurückbauen&nbsp; ![Wink](https://forum.shopware.com/plugins/CKEditor/plugins/smiley/images/wink.png "Wink")
