# Frontend Fehler

**URL:** <https://forum.shopware.com/t/frontend-fehler/44862>\
**Category:** Allgemein\
**Created:** [28. März 2017 um 16:46 UTC](https://forum.shopware.com/t/frontend-fehler/44862 "2017-03-28T16:46:47Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![TrikeRanch](https://avatars.discourse-cdn.com/v4/letter/t/919ad9/32.png) [@TrikeRanch](https://forum.shopware.com/u/TrikeRanch)\
**Post date:** [28. März 2017 um 16:46 UTC](https://forum.shopware.com/t/frontend-fehler/44862/1 "2017-03-28T16:46:47Z")

</div>

Nach dem Update auf 5.2.21 ist das frontend nicht mehr erreichbar und folgende Fehlermeldung wird angezeigt:

Fatal error: Uncaught Error: Call to a member function getHost() on null in /mnt/web220/b3/64/5247464/htdocs/shop/engine/Shopware/Plugins/Default/Core/Router/Bootstrap.php:79 Stack trace: #0 /mnt/web220/b3/64/5247464/htdocs/shop/engine/Library/Enlight/Event/Handler/Plugin.php(149): Shopware\_Plugins\_Core\_Router\_Bootstrap-\>onRouteStartup(Object(Enlight\_Controller\_EventArgs)) #1 /mnt/web220/b3/64/5247464/htdocs/shop/engine/Library/Enlight/Event/EventManager.php(214): Enlight\_Event\_Handler\_Plugin-\>execute(Object(Enlight\_Controller\_EventArgs)) #2 /mnt/web220/b3/64/5247464/htdocs/shop/engine/Library/Enlight/Controller/Front.php(156): Enlight\_Event\_EventManager-\>notify(‘Enlight\_Control…’, Object(Enlight\_Controller\_EventArgs)) #3 /mnt/web220/b3/64/5247464/htdocs/shop/engine/Shopware/Kernel.php(180): Enlight\_Controller\_Front-\>dispatch() #4 /mnt/web220/b3/64/5247464/htdocs/shop/vendor/symfony/http-kernel/HttpCache/HttpCache.php(491): Shopware\Kernel-\>handle(Object(Enlight\_Controller\_Request\_RequestHttp), 1, true) #5 /mnt/web220/b in /mnt/web220/b3/64/5247464/htdocs/shop/engine/Shopware/Plugins/Default/Core/Router/Bootstrap.php on line 79

Bin um ehrlich zu sein da relativ schnell mit meinem Latein am Ende, wo müsste ich denn zur Lösung ansetzen?

---

<div class="post-metadata">

**Author:** ![Moritz\_Naczenski](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/moritz_naczenski/32/7792_2.png) [@Moritz\_Naczenski](https://forum.shopware.com/u/Moritz_Naczenski)\
**Post date:** [28. März 2017 um 17:59 UTC](https://forum.shopware.com/t/frontend-fehler/44862/2 "2017-03-28T17:59:30Z")

</div>

Hast du denn in den Grundeinstellungen \> Shopeinstellungen \> Shops einen Host hinterlegt?

---

<div class="post-metadata">

**Author:** ![TrikeRanch](https://avatars.discourse-cdn.com/v4/letter/t/919ad9/32.png) [@TrikeRanch](https://forum.shopware.com/u/TrikeRanch)\
**Post date:** [28. März 2017 um 18:08 UTC](https://forum.shopware.com/t/frontend-fehler/44862/3 "2017-03-28T18:08:16Z")

</div>

Ja es ist ein Host in der Grundeinstellung hinterlegt.

---

<div class="post-metadata">

**Author:** ![TrikeRanch](https://avatars.discourse-cdn.com/v4/letter/t/919ad9/32.png) [@TrikeRanch](https://forum.shopware.com/u/TrikeRanch)\
**Post date:** [28. März 2017 um 18:29 UTC](https://forum.shopware.com/t/frontend-fehler/44862/4 "2017-03-28T18:29:54Z")

</div>

Der Hinweis war trotzdem super! Hab nochmals die Grundeinstellung genau unter die Lupe genommen, und siehe da, der Host war zwar korrekt eingetragen, aber nicht aktiv.

Kleine Ursache, große Wirkung, ich kann Dir gar nicht oft genug danken!
