# Fehlerseiten

**URL:** https://forum.shopware.com/t/fehlerseiten/8717
**Category:** Shopware 3.5
**Tags:** general
**Created:** [18. September 2012 um 17:08 UTC](https://forum.shopware.com/t/fehlerseiten/8717 "2012-09-18T17:08:12Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![simplybecause](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/simplybecause/32/7845_2.png) [@simplybecause](https://forum.shopware.com/u/simplybecause)
#### Post date: [18. September 2012 um 17:08 UTC](https://forum.shopware.com/t/fehlerseiten/8717/1 "2012-09-18T17:08:12Z")

</div>

Gibt es einen besonderen Trick, Fehlerseiten nicht auf die Startseite weiterleiten zu lassen und stattdessen eigene Fehlerseiten zu verwenden? Die Option im Backend unter Module/Seo „Bei nicht vorhandenen Kategorien/Artikel auf Startseite umleiten“ habe ich bereits deaktiviert. Es wird jedoch weiterhin auf die Startseite weitergeleitet. Problem ist, dass nicht immer Fehler ins errorlog geschrieben werden und ich deshalb nicht herausfinden kann, wo die Ursache liegt. Dachte, ich könnte durch das Ausschalten der Weiterleitung des Shops die Ursache herausfinden. Das Plugin „404 Fehlerseite“ ist ebenfalls deaktiviert.

---

<div class="post-metadata">

### Author: ![Patrick\_Stahl](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/patrick_stahl/32/7679_2.png) [@Patrick\_Stahl](https://forum.shopware.com/u/Patrick_Stahl)
#### Post date: [18. September 2012 um 17:27 UTC](https://forum.shopware.com/t/fehlerseiten/8717/2 "2012-09-18T17:27:46Z")

</div>

Hallo Frank, du meinst vermutlich folgende Stelle in der .htaccess: ` RewriteCond %{REQUEST\_URI} !(\/(engine|files|templates)\/) RewriteCond %{REQUEST\_URI} !(\/media\/(archive|banner|image|music|pdf|unknown|video)\/) RewriteCond %{REQUEST\_FILENAME} !-f RewriteCond %{REQUEST\_FILENAME} !-d RewriteRule ^(.\*)$ shopware.php [PT,L,QSA] ` Hier wird einfach abgeprüft, ob: a) Die URL zu dem Ordner engine/files/templates führt ODER b) die URL zu einem Unterordner von media/ führt ODER c) es sich um eine Datei oder einem Verzeichnis handelt Wenn weder a), b) und c) eintreffen, wird auf shopware.php weitergeleitet. Hilft dir das weiter? Gruß, Patrick :shopware:

---

<div class="post-metadata">

### Author: ![eWeniger](https://avatars.discourse-cdn.com/v4/letter/e/9de053/32.png) [@eWeniger](https://forum.shopware.com/u/eWeniger)
#### Post date: [19. September 2012 um 06:47 UTC](https://forum.shopware.com/t/fehlerseiten/8717/3 "2012-09-19T06:47:51Z")

</div>

@simplybecause wenn Du dazu eine Lösung hast, würdest Du die hier posten? Ich versuche seit einiger Zeit das hinzubekommen. Viele Dank.

---

<div class="post-metadata">

### Author: ![simplybecause](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/simplybecause/32/7845_2.png) [@simplybecause](https://forum.shopware.com/u/simplybecause)
#### Post date: [20. September 2012 um 09:14 UTC](https://forum.shopware.com/t/fehlerseiten/8717/4 "2012-09-20T09:14:19Z")

</div>

@Patrick Danke für den Wink, den ich allerdings nicht verstehe. ;( Wenn Dein Posting die Lösung sein soll, was muss ich ändern, damit eine eigene Fehlerseite aufgerufen werden kann? By the way, der Eintrag in meiner .htaccess (3.5.6) lautet ` RewriteCond %{REQUEST\_URI} !(engine\/|images\/|files\/|templates\/|\.js$|\.css$|\.jpg$|\.png$) RewriteCond %{REQUEST\_FILENAME} !-f RewriteCond %{REQUEST\_FILENAME} !-d RewriteRule ^(.\*)$ shopware.php [PT,L,QSA] ` und weicht damit von Deinem Code ab.

---

<div class="post-metadata">

### Author: ![simplybecause](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/simplybecause/32/7845_2.png) [@simplybecause](https://forum.shopware.com/u/simplybecause)
#### Post date: [20. September 2012 um 09:14 UTC](https://forum.shopware.com/t/fehlerseiten/8717/5 "2012-09-20T09:14:50Z")

</div>

[quote=„eweniger“]@simplybecause wenn Du dazu eine Lösung hast, würdest Du die hier posten? Ich versuche seit einiger Zeit das hinzubekommen. Viele Dank.[/quote] Jepps, mach ich. 😉

---

<div class="post-metadata">

### Author: ![Patrick\_Stahl](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/patrick_stahl/32/7679_2.png) [@Patrick\_Stahl](https://forum.shopware.com/u/Patrick_Stahl)
#### Post date: [26. September 2012 um 17:07 UTC](https://forum.shopware.com/t/fehlerseiten/8717/6 "2012-09-26T17:07:19Z")

</div>

Hallo, ich bin davon ausgegangen, dass du die Fehlerseite meinst, wenn ein Kunde einen falschen Link aufruft, bspw.: [http://www.meinShop.de/testThis](http://www.meinShop.de/testThis) Da „testThis“ nicht existiert, würde ich auf die Startseite verlinkt. Falls das gemeint ist: Änder’ in der .htaccess einfach „shopware.php“ zu meinetwegen „error.php“. Somit würden alle Links, die nicht existieren, nicht mehr zu shopware.php und somit zur Startseite verlinkt werden, sondern zu der eigens erstellten „error.php“. Hilft dir das weiter? Gruß, Patrick :shopware:

---

<div class="post-metadata">

### Author: ![simplybecause](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/simplybecause/32/7845_2.png) [@simplybecause](https://forum.shopware.com/u/simplybecause)
#### Post date: [28. September 2012 um 08:48 UTC](https://forum.shopware.com/t/fehlerseiten/8717/7 "2012-09-28T08:48:29Z")

</div>

Hallo Patrick, das meinte ich - danke. 🙂 Werd ich am WE mal versuchen. Ich habe in einem anderen Thread schon mal gefragt wegen User-Agents. Wir haben immer wieder den Fehler 404 vom User-Agent Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.1 (KHTML, like Gecko) Chrome/21.0.1180.89 Safari/537.1 Ich kann es allerdings nicht nachvollziehen. Wenn ich den Referrer-Link klicke, ist alles okay. Kann mir jemand auf die Sprünge helfen und erklären, warum dieser User-Agent Fehler verursacht?

---

<div class="post-metadata">

### Author: ![meg-line](https://avatars.discourse-cdn.com/v4/letter/m/8e8cbc/32.png) [@meg-line](https://forum.shopware.com/u/meg-line)
#### Post date: [2. Dezember 2012 um 17:53 UTC](https://forum.shopware.com/t/fehlerseiten/8717/8 "2012-12-02T17:53:07Z")

</div>

[quote=„Patrick Stahl“]Hallo, Änder’ in der .htaccess einfach „shopware.php“ zu meinetwegen „error.php“. Somit würden alle Links, die nicht existieren, nicht mehr zu shopware.php und somit zur Startseite verlinkt werden, sondern zu der eigens erstellten „error.php“. [/quote] Hallo Patrik, soeben habe ich deinen Rat ausprobiert und mich vorab gefreut, das es so leicht ging. Leider musste ich jedoch feststellen, dass diese Änderung jedoch dazu führt, dass alle Seiten auf die error.php weiterleiten. Was habe ich falsch gemacht? EDIT: Allerdings nutze ich Shopware 4.0.4

---

<div class="post-metadata">

### Author: ![Neuland\_Communicatio](https://avatars.discourse-cdn.com/v4/letter/n/8edcca/32.png) [@Neuland\_Communicatio](https://forum.shopware.com/u/Neuland_Communicatio)
#### Post date: [22. Januar 2013 um 11:41 UTC](https://forum.shopware.com/t/fehlerseiten/8717/9 "2013-01-22T11:41:19Z")

</div>

Hallo, gibt es zu der Problematik bereits eine Lösung? Grüße!
