# Fehlermeldung im Backend

**URL:** <https://forum.shopware.com/t/fehlermeldung-im-backend/38207>\
**Category:** Programmierung\
**Created:** [13. Juli 2016 um 16:32 UTC](https://forum.shopware.com/t/fehlermeldung-im-backend/38207 "2016-07-13T16:32:13Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Der\_Segler](https://avatars.discourse-cdn.com/v4/letter/d/c4cdca/32.png) [@Der\_Segler](https://forum.shopware.com/u/Der_Segler)\
**Post date:** [13. Juli 2016 um 16:32 UTC](https://forum.shopware.com/t/fehlermeldung-im-backend/38207/1 "2016-07-13T16:32:13Z")

</div>

Servus. Mir wird diese Fehlermeldung nach dem Update angezeigt.

&nbsp;

**Fatal error** : Call to a member function getHeaders() on a non-object in&nbsp; **/www/htdocs/w00ff2d2/engine/Shopware/Kernel.php** &nbsp;on line&nbsp; **197**

In Forum finde ich nicht. Hat da ein Herr von Shopware eine Idee?

---

<div class="post-metadata">

**Author:** ![Synonymous](https://avatars.discourse-cdn.com/v4/letter/s/57b2e6/32.png) [@Synonymous](https://forum.shopware.com/u/Synonymous)\
**Post date:** [13. Juli 2016 um 16:33 UTC](https://forum.shopware.com/t/fehlermeldung-im-backend/38207/2 "2016-07-13T16:33:18Z")

</div>

Update von wo nach wo?

---

<div class="post-metadata">

**Author:** ![Der\_Segler](https://avatars.discourse-cdn.com/v4/letter/d/c4cdca/32.png) [@Der\_Segler](https://forum.shopware.com/u/Der_Segler)\
**Post date:** [14. Juli 2016 um 07:37 UTC](https://forum.shopware.com/t/fehlermeldung-im-backend/38207/3 "2016-07-14T07:37:36Z")

</div>

Guten Morgen. Altbestand war 4.0.6.

Dann habe ich die Mirror bis 4.1.0 durchgeführt und dann das auf 5.0.0.

Zwischendurch kamen Fehlermeldungen bezühlich Fehlender Daten aus 4.2.6.

Schlussendlich bleibt diese eine Meldung bestehen

---

<div class="post-metadata">

**Author:** ![Der\_Segler](https://avatars.discourse-cdn.com/v4/letter/d/c4cdca/32.png) [@Der\_Segler](https://forum.shopware.com/u/Der_Segler)\
**Post date:** [14. Juli 2016 um 10:54 UTC](https://forum.shopware.com/t/fehlermeldung-im-backend/38207/4 "2016-07-14T10:54:05Z")

</div>

So, ich habe nun Update von 5.0.0 auf 5.2.2 gemacht. Gab zwar ein problem mit folgender Fehlermeldung:

Error Received the following error message: Could not apply migration (Migrations\_Migration633). Error: SQLSTATE[42000]: Syntax error or access violation: 1061 Duplicate key name ‘mapping\_id’ Please try to fix this error and restart the update. Response {“valid”:false,“errorMsg”:"Could not apply migration (Migrations\_Migration633). Error: SQLSTATE[42000]: Syntax error or access violation: 1061 Duplicate key name ‘mapping\_id’ "}

Durch löschen der doppelten Zeile bezüglich&nbsp;‘mapping\_id’, lief das DB Update durch und nun funktioniert alles so weit.

In dem Fall Post gelöst&nbsp; ![Shopware](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/86c57fbace799dd4eb1f1b8a2d3bdc1733f0aea1.png "Shopware") ![Thumb-Up](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/7fcda44f782696668a3d093569d15e88105769e1.png "Thumb-Up") ![Wearing-Sunglasses](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/301eaa4db0af1251d93dae7904e5b71a4b15e729.png "Wearing-Sunglasses")

&nbsp;

---

<div class="post-metadata">

**Author:** ![Cati-Collection](https://avatars.discourse-cdn.com/v4/letter/c/ecccb3/32.png) [@Cati-Collection](https://forum.shopware.com/u/Cati-Collection)\
**Post date:** [10. September 2016 um 14:55 UTC](https://forum.shopware.com/t/fehlermeldung-im-backend/38207/5 "2016-09-10T14:55:53Z")

</div>

Hallo Der Segler,

wie und wo hast Du die doppelte Zeite ´mapping\_id`gelöscht? Ich habe gerade das selbe Problem das die Datenbank Migration hängen bleibt und genau diese Fehler angezeigt wird.&nbsp;

Update:

Habe die Lösung hier gefunden:&nbsp;[https://forum.shopware.com/discussion/35781/allgemein-zu-5-1-4-rc-im-backend-update-auf-5-1-4-rc-trotz-stable/p1#Comment\_155838](https://forum.shopware.com/discussion/35781/allgemein-zu-5-1-4-rc-im-backend-update-auf-5-1-4-rc-trotz-stable/p1#Comment_155838)

---

<div class="post-metadata">

**Author:** ![sschreier](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/sschreier/32/23296_2.png) [@sschreier](https://forum.shopware.com/u/sschreier)\
**Post date:** [10. September 2016 um 16:28 UTC](https://forum.shopware.com/t/fehlermeldung-im-backend/38207/6 "2016-09-10T16:28:36Z")

</div>

> [@Cati-Collection schrieb:](https://forum.shopware.com/profile/2646/Cati-Collection "Cati-Collection")
> 
> Hallo Der Segler,
> 
> wie und wo hast Du die doppelte Zeite ´mapping\_id`gelöscht? Ich habe gerade das selbe Problem das die Datenbank Migration hängen bleibt und genau diese Fehler angezeigt wird.&nbsp;
> 
> Update:
> 
> Habe die Lösung hier gefunden:&nbsp;[https://forum.shopware.com/discussion/35781/allgemein-zu-5-1-4-rc-im-backend-update-auf-5-1-4-rc-trotz-stable/p1#Comment\_155838](https://forum.shopware.com/discussion/35781/allgemein-zu-5-1-4-rc-im-backend-update-auf-5-1-4-rc-trotz-stable/p1#Comment_155838)

Hallo,

dazu gibt es auch zwei ausführliche Dokumentationen:

[https://forum.shopware.com/discussion/comment/155768/#Comment%5C\_155768](https://forum.shopware.com/discussion/comment/155768/#Comment%5C_155768)

[https://forum.shopware.com/discussion/comment/155838/#Comment%5C\_155838](https://forum.shopware.com/discussion/comment/155838/#Comment%5C_155838)

Beste Grüße

Sebastian
