# Fehlermeldung: Could not convert database value to 'object' as an error was triggered by the unserialization

**URL:** <https://forum.shopware.com/t/fehlermeldung-could-not-convert-database-value-to-object-as-an-error-was-triggered-by-the-unserialization/103477>\
**Category:** Shopware 5\
**Created:** [28. März 2024 um 18:22 UTC](https://forum.shopware.com/t/fehlermeldung-could-not-convert-database-value-to-object-as-an-error-was-triggered-by-the-unserialization/103477 "2024-03-28T18:22:09Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![futterbutze](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/futterbutze/32/23925_2.png) [@futterbutze](https://forum.shopware.com/u/futterbutze)\
**Post date:** [28. März 2024 um 18:22 UTC](https://forum.shopware.com/t/fehlermeldung-could-not-convert-database-value-to-object-as-an-error-was-triggered-by-the-unserialization/103477/1 "2024-03-28T18:22:09Z")

</div>

Moin zusammen

Wenn ich im Backend Grundeinstellungen die Einstellungen vom Plugin „Shopware Notification Bar Pro“ öffnen möchte, dann erscheint der Fehler  
`Could not convert database value to 'object' as an error was triggered by the unserialization: 'unserialize(): Error at offset 2 of 9 bytes'`  
im log.

Der Plugin Hersteller weiß leider nicht weiter, verweist als Lösungsvorschlag auf:

> [@503 Fehler beim Abruf der Stammdaten](https://forum.shopware.com/t/503-fehler-beim-abruf-der-stammdaten/98742/3):
>
> Hallo Markus, Danke Dir für Deine hilfreiche Antwort. Ich habe nun die Plugins getestet. Alles ohne Probleme. Habe dann das erweitere Debugging eingeschaltet und erhalte nun folgenden Fehler: Widgets Loading Stammdaten… Ups! Ein Fehler ist aufgetreten! Die nachfolgenden Hinweise sollten Ihnen weiterhelfen. Could not convert database value to ‚object‘ as an error was triggered by the unserialization: ‚unserialize(): Error at offset 2 of 127 bytes‘ in /www/htdocs/tona3/vendor/doctrine/dbal/lib…

Wenn wir das Plugin manuell deinstallieren und wieder installieren wollen, dann klappt das ohne Fehlermeldung. Das Plugin ist installiert und aktiviert.

Hat jemand eine Idee oder einen Ansatz wie das Problem gelöst werden könnte?

Vielen Dank

Gruß  
Tom

---

<div class="post-metadata">

**Author:** ![Lenovo](https://avatars.discourse-cdn.com/v4/letter/l/58f4c7/32.png) [@Lenovo](https://forum.shopware.com/u/Lenovo)\
**Post date:** [20. August 2024 um 12:37 UTC](https://forum.shopware.com/t/fehlermeldung-could-not-convert-database-value-to-object-as-an-error-was-triggered-by-the-unserialization/103477/2 "2024-08-20T12:37:11Z")

</div>

Hallo Tom,  
wir hatten soeben das gleiche Problem und konnten es beheben, indem wir einen Eintrag manuell aus der Datenbank gelöscht haben:  
In unserem Fall wurde in der Backend-Fehlermeldung im Stack-Trace noch folgendes mitgegeben:  
„#2 /[…]/lib/Doctrine/DBAL/Types/ObjectType.php(51): unserialize('s:225:“\<div sty…')"

Mit der folgenden Query haben wir dann in der Datenbank kurzerhand mal die Einträge des Plugins in der Config gesichtet.  
Wir wollten alle Einträge je shop sichten, daher haben wir die Query wie nachfolgend aufgebaut. Wenn Du die letzte Zeile weg lässt, bekommst Du natürlich alle Einträge des Plugins unabhängig vom Shop ausgegeben. Die wichtige Info ist dann die ID, die Dir in der Spalte „element\_id“ ausgegeben wird. Das ist dann später die ID des Datensatzes in der Tabelle „s\_core\_config\_values“:

SELECT sccf.id AS formId, scce.id, scce.name, scce.value, sccv.element\_id, sccv.shop\_id, sccv.value  
FROM s\_core\_config\_forms sccf LEFT JOIN s\_core\_config\_elements scce ON sccf.id = scce.form\_id  
LEFT JOIN s\_core\_config\_values sccv ON scce.id = sccv.element\_id  
WHERE sccf.name = ‚BenroeNotificationbarpro‘  
AND sccv.shop\_id = ‚1‘

Letztlich haben wir dann kurzerhand den Inhalt im Feld „value“ in der Table „s\_core\_config\_values“ für den Datensatz mit dem startenden Inhalt „\<div sty…“ (wie oben im Stack-Trace angegeben) gelöscht.

Ab dann wurde keine Fehlermeldung beim Öffnen der Plugin-Konfiguration mehr angezeigt und wir konnten neuen Inhalt eingeben.  
Vielleicht hilft Dir oder anderen die Info ja weiter.
