# Fehlermeldung beim Installation mit One-File Installer

**URL:** https://forum.shopware.com/t/fehlermeldung-beim-installation-mit-one-file-installer/57372
**Category:** Installation/Einstieg
**Created:** [9. Januar 2019 um 14:33 UTC](https://forum.shopware.com/t/fehlermeldung-beim-installation-mit-one-file-installer/57372 "2019-01-09T14:33:41Z")
**Posts on this page:** 8
**Page:** 1

<div class="post-metadata">

### Author: ![Aragorn68](https://avatars.discourse-cdn.com/v4/letter/a/f0a364/32.png) [@Aragorn68](https://forum.shopware.com/u/Aragorn68)
#### Post date: [9. Januar 2019 um 14:33 UTC](https://forum.shopware.com/t/fehlermeldung-beim-installation-mit-one-file-installer/57372/1 "2019-01-09T14:33:41Z")

</div>

Ich habe PHP erstmal auf 5.6 eingestellt weil es angeblich mit 7.0 Probleme gibt.

Datei Index.php in das Verzeichnis gelegt und folgende Einträge stehen in der php5.6.ini und .htaccess

\*\*php5.6.ini\*\*

upload\_max\_filesize = 50M  
allow\_url\_fopen = On  
display\_errors = Off  
magic\_quotes\_gpc = Off  
max\_execution\_time = 600  
memory\_limit = 1024M

extension\_dir="/usr/local/php\_extensions/php5.6/"  
extension=„apcu.so“

date.timezone = ‚Europe/Berlin‘  
date.default\_latitude = 52.5194  
date.default\_longitude = 13.4067

;verfuegbare PECL Erweiterungen  
;extension\_dir="/usr/local/php\_extensions/php5.6/"  
;extension=„apcu.so“  
;extension=„imagick.so“  
;extension=„ssh2.so“  
;extension=„dbase.so“  
;extension=„geoip.so“  
;extension=„redis.so“  
;extension=„tideways.so“  
;extension=„xdebug.so“

[Zend]

;Ioncube Loader

zend\_extension=/usr/local/php\_extensions/php5.6/ioncube.so  
zend\_extension=/usr/local/php\_extensions/php5.6/opcache.so  
opcache.memory\_consumption=128  
opcache.max\_accelerated\_files=10000  
opcache.max\_wasted\_percentage=10

;ZendGuard Loader

;zend\_extension="/usr/local/Zend/lib/ZendGuard/php-5.6.x/ZendGuardLoader.so"  
;zend\_loader.enable=1  
;zend\_loader.disable\_licensing=1

;Nach Möglichkeit immer nutzen: OpCache  
;die memory\_consumption kann auf 64 reduziert werden um RAM zu sparen  
;im Webhosting bis einschl. business muss immer opcache.memory\_consumption=64 definiert werden

;zend\_extension=/usr/local/php\_extensions/php5.6/opcache.so  
;opcache.memory\_consumption=128  
;opcache.max\_accelerated\_files=10000  
;opcache.max\_wasted\_percentage=10

\*\*.htaccess\*\*

# Liste der Dateiendungen die als PHP7.0 verarbeitet werden sollen

AddHandler php-fastcgi5.6 .php .phtml

&nbsp;

Folgende Fehlermeldung wird erzeugt nach dem Aufruf der index.php

&nbsp;

**Warning** : file\_get\_contents(): http:// wrapper is disabled in the server configuration by allow\_url\_fopen=0 in&nbsp; **/home/intjebhy/\*\*\*\*/index.php** &nbsp;on line&nbsp; **66**

**Warning** : file\_get\_contents([http://update-api.shopware.com/v1/releases/install](http://update-api.shopware.com/v1/releases/install)): failed to open stream: no suitable wrapper could be found in&nbsp; **/home/intjebhy/\*\*\*\*/index.php** &nbsp;on line&nbsp; **66**

**Warning** : array\_key\_exists() expects parameter 2 to be array, null given in&nbsp; **/home/intjebhy/\*\*\*\*/index.php** &nbsp;on line&nbsp; **68**

**Fatal error** : Uncaught exception ‚Exception‘ with message ‚Could not load latest version information from server‘ in /home/intjebhy/\*\*\*\*/index.php:69 Stack trace: #0 {main} thrown in&nbsp; **/home/intjebhy/\*\*\*\*/index.php** &nbsp;on line&nbsp; **69**

---

<div class="post-metadata">

### Author: ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)
#### Post date: [9. Januar 2019 um 14:57 UTC](https://forum.shopware.com/t/fehlermeldung-beim-installation-mit-one-file-installer/57372/2 "2019-01-09T14:57:51Z")

</div>

> file\_get\_contents(): http:// wrapper is disabled in the server configuration by allow\_url\_fopen=0

Nun in der Fehlermeldung steht ja das Problem dar. Also Server anpassen bzw. an den Hoster wenden.

---

<div class="post-metadata">

### Author: ![Aragorn68](https://avatars.discourse-cdn.com/v4/letter/a/f0a364/32.png) [@Aragorn68](https://forum.shopware.com/u/Aragorn68)
#### Post date: [9. Januar 2019 um 15:04 UTC](https://forum.shopware.com/t/fehlermeldung-beim-installation-mit-one-file-installer/57372/3 "2019-01-09T15:04:20Z")

</div>

aber wenn ich PHP 5.4 verwende kommt diese Fehlermeldung nicht. Muss ich nicht etwas zusätzlich in der htaccess oder der php.ini einstellen?

---

<div class="post-metadata">

### Author: ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)
#### Post date: [9. Januar 2019 um 15:07 UTC](https://forum.shopware.com/t/fehlermeldung-beim-installation-mit-one-file-installer/57372/4 "2019-01-09T15:07:25Z")

</div>

Du kannst per htaccess versuchen: php\_value allow\_url\_fopen On

oder per php.ini: allow\_url\_fopen = On; bzw. allow\_url\_fopen=1;

---

<div class="post-metadata">

### Author: ![Aragorn68](https://avatars.discourse-cdn.com/v4/letter/a/f0a364/32.png) [@Aragorn68](https://forum.shopware.com/u/Aragorn68)
#### Post date: [9. Januar 2019 um 15:24 UTC](https://forum.shopware.com/t/fehlermeldung-beim-installation-mit-one-file-installer/57372/5 "2019-01-09T15:24:30Z")

</div>

Wie oben in der php.ini Datei schon angegeben habe ich diesen Eintrag bereits schon enthalten.

---

<div class="post-metadata">

### Author: ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)
#### Post date: [9. Januar 2019 um 15:32 UTC](https://forum.shopware.com/t/fehlermeldung-beim-installation-mit-one-file-installer/57372/6 "2019-01-09T15:32:29Z")

</div>

Wird der Install ggf. noch durch eine andere PHP-Version ausgeführt? Hast du mal per htaccess versucht? Eventuell auch mal den Hoster fragen.

---

<div class="post-metadata">

### Author: ![Aragorn68](https://avatars.discourse-cdn.com/v4/letter/a/f0a364/32.png) [@Aragorn68](https://forum.shopware.com/u/Aragorn68)
#### Post date: [9. Januar 2019 um 15:46 UTC](https://forum.shopware.com/t/fehlermeldung-beim-installation-mit-one-file-installer/57372/7 "2019-01-09T15:46:49Z")

</div>

Folgende Einträge habe ich in der htaccess Datei:

# Liste der Dateiendungen die als PHP7.0 verarbeitet werden sollen

AddHandler php-fastcgi5.6 .php .phtml

RewriteEngine on  
RewriteCond 1 !^(index\.php|system|css|functions) RewriteRule ^(.\*) index.php?/$1 [L]

php\_value allow\_url\_fopen On

&nbsp;

Damit bekomme ich nun einen Internal Server Error. Sobald ich das php\_value raus nehme der alte Fehler. Ich habe es erstmal an Profihost gegeben damit die mal schauen.

---

<div class="post-metadata">

### Author: ![TimmeHosting](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/timmehosting/32/15580_2.png) [@TimmeHosting](https://forum.shopware.com/u/TimmeHosting)
#### Post date: [9. Januar 2019 um 17:14 UTC](https://forum.shopware.com/t/fehlermeldung-beim-installation-mit-one-file-installer/57372/8 "2019-01-09T17:14:58Z")

</div>

Versuch’ es mal mit

```
php_flag allow_url_fopen On

```

php\_flag nimmst Du, wenn Du einen Parameter auf on oder off bzw. 1 oder 0 setzen kannst, php\_value bei allen anderen.

![](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/1X/385eaa628505df573ebf33722f780335f53ac1b2.png)

Timme Hosting - schnelles nginx-Hosting

[www.timmehosting.de](https://timmehosting.de/)
