# Fehlermeldung beim Aufrufen des Shop als admin

**URL:** <https://forum.shopware.com/t/fehlermeldung-beim-aufrufen-des-shop-als-admin/101360>\
**Category:** Administration\
**Tags:** administration\
**Created:** [24. September 2023 um 09:03 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufrufen-des-shop-als-admin/101360 "2023-09-24T09:03:07Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![hadilowebdesign](https://avatars.discourse-cdn.com/v4/letter/h/ed8c4c/32.png) [@hadilowebdesign](https://forum.shopware.com/u/hadilowebdesign)\
**Post date:** [24. September 2023 um 09:03 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufrufen-des-shop-als-admin/101360/1 "2023-09-24T09:03:08Z")

</div>

{„errors“:[{„code“:„0“,„status“:„500“,„title“:„Internal Server Error“,„detail“:„[Semantical Error] The annotation \u0022@Shopware\Core\Framework\Routing\Annotation\RouteScope\u0022 in class SwagExtensionStore\Controller\DataController was never imported. Did you maybe forget to add a \u0022use\u0022 statement for this annotation? in /www/htdocs/w01e00da/[shop.alkana-tarot.de](http://shop.alkana-tarot.de/)/custom/plugins/SwagExtensionStore/src/Controller/DataController.php (which is being imported from \u0022/www/htdocs/w01e00da/[shop.alkana-tarot.de](http://shop.alkana-tarot.de/)/custom/plugins/SwagExtensionStore/src/Resources/config/routes.yaml\u0022). Make sure there is a loader supporting the \u0022annotation\u0022 type.“}]}

Was muss ich tun um diesen zu beheben?

---

<div class="post-metadata">

**Author:** ![chamaw](https://avatars.discourse-cdn.com/v4/letter/c/b487fb/32.png) [@chamaw](https://forum.shopware.com/u/chamaw)\
**Post date:** [24. September 2023 um 11:35 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufrufen-des-shop-als-admin/101360/2 "2023-09-24T11:35:54Z")

</div>

sieht mir nach einem Problem nach einem Update aus, und da ist wohl was im Cache hängen geblieben. Wenn Du Zugriff auf eine SSH Console hast, vielleicht erstmal hier den Cache löschen.

**Danach erst weitermachen, mit einem Backup, evtl. zerlegst Du mir mit den nachfolgenden Punkte Deinen kompletten Shop !!!**

Wenn das nicht geht mit FTP die Datei bearbeiten, unter custom/plugins/SwagExtensionStore  
und dann im Verzeichnis src/Controller

da steht dann recht weit oben :

```auto
/**
 * @internal
 * @RouteScope(scopes={"api"})
 * @Acl({"system.plugin_maintain"})
 */
class DataController
{

```

die Zeile @RouteScope(scopes={„api“}) löschen. Letztlich reicht hier auch nur das AT Zeichen rauszulöschen.  
Danach müsstest Du zumindest wieder in die Admin-App kommen. Evtl. kannst Du dann von dort den Cache löschen.  
ABER Achtung, das zerstört dann definitiv den Zugang zum SW-Store !!! Sprich danach sollte das wieder zurück in den Code … ALSO bitte ohne Gewähr und auf JEDEN Fall ein Backup der DB falls das noch geht !!!

---

<div class="post-metadata">

**Author:** ![hadilowebdesign](https://avatars.discourse-cdn.com/v4/letter/h/ed8c4c/32.png) [@hadilowebdesign](https://forum.shopware.com/u/hadilowebdesign)\
**Post date:** [24. September 2023 um 13:29 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufrufen-des-shop-als-admin/101360/3 "2023-09-24T13:29:15Z")

</div>

Danke für deine Antwort. Hat aber leider keine Veränderung gebracht. Im Store ist derzeit nur ein Artikel. Ist es möglich die Installation kpl neu aufzusetzen?

---

<div class="post-metadata">

**Author:** ![chamaw](https://avatars.discourse-cdn.com/v4/letter/c/b487fb/32.png) [@chamaw](https://forum.shopware.com/u/chamaw)\
**Post date:** [24. September 2023 um 18:54 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufrufen-des-shop-als-admin/101360/4 "2023-09-24T18:54:45Z")

</div>

dann wohl der beste Weg, wenn das „eh nur“ eine Test-Installation ist.

---

<div class="post-metadata">

**Author:** ![hadilowebdesign](https://avatars.discourse-cdn.com/v4/letter/h/ed8c4c/32.png) [@hadilowebdesign](https://forum.shopware.com/u/hadilowebdesign)\
**Post date:** [25. September 2023 um 10:27 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufrufen-des-shop-als-admin/101360/5 "2023-09-25T10:27:29Z")

</div>

Jetzt konnte ich die Installation abschließen und kann die Seite nicht mehr aufrufen.

 ![Screenshot 2023-09-25 120458](https://europe1.discourse-cdn.com/flex013/uploads/shopware/original/3X/1/9/198424079091f1b2327bf8fdaaeae53385e1ca99.jpeg)

Wo liegt jetzt das Problem?

---

<div class="post-metadata">

**Author:** ![ingo.siebeck](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/ingo.siebeck/32/13507_2.png) [@ingo.siebeck](https://forum.shopware.com/u/ingo.siebeck)\
**Post date:** [25. September 2023 um 16:18 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufrufen-des-shop-als-admin/101360/6 "2023-09-25T16:18:21Z")

</div>

Das /public in der URL ist ungewöhnlich. Passt der Basis Pfad in der Config auf dem Server? Der muss direkt ins public Verzeichnis zeigen.

Ansonsten was steht im Logfile? auch vom Webserver?

---

<div class="post-metadata">

**Author:** ![Teddie](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/teddie/32/26013_2.png) [@Teddie](https://forum.shopware.com/u/Teddie)\
**Post date:** [27. September 2023 um 06:54 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufrufen-des-shop-als-admin/101360/7 "2023-09-27T06:54:49Z")

</div>

Geh in die Datenbank, deaktiviere den Shopware Store, dann kannst du wieder ins Backend, den Shopware Store aktualisieren bzw. neu installieren.

Welches Update hast du gemacht? Kenne den Fehler vom Anfang der 6.5.x …

---

<div class="post-metadata">

**Author:** ![hadilowebdesign](https://avatars.discourse-cdn.com/v4/letter/h/ed8c4c/32.png) [@hadilowebdesign](https://forum.shopware.com/u/hadilowebdesign)\
**Post date:** [27. September 2023 um 07:15 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufrufen-des-shop-als-admin/101360/8 "2023-09-27T07:15:57Z")

</div>

Ich hatte das letzte Update ausgeführt. Jetzt kann ich wieder alles als admin aufrufen. Wie bekomme ich das Thema mit dem „Public“ gelöst? Wo muss ich was ändern? Wie erstelle ich meine „Webseite“ für den Shop. Wenn ich diesen jetzt aufrufen möchte, erhalte ich die Meldung, dass keine Produkte gefunden werden. Produkte sind angelegt und aktiv. [https://shop-alkana-tarot.de/publik](https://shop-alkana-tarot.de/publik)

---

<div class="post-metadata">

**Author:** ![area-net-gmbh](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/area-net-gmbh/32/21995_2.png) [@area-net-gmbh](https://forum.shopware.com/u/area-net-gmbh)\
**Post date:** [27. September 2023 um 08:25 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufrufen-des-shop-als-admin/101360/9 "2023-09-27T08:25:53Z")

</div>

- Der Document-Root deiner Domain muss auf den public-Ordner verweisen
- Verkaufskanal-Domain dann entsprechend auf [https://shop-alkana-tarot.de/](https://shop-alkana-tarot.de/) setzen
- Produkte müssen auch dem Verkaufskanal zugewiesen sein

---

<div class="post-metadata">

**Author:** ![rene](https://avatars.discourse-cdn.com/v4/letter/r/7cd45c/32.png) [@rene](https://forum.shopware.com/u/rene)\
**Post date:** [29. September 2023 um 06:32 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufrufen-des-shop-als-admin/101360/10 "2023-09-29T06:32:02Z")

</div>

Hallo,

allderdings sollte auch dein Apache DocumentRoot auf den Pfad /var/xx/Xx/XX/public/ zeigen (wenn ud Aoache nutzt)

Gruß ré

---

<div class="post-metadata">

**Author:** ![hadilowebdesign](https://avatars.discourse-cdn.com/v4/letter/h/ed8c4c/32.png) [@hadilowebdesign](https://forum.shopware.com/u/hadilowebdesign)\
**Post date:** [1. Oktober 2023 um 08:18 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufrufen-des-shop-als-admin/101360/11 "2023-10-01T08:18:10Z")

</div>

Ich komme hier nicht weiter. Der Support von All-Inkl ist auch keine große Hilfe. Hat hier jemand schon mal mit dem Hoster All-Inkl das Thema gelöst und kann mir hier helfen? Wäre echt super.

---

<div class="post-metadata">

**Author:** ![Max\_Shop](https://avatars.discourse-cdn.com/v4/letter/m/58f4c7/32.png) [@Max\_Shop](https://forum.shopware.com/u/Max_Shop)\
**Post date:** [1. Oktober 2023 um 09:12 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufrufen-des-shop-als-admin/101360/12 "2023-10-01T09:12:34Z")

</div>

Habe dort schon mehrere Shops, auch zwei parallel installiert. War nie ein Problem. Lässt sich alles über die Konfiguration von All Ink bzw. .htaccess erledigen.
