# Fehlermeldung beim Aufbauen des Suchindex

**URL:** <https://forum.shopware.com/t/fehlermeldung-beim-aufbauen-des-suchindex/92315>\
**Category:** Shopware 5\
**Created:** [11. Januar 2022 um 13:33 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufbauen-des-suchindex/92315 "2022-01-11T13:33:14Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![DieAnna](https://avatars.discourse-cdn.com/v4/letter/d/77aa72/32.png) [@DieAnna](https://forum.shopware.com/u/DieAnna)\
**Post date:** [11. Januar 2022 um 13:33 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufbauen-des-suchindex/92315/1 "2022-01-11T13:33:14Z")

</div>

Hallo,  
seit ca. 1 – 2 Wochen habe ich ein Problem mit der Suchfunktion des Shops. Die Default Suchwerte von Shopware werden gefunden, also Produktname, Produktnummer und Wörter aus der Beschreibung. Nur die Freitextfelder die ich selbst angelegt habe, findet der Shop nicht mehr.  
Ich dachte zuerst es würde am Cache liegen, da der Shop von Anfang an ein paar Schwierigkeiten damit hatte, aber nach dem Leeren sämtlicher Caches hat es immer noch nicht funktioniert.  
Danach habe ich den Suchindex neu Aufbauen lassen. Dieser hat mir direkt die Fehlermeldung unten ausgegeben.

`Indexierung fehlgeschlagen, weitere Informationen findest Du im Log. 503 Service Unavailable`

Und

```auto
An exception occurred while executing 'INSERT IGNORE INTO s_search_index (keywordID, elementID, fieldID)  
SELECT sk.id as keywordID, 3 as elementID, 5 as fieldID FROM s_search_keywords sk WHERE sk.keyword IN ('SW10002')  
UNION ALL SELECT sk.id as keywordID, 3762 as elementID, 5 as fieldID FROM s_search_keywords sk WHERE sk.keyword IN ('SW10002.1')  
..
SQLSTATE(42000): Syntax error or access violation: 1064 memory exhausted near 'sk.id as keywordID, 4827 as elementID, 5 as fieldID FROM s_search_keywords sk...' at line 15995

```

Ich habe diese Seite gefunden und habe diese bereits durchgearbeitet, allerdings hat es nicht funktioniert und der Suchindex lässt sich weiterhin nicht neu Aufbauen.  
[https://docs.shopware.com/de/shopware-5-de/tutorials-und-faq/suche-debuggen](https://docs.shopware.com/de/shopware-5-de/tutorials-und-faq/suche-debuggen)

Da ich die Fehlermeldung nicht zu Einhundert Prozent verstehe, kann ich auch die Zusammenhänge nicht so ganz verstehen.

Ich habe in dem Zeitraum noch eine weitere Fehlermeldung, die wohl bei der Produktpflege aufgetreten sein muss. Ich habe allerdings keine Ahnung, ob das im Zusammenhang steht.

```auto
An exception occurred while executing 'UPDATE s_article_configurator_options SET name = ? WHERE id = ?' with params ("Verarbeitungsset", 583): SQLSTATE(23000): Integrity constraint violation: 1062 Duplicate entry '6-Verarbeitungsset' for key 'group_id'

```

Zum System:  
Shopware: 5.6.9  
PHP: 7.3  
DB: MariaDB 10.3

Über jeden Tipp bin ich dankbar.

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [11. Januar 2022 um 14:39 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufbauen-des-suchindex/92315/2 "2022-01-11T14:39:28Z")

</div>

> [@DieAnna](#):
>
> `memory exhausted near`

Klingt sehr nach Speicherproblem beim MySQL. Eventuell mal in Richtung query\_cache\_limit forschen.

---

<div class="post-metadata">

**Author:** ![phil](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/phil/32/13661_2.png) [@phil](https://forum.shopware.com/u/phil)\
**Post date:** [11. Januar 2022 um 20:33 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufbauen-des-suchindex/92315/3 "2022-01-11T20:33:38Z")

</div>

Dieser Fehler tritt auch gerne auf, wenn das memory\_limit in PHP zu niedrig ist. Sollte mindestens 256MB sein, besser noch mehr. Steht bei uns auf 1024MB und unser Shop läuft absolut schnell und stabil, selbst wenn viele Kunden gleichzeitig drauf sind. Aber hängt natürlich von Deinem Hoster ab wo die obere Grenze liegt.

LG Phil

---

<div class="post-metadata">

**Author:** ![DieAnna](https://avatars.discourse-cdn.com/v4/letter/d/77aa72/32.png) [@DieAnna](https://forum.shopware.com/u/DieAnna)\
**Post date:** [12. Januar 2022 um 09:06 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufbauen-des-suchindex/92315/4 "2022-01-12T09:06:56Z")

</div>

Ich habe beim Provider den query\_cache\_limit abgefragt und dieser liegt bei 16M. Sollte also eigentlich passen, wenn meine Info nicht veraltet ist.

Das memory\_limit ist auf 256MB eingestellt - daran sollte es dann auch nicht liegen.

Gestern habe ich erfahren, dass ein Kollege schon vor Monaten eine Kopie in einem Unterverzeichnis erstellt hat und dort funktioniert alles, bei den gleichen Einstellungen.  
Der einzige Unterschied ist, dass die Kopie schon seit 4 - 5 Monaten nicht gepflegt wurde, was mich zu der Frage bringt, ob es möglich ist, dass der Fehler durch eine Falscheingabe bei der Produktpflege hervorgerufen wird.

Wäre das möglich?

---

<div class="post-metadata">

**Author:** ![R4M](https://dub1.discourse-cdn.com/flex013/user_avatar/forum.shopware.com/r4m/32/9983_2.png) [@R4M](https://forum.shopware.com/u/R4M)\
**Post date:** [12. Januar 2022 um 10:03 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufbauen-des-suchindex/92315/5 "2022-01-12T10:03:44Z")

</div>

> [@DieAnna](#):
>
> memory\_limit ist auf 256MB eingestellt

Unsere Erfahrungen haben leider gezeigt, dass dies in 80% der Fälle nicht ausreicht. Mal mit 512MB testen.

---

<div class="post-metadata">

**Author:** ![DieAnna](https://avatars.discourse-cdn.com/v4/letter/d/77aa72/32.png) [@DieAnna](https://forum.shopware.com/u/DieAnna)\
**Post date:** [13. Januar 2022 um 08:50 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufbauen-des-suchindex/92315/6 "2022-01-13T08:50:12Z")

</div>

Ich habe das memory\_limit auf 512MB setzten lassen, allerdings hat sich dadaurch nichts geändert.  
Sonst noch irgendwelche Tipps?

---

<div class="post-metadata">

**Author:** ![DieAnna](https://avatars.discourse-cdn.com/v4/letter/d/77aa72/32.png) [@DieAnna](https://forum.shopware.com/u/DieAnna)\
**Post date:** [19. Januar 2022 um 15:30 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufbauen-des-suchindex/92315/7 "2022-01-19T15:30:55Z")

</div>

Ich habe die Lösung gefunden.  
Es lag an einem alten Plugin welches noch installiert, aber nicht mehr wirklich genutzt wurde.

---

<div class="post-metadata">

**Author:** ![Sonja\_EH](https://avatars.discourse-cdn.com/v4/letter/s/47e85d/32.png) [@Sonja\_EH](https://forum.shopware.com/u/Sonja_EH)\
**Post date:** [5. Mai 2023 um 10:54 UTC](https://forum.shopware.com/t/fehlermeldung-beim-aufbauen-des-suchindex/92315/8 "2023-05-05T10:54:49Z")

</div>

@DieAnna ich habe das gleiche Problem.

Bei mir ging es vor ca. 3 Monaten los… haben auch versucht das memory limit anzupassen… Hat nicht geholfen.  
Unser Shop ist noch viel älter (5.3.7)  
Aber kannst du mir sagen, welches Plugin die Problem-Ursache war bei dir?

Wir haben auch Fehler Warm-up http-cache error… vielleicht hat es einen Zusammenhang.

lg  
SONJA
